PCB5.0C EPROM Program Operating Manual ( English language)
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. The jumpers for Volt set

.The USB cable for power supply

.The DC cable for power supply

.The jumpers for power select(DC or USB)
. The 25 SubD cable

. DIP switch (see window STATUS of software)

. The jumpers for special devices
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8.Set PCB4. 5C or PCB3B

9. The jumpers for special devices

10. The ZIF Socket for devices

11. For PLCC32 devices(Volt is 5HV)

12. For PLCC32 FWH/LPC devices(Volt is 3. 3V)
13. The ZIF Socket for 25XX devices

14. The ZIF Socket for 93XX devices

15. The ZIF Socket for PIC devices

16. The ZIF Socket for 24X X devices

.. The BIOS setting
Check the parallel port setting in the BIOS, it should be EPP or ECP+EPP

CHOS Setup Utilaity - Copyright (G} 19784-2002 Award Software
Integrated Peripherals

On-Chip Primary PCI IDE [Enabled]
IDE Primary Master PID [fute]
IDE Primary Slave PIN Hutn] Menu Lewvel
IDE Primary Master UDHA fluto
IDE Primary Slave UDHA [Auto]
On-Chip Secondary PCI IDE [Enahled]
IDE Secondary Master FID [Auto]
IDE Secondary Slave FID [Aute]
IDE Secondary HMaster DDMA Hutn]
IDE Secondary Slave UDMA [Auto
USE Contreller [Enabled]
USE Keyboard Support [Disahled
0SB Mouse Support |[Disabled
AC" 27 Audio [Auto]
AL’ 97 Hodem [Hutpl i
Onboard LAN selection lEnabled] Menu Lewel
IDE HED Block Mede [Enabled]
Floppy Controller [Enabled]
Serial Port A [3F8/IROG]
Serial PFort B [2FB/IRG3]
Serial Port B Hode [Hormall
Bzl , Tzl Active [Hi,Lao]
IR Transmission Delay [Enabled]
IR Buplex Made [Half¥]
IR Fin Select [IR-Rx2Tx2]
Parallel Paort [37871R071
Parallel Port Hode
EFF lersion
ECP Mode Use DHMA
Inboard Game Port [201]
Dnboard Midi Fort [330]
Midi IRQ Select [i0]

Tl+t:Move Enter:Select +/-SPUSPDzDalue F1D:5ave ESC-Exit F1:Gereral Help
F5: Previous Values F6: Fail-5afe Defaults F?: Optimized Defaunlts

=.Hardware connection
1. Connect to the printer port with a 25 SubD cable, the cable should not be
longer
than 1.8 meter(6 feet standard cable).
This must be a fully wired 1:1 cable, a null modem or serial cable won’ t work.
2. Connect the power supply with a USB cable or DC power, the power led(green)
must go on.

PJ. the software



1. Install the setup. exe, and run the software.

#=| PCB4. 5¢ EPRON Program

File Edit Dewice Action Help Bioshome:www. rebios. net
= H GQelEe % o A % <
Device Select | ssT4aFoas |

Size & Checksum | 0x7FFFF |Ux0000
Shift & Pattern adr |A0->A18 | 0x040000
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Firmware Hub / LPC Programmer Settings
[v Skip Write OxFF

[~ Fast Programming

[~ Smart Program chip S5T and Winbond [ reduce time Prog. 30-40%)
[ Quaduple Byte Program [ ST micro M50xxxs |

RAC delay time (On-Off Vcc) 50008 | Offset (Hex) o
'|||||J||||||||||||||||||||||||||||||||||||||||||||| | ChECkType |1BBIt'qdd vI
Printer Port ||-F’T1 [0x378) ']

| Buffer | temp | Configs | TestHAwW | CFG PIC18Fxu |
- - ~ StatusBar
2.Some driver problems may occur under Windows 2000:
* first, delete an entry in the device manager as follows:
1. On the Start Menu, click Start ——> Settings ——> Control Panel.
In the Control Panel, double click the System icon.
In the System Properties window, click the Hardware tab.
On the Hardware tab, click the Device Manager button.
In the Device Manager menu, click View ——> Show Hidden Devices.
6. In the device list find the Non—Plug and Play Drivers entry. Click the
"plus’ sign on  the left of the entry to expand the list.
7. Find the dlportio entry and right-click it. Click on Uninstall in the
context menu that appears.

G W

Fi. Test the connection with Test Hardware

Before put the IC in the programmer board, you have to run software fist for cutting Vdd
and Vpp which will supply to EPROM. You can check programmer board connecting by
using tab bar Test H/W on button of the panel or using menu Help -> Text Hardware



#= PCB4. 5c EPRON Program

File Edit Dewvice Action BiCIEJ Bioshome:www. rebios.

s @ @ i«
t.8 i
r . About
Device Select ] 5

Size & Checksum | Dx7FFFF nggggg
Shift & Pattern adr |40->A18 | 0:040000

B e S

twc :—l-l}l BB BEN0TA L BN e ) Iau.ous
Vpp'1 234567 8 9101112
B 0|0 HEooE R oo

ON

- Firmware Hub / LPC |~ Programmer Settings
v Skip Write OxFF

[~ Fast Programming

[ Smart Program chip SST and Winbond ( reduce time Prog. 30-40%)
[~ Quadruple Byte Proaram [ ST micro M50xxxs |

RAC delay time (On-Off Vcc) [500uS | Offset(Hex) [0 |

'Illll"lll‘llll|||'l|||||l||||"l'||||l'l||||"l||‘ ‘CheCkType I.IBBitAdd jv‘
| Printer Port ILPT1 (0x378) 'l}

| Buffer | temp | Configs | TestHAW | CFG PIC18Fxxx |

e
StatusBar

Hardware test fail, Causes:
1. The connect of printer port is error.
2. The connect of power supply is error.

75N.Burn a device

1. Selecting the IC number that you want to program by using menu DEVICE or click
the button



#=| PCB4. 5¢c EPRON Program

File Edit Dewice Action Help

EFROM

EPROM Electrical Erase
EEFROM

Flash 28Fxxx

Flash 29/39/49Fxxx
Flash 29/39/498 R

-=-mecsS1 programming ———
MCS-51

MCS-48/41

AVR

SRAM

DS12xx/TimerKeeper

v v v v v w

FEENL:

¥ whwewe w

S
o
=

--= Serial programming ——-—
Microchip PICIDf12/16
Microchip PIC18Fxxx

I2C -- 24Cxxx

SPI -- 25Cxkxx

Microwire —— 93Cxx

S24H (8)xx

-—-Request Adapter 3.3V-—-
Flash 16 bit (LV)
Flalsh 8/16bit (byte mode)

Bioshome:www. rebios. net

]

duce time Prog. 30-40%)
|

I 50.0uS '

11

i~ Programmer Settings

‘ Printer Port

v Skip Write OxFF

[~ Fast Programming

Offset (Hex) [0 |

| Check Type [16BitAdd ] |

ILPT1 (0x378) vl ‘

| CFG PIC18Fxxx |

StatusBar




=5 PCB4. 5¢ EPRON Program

File Edit Dewice Action Help

2 EH asliey

Bioshome:www. rebios. net

A->B

Device Select | __SST43LF004

Size & Checksum [ Dx7FFFF  |0x00(

Shift & Pattern adr |A0-> 418 | 004
twP rel

twC T/ [

Vpp(1 2 3 4567 8 91011

~Firmware Hub / LPC

[ Smart Program chip S5T and ‘Winbond [
7 Quadruple Byte Program [ ST micro M50x

RAC delay time [On-0ff Yec)

{Device | Buffer | temp | Configs | Test HAW

EFROM

EFPROM Electrical Erase
EEFROM

Flash 28Fxxx

Flash 29/39/49Fxxx
Flash 29/39/49% R

-=-mecsS1 programming ———
MCS-51

MCS-48/41

AVR

SRAM

DS12xx/TimerKeeper

--= Serial programming ———
Microchip PICI0/12/16
Microchip PIC18Fxxx

I2C -- 24Cxxx

SPI -- 25Cxxx

Microwire —— 93Cxx

S24H (S)xx

---Reaguest Adapter 3.3V-—-

R Yow'w ¥

% A%as D NS Sl s o

Port

nmer Settings

ip Write OxFF

gt Programming

Hex) ’U
Type |188itAdd v]

[LPTT (0x378) =] |

2. For the IC type 8-pin,18-pin setting DIPswitch doesn't need, but for the IC type
28-pin, 32-pin you have to set the DIPswitch same as the DIPswitchsetting picture.



| PCB4. 5c EPRON Program

= Hd %@ & 12 & % = a>B

File Edit Dewice Action Help Bioshome:www. rebios. net

Device Select | SST 25EED10 |
Size & Checksum | 0x1FFFF IUxUOUU
Shift & Pattern adr [A0->A16 | 0x010000

tWF“._-’......,,,,,..llll||z'l‘.l]u5
tWC'.......J..,,,,,,,,””l15.o.ms'

Vpp/1 234567 8 9101112
N

[~ AT28C/29Cxxx Sector Progamming

Sector size I 128 ;J

| Programmer Settings
[7 Skip Write OxFF
[T Fast Programming

Cffset (Hes) Ilf:
Check Type |16 BitAdd v |
Printer Port ILF'T1 [0x378) 'I

StatusBar

Programming the IC FLASH Memory 28C,29F,29C040 4 Mbit you have to set the
jumber, which locates on letf side of the DIPswitch, to the position 2-3( Default position is

1-2).



= PCB4. 5c EPRON Program

File Edit Dewice Action Help

Bioshome:www.rebios. net

FH QelEe B - as

Device Select l

55T 395F040 I

Size & Checksum l.Ox?FFFF

[6x0000

Shift & Pattern adr |A0->A18

[ 0x040000

tw'Pr._.)......,,,,””“.Il'Z.DuS'

twC )

l'ZU.U us

A18/1 2 3456789101112

~Programmer Settings

v Skip Write 0xFF
[~ Fast Programming

Dffset (Hex) IU
Check Type |1S Bit Add vI
Printer Port ILPT1 [0x378) 'l

......................

StatusBar

3. When you has finished the file, then select menu ACTION (as the picture below) or

click icon on toolbar menu.




~f~‘—j‘_ PCB4. 5c EPRON Program

File Edit Device FEESESH ﬂglp

; +
> H Qg b Ctrl+R
7 ~ Program/Test RAM Ctr1+P
. : s
Device Select Compare/Verify Ctrl4C
Blank Check Ctr1+B
Size & Checksum Erase 28/29/49/89/90/PIC Cirl+E
[ +
Shift & Pattern adr | $et 1D 28/29/49/89/90  Curl4l
WP Clear Buffer
: (I T T T T T B ni' Invert DATA
tWC..,,,,,“ RomIdent
9 9 a2 a 1 BYTE
Vep[1 2 3 4 ¢ v B

— Move A to B address
I m Copy Data to Full CHIP

Bioshome:www. rebios.

net

|

[~ AT28C/29Cxxx Sector Progamming

Sector size I 128 __'_]

“Programmer Settings

[ Skip Wnte OxFF
[T Fast Programming

Dftset {Hex]
Check Type
Printer Port

|1B Bit Add vI
ILPT1 (0x378) vl

¢ | Buffer | temp | Configs | TestH/w | CFG PICT8Fxux |

[ StatusBar




| Toolbar Menu and Action Menu Description

[& Read Chip ,Reads program from the 1C
[!#;}Prozramfl'estRAM IWrites program into the IC
[!@Compare/\’erify lCompares the program in the IC with the program in buffer

4‘ Erase 28/29/49/89/50/P1C

Erases the program in the IC ( * the IC number 27C has to
erase by UV light )

[Q, CheckEmpty

lChecks the IC is empty (OXFF)

Get ID 28/29/49/89/50/PIC

Reads the 1D code from CHIPS
( For some devices when the software reads the 1D code, it will
set parameters to the CHIPS automatically )

oot Block Lockout

Protects the data from rewriting. This data can not earase by
Erase commancd.
( Make sure you don't want to change this data anymore )

|{Lock Modes 895C

Mode 1: No protection

Mode 2: Protects the program in the chip from reading of
comand MOVC from outside memory. but it
doesn't protect verification from the machine
which's able to programming

Mode 3: same mode 2 and protects verification

Mode 4: same as mode 3 and protects the chip from out
side memory programming

[Ea ClearBuffer (0xFF)

lEmses program from buffer = 0xFF

CheckSumBuffer

Calculates CheckSum in buffer

4. Programming PIC you have to set more parameters as the picture below.




#| PCB4. 5¢c EPRON Program

File Edit Dewice Action Help Bioshome:www. rebios. net
= H Q% IEe % © A A |
Device Select | PIC 16FE84 I
Size & Checksum | Dx7FF {DxD1ED.
Shift & Pattern adr |A0->A12 [ 0:010000
t\,JP:—I.)IIIIlllllllllllIll||1‘0v.ui“sv
l“’v‘c'|—II,lllllllIIIIIIIIII|I4.DI"‘s
i' PIC Setting Calibration \Word [ Programmer Settings
Dscilstor | RCCkOwt ~ »|| ¥ WatchDog 02008 [V Skip Write 0x3FFF
[~ Power-up Timer Fast P ;
| Code Protect I CP OFF Ll B MCLHEP I [ Fast Programming
'BODEN | 11 ~|| W IESD 02009
CONFIG  [Owrrr ID[FFFF | ¥ FCMAN | Offset(Hex] [0
______ wsryrmemrl SO i v p CP EEPROM Read I -
(1111111111111 Check Type |1SB|tAdd v]
[~ MCLRE +5¥ wiite | || Printer Port ILF'T1 [0x378) vl
{Device. | Buffer | temp | Configs | TestHAw | CFG PIC18Fsxx |
StatusBar



Programing Data (EPROM,EEPROM,FLASH,PIC)
1. Select device type (Menu Device)

2. Set the DIP switch (see window STATUS).DIPswitch switches can be red(like in the
sofware),white or other colors.

3. Load program file (Menu File -> Load xxx)
4. Insert the IC to the ZIF Socket or the DIP socket

5. For:
Eprom 27Cxxx,27xxx make sure you earase all data (UV erase) by use (Menu Action ->
Checkempty)

Flash,Eeprom erase data by (Menu Action -> Erase 28X, 29x, 49x, AT89x)
PIC check parameter setting first by use (Menu Progsettings)

6. Program (Menu Action -> Program)

Reading Data (EPROM,EEPROM,FLASH,PIC)

1. Select device type (Menu Device)

2. Set the DIP switch (see window STATUS)

3. Insert the IC to the ZIF Socket or the DIP socket

4. Read data (Menu Action -> Read)

5. Save data, You can save as two types 1. binary(.bin) or 2. Intel hex (.hex) (Menu File
->Save XxX)

Programming MCS-51 (Adapter board is needed

1. Select pin type (40 or 20pin) and number program (Menu Device)
2. Set the DIP switch (see window STATUS).

3. Insert the 1C to Adaptor board

4. Select device type. For ATMEL chip you can read the ID code and set parameters
automatically (auto select)



5. Load program file (Menu File -> Load xxx)

6. Erase old program existing in the IC (Menu Action -> Erase 28C,29C,AT89)

7. Burn program (Menu Action -> Program)

8. Protect your data ( protect from copying ) (Menu Action ->Lock Bit)

TIPS

Programming AT89C55WD is needed voltage at least 5.6V

Programming data into the IC (follow ATMEL specification, it guarantees at 6.5 V)
If voltage less than 5.6V, it maybe can't program some lot of CHIPs.

It can solve this promblem by attaching one diode at the second pin of the 1C 7805.
The voltage that supply to the IC will be 0.6+0.6+5 =6.2 V

and the voltage that supply other chips will be increase 5.6 V.

When you have finished programming, you should move the added diod out to
decrease voltage to 5.6V.



Warning:

never insert an eprom when you haven' t started the program yet and the Vpp and Vcc leds
are still burning.
Never remove the power supply lead or disconnect the adapter when an eprom is still in the
socket, also make sure the power lead is firmly connected to the board and can’t become
disconnected

All of this can cause random “writes” to your eprom and change it’s contents.

J\.For example:to burn flash IC:SST49LF004A

1. connect the hardware and power.run the software

2.Select device type and set the DIPswitch

#| PCB4. 5¢ EPRON Program AEG
File Edit Device hction Help Bioshome:www. rebios. net
= A
= H Q%IEeHm A->B % A
Device Select | S5T2  EPEROM |
li i SST4OLFO0Z A
Size & Checksum 0+7EFFF EFEOM Electrical Erase S
EEFEOM SLFOD
Shift & Pattern adr | A0 > A13 Flash 28T 4GLFO04A
twP | Flash 29/39/49Fxxx S5T40LF004E
T T T S T O O T S T B B
L
2 AN o e ammine ——— - 4 SST49LF0E0
Mo 2346k 8d ncs-51 N : y | ATHEL Y| SST4OLFOZ0A
Winbond *
AVE N o ' SST49LF040
SEAM v o ' SST49LF040E
D212%x,/ TimerKeepear [ 3 m1cra SET49LFOS0A
SynclOS
—— Serial programming -—- 0K ,| 55T ZBEE0ID
Microchip PICI0f12F16 BooST | 35T 29EE0Z0
Microchip PIC18Fxxx ¥ AMD y 33T 395F512
I2C —— P4Cxxx 3 MEIC b S5T 395F010
SPI — 25Cxxx 3 AL b 53T 395F020
..................... Microwire — 93Cxx p [THFREFTOT =5T 395F040
Device | Bulfer | temp | Corfigs | Te 524k 5)xx g SST2ELE/VEDLD
——=Reauest Adanter 3. 3V-——— S SST29LE/VEDZD




5| PCB4. 5¢c EPRON Program

File Edit Dewice Action Help Bioshome:www. rebios. net
= H QelEe % o A % <

Device Select | ssT4gtFonas | |
Size & Checksum | 0x7FFFF |IJ$=0000
Shift & Pattern acr | A0->A18 | 0x040000

G e e
(T s pe—————

Vpp/1 234567 8 9101112

Firmware Hub / LPC- -1 Programmer Settings =

[ Smart Program chip ST and Winbond ( reduce time Prog. 30-40%) E 5""? :“f"“’ ?:Ff ‘
[~ Quadruple Byte Program [ ST micro M50xxxx ) Gl il

RAC delay time (On-Off Vcc) 50048 | Offset (Hex) |0
'|III|JIIIIIIllllIllllllIIllllIllllllllllllllllll||| ‘) ChECkType I'ISBItAdd vI
| Printer Port |LPT1 [0x378) ']

......................

StatusBar
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4. check ID. (not possible with older 27(C)XXXX devices), If you can’t get a valid chip ID
it’s useless to try reading, erasing or writing.

A valid ID gives the right manufacturer and chip type.

Electronic 1D

Manufacture | 0xBF | 55T / Sanpo
Device code | (x50 | SST49LFO044

]9

5.Erase IC,it is very fast

"}

6.Click = , load program file

7.Click# to program, the Vecc and Vpp led will light.
5 i S BT
— |

twp pealk twe pealk

Loop Feals

JL. Error

Programming can fail in different ways:

First byte, error message: error at 0x000000 Buffer=0xXX , Chip=0xFF or 0xXX.
Causes: chip not inserted right, faulty chip, Vpp too low.

random error, error message: error at OxXXXXXX , Buffer=0xXX , Chip=0xXX

Causes: 27CXXX eprom not completely UV erased, tWP too low, other causes.
Normally you should not change tWP and tWC unless you know what you are doing.

If you get random write errors with 27 (C) XXX eproms try higher settings.
Older eproms like the 2716 need higher settings.

In the Buffer section you can see the contents of your program file or the chip if you have

done a chip read.

The configs section give an overview of all settings and parameters.

If you need PIC in circuit programming, you can use a DIP connector for the 18 pin PIC 16F84
socket (5 gnd., 12 clock, 13 data i/o, 14 Vcc).



The Vpp volt set
J6, J7

nommal (1254} 2 28V 18Y
Ia I7
J8
normal (5V) 5V V6 6V2
J8
For the special devices
MO AL 2752 a7me 2818 etz g aly | ATAO0256

JF1 JP1 JF1 JF1 JFI JP1
JPZ2 JPZ JPZ JPZ JF2 JPZ2

Eq

[I*

H:

[q

Close the erase jumper only to erase W27X or SST27SFXXX devices.

E!! v 273 PIN
? v 4/2PIN

For the special devices

WACnx or 55T275F xux

& kR




MORMAL 2OX040 (i)

PTCOE0 (Bhibit)

Set the jumpers to Al8 and normal for standard use

Set the jumper to A19 for XXX080 devices

Set the jumper to 29X040 for the 29F040, 29C040 and for the 27C080(801)

A19, A20, A21 are used to connect to the TSOP 48 adapter.

A19, A20, A21 are also used to connect to the 16 bit 42 pin adapter (27C400..27C322).



