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1 Safety Requirement

1.1 General Safety Summary
Please review the following safety precautions carefully before putting the instrument
into operation so as to avoid any personal injury or damage to the instrument and
any product connected to it. To prevent potential hazards, please follow the
instructions specified in this manual to use the instrument properly.

• Use Proper Power Cord.

Only the exclusive power cord designed for the instrument and authorized for
use within the destination country could be used.

• Ground the Instrument.

The instrument is grounded through the Protective Earth lead of the power cord.
To avoid electric shock, it is essential to connect the earth terminal of the power
cord to the Protective Earth terminal before connecting any inputs or outputs.

• Connect the Probe Correctly.

If a probe is used, the probe ground lead must be connected to earth ground.
Do not connect the ground lead to high voltage. Improper way of connection
could result in dangerous voltages being present on the connectors, controls or
other surfaces of the oscilloscope and probes, which will cause potential hazards
for operators.

• Observe All Terminal Ratings.

To avoid fire or shock hazard, observe all ratings and markers on the instrument
and check your manual for more information about ratings before connecting
the instrument.

• Use Proper Overvoltage Protection.

Ensure that no overvoltage (such as that caused by a bolt of lightning) can reach
the product. Otherwise, the operator might be exposed to the danger of an
electric shock.

• Do Not Operate Without Covers.

Do not operate the instrument with covers or panels removed.

• Do Not Insert Objects into the Air Outlet.

Do not insert objects into the air outlet, as doing so may cause damage to the
instrument.

• Use the Proper Fuse.

Please use the specified fuses.
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• Avoid Circuit or Wire Exposure.

Do not touch exposed junctions and components when the instrument is
powered on.

• Do Not Operate With Suspected Failures.

If you suspect that any damage may occur to the instrument, have it inspected
by RIGOL authorized personnel before further operations. Any maintenance,
adjustment or replacement especially to circuits or accessories must be
performed by RIGOL authorized personnel.

• Provide Adequate Ventilation.

Inadequate ventilation may cause an increase of temperature in the instrument,
which would cause damage to the instrument. So please keep the instrument
well ventilated and inspect the air outlet and the fan regularly.

• Do Not Operate in Wet Conditions.

To avoid short circuit inside the instrument or electric shock, never operate the
instrument in a humid environment.

• Do Not Operate in an Explosive Atmosphere.

To avoid personal injuries or damage to the instrument, never operate the
instrument in an explosive atmosphere.

• Keep Instrument Surfaces Clean and Dry.

To avoid dust or moisture from affecting the performance of the instrument,
keep the surfaces of the instrument clean and dry.

• Prevent Electrostatic Impact.

Operate the instrument in an electrostatic discharge protective environment to
avoid damage induced by static discharges. Always ground both the internal and
external conductors of cables to release static before making connections.

• Use the Battery Properly.

Do not expose the battery (if available) to high temperature or fire. Keep it out of
the reach of children. Improper change of a battery (lithium battery) may cause
an explosion. Use the RIGOL specified battery only.

• Handle with Caution.

Please handle with care during transportation to avoid damage to keys, knobs,
interfaces, and other parts on the panels.

WARNING

Equipment meeting Class A requirements may not offer adequate protection to broadcast

services within residential environment.
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1.2 Safety Notices and Symbols
Safety Notices in this Manual:

WARNING

Indicates a potentially hazardous situation or practice which, if not avoided, will result in

serious injury or death.

CAUTION

Indicates a potentially hazardous situation or practice which, if not avoided, could result

in damage to the product or loss of important data.

Safety Notices on the Product:

• DANGER

It calls attention to an operation, if not correctly performed, could result in injury
or hazard immediately.

• WARNING

It calls attention to an operation, if not correctly performed, could result in
potential injury or hazard.

• CAUTION

It calls attention to an operation, if not correctly performed, could result in
damage to the product or other devices connected to the product.

Safety Symbols on the Product:

Hazardous
Voltage

Safety Warning Protective Earth
Terminal

Chassis Ground Test Ground

1.3 Measurement Category
Measurement Category

This instrument can make measurements in Measurement Category I.

WARNING

This instrument can only be used for measurements within its specified measurement

categories.
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Measurement Category Definitions

• Measurement category I is for measurements performed on circuits not directly
connected to MAINS. Examples are measurements on circuits not derived from
MAINS, and specially protected (internal) MAINS derived circuits. In the latter
case, transient stresses are variable. Thus, you must know the transient withstand
capability of the equipment.

• Measurement category II is for measurements performed on circuits directly
connected to low voltage installation. Examples are measurements on household
appliances, portable tools and similar equipment.

• Measurement category III is for measurements performed in the building
installation. Examples are measurements on distribution boards, circuit-breakers,
wiring (including cables, bus-bars, junction boxes, switches and socket-outlets) in
the fixed installation, and equipment for industrial use and some other
equipment. For example, stationary motors with permanent connection to a
fixed installation.

• Measurement category IV is for measurements performed at the source of a
low-voltage installation. Examples are electricity meters and measurements on
primary overcurrent protection devices and ripple control units.

1.4 Ventilation Requirement
This instrument uses a fan to force cooling. Please make sure that the air inlet and
outlet areas are free from obstructions and have free air. When using the instrument
in a bench-top or rack setting, provide at least 10 cm clearance beside, above and
behind the instrument for adequate ventilation.

CAUTION

Inadequate ventilation may cause an increase of temperature in the instrument, which

would cause damage to the instrument. So please keep the instrument well ventilated and

inspect the air outlet and the fan regularly.

1.5 Working Environment
Temperature

Operating: 0℃ to +50℃

Non-operating: -30℃ to +70℃

Humidity

• Operating:

Below +30℃: ≤90% RH (without condensation)

+30℃ to +40℃: ≤75% RH (without condensation)
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+40℃ to +50℃: ≤45% RH (without condensation)

• Non-operating:

Below +65℃: ≤90% RH (without condensation)

WARNING

To avoid short circuit inside the instrument or electric shock, never operate the

instrument in a humid environment.

Altitude

• Operating: below 3 km

• Non-operating: below 15 km

Protection Level Against Electric Shock

ESD ±8kV

Installation (Overvoltage) Category

This product is powered by mains conforming to installation (overvoltage) category II.

WARNING

Ensure that no overvoltage (such as that caused by a bolt of lightning) can reach the

product. Otherwise, the operator might be exposed to the danger of an electric shock.

Installation (Overvoltage) Category Definitions

Installation (overvoltage) category I refers to signal level which is applicable to
equipment measurement terminals connected to the source circuit. Among these
terminals, precautions are done to limit the transient voltage to a low level.

Installation (overvoltage) category II refers to the local power distribution level which
is applicable to equipment connected to the AC line (AC power).

Pollution Degree

Pollution Degree 2

Pollution Degree Definition

• Pollution Degree 1: No pollution or only dry, nonconductive pollution occurs.
The pollution has no effect. For example, a clean room or air-conditioned office
environment.

• Pollution Degree 2: Normally only nonconductive pollution occurs. Temporary
conductivity caused by condensation is to be expected. For example, indoor
environment.

• Pollution Degree 3: Conductive pollution or dry nonconductive pollution that
becomes conductive due to condensation occurs. To be found in industrial
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environment or construction sites (harsh environments). For example, sheltered
outdoor environment.

• Pollution Degree 4: The pollution generates persistent conductivity caused by
conductive dust, rain, or snow. For example, outdoor areas.

Safety Class

Class 1 – Grounded Product

1.6 Care and Cleaning
Care

Do not store or leave the instrument where it may be exposed to direct sunlight for
long periods of time.

Cleaning

Clean the instrument regularly according to its operating conditions.

1. Disconnect the instrument from all power sources.

2. Clean the external surfaces of the instrument with a soft cloth dampened with mild
detergent or water. Avoid having any water or other objects into the chassis via the
heat dissipation hole. When cleaning the LCD, take care to avoid scarifying it.

CAUTION

To avoid damage to the instrument, do not expose it to caustic liquids.

WARNING

To avoid short-circuit resulting from moisture or personal injuries, ensure that the

instrument is completely dry before connecting it to the power supply.

1.7 Environmental Considerations
The following symbol indicates that this product complies with the WEEE Directive
2002/96/EC.

The equipment may contain substances that could be harmful to the environment or
human health. To avoid the release of such substances into the environment and
avoid harm to human health, we recommend you to recycle this product
appropriately to ensure that most materials are reused or recycled properly. Please
contact your local authorities for disposal or recycling information.
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You can click on the following link https://int.rigol.com/services/services/declaration
to download the latest version of the RoHS&WEEE certification file.
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2 MSO8000 Series Overview
MSO8000 series is a medium and high-end mixed signal digital oscilloscope designed
based on UltraVision II platform built on RIGOL's custom ASIC technology. Integrating
7 independent instruments into one, the oscilloscope is equipped with the analog
bandwidth of up to 2 GHz, extremely high memory depth of 500 Mpts, sound
waveform display effects, excellent waveform capture rate, and powerful data analysis
functions. Many of its specifications have reached the top level in the industry.
Meanwhile, it supports the real-time eye diagram measurement and jitter analysis. Its
cost-effective features and high performance make it prominent as the 2 GHz mixed
signal digital oscilloscope.

Main Features:

• Analog channel bandwidth: 600 MHz, 1 GHz, and 2 GHz

• 4 analog channels, 1 EXT channel, and 16 digital channels (standard, required to

purchase the probe)

• Up to 10 GSa/s real-time sample rate

• Up to 500 Mpts memory depth (standard)

• Waveform capture rate > 600,000 wfms/s

• Up to 450,000 frames of hardware real-time and ceaseless waveforms recording

and playback

• Integrates 7 independent instruments into 1, including digital oscilloscope, 16-

channel logic analyzer, spectrum analyzer, arbitrary waveform generator (option),

digital voltmeter, 6-digit frequency counter and totalizer, and protocol analyzer

(option)

• Provides auto measurement for up to 41 waveform parameters, offers full-

memory hardware measurement function

• Various math operations, built-in powerful FFT analysis and peak search

functions

• Histogram analysis (standard)

• Independent search, navigation key, and event table

• Real-time eye diagram and jitter analysis software (option)

 MSO8000 Series Overview
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• Advanced built-in power analysis software (option)

• User-defined one-key quick operation

• 10.1-inch capacitive multi-touch screen, 256-level intensity grading display, with

color persistence

• Multiple interfaces available: USB HOST & DEVICE, LAN (LXI), HDMI, TRIG OUT,

and USB-GPIB

• Web Control remote command

• Unique online upgrade

• Compact and portable industrial design, easy to operate

 MSO8000 Series Overview
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3 Document Overview
This manual gives you a quick review about the front and rear panel of MSO8000 
series, the user interface, and the basic operation method.

TIP

For the latest version of this manual, download it from the official website of RIGOL 

( http:/ / www . rigol. com

Publication Number

UGA26105-1110

Format Conventions in this Manual:

1. Key

The front panel key is denoted by menu key icon. For example,  indicates
the "Default" key.

2. Menu

The menu items are denoted by the format of "Menu Word (Bold) + Character

Shading". For example, System denotes the "System" menu item under the
menu.

3. Operation Procedures:

">" denotes the next step of operation. For example, > System denotes that

first press , and then press the System key.

4. Connector

The connectors on the front or rear panel are usually denoted by the format of
"Connector Name (Bold) + Square Brackets (Bold)". For example, [TRIG OUT].

5. Knob

Label Knob Label Knob

Horizontal  SCALE
Horizontal Scale
Knob Vertical  SCALE

Vertical Scale
Knob

Horizontal  POSITION
Horizontal
Position Knob

Vertical 
OFFSET

Vertical Offset
Knob

 Document Overview

10 Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved.



Label Knob Label Knob

Wave Vertical  SCALE
Wave Vertical
Scale Knob Trigger  LEVEL

Trigger Level
Knob

Wave Vertical 
POSITION

Wave Vertical
Position Knob

Multifunction
knob

Content Conventions in this Manual:

MSO8000 series includes the following models. Unless otherwise specified, this
manual takes MSO8204 as an example to illustrate the functions and operation
methods of MSO8000 series oscilloscope.

Model
Max. Analog
Bandwidth

No. of Digital
Channels

No. of
Analog
Channels

No. of AWG
Channels

MSO8064 600 MHz 16 4 2

MSO8104 1 GHz 16 4 2

MSO8204 2 GHz 16 4 2
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4 Quick Start
This chapter introduces the precautions when using the oscilloscope for the first time,
the front/rear panels of the oscilloscope, the user interface, touch screen controls, and
how to use the built-in help system.

4.1 General Inspection

1. Inspect the packaging

If the packaging has been damaged, do not dispose the damaged packaging or
cushioning materials until the shipment has been checked for completeness and
has passed both electrical and mechanical tests.

The consigner or carrier shall be liable for the damage to the instrument resulting
from shipment. RIGOL would not be responsible for free maintenance/rework or
replacement of the instrument.

2. Inspect the instrument

In case of any mechanical damage, missing parts, or failure in passing the electrical
and mechanical tests, contact your RIGOL sales representative.

3. Check the accessories

Please check the accessories according to the packing lists. If the accessories are
damaged or incomplete, please contact your RIGOL sales representative.
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4.2 Appearance and Dimensions

Figure 4.1 Front View

13
4.
2m

m

Figure 4.2 Vertical View

4.3 To Prepare for Use

4.3.1 To Adjust the Supporting Legs

Adjust the supporting legs properly to use them as stands to tilt the oscilloscope
upwards for stable placement of the oscilloscope as well as better operation and
observation. Users can also fold the supporting legs when the instrument is not in
use for easier storage or shipment, as shown in the figure below.

 Quick Start
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Supporting Legs

(a) To unfold the supporting legs (b) To fold the supporting legs

Figure 4.3 To Adjust the Supporting Legs

4.3.2 To Connect to AC Power

The input AC power requirements of the oscilloscope are 100 V-240 V, 45 Hz-440 Hz.
Please use the power cord provided in the accessories to connect the oscilloscope to
the AC power source, as shown in the figure below.

Power Cord Connector

Figure 4.4 To Connect to AC Power

WARNING

To avoid electric shock, ensure that the instrument is correctly grounded.

4.3.3 Turn-on Checkout

When the oscilloscope is connected to power, press the Power key at the lower-left

corner of the front panel to start the oscilloscope. (You can also press  > System
> Power status, and select "Switch On". After the instrument is connected to power
source, it will start directly.) You can also enable the touch screen to perform the
above operations.) During the start-up process, all the backlights of the front-panel

 Quick Start
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keys are illuminated for a few seconds. The oscilloscope starts to perform a series of
self-tests. After the self-test, the splash screen is displayed.

NOTE

Restart and Shutdown:

1. Enable the touch screen and then tap the function navigation icon  at the lower-left

corner of the touch screen to enable the function navigation.

2. Tap the "Restart" icon, and then you can select "Restart" or "Shutdown", as shown in the

figure below.

3. If you tap "Restart" , the oscilloscope powers off and then automatically restarts again.

If you tap "Shutdown" , the oscilloscope powers off (you can also press the Power key

at the lower-left corner of the front panel to turn off the oscilloscope).

4.3.4 Fuse Replacement

If you need to replace the fuse, please use the specified fuse (AC 250 V, T3.15 A; 5.2
mm × 20 mm) and perform the following operations (as shown in Figure 4.5 ):

1. Turn off the instrument, cut off the power, and remove the power cord.

2. Use a small straight slotted screwdriver to pry out the fuse holder.

3. Take out the fuse holder.

4. Replace the old fuse with a specified fuse.

5. Install the fuse holder.

 Quick Start
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Fuse Holder

Fuse

 

Figure 4.5 Fuse Replacement

WARNING

To avoid electric shock, please ensure that the instrument has been turned off, the power

source has been cut off, and the fuse to be used conforms to the fuse rating.

4.3.5 To Connect the Probe

RIGOL provides the passive probe, the active probe, and the logic probe for the
MSO8000 series. For specific probe models, please refer to MSO8000 Datasheet. For
detailed technical information of the probes, please refer to the corresponding Probe
User Guide.

Connect the passive probe:

1. Connect the BNC terminal of the probe to an analog channel input terminal of the

oscilloscope on the front panel as shown in Figure 4.6 .

2. Connect the ground alligator clip or spring of the probe to the circuit ground

terminal, and then connect the probe tip to the circuit point to be tested.

 Quick Start

16 Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved.



Figure 4.6 Connect the Passive Probe

After you connect the passive probe, check the probe function and probe
compensation adjustment before making measurements. For detailed procedures,
refer to "Function Inspection" and "Probe Compensation".

Connect the active probe:

Take RP7150 (active differential probe head) as an example.

1. Connect the probe head to the preamp of the active probe, as shown in Figure

4.7 .

Figure 4.7 To Connect the Probe Head to the Preamp of the Active Probe

2. Connect the other end of the preamp to an analog channel input terminal of the

oscilloscope on the front panel, as shown in the figure below.

3. Note that you need to push the probe to the due position to lock it firmly.
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Figure 4.8 Connect the Active Probe

4. Use the probe's auxiliary device to connect the probe head to the circuit under

test. For details about the probes, refer to RP7000 Series Active Probe User Guide.

After you connect the active probe, you can make probe calibration and offset
voltage adjustment.

Connect the logic probe

1. Connect the output terminal of the logic probe to the digital channel input

terminal on the front panel of the oscilloscope in the correct direction, as shown in 

Figure 4.9 .

2. Connect the other terminal of the logic probe to the signal terminal under test.

RIGOL's MSO8000 series has a standard configuration of a logic probe RPL2316. To

apply to different application scenarios, RPL2316 provides three connection

methods to connect the signal under test. For details, refer to RPL2316 Logic Probe

User Guide.
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Figure 4.9 Connect the logic probe

NOTE

• Before you connect the logic probe to the signal under test, connect logic probe's

adapter provided in the accessories to its corresponding channel group.

• The digital channel input terminal does not support hot plugging. Please do not insert or

pull out the logic probe when the instrument is in power-on state.

4.3.6 Function Inspection

1. Press  on the front panel, then a prompt message "Restore default

settings?" is displayed. Press OK or tap OK to restore the instrument to its factory

default settings.

2. Connect the ground alligator clip of the probe to the "Ground Terminal" as shown

in Figure 4.10 .

3. Use the probe to connect the input terminal of CH1 of the oscilloscope and the

"Compensation Signal Output Terminal" of the probe, as shown in Figure 4.10 .

Compensation Signal Output Terminal

Ground Terminal

Figure 4.10 To Use the Compensation Signal

4. Set the probe attenuation to 10X, and then press .
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5. Observe the waveform on the display. In normal condition, the square waveform as

shown in Figure 4.11 should be displayed.

Figure 4.11 Square Waveform Signal

6. Use the same method to test the other channels. If the square waveforms actually

shown do not match that in the figure above, please perform "Probe

Compensation" introduced in the next section.

WARNING

To avoid electric shock when using the probe, please make sure that the insulated wire of

the probe is in good condition. Do not touch the metallic part of the probe when the

probe is connected to high voltage source.

4.3.7 Probe Compensation

When the probes are used for the first time, you should compensate the probes to
make them match the input channels of the oscilloscope. Non-compensated or
poorly compensated probes may cause measurement inaccuracy or errors. The probe
compensation procedures are as follows:

1. Perform Step 1, 2, 3 and 4 specified in "Function Inspection".

2. Check the displayed waveforms and compare them with the waveforms shown in 

Figure 4.12 .
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Over compensated Under compensatedPerfectly compensated

Figure 4.12 Probe Compensation

3. Use the probe compensation adjustment tool provided in the accessories to adjust

the low-frequency compensation adjustment hole on the probe until the displayed

waveform is consistent with the "Perfectly compensated" waveform shown in 

Figure 4.12 .

4.4 Front Panel Overview

1820 19 17 16 1415

1 2 3 4 5 67 8 109 12 1311

Figure 4.13 Front Panel Overview

Table 4.1 Front Panel Description

No. Description No. Description

1 Capacitive Touch Screen 11 RUN/STOP Key
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No. Description No. Description

2
Function Menu Operation
Keys

12 Single Trigger Control Key

3 Quick Key (Shortcut Key) 13 Trigger Control System

4 Multifunction Knob 14 Vertical Control System

5 Common Operation Keys 15 Analog Channel Input Terminals

6 Touch Lock Key 16
Probe Compensation Signal Output
Terminal/Ground Terminal

7 Horizontal Control System 17 Digital Channel Input

8 CLEAR key 18

Dual-channel Function/Arbitrary
Waveform Generator Output

Terminals[1]

9 Auto Waveform Display Key 19 USB HOST Interface

10 Waveform Control System 20 Power Key

NOTE

[1]: This function is only available for the model installed with the MSO8000-AWG option.
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4.5 Rear Panel Overview

10 9 8 7 6

5421 3

11

Figure 4.14 Rear Panel Overview

1. Handle

Rotate the handle upright to carry the instrument easily. Rotate it downward if you
do not need to carry it.

2. LAN Interface

Connect the instrument to network via this interface. The instrument is in
compliance with the standards specified in LXI Device Specification 2011. It can be
used to set up a test system.

When you access to the Internet, you can use the Web Control or PC software
Ultra Scope to send the SCPI commands or use the user-defined programming to
control the instrument. When update is available, you can perform online
upgrading for the system software of the instrument via the LAN interface. After it
is connected to the network, you can print the waveform displayed on the screen
when you use the network printer.

TIP

 Quick Start
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After the oscilloscope is connected to network (if you do not have the access to the

Internet, please ask the administrator to open the specified network authority), you can

perform online upgrading for the system software:

1. Enable the touch screen and then tap the function navigation icon  at the lower-left

corner of the touch screen to enable the function navigation.

2. Tap the "Help" icon, and then the "Help" menu is displayed on the screen.

3. Press Online upgrade or enable the touch screen to tap "Online upgrade", then a

"System Update Information" window is displayed, requesting you whether to accept or

cancel "RIGOL TERMS OF ONLINE UPGRADE SERVICE". Tap "Accept" to start online

upgrade. Tap "Cancel" to cancel the online upgrade.

3. USB DEVICE Interface

You can connect the instrument to the PC via this interface. Then you can use the
PC software Ultra Scope to send the SCPI commands or use the user-defined
programming to control the instrument.

4. USB HOST Interface

You can connect the storage device that is compatible with the USB to the
instrument via the USB HOST interface.

Connecting the storage device can save or recall the waveform files and setup files,
as well as save the data and screen image. When update is available, you can
perform local upgrading for the system software of the instrument via the USB
HOST interface.

NOTE

Perform local upgrading for the system software:

1. Insert the USB storage device (stored with upgrading files under its root directory) into

the USB HOST interface.

2. Press Local upgrade or enable the touch screen to tap "Local upgrade", then a dialog

box "Upgrade system firmware?" is displayed.

3. Press OK or enable the touch screen to tap "OK" to start local upgrade for the

oscilloscope. If you tap "Cancel", the local upgrade will be cancelled.

5. HDMI Video Output

Through this interface, you can connect the instrument to an external display (e.g.
monitor or projector) equipped with the HDMI interface to better observe the
waveform display clearly. At this time, you can also view the waveforms on the LCD
of the instrument.

6. 10 M In/Out

Indicates the reference clock. It can provide accurate sample clock signal for the
oscilloscope, and can be used to synchronize the clock of two or multiple
oscilloscopes.
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7. EXT TRIG

Inputs the external signal via the external input terminal.

8. Trigger Out and Pass/Fail

- TRIG OUT

The oscilloscope can output a signal that can reflect the current capture rate of
the oscilloscope at each trigger via this interface. Connect the signal to a
waveform display device and measure the frequency of the signal. The
measurement result is the same as the current capture rate.

- Pass/Fail

The instrument can output a pulse from the [TRIG OUT] connector when a
pass/failed event is detected during the pass/fail test.

9. Lock Hole

You can lock the instrument to a fixed location by using the security lock (please
purchase it by yourself) via the lock hole.

10. Fuse

If you need to replace the fuse, use only the specified fuse. For details, refer to
descriptions in "Fuse Replacement".

11. AC Power Cord Connector

Indicates the input terminal where AC power source is connected. The power
supply requirements of the instrument are: 100 V~240 V; 45 Hz~ 440 Hz. Please
use the power cord provided in the accessories to connect the oscilloscope to the
AC power source.

4.6 Front Panel Function Overview

4.6.1 Vertical

• , , , : indicates the analog channel switch key. The four channels are
marked by different colors which are also used to mark both the corresponding
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waveforms of the specified channel on the screen and the channel input
connectors.

•

, : indicates the Function/Arbitrary Waveform Generator key. Press GI
to enable or disable the output of the [GI] connector on the front panel; press
GII to enable or disable the output of the [GII] connector on the front panel;
and then enter the corresponding signal source setting interface. Enable or
disable the status display of the current signal.

NOTE

This function is only available for model installed with the MSO8000-AWG option.

• : indicates the default setting key. Press this key to restore the
instrument to its factory default settings.

• Vertical  OFFSET: indicates the channel vertical offset knob. You can rotate
the knob to modify the vertical offset of the current channel waveform. Each
analog channel is configured with an independent vertical offset adjustment
knob. Turn it clockwise to increase the offset, and turn it counterclockwise to
decrease the offset. During the modification, the waveform would move up and
down. Meanwhile, the offset information in the corresponding status label
would change accordingly. Press down this knob to quickly reset the vertical
offset to zero.

• Vertical  SCALE: indicates the channel vertical scale knob. It is used to modify
the vertical scale of the current channel. Each analog channel is configured with
an independent vertical scale adjustment knob. Turn it clockwise to decrease
the scale, and turn it counterclockwise to increase the scale. During the
modification, the display amplitude of the waveform will enlarge or reduce. The
scale information in the corresponding status label will change accordingly.
Press down this knob to quickly switch the vertical scale adjustment mode
between "Coarse" and "Fine".

4.6.2 Horizontal

• : indicates the delayed sweep key. Press this key to enable or disable the

delayed sweep function.
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• : indicates the Search key. Press this key to enter the search setting menu.

The search function allows you to search for relevant events from the collected

data based on the user-set search condition.

• : indicates the navigation combination key. With the

combination keys, you can perform recording&playing navigation, time

navigation, and event navigation.

• Horizontal  POSITION: indicates the horizontal position knob. Rotate the

knob to modify the horizontal position (i.g. trigger position). The trigger point

would move left or right relative to the center of the screen when you rotate the

knob. During the modification, waveforms of all the channels would move left or

right, and the horizontal position message (e.g. ) at the upper-right

corner of the screen would change accordingly. Press down this knob to quickly

reset the horizontal position (or the delayed sweep position).

• Horizontal  SCALE: indicates the horizontal time base knob. You can rotate

the knob to modify the horizontal time base. Turn it clockwise to decrease the

time base, and turn it counterclockwise to increase the time base. During the

modification, waveforms of all the channels will be displayed in expanded or

compressed form, and the time base message (e.g. ) at the upper section

of the screen would change accordingly. Press down this knob to quickly switch

the horizontal time base adjustment mode between "Coarse" and "Fine".
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4.6.3 Wave

• : indicates the math operation key. Press this key to enable the math

operation function. The math operations include A+B, A-B, A×B, A/B, FFT, and

etc. Besides, you can also set the math operation label.

• : indicates the logic analyzer key. Press this key to open the logic analyzer

control menu. You can enable or disable any channel or channel group, modify

the waveform sizes of the digital channel, modify the threshold of the digital

channel, and group the 16 digital channels. Besides, you can also set a label for

each digital channel.

• : indicates the reference waveform key. Press this key to open the reference

waveform setting menu. You can compare the actually measured waveform with

the reference waveform to locate the circuit failure.

• : indicates the decode key. Press this key to open the decode setting menu,

and then you can set the decode options. This series of oscilloscope supports

the parallel decoding and many protocol decodings. (For details, refer to the

descriptions in "Protocol Decoding").

• Wave Vertical  POSITION: indicates the waveform vertical position knob.

Rotate the knob to adjust the vertical position of the current digital channel

waveform, the vertical position of the math operation waveform, the vertical
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position of the reference waveform, or the vertical display position of the bus

decoding.

• Wave Vertical  SCALE: indicates the waveform vertical scale knob. Rotate the

knob to adjust the vertical scale of math operation waveform or the vertical scale

of the reference waveform, and also can adjust the size of the displayed digital

channel waveforms.

4.6.4 Trigger

• : Press this key to open the trigger operation menu.
This oscilloscope provides various trigger types.

• : Press this key to switch the trigger mode to Auto,
Normal, or SINGLE.

• : Press this key to generate a trigger signal forcibly.

• Trigger  LEVEL: modifies the trigger level/threshold level.
Turn it clockwise to increase the level, and turn it
counterclockwise to decrease the level. During the
modification, the trigger level line would move up and down
and the trigger level/threshold level value at the upper-right
corner of the screen would change accordingly. Press down
the knob to quickly set the trigger level to 50% of the
waveform peak-peak value.

4.6.5 Clear

Press this key to clear all the waveforms on the screen. If the
oscilloscope is in the "RUN" state, new waveforms will continue
being displayed.

4.6.6 Auto

Press this key to enable the waveform auto setting function.
The oscilloscope will automatically adjust the vertical scale,
horizontal time base, and trigger mode according to the input
signal to realize optimal waveform display.
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4.6.7 RUN/STOP

Press this key to set the operating state of the oscilloscope to
"RUN" or "STOP". In the "RUN" state, the key is illuminated in
yellow. In the "STOP" state, the key is illuminated in red.

4.6.8 Single

Press this key to set the trigger mode to "Single".

4.6.9 Multifunction knob

• Non-menu Operation:

In non-menu-operation mode, rotate this knob to adjust the brightness of
waveform display. The settable screen brightness ranges from 1% to 100%. Turn
it clockwise to increase the brightness, and turn it counterclockwise to decrease

the brightness. Press  > Intensity to adjust the waveform brightness. You
can also use the knob to adjust it.

• Menu Operation:

When you operate on the menu, the backlight of the knob is illuminated. For the
menu item that has multiple parameters under it, when you press the menu
softkey, rotate the knob to select the parameter item, then press down the knob
to select the item (sometimes, the specified parameter item can be selected by
rotating the knob). The knob can also be used to modify parameters, input
filenames, etc.

4.6.10 Function Menu
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: Press this key to enter the measurement setting menu. You can set the
measurement source, enable or disable the all measurement function, the statistical
analysis function, and etc. You can make a quick measurement for 41 waveform
parameters.

: Press this key to enter the acquisition setting menu. You can set the time base
mode, the acquisition mode, memory depth, and etc.

: Press this key to enter the file or waveform storage and load interface. The file
types for storage include image, waveform, and setups. Besides, waveform load and
setup load are supported. The disk management and file auto naming function are
also supported in this menu.

: Press this key to enter the cursor measurement menu. The oscilloscope
provides four cursor modes: Manual, Track, XY, and Measure. Note that XY cursor
mode is only available when the horizontal time base is set to "XY".

: Press this key to enter the Display setting menu. You can set the display type,
persistence time, wave intensity, and etc.

: Press this key to enter the system function setting menu. You can set system-
related functions or parameters, such as I/O, sound, language, and etc. Besides, some
advanced functions (such as the pass/fail test, waveform recording, and self-
calibration) are also supported.

4.6.11 Touch Lock Key

Press this key to disable the touch screen function.

NOTE

By default, the touch screen function of the oscilloscope is always enabled. If you disable the

function, press the key again to enable it.

4.6.12 Quick key (shortcut key)

Press this key to perform the quick operation, including screenshot,
waveform saving, setup saving, all measurement, statistics reset, and etc.

Press  > More > Quick settings to set the quick shortcut keys.
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4.7 User Interface
MSO8000 series has a 10.1-inch WSVGA (1024×600) LCD, with 256 level gray-scale
display. The user interface displays the acquired waveforms, the setting information,
and the measurement results.

1 2 3 4 5 867 9 10 11 12

131415161718192021222324

Figure 4.15 User Interface

1. Analog Channel Label/Waveform

Different channels are marked with different colors. The color of the channel label
is the same as that of the waveform.

2. Operating Status

The available states include RUN, STOP, T'D (triggered), WAIT, and AUTO.

3. Horizontal Time Base

- Represents the time length per grid in the horizontal axis of the screen.

- Use Horizontal  SCALE to modify this parameter. The adjustable range of the

horizontal time base is different for different models.
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4. Sample Rate/Memory Depth

- Displays the current sample rate and memory depth of the analog channel.

- The sample rate and the memory depth will change along with the horizontal

time base.

5. Auto Measurement Label

Enable the touch screen, and then tap the label. Up to 41 waveform parameters are
available for auto measurement. It also offers full-memory hardware measurement
function.

6. Save Wave

Provides a diagram of the position of the screen waveform in the memory.

waveform in the memory

screen waveform

7. Trigger Position

Displays the trigger position of the screen waveform and that of the waveform in
the memory.

8. Run/Stop Label

In the run state, the label is displayed in green; while in the stop state, it is
displayed in red. You can enable the touch screen to tap the icon "STOP/RUN" to
control its operating status.

9. Horizontal Position

Use Horizontal  POSITION to modify this parameter. Press down this knob to
quickly reset the horizontal position.

10. Trigger Type

Displays the currently selected trigger type and trigger condition setting. When

you select different trigger types, different labels are displayed. For example, 
represents triggering on the rising edge in "Edge" trigger.

11. Source

Displays the currently selected trigger source (CH1-CH4, AC Line, EXT, or D0-D15).
When you select different trigger sources, different labels are displayed. For

example,  denotes that CH1 is selected as the trigger source.
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12. Trigger LEVEL/Threshold Level

- When CH1-CH4 or EXT is selected as the trigger source, you need to set a

proper trigger level.

- When D0-D15 is selected as the trigger source, you need to set a proper

threshold level.

- The trigger level label  is displayed at the left section of the screen, and the

trigger level/threshold level value is displayed at the upper-right corner of the

screen.

- When you use Trigger  LEVEL to modify the trigger level/threshold level, the

trigger level/threshold level value will change with the up and down of .

13. Operation Menu

Press any softkey on the front panel to activate the corresponding menu.

14. Notification Area

Displays the beeper icon, the USB storage device icon, time, and the LAN
connection icon.

- Sound icon: Press  > Sound to turn on or off the sound. When the sound

is turned on,  will be displayed; when off,  will be displayed.

- USB storage device icon: When a USB storage device is detected,  will be

displayed.

- Time: displays the system time. For the system time setting, refer to

descriptions in "System Time".

- LAN connection icon: When the LAN interface is successfully connected, 

will be displayed.

15. AWG 2

- Displays the on/off status of AWG 2.

- Displays the waveform type set for the current AWG 2.
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- It is only available for the model installed with the MSO8000-AWG option.

16. AWG 1

- Displays the on/off status of AWG 1.

- Displays the waveform type set for the current AWG 1.

- It is only available for the model installed with the MSO8000-AWG option.

17. Digital Channel Status Area

Displays the current status of the 16 digital channels. The digital channels currently
turned on are displayed in green, and the currently selected digital channel is
highlighted in red. The digital channels turned off are displayed in gray.

18. CH4 Status Label

- Displays the status of CH4.

- It displays the vertical scale of CH4. That is, the voltage value per grid of CH4 in

the vertical axis.

- Displays the offset of CH4, i.g. the vertical offset of CH4 waveform.

- Different labels will be displayed according to the current channel setting. For

example, if you select "DC" for channel coupling,  is displayed; if you enable

the bandwidth limit,  is displayed; if you select "50 Ω" for impedance,  is

displayed.

19. Message Box

Displays the prompt messages.

20. CH3 Status Label

- Displays the status of CH3.

- Displays the vertical scale of CH3. That is, the voltage value per grid of CH3 in

the vertical axis.

- Displays the offset of CH3, i.g. the vertical offset of CH3 waveform.

- Different labels will be displayed according to the current channel setting. For

example,if you select "DC" for channel coupling,  is displayed; if you enable
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the bandwidth limit,  is displayed; if you select "50 Ω" for impedance,  is

displayed.

21. CH2 Status Label

- Displays the status of CH2.

- Displays the vertical scale of CH2. That is, the voltage value per grid of CH2 in

the vertical axis. Displays the offset of CH2, i.g. the vertical offset of CH2

waveform.

- Different labels will be displayed according to the current channel setting. For

example,if you select "DC" for channel coupling,  is displayed; if you enable

the bandwidth limit,  is displayed; if you select "50 Ω" for impedance,  is

displayed.

22. CH1 Status Label

- Displays the on/off status of CH1.

- Displays the vertical scale of CH1. That is, the voltage value per grid of CH1 in

the vertical axis.

- Displays the offset of CH1, i.g. the vertical offset of CH1 waveform.

- Different labels will be displayed according to the current channel setting. For

example,if you select "DC" for channel coupling,  is displayed; if you enable

the bandwidth limit,  is displayed; if you select "50 Ω" for impedance,  is

displayed.

23. Digital Channel Label/Waveform

The logic high and low level of the digital waveform are displayed in green. Its
edge is displayed in white. The color of the currently selected waveform of the
digital channel is consistent with that of the channel label, being displayed in red.
The grouping setting function under the logic analyzer function menu can divide
the digital channels into 4 channel groups. The channel label of the same channel
group is displayed in the same color; different channel groups are marked with
different colors.

24. Function Navigation
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Enable the touch screen and then tap this icon to enable the function navigation.

NOTE

In Slope Trigger, Runt Trigger, and Window trigger, you need to set the upper and lower limits

of the trigger level, and two trigger level labels (  and ) are displayed.

4.8 Touch Screen Controls
MSO8000 series provides a 10.1-inch super large capacitive touch screen, which
supports multi-touch and gesture operation. It has strong waveform display capability
and excellent user experience. It features great convenience, high flexibility, and great
sensitivity. The actions supported by the touch screen controls include tapping,
pinching & stretching, dragging, and rectangle drawing.

TIP

The touch screen function is available for all the menus displayed on the screen and the

buttons enabled. In this manual, key operation descriptions are illustrated in details, and as for

the touch screen function about some operations, refer to descriptions in relevant chapters.

4.8.1 Tap

Use one finger to touch the symbol or characters on the screen slightly, as shown in 
Figure 4.16 . With the Tap gesture, you can perform the following operation:

• Tap the menu displayed on the screen to operate on the menu.

• Tap the function navigation icon  at the lower-left corner of the touch screen

to open the function navigation.

• Tap the displayed numeric keypad to set the parameters.

• Tap the virtual keypad to set the label name and the filename.

• Tap the close button at the upper-right corner of the message box to close the

prompt window.

• Tap other windows on the touch screen and operate on the windows.
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Figure 4.16 Tap Gesture

4.8.2 Pinch & Stretch

Pinch or stretch two points on the screen with two fingers to zoom in or out the
waveform. To zoom in the waveform, first pinch the two fingers and then stretch the
fingers; to zoom out the waveform, first stretch the two fingers, and then pinch the
fingers together, as shown in Figure 4.17 . With the pinch&stretch gesture, you can
perform the following operation:

• Pinching&stretching in the horizontal direction can adjust the horizontal time

base of the waveform.

• Pinching&stretching in the vertical direction can adjust the vertical scale of the

waveform.

Figure 4.17 Pinch & Stretch Gesture

4.8.3 Drag

Use one finger to select the object, and then drag the object to a destination place, as
shown in Figure 4.18 . With the drag gesture, you can perform the following
operation:

• Drag the waveform to change its position or scale.

• Drag the window controls to change the position of the window (e.g. numeric

keypad).

• Drag the marker to change the position of the marker.
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Figure 4.18 Drag Gesture

4.8.4 Rectangle Drawing

Enable the function navigation, and then tap the "Draw rect" icon to switch to the
rectangle drawing mode. Drag a finger from upper left to lower right across the
screen to draw a rectangle on the screen, as shown in Figure 4.19 . Move your finger
away from the screen, and then a menu is displayed on the screen. At this time, you
can tap to select "Trigger zone A", "Trigger zone B", "Histogram", "Horizontal zoom
in", "Vertical zoom in", or "Waveform zoom in". Drag a finger from lower right to
upper left across the screen to draw a rectangle on the screen, as shown in Figure
4.20 . Move your finger away from the screen, and then a menu is displayed on the
screen. At this time, you can tap to select "Trigger zone A", "Trigger zone B",
"Histogram", "Horizontal zoom out", "Vertical zoom out", or "Waveform zoom out".

Figure 4.19 Rectangle Drawing Gesture(a)

Figure 4.20 Rectangle Drawing Gesture(b)
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• Select "Trigger zone A":

- Draw the region for Trigger zone A;

- Open Trigger zone A:

- Open the "Zone Trigger" menu.

• Select "Trigger zone B":

- Draw the region for Trigger zone B;

- Open Trigger zone B:

- Open the "Zone Trigger" menu.

• Select "Histogram":

- Draw the region for the histogram;

- Open the "Histogram" menu.

• Horizontal zoom in: expands the waveforms in the horizontal direction.

Horizontal zoom out: compresses the waveforms in the horizontal direction.

• Vertical zoom in: expands the waveforms in the vertical direction. Vertical zoom

out: compresses the waveforms in the vertical direction.

• Waveform zoom in: expands the waveforms both in the horizontal and vertical

direction. Waveform zoom out: compresses the waveforms both in the

horizontal and vertical direction.

TIP

Tap the "Draw rect" icon to switch between the rectangle drawing and waveform operation

modes.

Tap the "Draw rect" icon, if  is displayed, it indicates that the rectangle drawing mode is

enabled. Tap the "Draw rect" icon, if  is displayed, it indicates that the waveform operation

mode is enabled. By default, the waveform operation mode is enabled.

4.9 Parameter Setting Method
You can use the knob or enable the touch screen to set the parameters of MSO8000
series. The common parameter setting methods are as follows:

Method 1:
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For the parameters with the sign , rotate the multifunction knob  on the front
panel directly to select the parameter item or modify the parameter value.

Method 2:

For the parameters with the sign , rotate the multifunction knob  on the front
panel and then press it down to select the parameter item or modify the parameter
value.

Method 3:

For the parameters with  displayed on the menu, rotate the multifunction knob 
on the front panel directly to set the parameter, or press down the multifunction knob

 or the specified menu softkey, and then the numeric keypad is shown in Figure
4.21 below.

Parameter Input Field

Delete Key

Max. Value  

Min. Value

Default Value

Clear Key

Figure 4.21 Numeric Keypad

In the numeric keypad, rotate the multifunction knob  to select the parameter, then
press down the knob to select it. Then input the value or the unit. You can also enable
the touch screen and tap the value or unit in the numeric keypad to input them. After
you input all the values and select the desired units, the numeric keypad is turned off
automatically. This indicates that you have completed parameter setting. Besides,
after you have input the values, you can also press OK directly to confirm the input
and close the numeric keypad. At this time, the unit of the parameter is the default
unit. In the numeric keypad, you can also perform the following operations:

• Delete the parameter value that has been input.

• Set the parameter to a maximum or minimum value (sometimes, the maximum

or minimum value are the specified one for the current state).

• Set the parameter to a default value.

 Quick Start

Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved. 41



• Clear the parameter input field.

Method 4:

For the parameters without the above signs, press the desired menu softkey to switch
between the parameter items. This method is applicable to the parameters with only
two available options.

TIP

The above method is commonly used for the parameter settings of the oscilloscope. For other

methods of parameter settings, refer to details in User Guide of this instrument.

4.10 To Use the Security Lock
If necessary, you can lock the instrument to a fixed location by using the security lock
(please purchase it by yourself), as shown in Figure 4.22 .

The method is as follows: align the lock with the lock hole and plug it into the lock
hole vertically, turn the key clockwise to lock the oscilloscope, and then pull the key
out.

Security Lock Hole

Figure 4.22 To Use the Security Lock

NOTE

Please do not insert other objects into the security lock hole to avoid damaging the

instrument.
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4.11 To Use the Built-in Help System
The help system of this oscilloscope provides instructions for all the function keys on
the front panel and their corresponding menu keys. The steps for opening the built-in
help system are as follows:

1. Press  > System > Help, and then the "Help" menu is displayed on the

screen. You can also use the touch screen function , tap the navigation icon  at

the lower-left corner of the touch screen to enable the function navigation. Tap the

"Help" icon, and then the "Help" menu is displayed on the screen.

2. Press the Content menu key or tap the "Content" menu item, then the help

information is displayed on the screen, as shown in Figure 4.23 . The help interface

mainly consists of two sections. The left section lists "Help Options", and the right

section is the "Help Display Area".

 

Help Options     Help Display Area

Figure 4.23 Help Information

After opening the help interface, you can get its help information in the "Help Display
Area" through the following three methods:

Method 1:
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For the key operation, you can directly press the front-panel keys (except the Power

key,  key, and the  key) to obtain the help information. For the knob operation,
you can rotate the knob or press down the knob to get the help information (except

the multifunction knob , Wave Vertical  POSITION, and Wave Vertical 
SCALE). As the function of rotating the knob is different from that of pressing down
the knob, these two operations will give you different help information.

Method 2:

In the "Help Options", rotate the multifunction knob  to switch among the help
options to get the corresponding help information.

Method 3:

Enable the touch screen and tap the desired help option to get the corresponding
help information.

TIP

• Help information for other keys and buttons:

- Power key: powers on/off the instrument.

-  key: displays or hides menus. Pressing this key can hide the menus.

-  key: returns to the previous menu or last set function menu.

- Multifunction knob : In non-menu-operation mode, rotate this knob to adjust

the brightness of waveform display. When you operate on the menu, the backlight

of the knob is illuminated. For the menu item that has multiple parameters under it,

when you press the menu softkey, rotate the knob to select the parameter item,

then press down the knob to select it (sometimes, the specified parameter item can

be selected by rotating the knob). The knob can also be used to modify parameters,

input the filename, etc.

- Wave Vertical  POSITION: Rotate the knob to adjust the vertical position of the

current digital channel waveform, the vertical position of the math operation

waveform, the vertical position of the reference waveform, or the vertical display

position of the bus decoding.

- Wave Vertical  SCALE: Rotate the knob to adjust the vertical scale of math

operation waveform or the vertical scale of the reference waveform, and also can

adjust the size of the displayed digital channel waveforms.

• If the menu item is grayed out, you cannot press the corresponding front-panel menu

key to obtain the help information. What you can do is only to follow the above Method

2 or 3 to get the help information.

4.12 To View the Option and the Option Installation
This series of oscilloscope provides multiple options to fulfill your measurement
requirements. If you need any of these options, order them according to the Order
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No. available in "Appendix A: Options and Accessories", and then install the options
according to this section. Besides, you can also view the options currently installed on
the oscilloscope or activate the newly purchased option.

1. View the Installed Option

The instrument is installed with the trial versions of the options before leaving
factory. When you power on the instrument for the first time, the trial time is
about 2,160 minutes. If your instrument has currently installed the option, perform
the following operations to view the name of the installed option and other
detailed information about the option from the option list.

a. Press  > System > Help, and then the "Help" menu is displayed on the

screen. You can also use the touch screen function , tap the navigation icon 

at the lower-left corner of the touch screen to enable the function navigation.

Tap the "Help" icon, and then the "Help" menu is displayed on the screen.

b. Press Option list or tap the Option list menu item, and then a list of the

options installed is displayed on the screen for users to view.

2. Install the Option

The license is a fixed length of strings. Each instrument has a unique license. The
license file should be in specific format, with the filename extension ".lic". After you
have purchased an option, you will obtain a key (used for obtaining the license).
Then, you can install the option according to the following steps.

a. Obtain an option license

a. Log in to the RIGOL official website (www.rigol.com), click SERVICE CENTRE

(Products & Services) > License Activation to enter the license activation

interface.

b. In the software license registration interface, input the correct key, serial

number (press  > System > About to obtain the serial number of the

instrument; you can also open the "Help" function menu, and then press

About to obtain the serial number), and the verification code. Click Generate

to obtain the download link of the option license file. If you need to use the
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option license file, click on the link to download the file to the root directory

of the USB storage device.

b. Install the option

a. Confirm that the option license file is located in the root directory of the USB

storage device, and connect the USB storage device to the oscilloscope

properly.

b. The Option install key is activated, and press this menu key to start installing

the option.

c. After installation, a prompt message "Option activated successfully" is

displayed.

NOTE

After the option has been installed, you are recommended to restart the instrument.

TIP

• Only 1 option license file of one instrument is allowed to be stored in the same USB

storage device, but the USB storage device can store the option license file of several

different instruments. You are not allowed to modify the licensed filename.

• During the installation process, you are not allowed to power off the instrument or pull

out the USB storage device.

• Sending the SCPI commands (:SYSTem:OPTion:INSTall <license>) to install options is

supported. Installing options by inputting the license code manually is not supported.
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5 To Set the Vertical System
MSO8000 series provides 4 analog input channels (CH1-CH4). Each channel is
equipped with an independent vertical control system. The setting methods for the
vertical systems of the 4 channels are the same. This chapter takes CH1 as an example
to introduce the setting method for the vertical system. By default, only CH1 is
enabled.

5.1 To Enable or Disable the Analog Channel
Enable the Analog Channel:

Connect a signal to CH1, and then press  in the vertical control area (Vertical) on
the front panel to enable CH1. Then, the backlight of the channel is illuminated. At
this point, the channel setting menu is displayed at the right section of the screen and
the channel is activated. The channel status label at the bottom of the screen is shown
in the figure below. You can also enable the touch screen to tap the channel status
label to enable the channel.

Vertical Scale

The information displayed in the channel status label is related to the current channel
setting (irrelevant with the on/off status of the channel). After the channel is turned
on, modify the parameters such as the vertical scale, horizontal time base, trigger
mode, and trigger level according to the input signal for easy observation and
measurement of the waveform.

If CH1 is enabled but not activated, the channel status label is shown in the following

figure. To activate the channel, press  on the front panel in the vertical control area
(Vertical) or enable the touch screen to tap the waveform activation channel displayed
on the screen.

Disable the Analog Channel:

If the setting menu of the channel that needs to be disabled (the current channel is
activated) is displayed at the right section of the screen, press the channel key to
disable the channel. If the setting menu of the channel that needs to be disabled is
not displayed at the right section of the screen, first open the setting menu of the
channel to be disabled (activate the channel), then press the channel key to disable
the channel. You can also enable the touch screen to tap the channel status label to
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disable the channel. For example, if CH1 and CH2 are enabled and CH2 channel
setting menu is displayed on the screen, then if you need to disable CH1, first activate

CH1, and then press  or enable the touch screen to tap CH1 channel status label to
disable CH1. If CH1 is disabled, the channel status label is shown in the following
figure.

5.2 To Adjust the Vertical Scale
Vertical scale indicates the voltage value per grid in the vertical axis of the screen. It is
often expressed in V/div. While you adjust the vertical scale, the display amplitude of
the waveform would enlarge or reduce. The scale information of the channel status
label (e.g. as shown in the following figure) at the lower section of the screen would
change accordingly.

Vertical Scale

The adjustable range of the vertical scale is related to the currently set probe ratio
and input impedance. By default, the probe ratio is 1X and the input impedance is 1
MΩ. In this case, the adjustable range of the vertical scale is from 1 mV/div to 10 V/
div.

When CH1 is turned on, you can adjust the vertical scale with the following three
methods:

• Rotate Vertical  SCALE that corresponds to CH1 to adjust the vertical scale

(clockwise to reduce the scale and counterclockwise to increase).

• Enable the touch screen function, and then adjust the vertical scale with the

pinch & stretch gesture on the touch screen. For details, refer to the "Pinch &

Stretch" section.

• Enable the touch screen function, and tap the channel status label at the bottom

of the screen. The following window is displayed. Tap the icon at the right side of

the Scale input field to decrease or increase the scale. You can also tap the input

field to input a specific value with the displayed numeric keypad.
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Value Input Field Decrease Increase

In the vertical control area (Vertical) on the front panel, press Vertical  SCALE to

adjust the vertical scale in "Coarse" (by default) or "Fine" mode. You can also press 
> More > Fine to enable or disable the fine adjustment.

• Fine adjustment: Rotate Vertical  SCALE to further adjust the vertical scale

within a relatively smaller range to improve the vertical resolution. If the

amplitude of the input waveform is a little bit greater than the full scale under

the current scale and the amplitude would be a little bit lower if the next scale is

used, fine adjustment can be used to improve the amplitude of waveform

display to view signal details.

• Coarse adjustment (take counterclockwise as an example): Rotate Vertical 

SCALE to set the vertical scale at 1-2-5 step, i.e. 1 mV/div, 2 mV/div, 5 mV/div, 10

mV/div…10 V/div.

5.3 Vertical Expansion

When changing the vertical scale of the analog channel by rotating the Vertical 
SCALE, you can select to expand or compress the waveform around the "Center" or
"GND" (Ground). By default, "GND" is selected under Expand.

Press  > More, then press Expand continuously to select "Center" or "GND".

• Center: when the vertical scale is changed, the waveform will be expanded or

compressed around the screen center.

• GND: when the vertical scale is changed, the waveform will be expanded or

compressed around the signal ground level position.
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5.4 To Adjust the Vertical Offset
Vertical offset indicates the offset of the signal ground level position of the waveform
from the screen center in the vertical direction. Its unit is consistent with the currently
selected amplitude unit (refer to "Amplitude Unit"). When adjusting the vertical offset,
the waveforms of the corresponding channel moves up and down. The vertical offset
information (as shown in the following figure) in the channel status label at the
bottom of the screen will change accordingly.

The adjustable range of the vertical offset is related to the current input impedance,
probe ratio, and vertical scale.

When CH1 is turned on, you can adjust the vertical offset with the following four
methods:

• Rotate Vertical  OFFSET that corresponds to CH1 to adjust the vertical offset

within the adjustable range. Rotate this knob clockwise to increase the vertical

offset, and rotate it counterclockwise to reduce the vertical offset. Pressing down

the knob can quickly reset the vertical offset (set the vertical offset to 0).

• Menu setting: Press  > More > Offset, and then the numeric keypad is

displayed. Input the offset value with the numeric keypad.

• Enable the touch screen function, and then adjust the vertical offset with the

drag gesture. For details, refer to the "Drag" section.

• Enable the touch screen function, and tap the channel status label at the bottom

of the screen. The following window is displayed. Tap the  icon at the

right side of the Offset input field to decrease or increase the offset. You can also

tap the input field to input a specific value with the displayed numeric keypad.
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Value Input Field Decrease Increase

5.5 Channel Coupling
The undesired signals can be filtered out by setting the coupling mode. For example,
the signal under test is a square waveform with DC offset.

• When the coupling mode is "DC": the DC and AC components of the signal

under test can both pass the channel.

• When the coupling mode is "AC": the DC components of the signal under test

are blocked.

• When the coupling mode is "GND": the DC and AC components of the signal

under test are both blocked.

Press  to open the CH1 setting menu.Then, press Coupling continuously or rotate

the multifunction knob  to select the desired coupling mode (by default, it is DC).
The current coupling mode is displayed in the channel status label at the bottom of
the screen, as shown in the figure below. You can also enable the touch screen, and
then touch the CH1 setting menu to select the desired coupling mode.

DC AC GND

NOTE

• When the input impedance is set to "50 Ω", the channel coupling is set to DC coupling by

force, and the Coupling menu is grayed out and cannot be modified.

• When the coupling mode is "AC", the input impedance is set to 1 MΩ by force, and the

Impedance menu is grayed out and cannot be modified.
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5.6 BW Limit
This series oscilloscope supports the bandwidth limit function. Setting the bandwidth
limit can reduce the noises in the displayed waveforms. For example, the signal under
test is a pulse with high frequency oscillation.

• When the bandwidth limit is disabled, the high frequency components of the

signal under test can pass the channel.

• When you enable the bandwidth limit and limit it to 20 MHz or 250 MHz, the

high frequency components found in the signal under test that are greater than

20 MHz or 250 MHz are attenuated.

Press  to open the CH1 setting menu.Then, press BW Limit continuously or rotate

the multifunction knob  to select the desired bandwidth limit. Press down the knob
to select it. By default, it is OFF. When the bandwidth limit is enabled, the character
"B" will be displayed in the channel status label at the bottom of the screen. You can
also enable the touch screen to select the desired BW limit.

The bandwidth limit that you select is based on the input impedance of the
oscilloscope, as shown in Table 5.2 BW Limit .

Table 5.2 BW Limit

Input Impedance of the Oscilloscope Available Bandwidth Limit

50 Ω 20 M

1 MΩ 20 MHz and 250 MHz

NOTE

Bandwidth limit can not only reduce the noise, but also can attenuate or eliminate the high

frequency components of the signal.

5.7 Probe Ratio
This series oscilloscope allows you to set the probe attenuation manually. To obtain
the correct measurement results, you must set the probe ratio properly. By default,
the probe ratio is 1X.
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Press  to open the CH1 setting menu.Then, press Attenuation continuously or

rotate the multifunction knob  to select the desired probe ratio. You can also
enable the touch screen, and then tap to select the desired probe ratio. The probe
ratio values available are as shown in the following table.

Table 5.3 Probe Ratio

Menu

Attenuation

(display amplitude of the signal under test: actual
amplitude of the signal under test)

0.0001X

0.0002X

0.0005X

0.001X

0.002X

0.005X

0.01X

0.02X

0.05X

0.1X

0.2X

0.5X

1X (default)

2X

5X

10X

20X

50X

100X

200X

500X

1000X

2000X

0.0001:1

0.0002:1

0.0005:1

0.001:1

0.002:1

0.005:1

0.01:1

0.02:1

0.05:1

0.1:1

0.2:1

0.5:1

1:1

2:1

5:1

10:1

20:1

50:1

100:1

200:1

500:1

1000:1

2000:1
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Menu

Attenuation

(display amplitude of the signal under test: actual
amplitude of the signal under test)

5000X

10000X

20000X

50000X

5000:1

10000:1

20000:1

50000:1

NOTE

After the oscilloscope auto-recognized certain probes with a fixed attenuation ratio, the probe

ratio will also be auto recognized. You do not have to set it manually.

5.8 Input Impedance
To reduce the circuit load between the oscilloscope and the circuit under test, this
oscilloscope provides two input impedance modes: 1 MΩ (default) and 50 Ω.

• 1 MΩ: The input impedance of the oscilloscope is very high, and the current

flowed from the circuit under test can be ignored.

• 50 Ω: makes the oscilloscope match with the device whose input impedance is

50 Ω.

Press  to open the CH1 setting menu.Then, press Impedance continuously to select
the input impedance of the oscilloscope. If you select "50Ω", the channel status label

at the bottom of the screen will display the icon .

NOTE

• After the oscilloscope recognizes the probe automatically, the input impedance will also

be auto recognized. You do not have to set it manually.

• The setting of the input impedance will affect the ranges of channel vertical scale and

offset.

5.9 Waveform Invert

Press  to open the CH1 setting menu. Then, press Invert continuously to enable or
disable the waveform invert. When enabled, the channel label is displayed, as shown
in the following figure.
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When the waveform invert is turned off, the waveform is displayed normally; when
the waveform invert is turned on, the voltage values of the displayed waveform are
inverted. Enabling the waveform invert will change the result of math function and
waveform measurement.

Figure 5.1 Waveform Invert

NOTE

When the waveform invert is enabled, the trigger edge or the trigger polarity will change (e.g.

Edge trigger, Pulse trigger, or Slope trigger).

5.10 To Set the Probe
The analog channel of this oscilloscope not only supports the common passive probe,
but also the active probe. It can automatically recognize the currently connected
probe type and its probe ratio. For detailed technical information of the probes,
please refer to the corresponding Probe User Guide.

Press  to open the CH1 setting menu. Then, press Probe to open the probe menu.
If different probes are connected to the oscilloscope, different information about the
probe will be displayed, and you can perform the different operations on the menu.

5.10.1 Passive Probe

If a passive probe is connected, for example, when RIGOL RP3500A probe model is
connected to the oscilloscope, press Probe to open the probe menu. Its sub-menus
are grayed out and disabled.

TIP

For some of the ordinary passive probes, the oscilloscope can recognize their probe ratio

automatically. If not recognized, please refer to "Probe Ratio" to set the probe ratio.
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5.10.2 Active Probe

If an active probe is connected, for example, when RIGOL RP7150 probe model is
connected to the oscilloscope, press Probe to open the probe menu, then operate on
the menu item.

TIP

• When a 50 Ω active probe is connected, the input impedance (refer to "Input
Impedance") of the channel will be automatically set to "50 Ω".

• For the active probe, the oscilloscope can recognize the probe ratio automatically. If the

currently connected probe supports a variety of probe ratios, please refer to Probe Ratio
to set the probe ratio.

Probe Delay

To avoid measurement result errors arising from the transmission delay of the probe
cable, the oscilloscope provides the probe delay adjustment function for the active

probe. Press Skew, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the probe delay.

Bias Voltage

The oscilloscope provides the bias voltage adjustment function for active probes. This
function is used to adjust the signal under test that exceeds the input dynamic range
of the probe amplifier to an appropriate range to ensure the integrity of the signal

under test. Press Bias, rotate the multifunction knob  or use the pop-up numeric
keypad to set the DC bias voltage.

Probe Information

Press About to view information about the probe currently connected, such as the
manufacturer, model, serial number, and the last calibration date.

Probe Calibration

Press Calibration to start zero calibration automatically for the probe.

5.11 Amplitude Unit
Sets the amplitude display unit for the current channel. The available units are W, A, V,
and U. When the amplitude unit is changed, the unit related to the channel will also
be changed accordingly.

Press  > More > Unit, then press Unit continuously or rotate the multifunction

knob  to select a unit. You can also enable the touch screen to select the desired
unit. The default unit is V.
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5.12 Channel Delay
When using an oscilloscope for actual measurement, the transmission delay of the
probe cable may bring relatively greater errors (zero offset). This series oscilloscope
allows you to set a delay time for calibrating the zero offset of the corresponding
channel. Zero offset is defined as the offset of the crossing point of the waveform and
trigger level line relative to the trigger position, as shown in Figure 5.2 .

Figure 5.2 Zero Offset

Press  > More > CH-CH Skew, rotate the multifunction knob  or use the
numeric keypad to set the desired delay calibration time. The available range of the
delay calibration time is from -100 ns to 100 ns.

NOTE

This parameter is related to the instrument model and the current horizontal time base setting.

The larger the horizontal time base is, the larger the setting step will be.

5.13 To Set the Bias
When you use an oscilloscope to make actual measurements, a small offset that arises
from the temperature drift of the component or external environment disturbance
may occur on the zero-cross voltage of the channel, which will affect the
measurement results of the vertical parameters. This series oscilloscope allows you to
set an offset calibration voltage for calibrating the zero point of the corresponding
channel, so as to improve the accuracy of the measurement results.

 To Set the Vertical System

Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved. 57



Press  > More > Bias, rotate the multifunction knob  or use the numeric keypad
to set the desired bias voltage.

NOTE

If the zero-cross voltage of the channel has a larger amplitude offset that exceeds the

adjustable null range, please perform self-calibration for the instrument to ensure the

measurement accuracy. For details, refer to descriptions in "SelfCal".

5.14 Channel Label
The instrument uses the channel number to mark the corresponding channel by

default. For ease of use, you can also set a label for each channel. For example, " ".

Press  > More > Label to enter the label setting menu. You can use the built-in
label or manually input a label. Three input methods are available for you to input a
label name, including Chinese, English, and Traditional Chinese.

The label setting menu includes the following menu items.

• Press Display to turn on or off the display of the channel label. If it is enabled,

the label will be displayed at the left side of the waveform. When on, CH1 is, by

default, displayed to be the channel label.

• Press Library to select the preset labels such as CH1, ACK, ADDR, BIT, CLK, CS,

DATA, IN, MISO, MOSI, OUT, RX and TX.

• Press Label, and the label editing interface is automatically displayed, as shown

in Figure 5.3 . You can input the label manually. For details, refer to descriptions

in "To Create a Folder".

Label Input Area Virtual Keypad Delete KeyInput Selection Area

Upper/Lower Case Switch

Figure 5.3 Label Editing Interface
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For example, set the label to " ". In the virtual keypad, tap "Caps" to switch
the uppercase or lowercase mode. Input "C", then tap OK to confirm the input. If

Display is enabled, the label  will be displayed at the left side of the CH1
waveform.

To delete or modify the input characters, tap to move the cursor to the right side
of the character required to be deleted or modified, and then tap the delete key
to delete the character. To modify the characters, input the desired characters
again.

The "Input Selection Area" is available for you to select Chinese characters when you
choose the Chinese input mode.

• Press Info, and the channel information sub-menu is displayed. Rotate the

multifunction knob  to select "Bandwidth" or "Bias", and press down the knob

to select it. Then the channel label displays the current bandwidth or bias. Both

the bandwidth and bias information can also be displayed at the same time in

the channel label, as shown in the figure below.

You can also enable the touch screen to drag the channel label to move its position
on the screen.

You can run the :CHANnel<n>:LABel:POSition command to set the position of the
specified channel label;

run the :CHANnel<n>:LABel:SIZe command to set the font size of the specified
channel label.
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6 To Set the Horizontal System

6.1 To Adjust the Horizontal Time Base
Horizontal time base, also called the horizontal scale, refers to the time of each grid in
the horizontal direction of the screen. It is usually expressed in s/div. The adjustable
range of the horizontal time base is related to the model type.

While you change the horizontal time base, the displayed waveforms of all channels
are expanded or compressed (please refer to "Horizontal Expansion") horizontally
relative to the current selected horizontal Expand baseline. The horizontal time base
at the upper-left corner of the screen will be changed accordingly, as shown in the
figure below.

You can adjust the horizontal time base with the following three methods:

• Rotate Horizontal  SCALE to adjust the horizontal time base within the

available range (clockwise to reduce the horizontal time base and

counterclockwise to increase).

• Enable the touch screen function and adjust the horizontal time base with the

pinch & stretch gesture on the touch screen. For details, refer to the "Pinch &

Stretch" section.

• Enable the touch screen function, and tap the Horizontal Scale label  at

the top of the screen. The following window is displayed. Tap the icon at the

right side of the Scale input field to decrease or increase the horizontal time

base.You can also tap the Scale input field to input a specific value with the

displayed numeric keypad.

Decrease the timebase Increase the timebase
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In the Horizontal control area (Horizontal) on the front panel, press the Horizontal 
SCALE knob to switch the adjustment mode between "Coarse" and "Fine" (by default,

it is Coarse). You can also press  > More > Fine to enable or disable the fine
adjustment of the horizontal time base.

• Coarse adjustment: Rotate the Horizontal  SCALE knob will adjust the

horizontal time base of the waveforms of all channels at 1-2-5 step within the

adjustable range. Rotate it clockwise to reduce the horizontal time base, and

counterclockwise to increase the horizontal time base.

• Fine adjustment: Rotate the Horizontal  SCALE knob will adjust the horizontal

time base of the waveforms of all channels with a minor step value within the

adjustable range. Rotate it clockwise to reduce the horizontal time base, and

counterclockwise to increase the horizontal time base.

NOTE

When the delayed sweep is enabled, rotate the Horizontal  SCALE knob to adjust the time

base for the delayed sweep. The delayed sweep time base displayed in the center of the screen

will be changed accordingly, as shown in the following figure.

6.2 To Adjust the Horizontal Position
Horizontal position, also called trigger position, refers to the trigger point position of
the waveforms of all channels in the horizontal direction relative to the screen center.
When the waveform trigger point is at the left (right) side of the screen center, the
horizontal position is a positive (negative) value.

While you change the horizontal position, the waveform trigger points and the
displayed waveforms of all channels are moved left and right. The horizontal position
at the right-upper corner of the screen changes accordingly, as shown in the figure
below.

You can adjust the horizontal Position with the following three methods:

• Rotate Horizontal  POSITION to adjust the horizontal position of the

waveforms of all channels. When you rotate the knob clockwise, the waveform
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trigger point moves right on the screen; when rotate it counterclockwise, the

waveform trigger point moves left. Press down this knob to quickly reset the

horizontal position (the horizontal position is reset to zero).

• Enable the touch screen function, and then adjust the Horizontal Position with

the drag gesture. For details, refer to the "Drag" section.

• Enable the touch screen function, and tap the Horizontal position label 

at the top of the screen. The following window is displayed. Tap the 

icon at the right side of the Pos input field to decrease or increase the horizontal

position.You can also tap the Pos input field to input a specific value with the

displayed numeric keypad.

Decrease the position Increase the position

NOTE

When the delayed sweep is enabled, rotate the Horizontal  POSITION to adjust the

horizontal position of the delayed sweep (press down the knob to quickly reset it). The

horizontal position of the delayed sweep at the upper-right corner of the screen changes

accordingly.

6.3 Delayed Sweep
Delayed sweep can be used to enlarge a length of waveform horizontally to view
waveform details.

In the horizontal control area on the front panel, press  to enable or disable the

delayed sweep. By default, it is disabled. You can also press  > More > Zoom to
enable or disable the delayed sweep function.
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NOTE

To enable the delayed sweep, you must ensure that the current time base mode is "YT".

In delayed sweep mode, the screen is divided into two display areas as shown in 
Figure 6.1 .

Main Time Base

Horizontal Position of 
the Delayed Sweep

Waveform Before 
Enlargement

Waveform After Enlargement

Figure 6.1 Delayed Sweep Mode

Waveform before enlargement:

The waveform in the area that is not covered by subtransparent blue in the upper part
of the screen is the waveform before enlargement. Its horizontal time base (also
called main time base) is displayed at the upper-left corner of the screen. You can

rotate the Horizontal  POSITION knob to move the area left and right or rotate the

Horizontal  SCALE knob to enlarge or reduce this area.

NOTE

If you need to modify the horizontal time base (also called main time base) of the normal

sweep, please disable the delayed sweep function first. Rotate the Horizontal  SCALE knob

to set the required main time base, and then enable the delayed sweep function.

Waveform after enlargement:

The waveform in the lower part of the screen is the horizontally expanded delayed
sweep waveform. Its horizontal time base (also called the time base of the delayed
sweep) is displayed on the screen. Compared with the main time base, the time based
of the delayed sweep has increased the waveform resolution. At this time, the
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Horizontal  SCALE knob is to adjust the time base of the delayed sweep, and the

Horizontal  POSITION knob is to adjust the horizontal position of the delayed
sweep.

NOTE

The time base of the delayed sweep should be smaller than or equal to the main time base.
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7 To Set the Sample System

7.1 Timebase Mode
This series of oscilloscope supports three available time base modes: YT mode, XY
mode, and ROLL mode. By default, the time base mode is YT.

Press  > Timebase Mode on the front panel, and then rotate the multifunction

knob  to select the desired mode. Then, press down the knob to select the mode.
You can also press Timebase Mode continuously or enable the touch screen to select
the desired mode.

7.1.1 YT Mode

In this mode, the Y axis represents voltage, and the X axis represents time.

NOTE

Only when this mode is enabled, can delayed sweep be turned on. In this mode, when the

horizontal time base is equal to or greater than 200ms/div, the instrument enters slow sweep

mode. For details, refer to descriptions in "ROLL Mode".

7.1.2 XY Mode

In this mode, both the X axis and the Y axis represent the voltage. The mode changes
the display from voltage-time display mode to voltage-voltage display. You can use
the Lissajous method to measure the phase deviation of the two input signals whose
frequencies are the same. The following figure shows the measurement schematic
diagram of phase deviation.
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Figure 7.1 Measurement Schematic Diagram of Phase Deviation

According to sinθ=A/B or C/D, θ is the phase deviation angle between the two
channels. The definitions of A, B, C, and D are shown in the above figure. The phase
deviation angle is obtained, that is:

θ=±arcsin(A/B) or ±arcsin(C/D)

If the principal axis of the ellipse is within Quadrant I and III, the phase deviation
angle obtained should be within Quadrant I and IV, namely within (0 to π/2) or (3π/2
to 2π). If the principal axis of the ellipse is within Quadrant II and IV, the phase
deviation angle obtained should be within Quadrant II and III, namely within (π/2 to
π) or (π to 3π/2).

The XY function can be used to measure the phase deviation occurred when the
signal under test passes through a circuit network. Connect the oscilloscope to the
circuit to monitor the input and output signals of the circuit.

Application example: measures the phase deviation between the input signals of two
channels.

Use Lissajous method

1. Connect one sine signal to CH1, and then connect another sine signal (with the

same frequency and amplitude as the previous one but a 90° phase deviation from

the previous one) to CH2.
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2. Press AUTO, after you select "XY" mode, rotate the Horizontal  SCALE knob to

adjust the sample rate properly to obtain a better view of Lissajous graph for

observation and measurement.

3. Rotate the Vertical  SCALE knob that corresponds to CH1 and CH2 respectively

to make the signals easy to observe. Then, a circle, as shown in the figure below,

should be displayed.

4. Observe the measurement result shown in the figure above. According to the

measurement schematic diagram of the phase deviation (as shown in Figure 7.1 ),

A/B(C/D)=1. Thus, the phase deviation angle of the two channel input signals is

θ=±arcsin1=90°.

NOTE

• The maximum sample rate in XY mode is 2.5 GSa/s. In this mode, CH1 and CH2 are

forced to be enabled; CH3 and CH4 are forced to be disabled. Generally, a longer sample

waveform can ensure better display effect of Lissajous figure. But due to the limitation of

the memory depth, you have to reduce the waveform sample rate to acquire a longer

waveform (refer to the introduction in "Memory Depth"). Therefore, during the

measurement, reducing the sample rate properly can achieve better display effect of

Lissajous figure.

• The following functions cannot be set in XY mode:

"Delayed Sweep", "To Select the Display Type", "Show Scale", "Protocol Decoding", "Pass/

Fail Test", "Waveform Recording and Playing", and "Digital Channel".
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7.1.3 ROLL Mode

In this mode, the waveform scrolls from right to left to update the display. The
available range of the horizontal scale is from 200 ms to 1 ks. Press More > Auto
ROLL to select "ON". The system automatically enters the ROLL mode, and slow
sweep mode is disabled.

NOTE

• If the current delayed sweep is enabled, then when you enable the ROLL mode, the

delayed sweep is disabled automatically. When you re-enable the "YT" mode, the delayed

sweep will be re-enabled.

• The following functions cannot be set in ROLL mode:

"To Adjust the Horizontal Position” (available when the oscilloscope is in "Stop"

operating status), "Delayed Sweep", "To Trigger the Oscilloscope", "Protocol Decoding",

"Pass/Fail Test", "Waveform Recording and Playing", and "To Set the Persistence Time".

Slow Sweep

It is similar to the ROLL mode. In YT mode, when the horizontal time base is set to
200 ms/div or smaller, the instrument enters the "slow sweep" mode in which the
instrument first acquires the data at the left of the trigger point and then waits for a
trigger event. After the trigger occurs, the instrument continues to finish the
waveform at the right of the trigger point. When observing the low-frequency signal
in the slow sweep mode, it is recommended that you set "Channel Coupling" to
"DC".

7.2 Acquisition Mode
The acquisition mode is used to control how to generate waveform points from the
sample points.

This series of oscilloscope supports the following four acquisition modes: Normal,
Average, Peak, and High Res. By default, the acquisition mode is Normal.

Press  > Acquisition on the front panel, and then rotate the multifunction knob

 to select the desired acquisition mode. Then, press down the knob to select the
mode. You can also press Acquisition continuously or enable the touch screen to
select the mode.

7.2.1 Normal

In this mode, the oscilloscope samples the signal at a specified fixed time interval to
rebuild the waveform. For most of the waveforms, using this mode can produce the
optimal display effects.

 To Set the Sample System

68 Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved.



7.2.2 Average

In this mode, the oscilloscope averages the waveforms from multiple samples to
reduce the random noise of the input signal and improve the vertical resolution.
Greater number of averages can lower the noise and increase the vertical resolution;
while at the same time, it will slow the response of the displayed waveform to the
waveform changes.

When you select "Average" mode, press Averages, and rotate the multifunction knob

 to set the desired number of averages. You can also use the pop-up numeric
keypad to input the average count. When the average count value is not in N power-
of-2 increments, a prompt message "Truncation average error" is displayed. At this
time, a value that is smaller than the one you input and the closest to N power-of-2
increments will be input automatically. For example, if you input 9 with the numeric
keypad, the average count will be automatically input as 8.

The number of averages can be set to 2, 4, 8, 16, 32, 64, 128, 256, 512, 1024, 2048,
4096, 8192, 16384, 32768, or 65536. By default, it is 2.

Figure 7.2 Waveforms before Averaging

Figure 7.3 Waveforms after 128 Times of Averaging
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7.2.3 Peak

In this mode, the oscilloscope acquires the maximum and minimum values of the
signal within the sample interval to get the envelope of the signal or the narrow pulse
that might be lost. In this mode, signal aliasing can be prevented, but the noise
displayed would be larger.

In this mode, the oscilloscope can display all the pulses whose pulse widths are at
least the same as the sample period.

7.2.4 High Resolution

This mode uses a kind of ultra-sample technique to average the neighboring points
of the sample waveform to reduce the random noise on the input signal and generate
much smoother waveforms on the screen. This is generally used when the sample
rate of the digital converter is higher than the storage rate of the acquisition memory.

NOTE

• The averaging modes of the "Average" and "High Res" are different. The former uses

"Multi-sample Average" and the latter uses "Single Sample Average".

• In "High Res" mode, the oscilloscope improves the measurement accuracy at the cost of

bandwidth. Each time the sampling rate changes, a window displaying the current

bandwidth appears temporally at the lower-left corner of the screen.

• In high-resolution mode, highest capture rate is not available.

• The available number of resolution bits is 9, 10, 11, and 12. When each bit resolution is

selected, a corresponding bandwidth is displayed temporarily.

• The high-resolution mode supports all the timebase modes: YT mode (including

recording and ZOOM), XY mode, ROLL mode, and SCAN mode.

• In high-resolution mode, the high-resolution waveforms can be exported, with 16 bits

per point.

• When high-resolution waveforms are imported, waveform plotting and analysis also

support high resolution.

7.3 Sampling Mode
This oscilloscope only supports the real-time sampling mode. In this mode, the
oscilloscope produce the waveform display from samples collected during one trigger
event. The highest real-time sample rate on the analog channel of this oscilloscope
series is 10 GSa/s. The current sample rate is displayed under CH SampleRate.

TIP

Press  on the front panel to stop sampling, and then the oscilloscope will maintain its

last captured graph. You can still expand or zoom the waveforms by using the horizontal and

vertical control knobs.
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7.4 Sample Rate
Sampling is the process of converting the analog signal into the digital signal at a
specified time interval and then restoring them in sequence. The sample rate is the
reciprocal of the time interval.

The sample rate of the analog channel is related to the current channel mode. The
maximum real-time sample rate in the single-channel mode of the oscilloscope is 10
GSa/s. The maximum real-time sample rate in the dual-channel mode is 5 GSa/s, and
the maximum real-time sample rate in the 4-channel mode is 2.5 GSa/s.

TIP

Single-channel mode: only one of the four channels (CH1/CH2/CH3/CH4) is enabled.

Dual-channel mode: either CH1 or CH2 is enabled; and either CH3 or CH4 is enabled.

4-channel mode: CH1/CH2 are both enabled or CH3/CH4 are both enabled.

NOTE

The sample rate is displayed both in the status bar at the upper part of the screen and in the

CH SampleRate menu. To indirectly modify the sample rate, rotate the Horizontal  SCALE

knob to adjust the horizontal time base or modify the memory depth. In addition, if the

triggering source selects the analog channel, the channel mode will be changed, and thus

affecting the sampling rate.

The impact of low sample rate on the waveform:

1. Waveform Distortion: when the sample rate is too low, some waveform details

are lost, and the sample waveform displayed is rather different from the actual

waveform of the signal.

2. Waveform Aliasing: when the sample rate is twice lower than the actual signal

frequency (Nyquist Frequency), the frequency of the waveform rebuilt from the

sample data is smaller than the actual signal frequency.

 To Set the Sample System

Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved. 71



3. Waveform Leakage: when the sample rate is too low, the waveform rebuilt from

the sample data do not reflect all the actual signal information.

7.5 LA Sample Rate
LA sampling is the process of sampling on the compared digital signals at a certain
time interval. LA sample rate is the reciprocal of the time interval. For example, if the
LA sample rate is 500 MSa/s, it indicates that the oscilloscope will make data
acquisition on the digital signals at an interval of 2 ns. The maximum LA sample rate
of the oscilloscope is 1.25 GSa/s, and its display value is related to the sample rate of
the current analog channel.

NOTE

• The digital signals mentioned here refers to the signal obtained from the comparison

between the input signal and the user-defined threshold level. The rule of the

comparison is that when the amplitude of the input signal is greater than the threshold

level, it is judged to be the logic high level; when the amplitude of the input signal is

smaller than the threshold level, it is judged to be the logic low level.

• LA sample rate is displayed under the LA SampleRate menu. To indirectly modify the LA

sample rate, rotate the Horizontal  SCALE knob to adjust the horizontal time base or

modify the memory depth.

7.6 Memory Depth
Memory depth refers to the number of points of the oscilloscope that can store in
one trigger acquisition. It reflects the storage capability of the acquisition storage.
This oscilloscope is equipped with a standard memory depth of up to 500 Mpts.
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Figure 7.4 Memory Depth

The following equation shows the relations among memory depth, sample rate, and
horizontal time base scale:

MDepth = SRate x TScale x HDivs

• Mdepth: indicates the memory depth. The unit is pts.

• SRate: indicates the sample rate. The unit is Sa/s.

• TScale: indicates the horizontal time base scale. The unit is s/div.

• HDivs:indicates the number of grids in the horizontal direction. The unit is div.

Therefore, under the same horizontal time base scale, a higher memory depth can
ensure a higher sample rate.

Press  > Mem Depth, then rotate the multifunction knob  to select the
desired memory depth, and then press down the knob to select it. You can also press
Mem Depth continuously or enable the touch screen to select the desired memory
depth. By default, the memory depth is Auto.

• In single-channel mode, the memory depths available include Auto, 1 Kpts, 10

Kpts, 100 Kpts, 1 Mpts, 10 Mpts, 25 Mpts, 50 Mpts, 100 Mpts, 125 Mpts, 250

Mpts, and 500 Mpts.

• In dual-channel mode, the memory depths available include Auto, 1 Kpts, 10

Kpts, 100 Kpts, 1 Mpts, 10 Mpts, 25 Mpts, 50 Mpts, 100 Mpts, 125 Mpts, and 250

Mpts.
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• In 4-channel mode, the memory depths available include Auto, 1 Kpts, 10 Kpts,

100 Kpts, 1 Mpts, 10 Mpts, 25 Mpts, 50 Mpts, 100 Mpts, and 125 Mpts.

NOTE

In "Auto" mode, the oscilloscope selects the memory depth automatically according to the

current sample rate.

7.7 LA Memory Depth

Press  > More to view the memory depth of the current digital channel under
LA Mem Depth. The LA memory depth will change with the memory depth of the
analog channel, and cannot be set separately. The maximum LA memory depth is
62.5 Mpts.

7.8 Anti-Aliasing
At a slower sweep speed, the sample rate is reduced, and a dedicated display
algorithm can be used to minimize the possibility of aliasing.

Press  > Anti-Aliasing to enable or disable the anti-aliasing function. By default,
anti-aliasing is disabled. In this case, it is more likely to generate waveform aliasing.

NOTE

This function should be enabled when the horizontal time base has a large deviation from the

period of the signal under test (e.g. when the horizontal time base is greater than five-fold the

period of the signal under test).

7.9 Horizontal Expansion
Horizontal expansion indicates the reference position that the screen waveform is
referenced to when it is horizontally expanded or compressed in adjusting the

Horizontal  SCALE knob. In YT mode, press  > More > Expand, then rotate

the multifunction knob  to switch to the desired memory depth, and then press
down the knob to select the option. You can also press the Expand key continuously
or use the touch screen to select the desired reference. The horizontal expansion
reference supported by the oscilloscope includes Center, Left, Right, Trigger, and User.
The default is "Center".

• Center: when the horizontal time base is modified, the waveform will be

expanded or compressed horizontally relative to the screen center.
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• Left: when the horizontal time base is modified, the waveform will be expanded

or compressed horizontally relative to the leftmost position of the screen.

• Right: when the horizontal time base is modified, the waveform will be expanded

or compressed horizontally relative to the rightmost position of the screen.

• Trigger: when the horizontal time base is modified, the waveform will be

expanded or compressed horizontally relative to the trigger point.

• User: when the horizontal time base is modified, the waveform displayed will be

expanded or compressed horizontally relative to the user-defined reference

position.

After you select "User", press Expand User and then rotate the multifunction

knob  to set the expansion reference. Its available range is from rightmost
position of the screen to leftmost position of the screen. By default, it is the

screen center. Pressing down the multifunction knob  can quickly reset the
user-defined reference position to 0.

NOTE

This function is unavailable in XY mode, ROLL mode, and YT mode with the delayed sweep

being enabled.
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8 To Trigger the Oscilloscope
As for trigger, you set certain trigger condition according to the requirement and
when a waveform in the waveform stream meets this condition, the oscilloscope
captures this waveform as well as the neighboring part, and displays them on the
screen. For the digital oscilloscope, it samples waveform continuously no matter
whether it is stably triggered, but only stable trigger can be stably displayed. The
trigger module ensures that every time base sweep or acquisition starts from the
user-defined trigger condition, namely every sweep is synchronous with the
acquisition and the waveforms acquired is overlapped so as to display the stable
waveforms.

Trigger settings should be based on the features of the input signal. To quickly
capture the desired waveform, you need to understand the signal under test. This
oscilloscope provides abundant trigger types that help you focus on the desired
waveform details.

8.1 Trigger Source

In the trigger control area on the front panel, press  > Source, then rotate the

multifunction knob  to select a desired source, then press down the knob to select
it. You can also press Source continuously or enable the touch screen to select it.

The analog channels (CH1-CH4), digital channels (D0-D15), EXT, or AC Line can all be
selected as the trigger source.

Analog channel input:

Signals input from analog channels CH1-CH4 can all be used as trigger sources. No
matter whether the channel selected is enabled, the channel can work normally.

Digital channel input:

Signals input from digital channels D0-D15 can all be used as trigger sources. No
matter whether the channel selected is enabled, the channel can work normally.

External trigger input:

The external trigger source can trigger on the fifth channel while all the other four
channels are acquiring data. The trigger signal (e.g. external clock or signal of the
circuit under test) will be connected to EXT trigger source via the external trigger
input terminal [EXT TRIG] connector. You can set the trigger conditions within the
range of the trigger level (from -8 V to +8 V).

AC line input:

The trigger signal is obtained from the AC power input of the oscilloscope. AC trigger
is usually used to measure signals relevant to the AC power frequency. For example,
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stably triggering the waveform output from the transformer of a transformer
substation. It is mainly used in related measurements of the power industry.

8.2 Trigger LEVEL/Threshold Level
The adjustment of the trigger level/threshold level is related to the type of the trigger
source.

• When the trigger source is selected from CH1 to CH4, rotate the Trigger 
LEVEL knob to adjust the trigger level. During the adjustment, a trigger level line
(the color of the trigger level line is the same as that of the channel) and a

trigger label " " are displayed on the screen, and they move up and down with
the variation of the trigger level. When you stopping modifying the trigger level,
the trigger level line disappears in about 2 s. The current trigger level of is
displayed at the upper-right corner of the screen.

NOTE

In Runt Trigger, Slope Trigger, and Window trigger, you need to set the upper and lower

limits of the trigger level. Rotate the Trigger  LEVEL knob to adjust the trigger level.

The difference between the current upper limit and lower limit of the trigger level is

displayed at the upper-right side of the screen. Two trigger level labels  and  are

displayed at the left side of the screen. During the adjustment of trigger level, two trigger

level lines appear on the screen, and they move up and down with the change of the

trigger level. At the same time, the real-time trigger level information is displayed at the

lower-left corner of the screen (As shown in the figure below, H indicates the upper limit

of the trigger level, L indicates the lower limit of the trigger level, and △ indicates the

trigger level deviation).

• When the trigger source is EXT, rotate the Trigger  LEVEL knob to adjust the
trigger level. The current trigger level of is displayed at the upper-right corner of
the screen.

NOTE

For this trigger source, only the variation of the trigger level value is displayed on the

screen during the adjustment of the trigger level, without displaying the trigger level

lines on the screen.

• When the trigger source is AC Line, there is no trigger level.

• When the trigger source is D0-D15, rotate the Trigger  LEVEL knob to adjust

the threshold level. The current threshold level value is displayed at the upper-
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right corner of the screen. In addition, you can also press  to enter the LA

logic analysis setting menu. Then set the threshold level of the digital channel in

the sub-menu threshold setting. For the setting method, refer to "To Set the

Threshold".

You can also enable the touch screen to adjust the trigger level/threshold level.
Two methods are available for you:

Method 1: Enable the touch screen and drag the trigger level line to adjust the
trigger level. For details about the operations, refer to descriptions in "Drag".

Method 2: Enable the touch screen, and tap the trigger setting label

 at the upper-right corner of the screen. The following window is

displayed. Tap the  icon at the right side of the input field of the trigger
level to decrease or increase the trigger level. You can also tap the input field of
the trigger level to input a specific value with the displayed numeric keypad.

Level Input Field Decrease the level Increase the level

8.3 Trigger Mode
The following is the schematic diagram of the acquisition memory. To easily
understand the trigger event, we classify the acquisition memory into the pre-trigger
buffer and post-trigger buffer.

Pre-trigger Buffer Post-trigger Buffer

Trigger Event

Acquisition Memory

Figure 8.1 Schematic Diagram of the Acquisition Memory

After the system runs, the oscilloscope operates by first filling the pre-trigger buffer.
It starts searching for a trigger after the pre-trigger buffer is filled. While searching for
the trigger, the data sampled will still be transmitted to the pre-trigger buffer (the
new data will continuously overwrite the previous data). When a trigger is found, the
pre-trigger buffer contains the data acquired just before the trigger. Then, the

 To Trigger the Oscilloscope

78 Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved.



oscilloscope will fill the post-trigger buffer and display the data in the acquisition

memory. If the acquisition is activated via , the oscilloscope will repeat this

process; if the acquisition is activated via , the oscilloscope will stop after
finishing a single acquisition (you can pan and zoom the currently displayed
waveform).

This oscilloscope provides Auto, Normal, and Single trigger modes. The default is
Auto.

In the trigger control area on the front panel, press  to quickly switch the
current trigger mode. The trigger mode is displayed at the upper-right corner of the
screen: A (Auto), N (Normal), and S (Single).

• Auto: In this trigger mode, if the specified trigger conditions are not found, the

oscilloscope will initiate a trigger and capture waveforms forcibly. This trigger

mode should be used when the signal level is unknown or the DC should be

displayed as well as when forcible trigger is not necessary as the trigger

condition always occurs.

• Normal: In this trigger mode, triggers and acquisitions only occur when the

specified trigger conditions are found. This trigger mode should be used when

the signal is with low repetition rate or only the event specified by the trigger

setting needs to be sampled as well as when auto trigger should be prevented to

acquire stable display.

• Single: In this trigger mode, the oscilloscope performs a single trigger and

acquisition when the specified trigger conditions are found, and then stops. This

trigger mode should be used when you need to perform a single acquisition of

the specified event and analyze the acquisition result (you can pan and zoom the

currently displayed waveform, and the subsequent waveform data will not

overwrite the current waveform). After a single trigger mode is initiated, the

operating status of the oscilloscope turns out to be in "STOP" state.

NOTE

In Normal and Single trigger modes, pressing  can generate a trigger signal forcibly.
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You can also enable the touch screen to set the trigger mode. Tap the trigger setting

label  at the upper-right corner of the screen. Then the following
window is displayed. Tap to select "Auto", "Normal", or "Single" as the trigger mode.

Level Input Field Decrease the level Increase the level

8.4 Trigger Coupling
Trigger coupling decides which kind of components will be transmitted to the trigger
module. Please distinguish trigger coupling from "Channel Coupling".

NOTE

Trigger coupling is only valid when the trigger type is Edge and the trigger source is an analog

channel.

Press  > Coupling in the trigger control area on the front panel, and then rotate

the multifunction knob  to select the desired coupling mode (by default, it is DC).
You can also press Coupling key continuously or use the touch screen to select the
desired coupling mode.

• DC: allows DC and AC components to pass the trigger path.

• AC: blocks the DC components and attenuates signals.

• LFR: blocks the DC components and rejects the low-frequency components.

• HFR: rejects the high frequency components.

TIP

When "AC" or "LFR" is selected under Coupling, no trigger level lines and trigger icons are

displayed. When you adjust the trigger level, you can only see the changes of the trigger level

values at the upper-right corner of the screen.

8.5 Trigger Holdoff
Trigger holdoff can be used to stably trigger on complex repetitive waveforms that
have multiple edges (or other events) between waveform repetitions (such as pulse
series). Holdoff time indicates the time that the oscilloscope waits for re-arming the
trigger module after generating a correct trigger. The oscilloscope will not trigger
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even if the trigger condition is met during the holdoff time and will only re-arm the
trigger module after the holdoff time expires.

For example, to stably trigger the repetitive pulse series as shown in the figure below,
the holdoff time should be set to a value that is greater than t1 and smaller than t2.

Holdoff Time Trigger Position

t1
t2

Figure 8.2 Schematic Diagram of Trigger Holdoff

In the trigger control area (Trigger), press  > Holdoff (for some trigger, Holdoff

is a sub menu under More, at this time, press  > More > Holdoff), and then

rotate the multifunction knob  at a small step to modify the holdoff time (the
holdoff to this time when the waveforms are stably triggered; by default, the holdoff
time is 8 ns) or use the numeric keypad to set the holdoff time. The adjustable range
of the holdoff time is from 8 ns to 10 s.

8.6 Noise Rejection
Noise rejection can reject the high frequency noise in the signal and reduce the
possibility of miss-trigger of the oscilloscope.

In the trigger control area (Trigger) on the front panel, press  to enter the
trigger setting menu, then press Noise Reject continuously (for some trigger, Noise

Reject is a sub-menu under More, at this time, press  > More > Noise Reject)
to enable or disable the noise rejection.

NOTE

This function is only valid when the trigger source is an analog channel.

8.7 Trigger Type
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8.7.1 Edge Trigger

Triggers on the trigger leve/threshold level of the specified edge of the input signal.

Trigger Type:

In the trigger control area (Trigger) on the front panel, press  > Type, and rotate

the multifunction knob  to select "Edge", then press down the knob to select it. You
can also press Type continuously or enable the touch screen to select it. At this time,
the current trigger setting information (including trigger type, trigger source, and
trigger level/threshold level) is displayed at the upper-right corner of the screen, as
shown in the figure below. The information will change based on the trigger settings.

Source Selection:

Press Source to open the signal source list and select CH1-CH4, AC Line, EXT, or D0-
D15. For details, refer to descriptions in "Trigger Source". The current trigger source is
displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.

Edge Type:

Press Slope, then rotate the multifunction knob  to select the input signal edge on
which the oscilloscope triggers. Then the current edge type is displayed at the upper-
right corner of the screen. You can also press Slope continuously or enable the touch
screen to select it.

• Rising: triggers on the rising edge of the input signal when the voltage level

meets the specified trigger level.

• Falling: triggers on the falling edge of the input signal when the voltage level

meets the specified trigger level.

• Either: triggers on the rising or falling edge of the input signal when the

voltage level meets the preset trigger level.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".
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Trigger Parameter Setting:

Sets the trigger parameters (trigger coupling, trigger holdoff and noise rejection)
under this trigger type. For details, refer to descriptions in "Trigger Coupling", "Trigger
Holdoff" and "Noise Rejection".

Trigger LEVEL/Threshold Level:

Rotate the Trigger  LEVEL knob to adjust the trigger level or threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.

8.7.2 Pulse Trigger

Triggers on the positive or negative pulse with a specified width. In this mode, the
oscilloscope will trigger when the pulse width of the input signal satisfies the
specified pulse width condition.

In this oscilloscope, positive pulse width is defined as the time difference between the
two crossing points of the trigger level and positive pulse; negative pulse width is
defined as the time difference between the two crossing points of the trigger level
and negative pulse, as shown in the figure below.

Trigger Level

+Width

A B

-Width

A B
Trigger Level

Figure 8.3 Positive Pulse Width/Negative Pulse Width

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "Pulse". Press down
the knob to select the trigger type. Then, the current trigger setting information is
displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Source Selection:
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Press Source to open the signal source list and select CH1-CH4 or D0-D15. For
details, refer to descriptions in "Trigger Source". The current trigger source is
displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.

Polarity:

Press Polarity continuously to select the desired polarity. The polarities available are

positive polarity ( ) or negative polarity ( ).

Trigger Condition:

Press When, then rotate the multifunction knob  to select the trigger condition,
and then press down the knob to select it. You can also press When continuously or
enable the touch screen to select it.

• When you select "Positive" for polarity and ">" for trigger condition, the

oscilloscope triggers when the positive pulse width of the input signal is greater

than the specified pulse width.

• When you select "Positive" for polarity and "<" for trigger condition, the

oscilloscope triggers when the positive pulse width of the input signal is smaller

than the specified pulse width.

• When you select "Positive" for polarity and "<>" for trigger condition, the

oscilloscope triggers when the positive pulse width of the input signal is greater

than the specified lower limit of pulse width and smaller than the specified

upper limit of pulse width.

• When you select "Negative" for polarity and ">" for trigger condition, the

oscilloscope triggers when the negative pulse width of the input signal is greater

than the specified pulse width.

• When you select "Negative" for polarity and "<" for trigger condition, the

oscilloscope triggers when the negative pulse width of the input signal is smaller

than the specified pulse width.

• When you select "Negative" for polarity and "<>" for trigger condition, the

oscilloscope triggers when the negative pulse width of the input signal is greater
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than the specified lower limit of pulse width and smaller than the specified

upper limit of pulse width.

Pulse Width Setting:

• When">" or "<" is set to trigger conditions, press Lower or Upper , and then

rotate the multifunction knob  to set the lower limit value or the upper limit

value. You can also use the pop-up numeric keypad to set it. The pulse range

available is from 800 ps to 10 s.

• When the trigger condition is set to "<>", press Upper and Lower, and then

rotate the multifunction knob  to set the upper limit value and the lower limit

value. You can also use the pop-up numeric keypad to set them.

NOTE

The lower limit of the pulse width must be smaller than the upper limit.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameters (trigger holdoff and noise rejection) under this trigger
type. For details, refer to descriptions in "Trigger Holdoff" and "Noise Rejection".

Trigger LEVEL/Threshold Level:

Rotate the Trigger  LEVEL knob to adjust the trigger level or threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.

8.7.3 Slope Trigger

In Slope trigger, the oscilloscope triggers on the positive or negative slope of the
specified time. This trigger mode is applicable to ramp and triangle waveforms.

In this oscilloscope, positive slope time is defined as the time difference between the
two crossing points of trigger level line A and B with the rising edge; negative slope
time is defined as the time difference between the two crossing points of trigger level
line A and B with the falling edge. As shown in the figure below:
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Upper Limit of Trigger Level
(Up Level)

Lower Limit of Trigger Level
(Low Level)

A

B

Positive Slope Time Negative Slope Time

Figure 8.4 Positive Slope Time/Negative Slope Time

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "Slope". Press down
the knob to select the trigger type. Then, the current trigger setting information is
displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Source Selection:

Press Source to switch the trigger source and select CH1-CH4. For details, refer to
descriptions in "Trigger Source". The current trigger source is displayed at the upper-
right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger Wave.

Edge Type:

Press Slope to select the input signal edge on which the oscilloscope triggers.

• Rising: triggers on the rising edge of the input signal.

• Falling: triggers on the falling edge of the input signal.

Trigger Condition:

Press When, then rotate the multifunction knob  to select the trigger condition,
and then press down the knob to select the trigger condition. You can also press
When continuously or enable the touch screen to select it.

• When you select "Rising" for the edge type and ">" for trigger condition, the

oscilloscope triggers when the positive slope time of the input signal is greater

than the specified time.
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• When you select "Rising" for the edge type and "<" for trigger condition, the

oscilloscope triggers when the positive slope time of the input signal is smaller

than the specified time.

• When you select "Rising" for the edge type and "<>" for trigger condition, the

oscilloscope triggers when the positive slope time of the input signal is greater

than the specified lower limit time and smaller than the specified upper limit

time.

• When you select "Falling" for the edge type and ">" for trigger condition, the

oscilloscope triggers when the negative slope time of the input signal is greater

than the specified time.

• When you select "Falling" for the edge type and "<" for trigger condition, the

oscilloscope triggers when the negative slope time of the input signal is smaller

than the specified time.

• When you select "Falling" for the edge type and "<>" for trigger condition, the

oscilloscope triggers when the negative slope time of the input signal is greater

than the specified lower limit time and smaller than the specified upper limit

time.

Slope Time Setting:

• When the Trigger Condition is set to ">" or "<", press Lower or Upper, and

then rotate the multifunction knob  to set the lower limit value or the upper

limit value. You can also use the numeric keypad to set it. The available range of

the slope time is from 800 ps to 10 s.

• When the Trigger Condition is set to "<>", press Upper and Lower, and then

rotate the multifunction knob  to set the upper limit value and the lower limit

value. You can also use the numeric keypad to set them.

NOTE

The lower slope time limit must be smaller than the upper slope time limit.

Level Selection and Adjustment of Trigger Level:
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After the trigger condition setting is completed, you need to adjust the trigger level
to correctly trigger the signal and obtain a stable waveform. Press Level Select (when
"<>" is selected as the trigger condition, Level Select is a sub-menu under More),

then rotate the multifunction knob  to select the desired level type for adjustment,
and then press down the knob to select the type. You can also press Level Select
continuously or enable the touch screen to select it.

• Level A: only adjusts the upper limit of the trigger level, and the lower limit of

the trigger level remains unchanged.

• Level B: only adjusts the lower limit of the trigger level, and the upper limit of the

trigger level remains unchanged.

• Level AB: adjusts the upper and lower limits of the trigger level at the same time,

and the trigger level deviation (the difference between the upper limit and lower

limit of the trigger level) remains unchanged.

NOTE

In Slope trigger, pressing Trigger  LEVEL can quickly switch the current level adjustment

type.

Rotate the Trigger  LEVEL knob to adjust the corresponding trigger level. During
the adjustment of trigger level, two trigger level lines appear on the screen, and they
move up and down with the change of the trigger level. At the same time, the real-
time trigger level information is displayed at the lower-left corner of the screen (As
shown in the figure below, H indicates the upper limit of the trigger level, L indicates
the lower limit of the trigger level, and △ indicates the trigger level deviation). When
you stopping modifying the trigger level, the trigger level line and the trigger level
information at the lower-left corner of the screen disappear in about 2 s. The current
trigger level deviation is displayed at the upper-right corner of the screen.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameters (trigger holdoff and noise rejection) under this trigger
type. For details, refer to descriptions in "Trigger Holdoff" and "Noise Rejection".
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8.7.4 Video Trigger

The video signal can include image information and timing information, which adopts
different standards and formats. This series oscilloscope can trigger on the standard
video signal field or line of NTSC (National Television Standards Committee), PAL
(Phase Alternating Line), or SECAM (Sequential Couleur A Memoire).

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "Video". Press down
the knob to select the type. Then, the current trigger setting information is displayed
at the upper-right corner of the screen, as shown in the figure below. You can also
press Type continuously or enable the touch screen to select it.

Source Selection:

Press Source to switch the trigger source and select CH1-CH4. For details, refer to
descriptions in "Trigger Source". The current trigger source is displayed at the upper-
right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger Wave.

Video Polarity:

Press Polarity continuously to select the desired video polarity. The polarities

available are positive polarity ( ) and negative polarity ( ).

Video Standard:

Press Standard, and rotate the multifunction knob  to select the desired video
standard. You can also press Standard continuously or enable the touch screen to
select it.

Video Standard
Frame
Frequency
(Frame)

Scan Type TV Scan Line

NTSC 30 Interlaced Scan 525

PAL/SECAM 25 Interlaced Scan 625

480p/60Hz 60 Progressive Scan 525

576p/50Hz 50 Progressive Scan 625
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Video Standard
Frame
Frequency
(Frame)

Scan Type TV Scan Line

720p/60Hz 60 Progressive Scan 750

720p/50Hz 50 Progressive Scan 750

720p/30Hz 30 Progressive Scan 750

720p/25Hz 25 Progressive Scan 750

720p/24Hz 24 Progressive Scan 750

1080p/60Hz 60 Progressive Scan 1125

1080p/50Hz 50 Progressive Scan 1125

1080p/30Hz 30 Progressive Scan 1125

1080p/25Hz 25 Progressive Scan 1125

1080p/24Hz 24 Progressive Scan 1125

1080i/60Hz 60 Interlaced Scan 1125

1080i/50Hz 50 Interlaced Scan 1125

Sync:

Press Sync, then rotate the multifunction knob  to select the sync type, and then
press down the knob to select it. You can also press Sync continuously or enable the
touch screen to select it.

• All Lines: triggers on the first line found.

• Line: triggers on the specified line.

When this sync type is selected, you can specify a line number. Press Line, then

rotate the multifunction knob  or use the pop-up numeric keypad to modify
the line number. The range of the line number is related to the currently selected
video standards. The range is from 1 to 525 (NTSC), 1 to 625 (PAL/SECAM, 1 to
525 (480p), 1 to 625 (576p), 1 to 750 (720p), or 1 to 1125 (1080p/1080i).

• Odd: triggers on the rising edge of the first ramp pulse in the odd field. It is

available when the video standard is NTSC, PAL/SECAM, or 1080i.
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• Even: triggers on the rising edge of the first ramp pulse in the even field. It is

available when the video standard is NTSC, PAL/SECAM, or 1080i.

Noise Rejection:

Sets the trigger parameter (noise rejection) under this trigger type. For details, refer
to descriptions in "Noise Rejection".

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Level:

Rotate the Trigger  LEVEL knob to modify the level. For details, refer to
descriptions in "Trigger LEVEL/Threshold Level".

TIP

• For a better observation of the waveform details in the video signal, you can set a larger

memory depth first.

• In the trigger debugging process of video signals, the frequency in different part of the

signal can be reflected by a different brightness, as RIGOL digital oscilloscope provides

the intensity graded color display function. Experienced users can quickly judge the

signal quality and discover abnormalities during the debugging process.

8.7.5 Pattern Trigger

Identifies a trigger condition by searching for a specified pattern. This pattern is a
logical "AND" and "OR" combination of channels. Each channel can be set to H (high),
L (low), or X (don't care). A rising or falling edge (you can only specify a single edge)
can be specified for one channel included in the pattern. When an edge is specified,
the oscilloscope will trigger at the edge specified if the pattern set for the other
channels are true (namely the actual pattern of the channel is the same as the preset
pattern). If no edge is specified, the oscilloscope will trigger on the last edge that
makes the pattern true. If all the channels in the pattern are set to "X", the
oscilloscope will not trigger.
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Figure 8.5 Pattern Trigger

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "Pattern". Press down
the knob to select the trigger type. Then, the current trigger setting information is
displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Source Selection:

Press Source to open the signal source list and select CH1-CH4 or D0-D15. For
details, refer to descriptions in "Trigger Source". The current trigger source is
displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger Wave.

Pattern Setting:

Press Code, then rotate the multifunction knob  to select the pattern of the
currently selected channel, and then press down the knob to select it. You can also
press Code continuously or enable the touch screen to select it. The following five
patterns are available:

• H: sets the pattern of the channel selected to "1", i.g. the voltage level is higher

than the trigger level/threshold level of the channel.

• L: sets the pattern of the channel selected to "0", i.g. the voltage level is lower

than the trigger level/threshold level of the channel.
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• X: sets the pattern of the channel selected to "X", i.g. this channel is not used as

a part of the pattern. When all channels in the pattern are set to "X", the

oscilloscope will not trigger.

• Rising: sets the pattern to the rising edge (" ") of the channel selected.

• Falling: sets the pattern to the falling edge (" ") of the channel selected.

At this time, the corresponding pattern is displayed at the bottom of the screen. The
patterns of channels CH1-CH4 and D0-D15 are presented from left to right, as shown
in the figure below.

You can also set the pattern with the virtual keypad. The setting methods are as
follows:

Enable the touch screen to tap the channel pattern. Then, a virtual keypad is
displayed. Set the channel pattern with the keypad. For example, tap CH2 pattern,
then the the channel pattern is displayed, as shown in Figure 8.6 . Tap the left arrow

key  to move the cursor to the left or tap the right arrow key  to move the
cursor to the right. Then select a pattern. After the pattern of the current channel is
set completely, the cursor goes to the next pattern bit automatically. Set them
respectively. After all the pattern bits are set completely, tap OK to confirm the
setting, and close the virtual keypad. You can also tap ALL to apply the current pattern
to all the channels. This key functions the same as the All Bits menu key.

Confirmation Key

All Bits
Move the cursor 
to the left
Move the cursor 
to the right

Pattern

Figure 8.6 Virtual Keypad for Pattern Setting

NOTE

Only one edge (rising or falling edge) can be specified in the pattern. If one edge item is

currently defined and then another edge item is defined in another channel in the pattern,
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then a prompt message "Invalid input" is displayed. Then, the latter defined edge item will be

replaced by X.

All Bits:

Press All Bits to set the patterns of all trigger sources to the pattern settings selected
currently.

Trigger Condition:

Press When, then rotate the multifunction knob  to select the trigger condition,
and then press down the knob to select it. You can also press When continuously or
enable the touch screen to select it.

• And: triggers when the pattern meets the logical AND condition.

• Or: triggers when the pattern meets the logical OR condition.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameters (trigger holdoff and noise rejection) under this trigger
type. For details, refer to descriptions in "Trigger Holdoff" and "Noise Rejection".

Trigger LEVEL/Threshold Level:

Rotate the Trigger  LEVEL knob to adjust the trigger level/ threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.

8.7.6 Duration Trigger

In duration trigger, the instrument identifies a trigger condition by searching for the
duration of a specified pattern. This pattern is a logical "AND" combination of the
channels. Each channel can be set to H (high), L (low), or X (don't care). The
instrument triggers when the duration (△T) of this pattern meets the preset time, as
shown in the figure below.
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Figure 8.7 Duration Trigger

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "Duration". Press
down the knob to select the trigger type. Then, the current trigger setting information
is displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Source Selection:

Press Source to open the signal source list and select CH1-CH4 or D0-D15. For
details, refer to descriptions in "Trigger Source". The current trigger source is
displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger Wave.

Pattern Setting:

Press Code, then rotate the multifunction knob  to select the pattern of the current
signal source. Press down the knob to select it. At this time, the corresponding
pattern is displayed at the bottom of the screen. The patterns of channels CH1-CH4
and D0-D15 are presented from left to right, as shown in the figure below. You can
also press Code continuously or enable the touch screen to select it.
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• H: sets the pattern of the channel selected to "H", i.g. the voltage level is higher

than the trigger level/threshold level of the channel.

• L: sets the pattern of the channel selected to "L", i.g. the voltage level is lower

than the trigger level/threshold level of the channel.

• X: sets the pattern of the channel selected to "X", i.g. this channel is not used as

a part of the pattern. When all channels in the pattern are set to "Don’t Care",

the oscilloscope will not trigger.

Trigger Condition:

Press When, then rotate the multifunction knob  to select the the desired trigger
condition, and then press down the knob to select it. You can also press When
continuously or enable the touch screen to select it.

• >: triggers when the duration of the pattern is greater than the preset time.

Press Lower to set the lower limit of the duration of the pattern. Its range is from

800 ps to 10 s.

• <: triggers when the duration of the pattern is smaller than the preset time.

Press Upper to set the upper limit of the duration of the pattern. Its range is

from 800 ps to 10 s.

• <>: triggers when the duration of the pattern is smaller than the upper limit of

the preset time and greater than the lower limit of the preset time. Press Upper

to set the upper limit of the duration of the pattern. Its range is from 801 ps to

10 s. Press Lower to set the lower limit of the duration of the pattern. Its range is

from 800 ps to 9.9 s.

• > <: triggers when the duration of the pattern is greater than the upper limit of

the preset time or smaller than the lower limit of the preset time. Press Upper to

set the upper limit of the duration of the pattern. Its range is from 800 ps to 10 s.

Press Lower to set the lower limit of the duration of the pattern. Its range is from

800 ps to 9.9 s.

NOTE
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The lower time limit must be smaller than the upper time limit.

All Bits:

Press All Bits to set the patterns of all the trigger sources to the pattern settings
selected currently.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameters (trigger holdoff and noise rejection) under this trigger
type. For details, refer to descriptions in "Trigger Holdoff" and "Noise Rejection".

Trigger LEVEL/Threshold Level:

Rotate the Trigger  LEVEL knob to adjust the trigger level/ threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.

8.7.7 Timeout Trigger

In Timeout trigger, the instrument triggers when the time interval (ΔT) (the time from
when the rising edge (or falling edge) of the input signal passes through the trigger
level to the time from when the neighboring falling edge (or rising edge) passes
through the trigger level) is greater than the preset timeout value, as shown in the
figure below.

Time Out

T Time Out <      T

Figure 8.8 Timeout Trigger

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "Timeout". Press
down the knob to select the type. Then, the current trigger setting information is
displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.
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Source Selection:

Press Source to open the signal source list and select CH1-CH4 or D0-D15. For
details, refer to descriptions in "Trigger Source". The current trigger source is
displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger Wave.

Edge Type:

Press Slope, then rotate the multifunction knob  to select input signal edge on
which the oscilloscope triggers. You can also press Slope continuously or enable the
touch screen to select it.

• Rising: starts timing when the rising edge of the input signal passes through

the trigger level.

• Falling: starts timing when the falling edge of the input signal passes through

the trigger level.

• Either: starts timing when either edge of the input signal passes through the

trigger level.

Timeout Value:

Timeout value represents the maximum time that the signal remains idle before the
signal passes through the trigger level. Press Timeout, and then rotate the

multifunction knob  or use the pop-up numeric keypad to set the timeout value.
The available range is from 16 ns to 10 s.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameter (noise rejection) under this trigger type. For details, refer
to descriptions in "Noise Rejection".

Trigger LEVEL/Threshold Level:
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Rotate the Trigger  LEVEL knob to adjust the trigger level or threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.

8.7.8 Runt Trigger

This trigger mode is used to trigger pulses that pass through one trigger level but fail
to pass through another trigger level, as shown in the figure below.

Lower Limit of the 
Trigger Level

Upper Limit of the 
Trigger Level

Negative Runt Pulse

Positive Runt Pulse

Figure 8.9 Runt Trigger

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "Runt". Press down
the knob to select it. Then, the current trigger setting information is displayed at the
upper-right corner of the screen, as shown in the figure below. You can also press
Type continuously or enable the touch screen to select it.

Source Selection:

Press Source to switch the trigger source and select CH1-CH4. For details, refer to
descriptions in "Trigger Source". The current trigger source is displayed at the upper-
right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger Wave.

Polarity:

Press Polarity to select the polarity of the Runt trigger.

• Positive: triggers on the positive runt pulse.

• Negative: triggers on the negative runt pulse.
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Trigger Condition:

Press When, then rotate the multifunction knob  to select the the desired trigger
condition, and then press down the knob to select it. You can also press When
continuously or enable the touch screen to select it.

• None: indicates not setting the trigger condition of Runt trigger.

• >: triggers when the runt pulse width is greater than the lower limit of pulse

width. Press Lower to set the minimum pulse width of Runt trigger.

• <: triggers when the runt pulse width is smaller than the upper limit of pulse

width. Press Upper to set the maximum pulse width of Runt trigger.

• <>: triggers when the runt pulse width is greater than the lower limit and

smaller than the upper limit of pulse width. Press Upper to set the maximum

pulse width of Runt trigger. Press Lower to set the minimum pulse width of Runt

trigger.

NOTE

The lower limit of the pulse width must be smaller than the upper limit.

Level Selection and Adjustment of Trigger Level:

After the trigger condition setting is completed, you need to adjust the trigger level
to correctly trigger the signal and obtain a stable waveform. Press Level Select (when
"<>" is selected as the trigger condition, Level Select is a sub-menu under More),

then rotate the multifunction knob  to select the desired level type for adjustment,
and then press down the knob to select it. You can also press Level Select
continuously or enable the touch screen to select it.

Level A: only adjusts the upper limit of the trigger level, and the lower limit of the
trigger level remains unchanged.

Level B: only adjusts the lower limit of the trigger level, and the upper limit of the
trigger level remains unchanged.

Level AB: adjusts the upper and lower limits of the trigger level at the same time, and
the trigger level deviation (the difference between the upper limit and lower limit of
the trigger level) remains unchanged.

NOTE

In Runt trigger, pressing the Trigger  LEVEL knob can quickly switch the current level

adjustment type.
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Rotate the Trigger  LEVEL knob to adjust the corresponding trigger level. During
the adjustment of trigger level, two trigger level lines appear on the screen, and they
move up and down with the change of the trigger level. At the same time, the real-
time trigger level information is displayed at the lower-left corner of the screen (As
shown in the figure below, H indicates the upper limit of the trigger level, L indicates
the lower limit of the trigger level, and △ indicates the trigger level deviation). When
you stopping modifying the trigger level, the trigger level line and the trigger level
information at the lower-left corner of the screen disappear in about 2 s. The current
trigger level deviation is displayed at the upper-right corner of the screen.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameters (trigger holdoff and noise rejection) under this trigger
type. For details, refer to descriptions in "Trigger Holdoff" and "Noise Rejection".

8.7.9 Window Trigger

Window trigger provides a high trigger level and a low trigger level. The instrument
triggers when the input signal passes through the high trigger level or the low trigger
level.

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "Window". Press
down the knob to select the trigger type. Then, the current trigger setting information
is displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Source Selection:

Press Source to switch the trigger source and select CH1-CH4. For details, refer to
descriptions in "Trigger Source". The current trigger source is displayed at the upper-
right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.

 To Trigger the Oscilloscope

Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved. 101



Edge Type:

Press Slope, then rotate the multifunction knob  to select the input signal edge on
which the oscilloscope triggers. You can also press Slope continuously or enable the
touch screen to select it.

• Rising: triggers on the rising edge of the input signal when the voltage level

is higher than the preset high trigger level.

• Falling: triggers on the falling edge of the input signal when the voltage level

is lower than the preset low trigger level.

• Either: triggers on the rising or falling edge of the input signal when the

voltage level meets the preset trigger level.

Trigger Position:

After selecting the window type, press Position to select the trigger position so as to
further specify the time point of trigger. You can also press Position continuously or
enable the touch screen to select it.

• Enter: triggers when the input signal enters the specified trigger level range.

• Exit: triggers when the input signal exits the specified trigger level range.

• Time: triggers when the accumulated hold time since the input signal entered

the specified trigger level range is equal to the window time. Press Time, and

then rotate the multifunction knob  or use the pop-up numeric keypad to set

the window time. The available range is from 8 ns to 10 s.

Level Selection and Adjustment of Trigger Level:

After the trigger condition setting is completed, you need to adjust the trigger level
to correctly trigger the signal and obtain a stable waveform. Press Level Select, then

rotate the multifunction knob  to select the desired level type for adjustment, and
then press down the knob to select the type. You can also press Level Select
continuously or enable the touch screen to select it.

• Level A: only adjusts the upper limit of the trigger level, and the lower limit of

the trigger level remains unchanged.

• Level B: only adjusts the lower limit of the trigger level, and the upper limit of the

trigger level remains unchanged.
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• Level AB: adjusts the upper and lower limits of the trigger level at the same time,

and the trigger level deviation (the difference between the upper limit and lower

limit of the trigger level) remains unchanged.

NOTE

In Window trigger, pressing Trigger  LEVEL can quickly switch the current level adjustment

type.

Rotate the Trigger  LEVEL knob to adjust the corresponding trigger level. During
the adjustment of trigger level, two trigger level lines appear on the screen, and they
move up and down with the change of the trigger level. At the same time, the real-
time trigger level and slope information is displayed at the lower-left corner of the
screen (As shown in the figure below, H indicates the upper limit of the trigger level, L
indicates the lower limit of the trigger level, and △ indicates the trigger level
deviation). When you stopping modifying the trigger level, the trigger level line and
the trigger level information at the lower-left corner of the screen disappear in about
2 s. The current trigger level deviation is displayed at the upper-right corner of the
screen.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameters (trigger holdoff and noise rejection) under this trigger
type. For details, refer to descriptions in "Trigger Holdoff" and "Noise Rejection".

8.7.10 Delay Trigger

In Delay trigger, you need to set Source A and Source B. The oscilloscope triggers
when the time difference (△T) between the specified edges of Source A (Edge A) and
Source B (Edge B) meets the preset time limit, as shown in the figure below.

NOTE

Edge A and Edge B must be two neighboring edges.
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Figure 8.10 Delay Trigger

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "Delay". Press down
the knob to select the trigger type. Then, the current trigger setting information is
displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Source A:

Press SourceA to select CH1-CH4 or D0-D15 as the trigger source of Source A. For
details, refer to descriptions in "Trigger Source". The current trigger source is
displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.

Edge A:

Press EdgeA continuously to select the trigger edge type of Source A in Delay trigger.

It can be set to "Rising"  or "Falling" .

Source B:

Press SourceB to select CH1-CH4 or D0-D15 as the trigger source of Source B. For
details, refer to descriptions in "Trigger Source". The current trigger source is
displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.

Edge B:
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Press EdgeB continuously to select the trigger edge type of Source B in Delay trigger.

It can be set to "Rising"  or "Falling" .

Trigger Condition:

Press When to set the time limit condition of Delay trigger.

• >: triggers when the time difference (ΔT) between the specified edges of Source

A and Source B is greater than the preset time lower limit. Press Lower to set the

delay time lower limit in Delay trigger.

• <: triggers when the time difference (ΔT) between the specified edges of Source

A and Source B is smaller than the preset time upper limit. Press Upper to set

the delay time upper limit in Delay trigger.

• < >: triggers when the time difference (ΔT) between the specified edges of

Source A and Source B is greater than the lower limit of the preset time and

smaller than the upper limit of the preset time. Press Upper to set the delay time

upper limit in Delay trigger. Press Lower to set the delay time lower limit in

Delay trigger.

NOTE

The lower time limit must be smaller than the upper time limit.

• > <: triggers when the time difference (ΔT) between the specified edges of

Source A and Source B is smaller than the lower limit of the preset time or

greater than the upper limit of the preset time. Press Upper to set the delay time

upper limit in Delay trigger. Press Lower to set the delay time lower limit in

Delay trigger.

NOTE

The lower time limit must be smaller than the upper time limit.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameters (trigger holdoff and noise rejection) under this trigger
type. For details, refer to descriptions in "Trigger Holdoff" and "Noise Rejection".
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Trigger LEVEL/Threshold Level:

Rotate the Trigger  LEVEL knob to adjust the trigger level/ threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.

8.7.11 Setup/Hold Trigger

In setup&hold trigger, you need to set the clock source and data source. The setup
time starts when the data signal passes the trigger level and ends at the coming of
the specified clock edge; the hold time starts at the coming of the specified clock
edge and ends when the data signal crosses the trigger level again, as shown in the
figure below. The oscilloscope triggers when the setup time or hold time is smaller
than the preset time.

T1
T2

Data Source

Clock Source

T2 is the hold time

T1 is the setup time

Edge

The data type is H

Figure 8.11 Setup/Hold Trigger

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "Setup/Hold". Press
down the knob to select the trigger type. Then, the current trigger setting information
is displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Clock Source:

Press SCL to set the signal source of the clock line. It can be set to CH1-CH4 or D0-
D15. For details, refer to descriptions in "Trigger Source". The current clock source
(trigger source) is displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the clock source, can we

obtain a stable trigger.
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Edge Type:

Press Slope to select the desired clock edge type. It can be set to "Rising"  or

"Falling" .

Data Source:

Press SDA to set the signal source of the data line. It can be set to CH1-CH4 or D0-
D15. For details, refer to descriptions in "Trigger Source". The current data source
(trigger source) is displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.

Data Type:

Press Data Type to set the effective pattern of the data signal. It can be set to H (high
level) or L (low level).

Trigger Condition:

Press When, then rotate the multifunction knob  to select the of Setup/Hold
trigger condition, and then press down the knob to select it. You can also press When
continuously or enable the touch screen to select it.

• Setup: the oscilloscope triggers when the setup time is smaller than the

specified setup time. After selecting this type, press Setup, and then rotate the

multifunction knob  or use the pop-up numeric keypad to set the setup time.

• Hold: the oscilloscope triggers when the hold time is smaller than the specified

hold time. After selecting this type, press Hold, and then rotate the

multifunction knob  or use the pop-up numeric keypad to set the hold time.

• Setup/Hold: the oscilloscope triggers when the setup time or hold time smaller

than the specified time value. After selecting this type, press Setup and Hold

respectively, then rotate the multifunction knob  or use the pop-up numeric

keypad to set the setup and hold time.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:
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Sets the trigger parameter (noise rejection) under this trigger type. For details, refer
to descriptions in "Noise Rejection".

Trigger LEVEL/Threshold Level:

Rotate the Trigger  LEVEL knob to adjust the trigger level/ threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.

8.7.12 Nth Edge Trigger

Triggers on the Nth edge that appears after the specified idle time. For example, in
the waveform shown in the figure below, the instrument should trigger on the second
rising edge after the specified idle time (the time between two neighboring rising
edges), and the idle time should be within the range between P and M (P< Idle
Time<M). Wherein, M is the time between the first rising edge and its previous rising
edge; P is the maximum time between the rising edges that participate in counting.

PM

Edge Type=
Edge Num=2

P<Idle Time<M

Figure 8.12 Nth Edge Trigger

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "Nth Edge". Press
down the knob to select the trigger type. Then, the current trigger setting information
is displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Source Selection:

 To Trigger the Oscilloscope

108 Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved.



Press Source to open the signal source list and select CH1-CH4 or D0-D15. For
details, refer to descriptions in "Trigger Source". The current trigger source is
displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.

Edge Type:

Press Slope to select the input signal edge on which the oscilloscope triggers.

• Rising: triggers on the rising edge of the input signal when the voltage level

meets the specified trigger level.

• Falling: triggers on the falling edge of the input signal when the voltage level

meets the specified trigger level.

Idle Time:

Press Idle Time, then use the pop-up numeric keypad to set the idle time before the

edge counting in Nth edge trigger. Rotate the multifunction knob  or use the pop-
up numeric keypad to set the idle time.

Edge Count:

Press Edges to set the value of "N" in Nth edge trigger. Rotate the multifunction knob

 or use the pop-up numeric keypad to set the edge count. The available range is
from 1 to 65,535.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameter (noise rejection) under this trigger type. For details, refer
to descriptions in "Noise Rejection".

Trigger LEVEL/Threshold Level:

Rotate the Trigger  LEVEL knob to adjust the trigger level/ threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.
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8.7.13 RS232 Trigger (Option)

RS232 bus is a serial communication mode used in data transmission between PCs or
between a PC and a terminal. In RS232 serial protocol, a character is transmitted as a
frame of data. The frame consists of 1 start bit, 5-8 data bits, 1 check bit, and 1-2 stop
bits. Its format is as shown in the figure below. This series oscilloscope triggers when
the start frame, error frame, check error, or the specified data of the RS232 signal is
detected.

Stop BitCheck BitData BitStart Bit

1 bit 5~8 bits 1 bit 1~2 bits

Figure 8.13 Schematic Diagram of RS232 Protocol

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "RS232". Press down
the knob to select the trigger type. Then, the current trigger setting information is
displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Source Selection:

Press Source to open the signal source list and select CH1-CH4 or D0-D15. For
details, refer to descriptions in "Trigger Source". The current trigger source is
displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.

Trigger Condition:

Press When, then rotate the multifunction knob  to select the the desired trigger
condition. Press down the knob to select it. You can also press When continuously or
enable the touch screen to select it.

• Start: triggers on the start frame position.

• Error: triggers when an error frame is detected.

 To Trigger the Oscilloscope

110 Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved.



• Check Error: triggers when a check error is detected.

• Data: triggers on the last bit of the preset data bits. Press Data, then rotate the

multifunction knob  or use the pop-up numeric keypad to set the data of

RS232 trigger.

Data Bits:

Indicate the number of bits per frame. Press More > Data Bits, then rotate the

multifunction knob  to select the desired data bits, and then press down the knob
to select it. You can also press Data Bits continuously or enable the touch screen to
select it. The available data bits include "5 Bits", "6 Bits", "7 Bits", and "8 Bits".

Stop Bit:

Indicates when to stop outputting data. Press More > Stop Bit, then rotate the

multifunction knob  to select the desired stop bit, and then press down the knob to
select it. You can also press Stop Bit continuously or enable the touch screen to select
it. The available stop bits include 1 Bit, 1.5 Bits, and 2 Bits.

Parity:

Used to verify whether data are properly transmitted. Press More > Parity, and rotate

the multifunction knob  to select the desired parity mode. Then press down the
knob to select it. You can also press Parity continuously or enable the touch screen to
select it. The available parity modes include "None", "Even", and "Odd".

Polarity

Press Polarity continuously to select the polarity of data transmission. It can be set to

"Pos"  or "Neg" .

Baud Rate:

Sets the baud rate of data transmission (i.g. specifies a clock frequency). Three setting
methods are available for baud rate:

• Press Baud Rate, then set the user-defined baud rate with the displayed numeric

keypad.

• Press Baud Rate, then select the preset baud rate from the drop-down list. The

available baud rates include 50 bps, 75 bps, 110 bps, 134 bps, 150 bps, 300 bps,

and etc.

• Press Baud Rate, then rotate the multifunction knob  to adjust the baud rate

at a small step of 1 bps.

Trigger Mode:
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In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameter (noise rejection) under this trigger type. For details, refer
to descriptions in "Noise Rejection".

Trigger LEVEL/Threshold Level:

Rotate the Trigger  LEVEL knob to adjust the trigger level/ threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.

8.7.14 I2C Trigger (Option)

I2C is a 2-wire serial bus used to connect the microcontroller and its peripheral
device. It is a bus standard widely used in the microelectronic communication control
field.

The I2C serial bus consists of SCL and SDA. Its transmission rate is determined by SCL,
and its transmission data is determined by SDA, as shown in the figure below. This
series oscilloscope triggers on the start condition, restart, stop, missing
acknowledgment, specific device address, or data value. Besides, it can also trigger on
the specific device address and data values at the same time.

Figure 8.14 Schematic Diagram of I2C Protocol

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "I2C". Press down the
knob to select the trigger type. Then, the current trigger setting information is
displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Source Selection:
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Press SCL and SDA to specify the sources of SCL and SDA respectively. They can be
set to CH1-CH4 or D0-D15. For details, refer to descriptions in "Trigger Source". The
current trigger source is displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.

Trigger Condition:

Press When, then rotate the multifunction knob  to select the the desired trigger
condition. Press down the knob to select it. You can also press When continuously or
enable the touch screen to select it.

• Start: triggers when SDA data transitions from high level to low level while SCL is

high level.

• Stop: triggers when SDA data transitions from low level to high level while SCL is

high level.

• Restart: triggers when another start condition occurs before a stop condition.

• MissedAck: triggers when the SDA data is high level during any

acknowledgment of SCL clock position.

• Address: the trigger searches for the specified address value. When this event

occurs, the oscilloscope will trigger on the read/write bit. After this trigger

condition is selected:

- Press AddrBits, then rotate the multifunction knob  to select the desired

address bits, and then press down the knob to select it. You can also press

AddrBits continuously or enable the touch screen to select it. The available

address bits are "7 Bits", "8 Bits", and "10 Bits".

- Press Address, then rotate the multifunction knob  or use the pop-up

numeric keypad to set the address of I2C trigger.

- Press More > Direction to select "Read", "Write" or "R/W".

NOTE

This setting is not available when AddrBits is set to "8 Bits".
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• Data: the trigger searches for the specified data value on the data line (SDA).

When this event occurs, the oscilloscope will trigger on the clock line (SCL)

transition edge of the last bit of data. After this trigger condition is selected:

- Press Bit X, and set the current bit with the following two methods.

Method 1: First rotate the multifunction knob  to switch to the data bit
that needs to be operated on. Then press down the knob continuously to
set the current bit. As shown in the figure below, the left is its binary
format, and the right is its corresponding Hex format.

Method 2: Press Bit X or enable the touch screen to select the data bit.
Then set it with the pop-up virtual keypad. For setting methods, refer to
descriptions in "Pattern Trigger". If you modify the binary data bit, a virtual
keypad as shown in Figure 8.15 is displayed. If you modify the hex data bit,
a virtual keypad as shown in Figure 8.16 is displayed.

Figure 8.15 Virtual Keypad for Binary Data Bit
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Figure 8.16 Virtual Keypad for Hex Data Bit

- Press Bytes, then rotate the multifunction knob  or use the pop-up

numeric keypad to set the length of the data. Its range is from 1 to 5.

- Press More > Addr Bits, then rotate the multifunction knob  to select

the desired address bits, and then press down the knob to select it. You can

also press Addr Bits continuously or enable the touch screen to select it.

The available address bits are "7 Bits", "8 Bits", and "10 Bits".

• A&D: the oscilloscope searches for the specified address and data at the same

time, then triggers when both the address and data meet the conditions. After

this condition is selected, you need to set the sub-menu items such as Bit X,

Bytes, Addr Bits, Address, and Direction. For the setting methods, refer to

descriptions in "Address" and "Data" conditions.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameter (noise rejection) under this trigger type. For details, refer
to descriptions in "Noise Rejection".

Trigger LEVEL/Threshold Level:

Rotate the Trigger  LEVEL knob to adjust the trigger level/ threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.
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8.7.15 SPI Trigger (Option)

In SPI trigger, after the CS or timeout condition is satisfied, the oscilloscope triggers
when the specified data is found. When using SPI trigger, you need to specify the CLK
clock sources and MISO data sources.

Below is the sequential chart of SPI bus.

SDA

SCL

CS

D7 D6 D5 D4 D3 D2 D1 D0

Figure 8.17 Sequential Chart of SPI Bus

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "SPI". Press down the
knob to select the trigger type. Then, the current trigger setting information is
displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Source Selection:

Press CLK and MISO to specify the sources of CLK and MISO respectively. They can be
set to CH1-CH4 or D0-D15. For details, refer to descriptions in "Trigger Source". The
current trigger source is displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.

Edge Type:

Press Slope continuously to select the desired clock edge type. Press down the knob
to select it.

• Rising: samples the MISO data on the rising edge of the clock.

• Falling: samples the MISO data on the falling edge of the clock.

Trigger Condition:
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Press When continuously to select the desired trigger condition.

• Timeout: the oscilloscope starts to search for the data (MISO) on which to

trigger after the clock signal (CLK) stays in the idle state for a specified period of

time. After selecting this condition, you can press Timeout, then rotate the

multifunction knob  or use the pop-up numeric keypad to set the idle time.

The range is from 8 ns to 10 s.

• With CS: if the CS signal is valid, the oscilloscope will trigger when the data

(SDA) satisfying the trigger conditions is found.

- After selecting this condition, you can press CS select the chip selection

signal line. The available channels are CH1-CH4 and D0-D15. For details,

refer to descriptions in "Trigger Source". The current trigger source is

displayed at the upper-right corner of the screen.

- Press More > CS Mode to set the current CS mode to "Pos " (high

level is valid) or "Neg " (low level is valid).

Current Bit:

Press More > Bit X to set the data bit that needs to be operated on. For setting
methods, refer to descriptions in "I2C Trigger (Option)".

Data Bits:

Press More > DataBits, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the number of bits in the serial data string. The number of bits
in the string can be set to any integer ranging from 4 to 32.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameter (noise rejection) under this trigger type. For details, refer
to descriptions in "Noise Rejection".

Trigger LEVEL/Threshold Level:

Rotate the Trigger  LEVEL knob to adjust the trigger level/ threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.

 To Trigger the Oscilloscope

Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved. 117



8.7.16 CAN Trigger (Option)

This oscilloscope can trigger on the start of a frame, end of a frame, frame of the
specified type (e.g. Remote, Overload, Data, etc.), or error frame of the specified type
(e.g. Answer Error, Check Error, Format Error, etc.) of the CAN signal.

The data frame format of the CAN bus is as shown in the figure below.

Figure 8.18 Data Frame Format of the CAN Bus

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "CAN". Press down
the knob to select the trigger type. Then, the current trigger setting information is
displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Source Selection:

Press Source to open the signal source list and select CH1-CH4 or D0-D15. For
details, refer to descriptions in "Trigger Source". The current trigger source is
displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.

Trigger Condition:

Press When to select the desired trigger condition.

• SOF: triggers at the start of a frame.

• EOF: triggers at the end of a frame.

• Remote ID: triggers on the specified ID of Remote frame. Set the following

parameters:

- Press Extend ID to enable or disable the extended ID.
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- Press Bit X to set the data bit that needs to be operated. For setting

methods, refer to descriptions in "I2C Trigger (Option)".

• Overload: triggers on the overload frames.

• Frame ID: triggers on the data frames with the specified ID. Set the following

parameters:

- Press Extend ID to enable or disable the extended ID.

- Press Bit X to set the data bit that needs to be operated. For setting

methods, refer to descriptions in "I2C Trigger (Option)".

• Frame Data: triggers on the data frames with the specified Data. Set the

following parameters:

- Press Bit X to set the data bit that needs to be operated. For setting

methods, refer to descriptions in "I2C Trigger (Option)".

- Press Bytes, then rotate the multifunction knob  or use the numeric

keypad to set the length of the data. Its range is from 1 to 8.

• Data & ID: triggers on the data frames with the specified ID and data. Set the

following parameters:

- Press Define to select "Data" or "ID".

- When you select "Data", set Bit X and Bytes. For detailed settings, refer to

parameter settings for "Frame Data".

- When you select "ID", set Extended ID and Bit X. For detailed settings, refer

to parameter settings for "Frame ID".

• Frame Error: triggers on the error frame.

• Bit Fill: triggers on the error frame with the bit fill.

• Answer Error: triggers on the answer error frame.

• Check Error: triggers on the check error frame.

• Format Error: triggers on the format error frame.

• Random Error: triggers on the random error frame, such as the format error

frame, answer error frame, etc.
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Signal Type:

Press More > Signal Type to select the desired signal type.

• CAN_H: indicates the actual CAN_H bus signal.

• CAN_L: indicates the actual CAN_L bus signal.

• TX/RX: indicates the Transmit signal and Receive signal from the CAN bus

transceiver.

• DIFF: indicates the CAN differential bus signals connected to an analog channel

by using a differential probe. Connect the differential probe's positive lead to the

CAN_H bus signal and connect the negative lead to the CAN_L bus signal.

Baud Rate:

Press More > Baud to set the baud rate. Three methods are available for setting the
baud rate:

• Press Baud, then set the user-defined baud rate with the displayed numeric

keypad.

• Press Baud, then rotate the multifunction knob  to select the preset baud rate

from the available options. The available baud rates include 10 kb/s, 20 kb/s,

33.3 kb/s, 50 kb/s, 62.5 kb/s, 83.3 kb/s, and etc.

• Press Baud, then rotate the multifunction knob  to adjust the baud rate at a

small step. The step size is different for adjusting different baud rates.

Sample Position

Sample position is a point within a bit’s time. The oscilloscope samples the bit level
at this point. The sample position is represented by the proportion of "the time from
the start of the bit to the sample position" to the "bit time", as shown in the figure
below.

  
One Bit

60%
70%

80%

Figure 8.19 Sample Position
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Press More > Sample Position, then rotate the multifunction knob  or use the
pop-up numeric keypad to set the sample position. The settable range is from 10% to
90%.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameter (noise rejection) under this trigger type. For details, refer
to descriptions in "Noise Rejection".

Trigger LEVEL/Threshold Level:

Rotate the Trigger  LEVEL knob to adjust the trigger level/ threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.

8.7.17 FlexRay Trigger (Option)

This series oscilloscope can trigger on the specified frame, symbol, error, or position
of the FlexRay bus.

FlexRay is a type of differential serial bus configured with three consecutive segments
(i.g. packet header, payload, and packet trailer). Its data transmission rate is up to 10
Mb/s. Each frame contains a static segment and a dynamic segment, and ends with
the bus idle time.

Its format is as shown in the figure below.

Figure 8.20 Frame Format of FlexRay Bus

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "FlexRay". Press down
the knob to select the trigger type. Then, the current trigger setting information is
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displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Source Selection:

Press Source to open the signal source list and select CH1-CH4 or D0-D15. For
details, refer to descriptions in "Trigger Source". The current trigger source is
displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.

Baud Rate:

Press Baud, and rotate the multifunction knob  to select a FlexRay baud rate that
matches the actual FlexRay bus signal. Press down the knob to select it. You can also
press Baud continuously or enable the touch screen to select it. The available baud
rates are 2.5 Mb/s, 5 Mb/s, and 10 Mb/s.

Trigger Condition:

Press When, then rotate the multifunction knob  to select the trigger condition,
and then press down the knob to select it. You can also press When continuously or
enable the touch screen to select it.

• Post: triggers on the specified position of the FlexRay bus. Press Post to select

"TSS End", "FSS_BSS End", "FES End", or "DTS End".

• Frame: triggers on the frame of FlexRay bus.

- Press Frame to select the frame type. The types of frames include null, Sync,

Start, and All.

- Press More > Define to select "ID" or "Cyc Count".

When you select "ID", set the following parameters: ID Comp and ID Min.
Press More > ID Comp to select the comparison conditions. The available
choices include =, ≠, >, <, ><, <>. Press More > ID Max or press More >

ID Min, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the frame ID.

When you select "Cyc Count", set the following parameters: Cyc Comp and
Count Min. Press More > Cyc Comp to select the comparison conditions.
The available choices include =, ≠, >, <, ><, <>. Press More > Count Max
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or press More >Count Min, then rotate the multifunction knob  or use
the pop-up numeric keypad to set the cycle count.

• Symbol: triggers on the CAS/MTS (Collision Avoidance Symbol/Media Access

Test Symbol) and WUP (Wakeup Pattern) of FlexRay bus.

- Press Symbol to select the symbol type. The symbol type includes CAS/MTS

and WUS.

- Press More > ID Comp to select the comparison conditions. The available

choices include =, ≠, >, <, ><, <>. Press More > ID Max or press More >

ID Min, then rotate the multifunction knob  or use the pop-up numeric

keypad to set the frame ID.

• Error: triggers when an error occurs to the FlexRay bus. Press Error to select the

error type. It includes Head CRC Err, Tail CRC Err, Decode Err, and Random Err.

NOTE

As the occurrence possibility of specified FlaxRay frame is very low, it is recommended that you

set the oscilloscope to "Normal" trigger mode when the trigger condition is set to "Frame", so

as to prevent the instrument from triggering automatically while waiting for the specified

frame. The same goes for "Error" trigger condition. In addition, when multiple FlexRay errors

occur at the same time, you need to adjust the trigger holdoff so as to view the specific error.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameter (noise rejection) under this trigger type. For details, refer
to descriptions in "Noise Rejection".

Trigger LEVEL/Threshold Level:

Rotate the Trigger  LEVEL knob to adjust the trigger level/ threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.

8.7.18 LIN Trigger (Option)

This oscilloscope can trigger on the sync field of LIN signal, and can also trigger on
the specified identifier, data, or frame.

The data frame format of the LIN bus is as shown in the figure below.
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Figure 8.21 Data Frame Format of the LIN Bus

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "LIN". Press down the
knob to select the trigger type. Then, the current trigger setting information is
displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Source Selection:

Press Source to open the signal source list and select CH1-CH4 or D0-D15. For
details, refer to descriptions in "Trigger Source". The current trigger source is
displayed at the upper-right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.

Trigger Condition:

Press When, then rotate the multifunction knob  to select the trigger condition,

and then press down the knob to select it.

You can also press When continuously or enable the touch screen to select it.

• Sync: triggers on the last bit of the sync field.

• ID: triggers when the frames with the specified ID are found. Press ID, then

rotate the multifunction knob  or use the pop-up numeric keypad to set ID.

• Data: triggers when the data that meet the preset conditions are found.

- Press Bit X to set the data bit that needs to be operated. For setting

methods, refer to descriptions in "I2C Trigger (Option)".

- Press Bytes, then rotate the multifunction knob  or use the pop-up

numeric keypad to set the length of the data. Its range is from 1 to 8.
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• Data&ID: triggers when the frames with the specified ID and data that meet the

preset conditions are both found.

- Press Bit X to set the data bit that needs to be operated. For setting

methods, refer to descriptions in "I2C Trigger (Option)".

- Press Bytes, then rotate the multifunction knob  or use the pop-up

numeric keypad to set the length of the data. Its range is from 1 to 8.

- Press ID, then rotate the multifunction knob  or use the pop-up numeric

keypad to set ID.

• Sleep: triggers when the sleep frame is found.

• Wakeup: triggers when the wakeup frame is found.

• Error: triggers on the specified type of error frame. Press Error Type to select the

error type: Sync, Even Odd, or Check Sum.

Protocol Version:

Press More > Version, select the protocol version that matches the signal under test.
The available versions include 1.X, 2.X and Both.

Baud Rate:

Press More > Baud to set the baud rate. Three methods are available for setting the
rate:

• Press Baud, then set the user-defined baud rate with the displayed numeric

keypad.

• Press Baud, then rotate the multifunction knob  to select the preset baud rate

from the available options. The available baud rates include 1.2 kbps, 2.4 kbps,

4.8 kbps, 9.6 kbps, 19.2 kbps, and etc.

• Press Baud, then rotate the multifunction knob  to adjust the baud rate at a

small step.

Sample Position

Sample position is a point within a bit’s time. The oscilloscope samples the bit level
at this point. The sample position is represented by the proportion of "the time from
the start of the bit to the sample point" to the "bit time", as shown in the figure
below.
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Figure 8.22 Sample Position

Press More > Sample Position, then rotate the multifunction knob  or use the
pop-up numeric keypad to set the sample position. The settable range is from 10% to
90%.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameter (noise rejection) under this trigger type. For details, refer
to descriptions in "Noise Rejection".

Trigger LEVEL/Threshold Level:

Rotate the Trigger  LEVEL knob to adjust the trigger level/ threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.

8.7.19 I2S Trigger (Option)

In I2S trigger, the oscilloscope searches for the specified data value and take it as the
condition for identifying the trigger. You need to specify the serial clock line (SCLK, 1
pulse is found on the clock line once 1 bit of digital audio data is sent), frame clock
line (WS, used for switch the audio channel data), and serial data line (SDA, used for
transmit audio data represented in binary (2's complement)).

Below is the sequential chart of I2S bus.
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Figure 8.23 Sequential Chart of I2S Bus

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "I2S". Press down the
knob to select the trigger type. Then, the current trigger setting information is
displayed at the upper-right corner of the screen, as shown in the figure below. You
can also press Type continuously or enable the touch screen to select it.

Source Selection:

Press SCLK, WS, and SDA to specify the sources for SCLK, WS, and SDA. The available
choices are CH1-CH4, EXT, or D0-D15. For details, refer to descriptions in "Trigger
Source". The current trigger source is displayed at the upper-right corner of the
screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.

Edge Type:

Press SCLK Edge, then rotate the multifunction knob  to select the desired clock
edge type. Press down the knob to select it.

• Rising: samples the SDA data on the rising edge of the clock.

• Falling: samples the SDA data on the falling edge of the clock.

Audio:

Press Audio continuously or rotate the multifunction knob  to select the audio
channel. The available choices include "Left", "Right", and "Either".

Trigger Condition:
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Press More > When, then rotate the multifunction knob  to select the trigger
condition, and then press down the knob to select it. You can also press When
continuously or enable the touch screen to select it.

• =: triggers when the channel's data value equals the set data value. Press Data

to set the data bit. For setting methods, refer to descriptions in "I2C Trigger

(Option)".

• ≠: triggers when the channel's data value does not equal the set data value.

Press Data to set the data bit. For setting methods, refer to descriptions in "I2C

Trigger (Option)".

• <: triggers when the channel's data value is smaller than the set data value. Press

Data Max to set the upper limit of the data bit. For setting methods, refer to

descriptions in "I2C Trigger (Option)".

• >: triggers when the channel's data value is greater than the set data value. Press

Data Min to set the lower limit of the data bit. For setting methods, refer to

descriptions in "I2C Trigger (Option)".

• ><: triggers when the channel's data value is smaller than the upper limit of the

data value and greater than the lower limit of the data value. Press Data Max

and Data Min to set the upper limit and lower limit of the data bit respectively.

For setting methods, refer to descriptions in "I2C Trigger (Option)".

• <>: triggers when the channel's data value is greater than the upper limit of the

data value and smaller than the lower limit of the data value. Press Data Max

and Data Min to set the upper limit and lower limit of the data bit respectively.

For setting methods, refer to descriptions in "I2C Trigger (Option)".

Width:

Press More > Width, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the width. Its range is from 4 to 32.

User Width:

Press More > User Width, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the user width. Its range is from 4 to 32.
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NOTE

The user width is smaller than or equal to the width.

Alignment:

Press More > Alignment, and rotate the multifunction knob  to select the
alignment way for data signal. You can also press Alignment continuously or enable
the touch screen to select it.

I2S: MSB (Most Significant Bit) of data for each sample is sent first, and LSB (Least
Significant Bit) is sent last. The MSB appears on the SDA line one bit clock after the
edge of the WS transition.

LJ: data transmission (MSB first) begins at the edge of the WS transition.

RJ: data transmission (MSB first) is right-justified to the WS transition.

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameter (noise rejection) under this trigger type. For details, refer
to descriptions in "Noise Rejection".

Trigger LEVEL/Threshold Level:

Rotate the Trigger  LEVEL knob to adjust the trigger level/ threshold level. Please
refer to descriptions in "Trigger LEVEL/Threshold Level". The current trigger level/
threshold level is displayed at the upper-right corner of the screen.

8.7.20 MIL-STD-1553 Trigger (Option)

1553B is the abbreviation for the MIL-STD-1553 bus. This oscilloscope can trigger on
the sync field of 1553B bus, and can also trigger on the specified data word,
command word, status word, or error type.

The command word, data word, and status word format of the 1553B bus is as shown
in the figure below.
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Figure 8.24 Formats of the Command Word, Data Word, and Status Word of the

1553B Bus

Trigger Type:

Press Type, and then rotate the multifunction knob  to select "MIL-STD-1553".
Press down the knob to select the trigger type. Then, the current trigger setting
information is displayed at the upper-right corner of the screen, as shown in the
figure below. You can also press Type continuously or enable the touch screen to
select it.

Source Selection:

Press Source to open the signal source list and select CH1-CH4. For details, refer to
descriptions in "Trigger Source". The current trigger source is displayed at the upper-
right corner of the screen.

NOTE

Only when we select the channel (that has been input with signals) as the trigger source, can

we obtain a stable trigger.
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Trigger Condition:

Press When, then rotate the multifunction knob  to select the trigger condition,

and then press down the knob to select it.

You can also press When continuously or enable the touch screen to select it.

• Sync: triggers on the specified sync type. After this trigger condition is selected,

press Sync to select the desired sync type: Data Sync, Cmd/Status Sync, or All

Sync.

• Data: triggers on the specified data word. After this trigger condition is selected,

press Comp to select the comparison conditions. The available choices include

=, ≠, >, <, ><, and <>.

- =: triggers when the channel's data word equals the set data word. Press

Min to set the lower limit of the data word. For setting methods, refer to

descriptions in "I2C Trigger (Option)".

- ≠: triggers when the channel's data word does not equal the set data word.

Press Min to set the lower limit of the data word. For setting methods, refer

to descriptions in "I2C Trigger (Option)".

- <: triggers when the channel's data word is smaller than the set data word.

Press Max to set the upper limit of the data word. For setting methods,

refer to descriptions in "I2C Trigger (Option)".

- >: triggers when the channel's data word is greater than the set data word.

Press Min to set the lower limit of the data word. For setting methods, refer

to descriptions in "I2C Trigger (Option)".

- < >: triggers when the channel's data word is smaller than the upper limit

of the data word and greater than the lower limit of the data word. Press

Max and Min to set the upper limit and lower limit of the data word

respectively. For setting methods, refer to descriptions in "I2C Trigger

(Option)".
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- > <: triggers when the channel's data word is greater than the upper limit

of the data word and smaller than the lower limit of the data word. Press

Max and Min to set the upper limit and lower limit of the data word

respectively. For setting methods, refer to descriptions in "I2C Trigger

(Option)".

• RTA: triggers on the specified remote terminal address. After this trigger

condition is selected, press RTA to set the remote terminal address. For setting

methods, refer to descriptions in "I2C Trigger (Option)".

• RTA+11Bit: triggers on the RTA and the remaining 11 bits. After this trigger

condition is selected:

- Press RTA to set the remote terminal address. For setting methods, refer to

descriptions in "I2C Trigger (Option)".

- Press Bit time to set the bit time position value to 0 (low), 1 (high), or X

(don't care). For setting methods, refer to descriptions in "I2C Trigger

(Option)".

• Error: triggers on the specified error type. After this trigger condition is selected,

press Err Type to select the error type.

- Sync Error: triggers when an invalid sync pulse is found.

- Check Error: triggers when the parity bit is incorrect for the data in the

word.

Level Selection and Adjustment of Trigger Level:

After the trigger condition setting is completed, you need to adjust the trigger level
to correctly trigger the signal and obtain a stable waveform. Press Level Select (when
"Data" is selected for the trigger condition, press More > Level Select), then rotate

the multifunction knob  to select the desired level type for adjustment, and then
press down the knob to select it. You can also press Level Select continuously or
enable the touch screen to select it.

• Level A: only adjusts the upper limit of the trigger level, and the lower limit of

the trigger level remains unchanged.
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• Level B: only adjusts the lower limit of the trigger level, and the upper limit of the

trigger level remains unchanged.

• Level AB: adjusts the upper and lower limits of the trigger level at the same time,

and the trigger level deviation (the difference between the upper limit and lower

limit of the trigger level) remains unchanged.

NOTE

In MIL-STD-1553 trigger, pressing the Trigger  LEVEL knob can quickly switch the current

level adjustment type.

Rotate the Trigger  LEVEL knob to adjust the corresponding trigger level. During
the adjustment of trigger level, two trigger level lines appear on the screen, and they
move up and down with the change of the trigger level. At the same time, the real-
time trigger level and slope information is displayed at the lower-left corner of the
screen (As shown in the figure below, H indicates the upper limit of the trigger level, L
indicates the lower limit of the trigger level, and △ indicates the trigger level
deviation). When you stopping modifying the trigger level, the trigger level line and
the trigger level information at the lower-left corner of the screen disappear in about
2 s. The current trigger level deviation is displayed at the upper-right corner of the
screen.

Polarity:

Press More > Polarity continuously to select the desired polarity. The polarities

available are positive polarity ( ) and negative polarity ( ).

Trigger Mode:

In the trigger control area (Trigger) on the front panel, press  to quickly switch
the current trigger mode. For details, refer to descriptions in "Trigger Mode".

Trigger Parameter Setting:

Sets the trigger parameter (noise rejection) under this trigger type. For details, refer
to descriptions in "Noise Rejection".

8.8 Zone Trigger
This series oscilloscope supports the zone trigger and provides two rectangle areas:
Trigger zone A and Trigger zone B. You can set the trigger conditions to "Intersect" or
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"Not intersect". Refer to "Rectangle Drawing" to select "Trigger zone A" or "Trigger

zone B" to open the zone trigger setting menu. You can also press  > Analyze >
Zone trigger to enter the zone trigger setting menu.

Enable or Disable Trigger zone A or Trigger zone B:

Press Zone A enable or Zone B enable continuously to enable or disable Trigger
zone A or Trigger zone B. You can also refer to "Rectangle Drawing" to select "Trigger
zone A" or "Trigger zone B" to enable Trigger zone A or Trigger zone B. If both Trigger
zone A and Trigger zone B are disabled, then the zone trigger function is disabled. At
this time, you must enable either of them to re-enable the zone trigger.

NOTE

If "XY Mode" or "ROLL Mode" is enabled, the zone trigger function is disabled.

Select Source A or Source B:

Press Source A or Source B, then rotate the multifunction knob  to select the
desired source, and then press down the knob to select it. You can also press Source
A or Source B continuously to select the trigger source; or enable the touch screen to
tap the desired trigger source and select it. The available sources include CH1-CH4.
The zone name color and the zone color are the same as the color of the selected
source channel.

Set the Conditions for Trigger zone A and Trigger zone B:

Press Zone A or Zone B, then rotate the multifunction knob  to select "Intersect" or
"Not intersect", then press down the knob to select it. You can also press Zone A or
Zone B continuously to select the condition; or enable the touch screen to tap the
desired condition and select it.

If you enable Zone A, select CH1 as Source A and select "Intersect" as the condition,
as shown in the figure below.
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If you enable Zone A, select CH1 as Source A and select "Intersect" as the condition,
the following figure is displayed.

TIP

If you enable both Trigger zone A and Trigger zone B, then perform the "A&&B" operation,

and it will become the final trigger condition.

8.9 Trigger Output Connector
The trigger output connector ([TRIG OUT]) on the rear panel of this oscilloscope
series can output trigger signals determined by the current setting.

Trigger Output Connector

Figure 8.25 Trigger Output Connector

Press  > System > AUX Out to select "TrigOut”. A signal which reflects the
current capture rate of the oscilloscope can be output from the [TRIG OUT]
connector each time a trigger is generated by the oscilloscope. If this signal is
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connected to a waveform display device to measure the frequency, the measurement
result is the same as the current capture rate.

NOTE

If you press  > System > AUX Out to select "PassFail", then in the pass/fail test, when a

pass/fail event is detected, the oscilloscope outputs a pulse from the rear-panel [TRIG OUT]

connector.
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9 Operations and Measurements
MSO8000 can perform math operations, auto measurements, and cursor
measurements on sampled and displayed data.

9.1 Math Operation

Press  in the waveform control area (Wave) on the front panel to open the math

operation menu. You can also tap the function navigation icon  at the lower-left
corner of the screen to open the function navigation. This oscilloscope provides 4
math operations: Math1, Math2, Math3, and Math4. The following section takes
Math1 as an example to introduce math operation.

Press  > Math1 > Operator to select the desired math function. Press
Operation continuously to enable or disable the operation. When enabled, the results
of math operation are displayed with purple waveforms on the screen, and the math
operation formula, vertical scale, and other parameters (the displayed data
parameters are different for different math operations) are displayed at the bottom of
the screen. The results of the math operation also allow further measurement. This
oscilloscope supports enabling four math operations at the same time, as shown in
the figure below.

This series of oscilloscope can realize multiple math operations between waveforms
of different channels, including

• arithmetic operations (A+B, A-B, A×B, A/B, and Avg)

• FFT operation

• logic operation: A&&B, A||B, A^B, and !A

• function operation: Intg, Diff, Sqrt, Lg, Ln, Exp, Abs, and AX+B (linear function)

• math filter: low-pass filter, high-pass filter, band-pass filter, and band-stop filter

NOTE

When you select the source, only the enabled channel is available.
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9.1.1 Addition

Add the waveform voltage values of signal source A and B point by point and display
the results.

Press  > Math1 > Operator to select "A+B":

• Press Operation continuously to enable or disable the addition operation

function.

• Press SourceA and SourceB respectively, and rotate the multifunction knob 
to select the channel for SourceA and SourceB. Then press down the knob to
select the channel. You can also press SourceA and SourceB continuously or
enable the touch screen to select the channel. The available channels for
SourceA and SourceB are CH1-CH4 and Ref1-Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press More > AutoSetting to adjust the vertical scale and offset of the

operation results to the optimal value according to the current configuration for

better observation.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Expand to expand or compress the math operation waveform

around the "Center" or "GND".

 Operations and Measurements

138 Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved.



• Press More > Label to set the label for math operation results. For details, refer

to the descriptions in "Math Operation Label".

• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

9.1.2 Subtraction

Subtract the waveform voltage values of signal source B from that of source A point
by point and display the results.

Press  > Math1 > Operator to select "A-B":

• Press Operation continuously to enable or disable the subtraction operation

function.

• Press SourceA and SourceB respectively, and rotate the multifunction knob 
to select the channel for SourceA and SourceB. Then press down the knob to
select the channel. You can also press SourceA and SourceB continuously or
enable the touch screen to select the channel. The available channels for
SourceA and SourceB are CH1-CH4 and Ref1-Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly
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rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press More > AutoSetting to adjust the vertical scale and offset of the

operation results to the optimal value according to the current configuration for

better observation.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Expand to expand or compress the math operation waveform

around the "Center" or "GND".

• Press More > Label to set the label for math operation results. For details, refer

to descriptions in "Math Operation Label".

• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

9.1.3 Multiplication

Multiply the waveform voltage values of signal source A and B point by point and
display the results.

Press  > Math1 > Operator to select "A×B":

• Press Operation continuously to enable or disable the multiplication operation

function.

• Press SourceA and SourceB respectively, and rotate the multifunction knob 
to select the channel for SourceA and SourceB. Then press down the knob to
select the channel. You can also press SourceA and SourceB continuously or
enable the touch screen to select the channel. The available channels for
SourceA and SourceB are CH1-CH4 and Ref1-Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-
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Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press More > AutoSetting to adjust the vertical scale and offset of the

operation results to the optimal value according to the current configuration for

better observation.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Expand to expand or compress the measurement waveform

around the "Center" or "GND".

• Press More > Label to set the label for math operation results. For details, refer

to descriptions in "Math Operation Label".

• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

9.1.4 Division

Divide the waveform voltage values of signal source A by that of source B point by
point and display the results. It can be used to analyze the multiple relationships of
waveforms of two channels. Note: When the voltage of signal source B is 0 V, the
division result is treated as 0.

 Operations and Measurements

Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved. 141



Press  > Math1 > Operator to select "A÷B":

• Press Operation continuously to enable or disable the division operation

function.

• Press SourceA and SourceB respectively, and rotate the multifunction knob 
to select the channel for SourceA and SourceB. Then press down the knob to
select the channel. You can also press SourceA and SourceB continuously or
enable the touch screen to select the channel. The available channels for
SourceA and SourceB are CH1-CH4 and Ref1-Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press More > AutoSetting to adjust the vertical scale and offset of the

operation results to the optimal value according to the current configuration for

better observation.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Expand to expand or compress the measurement waveform

around the "Center" or "GND".

• Press More > Label to set the label for math operation results. For details, refer

to descriptions in "Math Operation Label".
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• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

9.1.5 FFT

FFT (Fast Fourier Transform) is used to transform time-domain signals to frequency-
domain components (frequency spectrum). This series of oscilloscope provide FFT
operation function which enables you to observe the time-domain waveform and
spectrum of the signal at the same time. FFT operation can facilitate the following
works:

• Measure harmonic components and distortion in the system;

• Display the characteristics of the noise in DC power;

• Analyze vibration.

Press  > Math1 > Operator to "FFT":

• Press Operation continuously to enable or disable the FFT operation function.

When enabled, the operation results are displayed as purple waveforms on the

screen. At the same time, the parameters such as vertical scale, center frequency,

and resolution are displayed at the bottom of the screen, as shown in the

following figure. Of which, FFT resolution is the quotient of the sample rate and

the number of FFT points. If the number of FFT points is a fixed value (65535 at

most), then the lower the sample rate, the higher the resolution.

Vertical Scale Span ResolutionCenter FrequencySample Rate

• Press Source, rotate the multifunction knob , and then press the knob to

select the channel. You can also press Source continuously or enable the touch

screen to select the channel. The available channels are CH1, CH2, CH3, CH4.
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• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen and use the "Pinch &

Stretch" gesture to adjust the vertical scale. If the source channel unit is set to

"V", then the unit of the vertical scale is displayed as dBV. If you select other

source channel unit, then the unit of the vertical scale is displayed as dB.

• Press AutoSetting to adjust the vertical scale and offset of the operation results

to an optimal value based on the current configuration, so as to better observe.

• Press More > Unit to select the vertical unit. The vertical unit can be set to

dB/dBm or Vrms. The vertical amplitude can be expressed both in log form and

linear form, with dBm/dBV and Vrms as the unit respectively. If you need to

display the FFT spectrum within a larger dynamic range, dBm/dBV is

recommended.

• Press More > X to select "Span-Center" (frequency range to center frequency) or

"Start-End" (start frequency to stop frequency).

- "Span-Center" (frequency range to center frequency): the frequency range

refers to the screen width, and you can divide the frequency range by 10 to

obtain the frequency per division. Press Span to set the frequency range of

the frequency-domain waveform. For setting methods, refer to descriptions

in "Parameter Setting Method". Press Center to set the frequency of the

frequency-domain waveform relative to the horizontal center of the screen.

For setting methods, refer to descriptions in "Parameter Setting Method".

- "Start-End" (start frequency to stop frequency): start frequency refers to the

frequency at the left side of the screen. Press Start to set the start
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frequency of the frequency-domain waveform. For setting methods, refer to

descriptions in "Parameter Setting Method". Stop frequency refers to the

frequency at the right side of the screen. Press End to set the stop

frequency of the frequency-domain waveform. For setting methods, refer to

descriptions in "Parameter Setting Method".

• Press More > Peak Search to enter the peak search menu.

Press Peak Search continuously to enable or disable the Peak search function.
When enabled, the peak search results are displayed on the screen, as shown in
the figure below. Enable the touch screen and tap the "Math" label at the top of
the peak search results to switch among Math1-Math4.

- Press Peak Number, then rotate the multifunction knob  or use the pop-

up numeric keypad to set the number of peaks. Its range is from 1 to 15. By

default, it is is 5.

- Press Threshold, then rotate the multifunction knob  or use the pop-up

numeric keypad to set the threshold of the peak.

- Press Excursion, then rotate the multifunction knob  or use the pop-up

numeric keypad to set the excursion of the peak.

- Press Table Order, and rotate the multifunction knob  to select the

sorting mode of the peak, and then press down the knob to select the

mode. You can also press Source continuously or enable the touch screen

to select the mode. The available sorting mode is "Amp Order" and "Freq

Order". By default, it is "Amp Order".
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- Press Export, and the save setting menu is displayed. You can export the

peak search results to the internal memory or the external USB storage

device in CSV format. For detailed saving operation, refer to descriptions in

"Store and Load".

• Press More > Window to select the desired window function.

Spectral leakage can be considerably decreased when a window function is used.
This series of oscilloscope provides 6 FFT window functions (as shown in Table
9.1 Window Function ) which have different characteristics and are applicable to
measure different waveforms. You need to select the window function according
to the characteristics of the waveform to be measured.

Table 9.1 Window Function

Window
Function

Characteristics
Waveforms Applicable to the Window
Function

Rectangular

Best frequency
resolution

Poorest amplitude
resolution

Similar to the situation
when no window is
applied.

Transient or short pulse, the signal levels
before and after the multiplication are
basically the same.

Sine waveforms with the same amplitudes
and rather similar frequencies.

Wide band random noise with relatively
slow change of waveform spectrum.

Blackman-
Harris

Best amplitude
resolution

Poorest frequency
resolution

Single frequency signal, searching for higher
order harmonics

Hanning

Better frequency
resolution and poorer
amplitude resolution
compared with
Rectangular

Sine, periodic, and narrow band random
noise

Hamming
A little bit better
frequency resolution
than Hanning

Transient or short pulse, the signal levels
before and after the multiplication are
rather different
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Window
Function

Characteristics
Waveforms Applicable to the Window
Function

Flattop
Measure the signals
accurately

Measure the signal that has no accurate
reference and requires an accurate
measurement

Triangle
Better frequency
resolution

Measure the narrow band signal and that
has strong noise interference

• For FFT math operation setting label, refer to descriptions in "Math Operation

Label".

• Press More > More > Color Grade to enable or disable the color grade display

of the FFT operation results. When enabled, different colors are displayed on the

screen to indicate the times of data acquisition or acquisition probability.

• Press More > More > Reset ColorGrade to clear the color grade display and

then display the color grade again.

TIP

FFT shortcut operation: Enable the touch screen, and then tap the function navigation icon 

at the lower-left corner of the screen to open the function navigation. Then, tap the "FFT" icon

to open the FFT menu. This oscilloscope supports 4 FFTs: FFT1, FFT2, FFT3, and FFT4. For

details, refer to the descriptions in this section.

9.1.6 "AND" Operation

Performs logic "AND" operation on the waveform voltage values of the specified
sources point by point and displays the results. In operation, when the voltage value
of the source channel is greater than the threshold of the corresponding channel, it is
regarded as logic "1"; otherwise it is logic "0". The results of logic AND operation of
two binary bits are shown in Table 9.2 Logic "AND" Operation .

Table 9.2 Logic "AND" Operation

A B A&&B

0 0 0

0 1 0

1 0 0
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A B A&&B

1 1 1

Press  > Math1 > Operator to "A&&B":

• Press Operation continuously to enable or disable the "AND" function.

• Press SourceA and SourceB respectively, and rotate the multifunction knob 
to select the channel for SourceA and SourceB. Then press down the knob to
select the channel. You can also press SourceA and SourceB continuously or
enable the touch screen to select the channel. The available channels for
SourceA and SourceB are CH1-CH4 and D0-D15.

NOTE

Only the channels that have been enabled currently can be selected.

- If Source A (or Source B) selects CH1, press More > Thre.CH1 to set the
threshold of Source A (or Source B) in logic operation. For setting methods,
refer to descriptions in "Parameter Setting Method".

- If Source A (or Source B) selects CH2, press More > Thre.CH2 to set the
threshold of Source A (or Source B) in logic operation. For setting methods,
refer to descriptions in "Parameter Setting Method".

- If Source A (or Source B) selects CH3, press More > Thre.CH3 to set the
threshold of Source A (or Source B) in logic operation. For setting methods,
refer to descriptions in "Parameter Setting Method".

- If Source A (or Source B) selects CH4, press More > Thre.CH4 to set the
threshold of Source A (or Source B) in logic operation. For setting methods,
refer to descriptions in "Parameter Setting Method".

TIP

The thresholds of the digital channels (D0-D15) are respectively set in the LA

module.

• Press Offset, then rotate the multifunction knob  to set the vertical offset of

the operation results. You can also directly rotate Wave Vertical  POSITION or

enable the touch screen to adjust the vertical offset.

• Press Size, then rotate the multifunction knob  to select the waveform size,

and press down the knob to select the size. You can also press Size continuously

or enable the touch screen to select the channel. The available sizes include
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"Small", "Medium", and "Large". In addition, you can also rotate Wave Vertical

 SCALE to adjust the waveform size.

• Press More > AutoSetting to adjust the vertical scale and offset of the

operation results to the optimal value according to the current configuration for

better observation.

• Press More > Sensitivity to set the sensitivity of the digital signal converted

from the analog signal on the source. For setting methods, refer to descriptions

in "Parameter Setting Method".

• Press More > Label to set the label for math operation results. For details, refer

to the descriptions in "Math Operation Label".

9.1.7 "OR" Operation

Performs logic "OR" operation on the waveform voltage values of the specified
sources point by point and displays the results. In operation, when the voltage value
of the source channel is greater than the threshold of the corresponding channel, it is
regarded as logic "1"; otherwise it is logic "0". The results of logic OR operation of
two binary bits are shown in Table 9.3 Logic "OR" Operation .

Table 9.3 Logic "OR" Operation

A B A||B

0 0 0

0 1 1

1 0 1

1 1 1

Press  > Math1 > Operator to select "A||B":

• Press Operation continuously to enable or disable the "A||B" operation function.

• Press SourceA and SourceB respectively, and rotate the multifunction knob 
to select the channel for SourceA and SourceB. Then press down the knob to
select the channel. You can also press SourceA and SourceB continuously or
enable the touch screen to select the channel. The available channels for
SourceA and SourceB are CH1-CH4 and D0-D15.

 Operations and Measurements

Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved. 149



NOTE

Only the channels that have been enabled currently can be selected.

- If Source A (or Source B) selects CH1, press More > Thre.CH1 to set the
threshold of Source A (or Source B) in logic operation. For setting methods,
refer to descriptions in "Parameter Setting Method".

- If Source A (or Source B) selects CH2, press More > Thre.CH2 to set the
threshold of Source A (or Source B) in logic operation. For setting methods,
refer to descriptions in "Parameter Setting Method".

- If Source A (or Source B) selects CH3, press More > Thre.CH3 to set the
threshold of Source A (or Source B) in logic operation. For setting methods,
refer to descriptions in "Parameter Setting Method".

- If Source A (or Source B) selects CH4, press More > Thre.CH4 to set the
threshold of Source A (or Source B) in logic operation. For setting methods,
refer to descriptions in "Parameter Setting Method".

• Press Offset, then rotate the multifunction knob  to set the vertical offset of

the operation results. You can also directly rotate Wave Vertical  POSITION or

enable the touch screen to adjust the vertical offset.

• Press Size, then rotate the multifunction knob  to select the waveform size.

Press down the knob to select it. You can also press Size continuously or enable

the touch screen to select the channel. The available sizes include "Small",

"Medium", and "Large". In addition, you can also rotate Wave Vertical  SCALE

to adjust the waveform size.

• Press More > AutoSetting to adjust the vertical scale and offset of the

operation results to the optimal value according to the current configuration for

better observation.

• Press More > Sensitivity to set the sensitivity of the digital signal converted

from the analog signal on the source. For setting methods, refer to descriptions

in "Parameter Setting Method".

• Press More > Label to set the label for math operation results. For details, refer

to descriptions in "Math Operation Label".
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9.1.8 "XOR" Operation

Performs logic "XOR" operation on the waveform voltage values of the specified
sources point by point and displays the results. In operation, when the voltage value
of the source channel is greater than the threshold of the corresponding channel, it is
regarded as logic "1"; otherwise it is logic "0". The results of logic OR operation of
two binary bits are shown in Table 9.4 Logic "XOR" Operation .

Table 9.4 Logic "XOR" Operation

A B A^B

0 0 0

0 1 1

1 0 1

1 1 0

Press  > Math1 > Operator to select "A^B":

• Press Operation continuously to enable or disable the "A^B" operation function.

• Press SourceA and SourceB respectively, and rotate the multifunction knob 
to select the channel for SourceA and SourceB. Then press down the knob to
select the channel. You can also press SourceA and SourceB continuously or
enable the touch screen to select the channel. The available channels for
SourceA and SourceB are CH1-CH4 and D0-D15.

NOTE

Only the channels that have been enabled currently can be selected.

- If Source A (or Source B) selects CH1, press More > Thre.CH1 to set the
threshold of Source A (or Source B) in logic operation. For setting methods,
refer to descriptions in "Parameter Setting Method".

- If Source A (or Source B) selects CH2, press More > Thre.CH2 to set the
threshold of Source A (or Source B) in logic operation. For setting methods,
refer to descriptions in "Parameter Setting Method".

- If Source A (or Source B) selects CH3, press More > Thre.CH3 to set the
threshold of Source A (or Source B) in logic operation. For setting methods,
refer to descriptions in "Parameter Setting Method".

- If Source A (or Source B) selects CH4, press More > Thre.CH4 to set the
threshold of Source A (or Source B) in logic operation. For setting methods,
refer to descriptions in "Parameter Setting Method".
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• Press Offset, then rotate the multifunction knob  to set the vertical offset of

the operation results. You can also directly rotate Wave Vertical  POSITION or

enable the touch screen to adjust the vertical offset.

• Press Size, then rotate the multifunction knob  to select the waveform size.

Press down the knob to select it. You can also press Size continuously or enable

the touch screen to select the channel. The available sizes include "Small",

"Medium", and "Large". In addition, you can also rotate Wave Vertical  SCALE

to adjust the waveform size.

• Press More > AutoSetting to adjust the vertical scale and offset of the

operation results to the optimal value according to the current configuration for

better observation.

• Press More > Sensitivity to set the sensitivity of the digital signal converted

from the analog signal on the source. For setting methods, refer to descriptions

in "Parameter Setting Method".

• Press More > Label to set the label for math operation results. For details, refer

to the descriptions in "Math Operation Label".

9.1.9 "NOT" Operation

Performs logic "NOT" operation on the waveform voltage values of the specified
sources point by point and displays the results. In operation, when the voltage value
of the source channel is greater than the threshold of the corresponding channel, it is
regarded as logic "1"; otherwise it is logic "0". The results of logic "NOT" operation of
two binary bits are as shown in Table 9.5 Logic "NOT" Operation .

Table 9.5 Logic "NOT" Operation

A !A

0 1

1 0

Press  > Math1 > Operator to select "!A":
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• Press Operation continuously to enable or disable the "NOT" function.

• Press SourceA, and rotate the multifunction knob  to select the channel for
SourceA. Then press down the knob to select the channel. You can also press
SourceA continuously or enable the touch screen to select the channel. The
available channels for SourceA are CH1-CH4 and D0-D15.

NOTE

Only the channels that have been enabled currently can be selected.

- If Source A selects CH1, press More > Thre.CH1 to set the threshold of
Source A in logic operation. For setting methods, refer to descriptions in
"Parameter Setting Method".

- If Source A selects CH2, press More > Thre.CH2 to set the threshold of
Source A in logic operation. For setting methods, refer to descriptions in
"Parameter Setting Method".

- If Source A selects CH3, press More > Thre.CH3 to set the threshold of
Source A in logic operation. For setting methods, refer to descriptions in
"Parameter Setting Method".

- If Source A selects CH4, press More > Thre.CH4 to set the threshold of
Source A in logic operation. For setting methods, refer to descriptions in
"Parameter Setting Method".

• Press Offset, then rotate the multifunction knob  to set the vertical offset of

the operation results. You can also directly rotate Wave Vertical  POSITION or

enable the touch screen to adjust the vertical offset.

• Press Size, then rotate the multifunction knob  to select the waveform size.

Press down the knob to select it. You can also press Size continuously or enable

the touch screen to select the channel. The available sizes include "Small",

"Medium", and "Large". In addition, you can also rotate Wave Vertical  SCALE

to adjust the waveform size.

• Press AutoSetting to adjust the vertical scale and offset of the operation results

to an optimal value based on the current configuration, so as to better observe.

• Press More > Sensitivity to set the sensitivity of the digital signal converted

from the analog signal on the source. For setting methods, refer to descriptions

in "Parameter Setting Method".
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• Press More > Label to set the label for math operation results. For details, refer

to the descriptions in "Math Operation Label".

9.1.10 Intg

Calculates the integral of the selected source. For example, you can use integral to
measure the area under a waveform or the pulse energy.

Press  > Math1 > Operator to "Intg":

• Press Operation continuously to enable or disable the "Intg" operation function.

• Press SourceA, and rotate the multifunction knob  to select the channel for
SourceA. You can also press SourceA continuously or enable the touch screen to
select the channel. The available channels for SourceA are CH1-CH4 and Ref1-
Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press AutoSetting to adjust the vertical scale and offset of the operation results

to an optimal value based on the current configuration, so as to better observe.

• Press More > Bias to set the DC offset correction factor for the input signal.

Note that this parameter can only be set by using the numeric keypad.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

 Operations and Measurements

154 Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved.



• Press More > Label to set the label for math operation results. For details, refer

to the descriptions in "Math Operation Label".

• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

9.1.11 Diff

Calculates the discrete time derivative of the selected source. For example, you can
use differentiate to measure the instantaneous slope of a waveform.

Press  > Math1 > Operator to "Diff":

• Press Operation continuously to enable or disable the "Diff" operation function.

• Press SourceA, and rotate the multifunction knob  to select the channel for
SourceA. You can also press SourceA continuously or enable the touch screen to
select the channel. The available channels for SourceA are CH1-CH4 and Ref1-
Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.
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• Press AutoSetting to adjust the vertical scale and offset of the operation results

to an optimal value based on the current configuration, so as to better observe.

• Press More > Smooth to set the number of smoothing times in differential

operation. For setting methods, refer to descriptions in "Parameter Setting

Method".

NOTE

As the high-frequency component of waveform data has a great impact on the

differential operation, you need to adjust the parameter "Smooth" to a larger value, so as

to restore the low-frequency component.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Label to set the label for math operation results. For details, refer

to descriptions in "Math Operation Label".

• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

TIP

Because differentiation is very sensitive to noise, it is helpful to set acquisition mode to

"Average".

9.1.12 Sqrt

Calculates the square roots of the selected source point by point and displays the
results.

Press  > Math1 > Operator to select "Sqrt":

• Press Operation continuously to enable or disable the "Sqrt" operation function.

• Press SourceA, and rotate the multifunction knob  to select the channel for
SourceA. You can also press SourceA continuously or enable the touch screen to
select the channel. The available channels for SourceA are CH1-CH4 and Ref1-
Ref10.
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NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press AutoSetting to adjust the vertical scale and offset of the operation results

to an optimal value based on the current configuration, so as to better observe.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Label to set the label for math operation results. For details, refer

to descriptions in "Math Operation Label".

• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

9.1.13 Lg (Base 10 Exponential)

Calculates the base 10 exponential of the selected source point by point and displays
the results.

Press  > Math1 > Operator to "Lg":

• Press Operation continuously to enable or disable the "Lg" operation function.
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• Press SourceA, and rotate the multifunction knob  to select the channel for
SourceA. You can also press SourceA continuously or enable the touch screen to
select the channel. The available channels for SourceA are CH1-CH4 and Ref1-
Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press AutoSetting to adjust the vertical scale and offset of the operation results

to an optimal value based on the current configuration, so as to better observe.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Label to set the label for math operation results. For details, refer

to descriptions in "Math Operation Label".

• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

9.1.14 Ln

Calculates the natural logarithm (Ln) of the selected source point by point and
displays the results.
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Press  > Math1 > Operator to "Ln":

• Press Operation continuously to enable or disable the "Ln" operation function.

• Press SourceA, and rotate the multifunction knob  to select the channel for
SourceA. You can also press SourceA continuously or enable the touch screen to
select the channel. The available channels for SourceA are CH1-CH4 and Ref1-
Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press AutoSetting to adjust the vertical scale and offset of the operation results

to an optimal value based on the current configuration, so as to better observe.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Label to set the label for math operation results. For details, refer

to descriptions in "Math Operation Label".

• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.
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9.1.15 Exp

Calculates the exponential of the selected source point by point and displays the
results.

Press  > Math1 > Operator to "Exp":

• Press Operation continuously to enable or disable the "Exp" operation function.

• Press SourceA, and rotate the multifunction knob  to select the channel for
SourceA. You can also press SourceA continuously or enable the touch screen to
select the channel. The available channels for SourceA are CH1-CH4 and Ref1-
Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press AutoSetting to adjust the vertical scale and offset of the operation results

to an optimal value based on the current configuration, so as to better observe.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Label to set the label for math operation results. For details, refer

to descriptions in "Math Operation Label".
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• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

9.1.16 Abs

Calculates the absolute value of the selected source and displays the results.

Press  > Math1 > Operator to select "Abs":

• Press Operation continuously to enable or disable the "Abs" function.

• Press SourceA, and rotate the multifunction knob  to select the channel for
SourceA. Then press down the knob to select the channel. You can also press
SourceA continuously or enable the touch screen to select the channel. The
available channels for SourceA are CH1-CH4 and Ref1-Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press AutoSetting to adjust the vertical scale and offset of the operation results

to an optimal value based on the current configuration, so as to better observe.

• Press More > Invert to enable or disable the inverted display function of the

waveform.
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• Press More > Label to set the label for math operation results. For details, refer

to the descriptions in "Math Operation Label".

• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

9.1.17 Low Pass

Only allows the signals whose frequencies are lower than the current upper limit
frequency to pass.

Press  > Math1 > Operator to "LowPass":

• Press Operation continuously to enable or disable the "LowPass" operation

function.

• Press SourceA, and rotate the multifunction knob  to select the channel for
SourceA. You can also press SourceA continuously or enable the touch screen to
select the channel. The available channels for SourceA are CH1-CH4 and Ref1-
Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.
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• Press ωc to set the upper limit frequency. For setting methods, refer to

descriptions in "Parameter Setting Method".

NOTE

The settable range of the Upper limit frequency is related to the Math sample rate

(displayed at the bottom of the screen when the Math function is enabled). The sample

rate of the analog channel or the changes of the memory depth can affect the Math

sample rate.

• Press More > AutoSetting to adjust the vertical scale and offset of the

operation results to an optimal value based on the current configuration, so as

to better observe.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Label to set the label for math operation results. For details, refer

to descriptions in "Math Operation Label".

• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

9.1.18 High Pass

Only allows the signals whose frequencies are higher than the current lower limit
frequency to pass.

Press  > Math1 > Operator to select "HighPass":

• Press Operation continuously to enable or disable the "HighPass" operation

function.

• Press SourceA, and rotate the multifunction knob  to select the channel for
SourceA. You can also press SourceA continuously or enable the touch screen to
select the channel. The available channels for SourceA are CH1-CH4 and Ref1-
Ref10.

NOTE
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The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset set the vertical offset of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  POSITION or enable the touch screen to adjust the

vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press ωc to set the lower limit frequency. For setting methods, refer to

descriptions in "Parameter Setting Method".

NOTE

The settable range of the lower limit frequency is related to the Math sample rate

(displayed at the bottom of the screen when the Math function is enabled). The sample

rate of the analog channel or the changes of the memory depth can affect the Math

sample rate.

• Press More > AutoSetting to adjust the vertical scale and offset of the

operation results to an optimal value based on the current configuration, so as

to better observe.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Label to set the label for math operation results. For details, refer

to descriptions in "Math Operation Label".

• Press More > Color Grade to enable or disable the color grade display on the of

the operation results. When enabled, different colors are displayed on the screen

to indicate the times of data acquisition or acquisition probability.

• Press More > Color Grade to clear the color grade display and display the color

grade again.
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9.1.19 Band Pass

Only allows the signals whose frequencies are higher than the current lower limit
frequency and lower than the current upper limit frequency to pass.

Press  > Math1 > Operator to "BandPass":

• Press Operation continuously to enable or disable the "BandPass" operation

function.

• Press SourceA, and rotate the multifunction knob  to select the channel for
SourceA. You can also press SourceA continuously or enable the touch screen to
select the channel. The available channels for SourceA are CH1-CH4 and Ref1-
Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press AutoSetting to adjust the vertical scale and offset of the operation results

to an optimal value based on the current configuration, so as to better observe.

• Press More > ωc1 to set the lower limit frequency. For setting methods, refer to

descriptions in "Parameter Setting Method".

• Press More > ωc2 to set the upper limit frequency. For setting methods, refer to
descriptions in "Parameter Setting Method".

NOTE

The settable ranges of the upper and lower limit frequencies are related to the Math

sample rate (displayed at the bottom of the screen when the Math function is enabled).
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The sample rate of the analog channel or the changes of the memory depth can affect

the Math sample rate.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Label to set the label for math operation results. For details, refer

to descriptions in "Math Operation Label".

• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

9.1.20 Band Stop

Only allows the signals whose frequencies are lower than the current lower limit
frequency and higher than the current upper limit frequency to pass.

Press  > Math1 > Operator to "BandStop":

• Press Operation continuously to enable or disable the "BandStop" operation

function.

• Press SourceA, and rotate the multifunction knob  to select the channel for
SourceA. You can also press SourceA continuously or enable the touch screen to
select the channel. The available channels for SourceA are CH1-CH4 and Ref1-
Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.
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• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press AutoSetting to adjust the vertical scale and offset of the operation results

to an optimal value based on the current configuration, so as to better observe.

• Press More > ωc1 to set the lower limit frequency. For setting methods, refer to

descriptions in "Parameter Setting Method".

• Press More > ωc2 to set the upper limit frequency. For setting methods, refer to

descriptions in "Parameter Setting Method".

NOTE

The settable ranges of the Lower and Upper limit frequencies are related to the Math

sample rate (displayed at the bottom of the screen when the Math function is enabled).

The sample rate of the analog channel or the changes of the memory depth can affect

the Math sample rate.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Label to set the label for math operation results. For details, refer

to the descriptions in "Math Operation Label".

• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

9.1.21 AX+B

Applies a linear function to the selected source, and displays the results.

Press  > Math1 > Operator to "AX+B":
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• Press Operation continuously to enable or disable the "AX+B" operation

function.

• Press SourceA, and rotate the multifunction knob  to select the channel for
SourceA. You can also press SourceA continuously or enable the touch screen to
select the channel. The available channels for SourceA are CH1-CH4 and Ref1-
Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.

• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press AutoSetting to adjust the vertical scale and offset of the operation results

to an optimal value based on the current configuration, so as to better observe.

• Press More > A to set the value of A. Note that this parameter can only be set

by using the numeric keypad.

• Press More > B to set the value of B. Note that this parameter can only be set by

using the numeric keypad.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Label to set the label for math operation results. For details, refer

to the descriptions in "Math Operation Label".
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• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

9.1.22 Avg

Averages the waveforms of the specified channel for several times and displays the
results.

Press  > Math1 > Operator to "Avg":

• Press Operation continuously to enable or disable the "Avg" operation function.

• Press SourceA, and rotate the multifunction knob  to select the channel for
SourceA. You can also press SourceA continuously or enable the touch screen to
select the channel. The available channels for SourceA are CH1-CH4 and Ref1-
Ref10.

NOTE

The source of Math2 can be CH1-CH4, Ref1-Ref10, or Math1; the source of Math3 can be

CH1-CH4, Ref1-Ref10, Math1, or Math2; the source of Math4 can be CH1-CH4, Ref1-

Ref10, Math1, Math2, or Math3; only the channels that have been enabled currently can

be selected.

• Press Averages to input the average time in the displayed numeric keypad.

When the average count value is not in N power-of-2 increments, a prompt

message "Truncation average error" is displayed. At this time, a value that is

smaller than the one you input and the closest to N power-of-2 increments will

be input automatically. For example, if you input 9 with the numeric keypad, the

average count will be input 8 automatically.

The number of averages can be set to 2, 4, 8, 16, 32, 64, 128, 256, 512, 1024,
2048, 4096, 8192, 16384, 32768, or 65536. By default, it is 2.

• Press Offset to set the vertical offset of the operation results. For setting

methods, refer to the descriptions in "Parameter Setting Method". You can also

directly rotate Wave Vertical  POSITION or enable the touch screen to adjust

the vertical offset.
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• Press Scale to set the vertical scale of the operation results. For setting methods,

refer to the descriptions in "Parameter Setting Method". You can also directly

rotate Wave Vertical  SCALE or enable the touch screen to adjust the vertical

Scale.

• Press More > AutoSetting to adjust the vertical scale and offset of the

operation results to an optimal value based on the current configuration, so as

to better observe.

• Press More > Invert to enable or disable the inverted display function of the

waveform.

• Press More > Expand to expand or compress waveform around the "Center" or

"GND".

• Press More > Label to set the label for math operation results. For details, refer

to descriptions in "Math Operation Label".

• Press More > Color Grade to enable or disable the color grade display of the

operation results. When enabled, different colors are displayed on the screen to

indicate the times of data acquisition or acquisition probability.

• Press More > Reset ColorGrade to clear the color grade display and display the

color grade again.

9.1.23 Math Operation Label

Press Label to enter the label setting menu.

• Press Display continuously to enable or disable the label display of the

waveform. If it is enabled, the label will be displayed at the left side of the

waveform.

• Press Library to select the preset waveform label, including ADD, SUB, MUL, DIV,

FFT, AND, OR, XOR, NOT, Intg, Diff, Sqrt, Lg, Ln, Exp, Abs, LPas, HPas, BPas, Bstop,

and AX+B.

• Press Label, and the label editing interface is automatically displayed. You can

input the label manually. For details, refer to descriptions in "Channel Label".
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9.2 Auto Measurement
This series oscilloscope provides auto measurements for 41 waveform parameters,
enabling users to make statistics and analysis of the measurement results.

9.2.1 Quick Measurement after AUTO

When the oscilloscope is correctly connected and has detected a valid input signal,

press  to enable the waveform auto setting function and open the auto setting
function menu.

• : Press this key, and then the single period of the signal is displayed

automatically on the screen. Meanwhile, the system will make measurements for

the "Period" and "frequency" of the currently displayed waveforms in a of single

period. The measurement results are displayed at the bottom of the screen.

• : Press this key, and then multiple periods of the signal are displayed

automatically on the screen. Meanwhile, the system will make measurements for

the "Period" and "frequency" of the currently displayed waveforms in multiple

periods. The measurement results are displayed at the bottom of the screen.

• : Press this key, and then one rising edge of the signal is displayed

automatically on the screen. Meanwhile, the system will make measurements for

the "rise time" of the currently displayed rising edge. The measurement results

are displayed at the bottom of the screen. By default, it is intended for the fast

edge signal.

• : Press this key, and then one falling edge of the signal is displayed

automatically on the screen. Meanwhile, the system will make measurements for

the "fall time" of the currently displayed falling edge. The measurement results

are displayed at the bottom of the screen. By default, it is intended for the fast

edge signal.

• : Press this key, and the system returns to the last set menu.

• Press Option to enter the auto setting function menu.
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- Press Lock to lock the AUTO function. To unlock the AUTO function, use the

following two methods:

Method 1: Send the remote command :SYSTem:AUTOscale ON to unlock
the AUTO function.

Method 2: Press Lock again, then a password input dialog box is displayed.
Input the password. By default, there is no password, and press OK to
unlock the function.

NOTE

If you lock the Auto function and then exit the auto setting function menu, you can

press  > More > Auto Config to enter the auto setting function menu again

to unlock the Auto function.

- Press Peak to Peak to enable or disable the peak-peak priority setting. This

function is intended for the shifted signal. If there is a large deviation, you

can view the signal waveform in priority when you enable the function.

- Press CH to select "All" or "Open".

If you select "All", press  and the system will test the 4 analog
channels (CH1-CH4) in sequence. If no signal is found on the channel, then
the channel is disabled; if a signal is found on the channel, adjust the
channel to an optimal scale to display the signal. If you select "Open", press

 and the system will only test the enabled channels.

- Press Overlay to enable or disable the waveform overlay display function. If

enabled, waveforms of different channels will be displayed in the same

position of the screen; if disabled, waveforms of different channels will be

displayed on the screen from top to bottom in sequence.

- Press Coupling to enable or disable the coupling hold function. If enabled,

after you press , the settings for the channel coupling remain

unchanged; if disabled, then the channel coupling is, by default, set to "DC".

- Press Password, and then the password reset dialog box is displayed, as

shown in the figure below. You can reset the password. The initial password
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is empty. You do not need to input the old password when you reset the

password for the first time.

• : Press this key to cancel the auto setting and recovers to the parameter

settings prior to pressing the  key.

NOTE

The waveform auto setting function requires that the frequency of the signal should be greater

than or equal to 35 Hz, the amplitude greater than or equal to 5 mV. Otherwise, the waveform

auto setting function may be invalid.

9.2.2 Measurement Parameter

Press  on the front panel to enter the measurement setting menu. You can set
the measurement source, enable or disable the all measurement function, the
statistical analysis function, and etc. You can also quickly make measurements for 41
waveform parameters. The measurement results will be displayed on the screen. The
measurement results on the screen are always marked in the same color as the
current measurement channel. You can also enable the touch screen and tap the auto
measurement label "MEASURE" at the top of the screen to enter the measurement
setting menu.

NOTE

If there is no signal input for the current source or the measurement result is not within the

valid range (too large or too small), then the measurement results are invalid, and "*****" is

displayed on the screen. Please re-input the signal or set the signal.

Time Parameters
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Figure 9.1 Time Parameters

1. Period: defined as the time between the middle threshold points of two

consecutive, like-polarity edges.

2. Frequency: defined as the reciprocal of period.

3. Rise Time: indicates the time for the signal amplitude to rise from the threshold

lower limit to the threshold upper limit.

4. Fall Time: indicates the time for the signal amplitude to rise from the threshold

upper limit to the threshold lower limit.

5. +Width: indicates the time between the threshold middle value of a rising edge to

the threshold middle value of the next falling edge.

6. -Width: indicates the time between the threshold middle value of a falling edge to

the threshold middle value of the next rising edge.

7. +Duty: indicates the ratio of the positive pulse width to the period.

8. -Duty: indicates the ratio of the negative pulse width to the period.

9. Tvmax: indicates the time that corresponds to the maximum value of the

waveform (Vmax).

10. Tvmin: indicates the time that corresponds to the minimum value of the waveform

(Vmin).
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NOTE

The default values for threshold upper limit, threshold middle value, and threshold low limit

are 90%, 50%, and 10%, respectively. You can press  > Setting to enter the sub-menu to

set the parameters.

Count Values

1. Positive Pulse Count: The number of positive pulses that rise from under the

threshold lower limit to above the threshold upper limit.

Positive Pulse Count = n

1 n2
Threshold 

Upper Limit

Threshold 
Lower Limit

2. Negative Pulse Count: The number of negative pulses that fall from above the

threshold upper limit to below the threshold lower limit.

1 n2

Negative Pulse Count = n

Threshold 
Upper Limit

Threshold 
Lower Limit

3. Rising Edge Count: The number of rising edges that rise from under the threshold

lower limit to above the threshold upper limit.
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1 n2

Rising Edge Count = n

Threshold 
Upper Limit

Threshold 
Lower Limit

4. Falling Edge Count: The number of falling edges that fall from above the

threshold upper limit to below the threshold lower limit.

1 n2

Falling Edge Count = n

Threshold 
Upper Limit

Threshold 
Lower Limit

NOTE

• The above measurement items are only available for the analog channels.

• The default values for threshold upper limit and threshold low limit are 90% and 10%,

respectively. You can press  > Setting to enter the sub-menu to set the parameters.

Delay and Phase Parameters

Source A

Source B

Period

Delay
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1. Delay A →B : indicates the time difference between the threshold middle values

on the rising edge of Source A and that of Source B. Negative delay indicates that

the rising edge of Source A occurred after that of Source B.

2. Delay A →B : indicates the time difference between the threshold middle values

on the falling edge of Source A and that of Source B. Negative delay indicates that

the falling edge of Source A occurred after that of Source B.

3. Delay A →B : indicates the time difference between the threshold middle values

on the rising edge of Source A and the falling edge of Source B. Negative delay

indicates that the rising edge of Source A occurred after the falling edge of Source

B.

4. Delay A →B : indicates the time difference between the threshold middle values

on the falling edge of Source A and the rising edge of Source B. Negative delay

indicates that the falling edge of Source A occurred after the rising edge of Source

B.

5. Phase A →B : indicates the phase deviation between the threshold middle

values on the rising edge of Source A and that of Source B. The phase formula is as

follows:

°360×=
sourceA

RR
RR Period

BDelayA
BPhaseA

Wherein, RR BPhaseA  represents Phase A →B , RR BDelayA  represents Delay A

→B , and sourceAPeriod  represents period of Source A.

6. Phase A →B : indicates the phase deviation between the threshold middle

values on the falling edge of Source A and that of Source B. The phase formula is

as follows:

°360×=
sourceA

FF
FF Period

BDelayA
BPhaseA

Wherein, FF BPhaseA  represents Phase A →B , FF BDelayA  represents Delay A

→B , and sourceAPeriod  represents period of Source A.

 Operations and Measurements

Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved. 177



7. Phase A →B : indicates the phase deviation between the threshold middle

values on the rising edge of Source A and falling edge of Source B. The phase

formula is as follows:

°360×=
sourceA

FR
FR Period

BDelayA
BPhaseA

Wherein, FR BPhaseA  represents Phase A →B , FR BDelayA  represents Delay A

→B , and sourceAPeriod  represents period of Source A.

8. Phase A →B : indicates the phase deviation between the threshold middle

values on the falling edge of Source A and the rising edge of Source B. The phase

formula is as follows:

°360×=
sourceA

RF
RF Period

BDelayA
BPhaseA

Wherein, RF BPhaseA  represents Phase A →B , RF BDelayA  represents Delay A

→B , and sourceAPeriod  represents period of Source A.

NOTE

• Source A and Source B can be any channel among CH1-CH4, Math1-Math4, and D0-D15.

You can press  > Add to enter the sub-menu to set the parameters.

• The default threshold middle value is 50%. You can press  > Setting to enter the

sub-menu to set the parameters.

Voltage Parameters
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Vpp

Vtop

Vbase

Overshoot

Vmax

Vmin

Vupper

Vmid

Vlower

Preshoot

Vamp

Figure 9.2 Voltage Parameters

1. Vmax: indicates the voltage value from the highest point of the waveform to the

GND.

2. Vmin: indicates the voltage value from the lowest point of the waveform to the

GND.

3. Vpp: the voltage value from the highest point to the lowest point of the waveform.

4. Vtop: indicates the voltage value from the flat top of the waveform to the GND.

5. Vbase: indicates the voltage value from the flat base of the waveform to the GND.

6. Vamp: indicates the voltage value from the top of the waveform to the base of the

waveform.

7. Vupper: indicates the actual voltage value that corresponds to the threshold

maximum value.

8. Vmid: indicates the actual voltage value that corresponds to the threshold middle

value.

9. Vlower: indicates the actual voltage value that corresponds to the threshold

minimum value.

10. Vavg: indicates the arithmetic average value on the whole waveform or in the

gating area. The formula is shown as follows:
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n

x
Average

n
i i∑ 1==

Wherein, ix  is the measurement result of the i th point, and n  is the number of
points being measured.

11. RMS: indicates the root mean square value on the whole waveform or in the

gating area. The formula is as follows.

n

x
RMS

n

i i∑
1

2

==

Wherein, ix  is the measurement result of the i th point, and n  is the number of
points being measured.

12. Per.VRMS: indicates the root mean square value within a period. The formula is as

shown above.

13. Overshoot: indicates the ratio of the difference between the maximum value and

the top value of the waveform to the amplitude value.

14. Preshoot: indicates the ratio of the difference between the minimum value and

the base value of the waveform to the amplitude value.

15. Std. Dev: indicates the root-mean-square value of the waveforms, with the DC

component removed. The formula is shown as follows:

n

Averagex
DevS

n

i i∑
1

2)(
.td =

−
=

Wherein, ix  is the amplitude of the i th point, Average  is the waveform average value,

and n  is the number of the points being measured.

Other Parameters

1. +SlewRate: On the rising edge, first calculate the difference between the high

value and the low value, then use the difference to divide the corresponding time

value to obtain the positive slew rate.

2. -SlewRate: On the falling edge, first calculate the difference between the low value

and the high value, then use the difference to divide the corresponding time value

to obtain the negative slew rate.
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3. Area: indicates the area of the whole waveform within the screen. The unit is V*s.

The area of the waveform above the zero reference (namely the vertical offset) is

positive, and the area of the waveform below the zero reference is negative. The

area measured is the algebraic sum of the area of the whole waveform within the

screen.

4. Period Area: indicates the area of the first period of waveform on the screen. The

unit is V*s. The area of the waveform above the zero reference (namely the vertical

offset) is positive, and the area of the waveform below the zero reference is

negative. The area measured is the algebraic sum of the whole period area.

9.2.3 Measurement Settings

1. Measure Category

Press  > Add > Category to select "Horizontal", "Vertical", or "Other".
Meanwhile, the specific measurement parameters are displayed on the screen, as

shown in the figure below. You can also rotate the multifunction knob  to select
"Horizontal", "Vertical", or "Other". Then press down the knob to select it.

- "Horizontal" measurement parameters: Period, Frequency, Rise Time, Fall Time,

+Width, -Width, +Duty, -Duty, Positive Pulse Count, Negative Pulse Count,

Rising Edge Count, Falling Edge Count, Tvmax, Tvmin, +Slew Rate, and -Slew

Rate.

- "Vertical" measurement parameters: Vmax, Vmin, Vpp, Vtop, Vbase, Vamp,

Vupper, Vmid, Vlower, Vavg, VRMS, Per. VRMS, Overshoot, Preshoot, Area,

Period Area, and Std Dev.

- "Other" measurement parameters: Delay A →B , Delay A →B , Delay A →B

, Delay A →B , Phase A →B , Phase A →B , Phase A →B , and Phase A

→B .
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Measurement Category Area Measurement Parameter Area

In the measurement parameter interface, rotate the multifunction knob  to
select a measurement item and then press down the knob to select it. Then the
measurement results of the item are displayed at the bottom of the screen
(measurement results of up to 10 items can be displayed at most). When you add a
new measurement item, its measurement result will be displayed as the first, with
the original items moving right in sequence. When you add a new measurement
item after ten items have been added, the last item at the bottom of the screen will
be closed. You can also enable the touch screen to tap the specified measurement
category and measurement item.

TIP

- When you rotate the multifunction knob to switch between the measurement parameter

area and the measurement category, you need to press down the knob to select the

desired measurement category.

- In the measurement category area, rotate the multifunction knob  to select "Analyze".

The following figure is displayed. Select "Counter", "DVM", "Histogram", "Power"

(required to install the option MSO8000-PWR), "Eye", or "Jitter" (required to install the

option MSO8000-JITTER when "Eye" or "Jitter" is selected) to open the specified menu.

For description about these functions, refer to relevant chapters.

2. Source Selection

For different measurement categories, the selection methods for measurement
sources are different.

- Horizontal and vertical parameter measurement

Press  > Add > Source A, then rotate the multifunction knob  to select
the desired channel for measurement and press down the knob to select it. You
can also press Source A continuously or enable the touch screen to select it.
The available channels include CH1-CH4, Math1-Math4, and D0-D15.
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- Other (Delay and Phase) parameter measurement

Press  > Add > Source A (Source B) to set the two source channels for
the current measurement category. The available channels include CH1-CH4,
Math1-Math4, and D0-D15.

3. Edge Setting

Press  > Add > EdgeSet to set the EdgeA Event, EdgeB Event, EdgeA

Number, and EdgeB Number. You can rotate the multifunction knob  to select
"Auto", "First", "Last", or "Any Edge" for the EdgeA Event or EdgeB Event. Then
press down the knob to select it. When EdgeA Event or EdgeB Event selects "Any
Edge", you can set the EdgeA Number and EdgeB Number. The range is from 1 to
1,000.

- First: selects the first edge searched across the screen range to measure.

- Last: selects the last edge searched across the screen range to measure.

- Auto: selects the nearest edge to measure according to the principle of

proximity. By default, "Auto" is selected.

- Any Edge: selects any edge searched across the screen range to measure.

NOTE

Only in "Other" measurement category, can you set these parameters. To select "Other"

measurement category, press  > Add > Category to set the measurement category

to "Other".

4. Indicator

Press Indicatorcontinuously to enable or disable the indicator. You can also press

 > Remove > Indicator to enable or disable the indicator. For details, refer to
descriptions in Measure Mode.

5. Measurement Settings

Press Settings to enter the sub-menu of measurement.

- Press Mode to select the measurement mode to "Normal" or "Precision".

- Normal: executes measurement of up to 1 Mpts.

- Precision: executes measurement of up to 200 Mpts, improving the

resolution of measurement results. In this mode, the refresh rate of the

waveforms may be reduced.
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- Press Type to select "Threshold", "Range", or "Amp Method".

- Select "Threshold", and then make the following settings:

Press Source to select the desired channel for measurement (CH1-CH4 or
Math1-Math4).

Press Upper to select "Upper(%)" or "Upper(Abs)" first, and then press the
key to set the upper limit of the measurement. For details, refer to
descriptions in "Parameter Setting Method". When the upper limit is set to
be smaller than or equal to the current middle value, a prompt message "Set
at lower limit" is displayed. Then, the oscilloscope will automatically adjust
the upper limit and make it greater than the middle value. By default, it is
90%.

Press Mid to select "Mid(%)" or "Mid(Abs)" first, and then press the key to
set the middle value of the measurement. For details, refer to descriptions in
"Parameter Setting Method". The middle value is limited by the settings of
the upper limit and lower limit. By default, it is 50%.

Press Lower to select "Lower(%)" or "Lower(Abs)" first, and then press the
key to set the lower limit of the measurement. For details, refer to
descriptions in "Parameter Setting Method". When the lower limit is set to be
greater than or equal to the current middle value, a prompt message "Set at
upper limit" is displayed. Then, the oscilloscope will automatically adjust the
lower limit and make it smaller than the middle value. By default, it is 10%.

Press Default, and then the upper value, middle value, and lower value will
be restored to the defaults.

NOTE

- In "Normal" measurement mode, different types of threshold can be configured

for each source. The threshold type for different sources is independent of each

other and does not affect each other.

- In "Precision" measurement mode, only the "percentage (%)" threshold type is

supported.

- Select "Range", and then press Region to select "Main", "Zoom", or "Cursor".

Main: indicates that the measurement range is within the main time base
region.

Zoom: indicates that the measurement range is within the zoomed time base
region.

NOTE

Only when you enable the delayed sweep function first, can "Zoom" be enabled.

Cursor: when you select it, two cursors will be displayed on the screen. At
this time, press CursorA and CursorB respectively and then rotate the
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multifunction knob  to adjust the positions of the two cursors to
determine the measurement range. Also, you can press CursorAB and then

rotate the multifunction knob  to adjust the positions of the two cursors
simultaneously.

- Select "Amp Method", and then press Amp Method to select "Auto" or

"Manual". This method affects the measurement method for the top and

base values. If you select "Manual", you need to set the following

parameters:

Press Top to select "Histogram" or "Max-Min".

Press Base to select "Histogram" or "Max-Min".

NOTE

• Modifying the threshold will affect the measurement results of time, delay and phase

parameters.

• If you select "Manual" for the amplitude method, the measurement results of other

parameters may be affected.

• "Histogram" and "Max-Min" are the internal measurement algorithm for the oscilloscope.

The "Histogram" method here is different from the Histogram function of the

oscilloscope.

9.2.4 Remove the Measurement Result

This oscilloscope allows you to remove the measurement results of the parameters.

Press  > Remove to enter the "Remove" sub-menu.

• Press Remove to remove the last added measurement item. Note that pressing

this key one time can only remove one measurement item. When you remove a

measurement item, the measurement result of the last added item at the bottom

of the screen will be removed. You can rotate the multifunction knob  to

switch the measurement item, then press down the knob  or press Remove to

remove the item. You can also enable the touch screen to tap the desired

measurement item, and then press Remove to remove the item.

• Press Remove All to remove all the displayed measurement items.

• Press Indicator to enable or disable the indicator.

Besides, you can also press  > Add > Remove to enter the "Remove" sub-menu.
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TIP

If the "Remove" sub-menu is not displayed in the current menu, when you select a certain

measurement item, the system will automatically enter the "Remove" sub-menu.

9.2.5 Statistical Function

Performs statistics and displays the measurement results (Cur, Avg, Max, Min, Dev,
and Cnt) of at most 10 items, as shown in the figure below.

Press  > Statistic to enter the sub-menu of "Statistic".

• Press Statistic to enable or disable the statistical function.

• Press Reset Stat. to clear the history statistics data and makes parameters

statistics again.

• Press Count, then rotate the multifunction knob  or use the pop-up numeric

keypad to set the count value. Its range is from 2 to 100000. Its default value is

1000.

9.2.6 All Measurement

All measurement could measure the time parameter, count value, voltage parameters,
and other parameters of the current measurement source and display the results on

the screen. Press  > All Measure to select "OFF" (disabling the all measurement
function) or select the desired channel for measurement (CH1-CH4). If you select
"CH1", data of all measurement parameters of CH1 are displayed on the screen.

NOTE

The removal operation will not clear the measurement results of the all-measurement function.
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9.3 Cursor Measurement
Cursor measurement can measure the X axis values (e.g Time) and Y axis values (e.g.
Voltage) of the selected waveform. Before making cursor measurement, connect the
signal to the oscilloscope to acquire stable display. All the parameters supported by
the "Auto Measurement" function can be measured with cursor measurement. The
cursor measurement function provides the following two cursors.

X Cursor (Cursor A)X Cursor (Cursor A) X Cursor (Cursor B)X Cursor (Cursor B)

Y Cursor 
(Cursor A)
Y Cursor 

(Cursor A)

Y Cursor 
(Cursor B)
Y Cursor 

(Cursor B)

• X Cursor

X cursor is a vertical solid/dotted line that is used to make horizontal
adjustments. It can be used to measure time (s), frequency (Hz), phase (°), and
ratio (%).

- Cursor A is a vertical solid line (  is displayed at the bottom of the screen),

and Cursor B is a vertical dotted line (  is displayed at the bottom of the

screen).

- In the X-Y cursor mode, X cursor is used to measure the waveform

amplitude of CH1.

• Y Cursor

Y cursor is a horizontal solid/dotted line that is used to make vertical
adjustment. It can be used to measure amplitude (the unit is the same as that of
the source channel amplitude) and ratio (%).
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- Cursor A is a horizontal solid line (  is displayed at the bottom of the

screen), and Cursor B is a horizontal dotted line (  is displayed at the

bottom of the screen).

- In the X-Y cursor mode, Y cursor is used to measure the waveform

amplitude of CH2.

Press  on the front panel to open the cursor measurement menu, or enable the

touch screen and then tap the function navigation icon  at the lower-left corner of
the screen to open the function navigation. Then, tap the "Cursor" icon to open the
cursor measurement menu.

In the cursor measurement menu, press Mode and then rotate the multifunction

knob  to select the desired cursor mode (the default is "OFF"). Press down the
knob to select it. You can also press Mode continuously or enable the touch screen to
select it. The available modes are "Manual", "Track", "XY", and "Measure". When you
select "OFF", the cursor measurement function is disabled.

NOTE

• When the Time Base Mode is set to "XY", the XY cursor measurement mode is valid.

• No cursor will be displayed if no cursor measurement parameter is selected or the

measurement source has no input.

• When the waveform is expanded or compressed horizontally, the cursor will change

accordingly.

9.3.1 Manual Mode

In this mode, you can adjust the cursor manually to measure the value of the
waveforms of the specified source at the current cursor. The measurement results are
displayed at the upper-left corner of the screen. When you change the cursor
position, the measurement results will be changed accordingly.

Press Mode to select "Manual" to enable the manual cursor measurement function. If
the settings for the parameter such as the cursor type, measurement source,
horizontal measurement unit, and vertical measurement unit are different, the
measurement results will be different for cursor measurement. The measurement
results are displayed at the upper-left corner of the screen, as shown in the figure
below.
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• AX: indicates the X value at Cursor A.

• AY: indicates the Y value at Cursor A.

• BX: indicates the X value at Cursor B.

• BY: indicates the Y value at Cursor B.

• ∆X: indicates the horizontal spacing between Cursor A and Cursor B.

• ∆Y: indicates the vertical spacing between Cursor A and Cursor B.

• 1/∆X: indicates the reciprocal of the horizontal spacing between Cursor A and

Cursor B.

1. Select the Cursor Type

Press Select continuously to select the cursor type.

- X-X: It is a pair of vertical solid (Cursor A)/dotted (Cursor B) lines, used for

measuring time parameters. The measurement results include AX, BX, ∆X, and

1/ΔX (displayed only when "s" or "Hz" is selected under Hori. Unit).

- Y-Y: It is a pair of horizontal solid (Cursor A)/dotted (Cursor B) lines, used for

measuring voltage parameters. The measurement results include AY, BY, and ∆Y.

- XY-X: when this mode is selected, X cursors and Y cursors are both displayed.

However, you can only set the AX and BX values by pressing the specified menu

on the front panel.

- XY-Y: when this mode is selected, X cursors and Y cursors are both displayed.

However, you can only set the AY and BY values by pressing the specified menu

on the front panel.

2. Select the Measurement Source

Press Source, rotate the multifunction knob  to select the measurement
channel, and then press down the knob to select it. You can also press Source
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continuously or enable the touch screen to select it. The available source channels
are NONE, CH1-CH4, LA, and Math1-Math4.

NOTE

- Only channels currently enabled can be selected.

- When "LA" is selected as the channel source, Select is grayed out and disabled. By

default, "X" is selected under Select.

3. Adjust the Cursor Position

a. When "X-X" or "XY-X" is selected, you can adjust the position of X cursors.

- Press AX, then rotate the multifunction knob  to adjust the horizontal

position (X-axis) of Cursor A (X cursor). Its adjustable range is limited within

the screen.

Enable the touch screen and tap AX to set the horizontal position of Cursor
A (X cursor) with the pop-up numeric keypad. The horizontal axis indicates
time, and the unit of its setting value is the same as that of the horizontal
unit.

- Press BX, then rotate the multifunction knob  to adjust the horizontal

position (X-axis) of Cursor B (X cursor). Its adjustable range is limited within

the screen.

Enable the touch screen and tap BX to set the horizontal position of Cursor B
(X cursor) with the pop-up numeric keypad. The horizontal axis indicates
time, and the unit of its setting value is the same as that of the horizontal
unit.

- Press AX BX, then rotate the multifunction knob  to adjust the horizontal

positions (X-axis) of Cursor A and Cursor B (X cursors). Its adjustable range is

limited within the screen. The horizontal spacing between Cursor A and

Cursor B (X cursors) remains unchanged.

b. When "Y-Y" or "XY-Y" is selected, you can adjust the position of Y cursors.

- Press AY, then rotate the multifunction knob  to adjust the vertical

position (Y-axis) of Cursor A (Y cursor).

Enable the touch screen and tap AY to set the vertical position of Cursor A (Y
cursor) with the pop-up numeric keypad. The vertical axis indicates voltage,
and the unit of its setting value is the same as that of the vertical unit.
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- Press BY, then rotate the multifunction knob  to adjust the vertical

position (Y-axis) of Cursor B (Y cursor).

Enable the touch screen and tap BY to set the vertical position of Cursor B (Y
cursor) with the pop-up numeric keypad. The vertical axis indicates voltage,
and the unit of its setting value is the same as that of the vertical unit.

- Press AY BY, then rotate the multifunction knob  to adjust the vertical

positions (Y-axis) of Cursor A and Cursor B (Y cursors). The vertical spacing

between Cursor A and Cursor B (Y cursors) remains unchanged.

NOTE

If one of the three menu items (AX, BX, and AX BX) is selected; or one of the three menu

items (AY, BY, and AY BY) is selected; you can press down the multifunction knob 

continuously to switch among the three items.

4. Set the Horizontal/Vertical Measurement Unit

- When "X-X" or "XY-X" is selected, you can set the horizontal measurement unit.

When the source is set to Math1-Math4, this menu is grayed out and disabled.

Press More > Hori. Unit, then rotate the multifunction knob  to select the
horizontal measurement unit, and then press down the knob to select it. You
can also press Hori. Unit continuously or enable the touch screen to select it.
The available units include "s", "Hz", "Degree(°)", and "Percent(%)".

- s: measures the time value at X Cursor (taking the trigger position as

reference). The measurement results include AX, BX, ∆X, and 1/∆X. Wherein,

AX, BX, and ∆X all indicate time, and 1/∆X indicates frequency.

- Hz: measures the frequency value at X Cursor (taking the trigger position as

reference). The measurement results include AX, BX, ∆X, and 1/∆X. Wherein,

AX, BX, and ∆X all indicate frequency, and 1/∆X indicates time.

- Degree(°): measures the phase value at X Cursor. The measurement results

include AX, BX, and ∆X, and they are all expressed in degree.

This oscilloscope allows you to set the phase reference position according to
your needs. After adjusting X Cursor to a desired position, press Set
Reference to take the current cursor position as the reference. The current
positions of Cursor A and Cursor B are respectively defined as "0°" and
"360°". Meanwhile, two vertical cursors (in blue) that cannot be moved are
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displayed on the screen as the phase reference position (the phase position
at "0°" and "360°" are respectively marked by a solid line and a dotted line).
Before you set manually, the oscilloscope adopts the default phase reference
position.

- Percent(%): measures ratio at X Cursor. The measurement results include AX,

BX, and ∆X, and they are all expressed in percentage.

This oscilloscope allows you to set the ratio reference position according to
your needs. After adjusting X Cursor to a desired position, press Set
Reference to take the current cursor position as the reference. The current
positions of Cursor A and Cursor B are respectively defined as "0%" and
"100%". Meanwhile, two cursors (in blue) that cannot be moved are
displayed on the screen as the ratio reference position (the ratio position at
"0%" and "100%" are respectively marked by a solid line and a dotted line).
Before you set manually, the oscilloscope adopts the default ratio reference
position.

- When "Y-Y" or "XY-Y" is selected, you can set the vertical measurement unit.

When the source is set to Math1-Math4, this menu is grayed out and disabled.

Press More > Vert. Unit, then rotate the multifunction knob  to select the
vertical measurement unit, and then press down the knob to select it. You can
also press Vert. Unit continuously or enable the touch screen to select it. The
available units include "Source" and "Percent(%)".

- Source: measures the amplitude at Y Cursor (taking the channel ground

point as the reference). The measurement results include AY, BY, and ∆Y (its

unit is consistent with that of the current source).

- Percent(%): measures ratio at Y Cursor. The measurement results include AY,

BY, and ∆Y, and they are all expressed in percentage.

This oscilloscope allows you to set the ratio reference position according to
your needs. After adjusting Y Cursor to a desired position, press Set
Reference to take the current cursor position as the reference. The current
positions of Cursor A and Cursor B are respectively defined as "0%" and
"100%". Meanwhile, two cursors (in blue) that cannot be moved are
displayed on the screen as the ratio reference position (the ratio position at
"0%" and "100%" are respectively marked by a solid line and a dotted line).
Before you set manually, the oscilloscope adopts the default ratio reference
position.

5. Set LA Type

 Operations and Measurements

192 Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved.



When the measurement source is set to "LA", you need to set the LA display type.
Press More, and then press La Type continuously to select "HEX" or "BIN".

6. Measurement Example

Measure the period of a sine wave by using the manual cursor measurement and
Auto measurement respectively. The measurement results are both 1 ms, as shown
in Figure 9.3 .

Auto Measurement

Cursor Measurement

Figure 9.3 Manual Cursor Measurement Example

9.3.2 Track Mode

In this mode, you can adjust the two pairs of cursors (Cursor A and Cursor B) to
measure the X and Y values on two different sources respectively. The points being

measured on Cursor A and Cursor B are marked by  and  respectively. When
the cursors are moved horizontally/vertically, the markers will position on the
waveform automatically. When the waveform is expanded or compressed
horizontally/vertically, the markers will track the points being marked at the last
adjustment of the cursors.

NOTE

When the delayed sweep function is enabled, the track cursor is within the expanded area.

Press Mode to select "Track" to enable the cursor track function. The measurement
results will be displayed at the upper-left corner of the screen, as shown in the
following figure. When you modify the Track measurement parameter, the
measurement results will be changed accordingly.
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• AX: indicates the X value at Cursor A.

• AY: indicates the Y value at Cursor A.

• BX: indicates the X value at Cursor B.

• BY: indicates the Y value at Cursor B.

• ΔX: indicates the horizontal spacing between Cursor A and Cursor B.

• ΔY: indicates the vertical spacing between Cursor A and Cursor B.

• 1/ΔX: indicates the reciprocal of the horizontal spacing between Cursor A and

Cursor B.

1. Select the Measurement Source

- Press AX Source, rotate the multifunction knob  to select the measurement

channel, and then press down the knob to select it. You can also press AX

Source continuously or enable the touch screen to select it. The available

source channels include NONE, CH1-CH4, and Math1-Math4.

- Press BX Source, rotate the multifunction knob  to select the measurement

channel, and then press down the knob to select it. You can also press BX

Source continuously or enable the touch screen to select it. The available

source channels include NONE, CH1-CH4, and Math1-Math4.

NOTE

Only channels currently enabled can be selected.

2. Select the Track Cursor

Press Track to select "X" or "Y" as the current track cursor. By default, it is "X".

- X: tracks X Cursor and measures the value at X Cursor.
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- Y: tracks Y Cursor and measures the time of the first point at the left side of the

screen.

3. Adjust the Cursor Position

a. When "X" is selected for the track mode, you can adjust the position of X cursor.

- Press AX, then rotate the multifunction knob  to adjust the horizontal

position (X-axis) of Cursor A (X cursor). Its adjustable range is limited within

the screen.

- Press BX, then rotate the multifunction knob  to adjust the horizontal

position (X-axis) of Cursor B (X cursor). Its adjustable range is limited within

the screen.

- Press AX BX, then rotate the multifunction knob  to adjust the horizontal

positions (X-axis) of Cursor A and Cursor B (X cursors). Its adjustable range is

limited within the screen. The horizontal spacing between Cursor A and

Cursor B (X cursors) remains unchanged.

b. When "Y" is selected for the track mode, you can adjust the position of Y cursor.

- Press AY, then rotate the multifunction knob  to adjust the vertical

position (Y-axis) of Cursor A (Y cursor).

- Press BY, then rotate the multifunction knob  to adjust the vertical

position (Y-axis) of Cursor B (Y cursor).

- Press AY BY, then rotate the multifunction knob  to adjust the vertical

positions (Y-axis) of Cursor A and Cursor B (Y cursors). The vertical spacing

between Cursor A and Cursor B (Y cursors) remains unchanged.

NOTE

- If one of the three menu items (AX, BX, and AX BX) is selected; or one of the three

menu items (AY, BY, and AY BY) is selected; you can press down the multifunction knob

 continuously to switch among the three items.

- In track mode, the horizontal cursor (or vertical cursor) will track the marked point in a

timely manner (i.g, the cursor will move up and down with the transient change of the

waveform). Thus, the X value (or Y value) might change even though you do not adjust

the cursor.
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4. Measurement Example

Measure the waveforms of CH1 and CH2 with Cursor A and Cursor B, respectively.
Then, expand the waveforms horizontally, and you will find that the cursor will
track the point that has been marked, as shown in the following figure.

Track Measurement (before Horizontal Expansion):

Track Measurement (after Horizontal Expansion):

9.3.3 XY Mode

XY mode is only available when the horizontal time base mode is "XY" (refer to
"Timebase Mode"). In this mode, two pairs of cursors will appear. You can adjust the
cursor positions to measure the X and Y values at the crossing points of the two pairs
of cursors.
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Press Mode to select "XY" to enable the XY cursor measurement function. The
measurement results will be displayed at the upper-left corner of the screen, as
shown in the following figure.

• AX: indicates the X value at Cursor A.

• AY: indicates the Y value at Cursor A.

• BX: indicates the X value at Cursor B.

• BY: indicates the Y value at Cursor B.

• ΔX: indicates the horizontal spacing between Cursor A and Cursor B.

• ΔY: indicates the vertical spacing between Cursor A and Cursor B.

1. Adjust the Cursor Position

- Press AX, then rotate the multifunction knob  to adjust the X value at Cursor

A.

- Press BX, then rotate the multifunction knob  to adjust the X value at Cursor

B.

- Press AY, then rotate the multifunction knob  to adjust the Y value at Cursor

A.

- Press BY, then rotate the multifunction knob  to adjust the Y value at Cursor

B

- Press More > ABX, then rotate the multifunction knob  to adjust the X values

at Cursor A and Cursor B simultaneously.

- Press More > ABY, then rotate the multifunction knob  to adjust the Y values

at at Cursor A and Cursor B simultaneously.

During the adjustment, the measurement results will change accordingly. The
adjustable range is limited within the screen.
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NOTE

If you select either of the items (ABX and ABY), you can press down the multifunction knob

 continuously to switch between them.

2. Display Lissajous Legend

This oscilloscope provides the Lissajous schematic diagram under different
frequencies and phase deviations, as shown in Figure 9.4 . Press More > Lissajous,
then the Lissajous schematic diagram is displayed.

Phase deviation 
between two signals

Frequency ratio 
between two signals

Figure 9.4 Lissajous Schematic Diagram

9.3.4 Measure Mode

Press Mode to select "Measure". In this mode, the cursor position for measurement is
displayed.

Press Indicator continuously to enable or disable the Indicator. If it is enabled, one or
multiple cursors are displayed on the screen. Before enabling the indicator, you need
to enable at least one parameter for auto measurement. The number of cursors will
change along with the enabled measurement parameters.
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10 Digital Voltmeter (DVM) and Frequency
Counter
This series oscilloscope provides a built-in digital voltmeter (DVM) and frequency
counter, which enable you to perform an accurate measurement, improving user
experience in counter and frequency measurement.

10.1 Digital Voltmeter (DVM)
The built-in DVM of this oscilloscope provides 3-digit voltage measurements on any
analog channel. DVM measurements are asynchronous from the oscilloscope's
acquisition system and are always acquiring.

Press  > Analyze > DVM to open the DVM setting menu, or enable the touch

screen and then tap the function navigation icon  at the lower-left corner of the
screen to open the function navigation. Then, tap the "DVM" icon to open the DVM

setting menu. You can also press  > Add, then in the displayed measurement

category area, rotate the multifunction knob  to select "Analyze", and then select
"DVM" to open the DVM setting menu.

10.1.1 To Enable or Disable DVM Measurement

In the "DVM" setting menu, press the DVM continuously to enable or disable DVM
measurement. When enabled, the following figure is displayed. The DVM display also
has a scale that is determined by the channel's vertical scale and vertical offset. The
scale range is the range of the screen. The scale's yellow triangle pointer shows the
most recent measurement result. The specific value above the pointer shows the
measurement extrema over the last 3 seconds.

Pointer Scale

Source Mode Voltage Value
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NOTE

DVM measurement and the oscilloscope share the same probe, so the unit for the DVM

measurement is consistent with that of the channel.

10.1.2 To Select the Measurement Source

Press Source in the "DVM" setting menu, then rotate the multifunction knob  to
select the desired source. You can also press Source continuously or enable the touch
screen to select it. The analog channel (CH1-CH4) can be selected to be the
measurement source.

NOTE

Even if the analog channel (CH1-CH4) is not enabled, you can still perform the DVM

measurement.

10.1.3 To Select Measurement Mode

Press Mode, and rotate the multifunction knob  to select the desired Mode, and
then press down the knob to select it. You can also press Mode continuously to select
the mode or enable the touch screen to tap the desired mode and select it. The DVM
measurement modes include AC RMS, DC, and AC+DC RMS.

• AC RMS: displays the root-mean-square value of the acquired data, with the DC

component removed.

• DC: displays the average value of the acquired data.

• AC+ DC RMS: displays the root-mean-square value of the acquired data.

10.1.4 To Set the Limits

Press Limits to enter the sub-menu of Limits. Then set the following parameters.

• Beeper

Press Beeper continuously to enable or disable the Beeper.

• Limits Condition Setting

Press When, then rotate the multifunction knob  to select desired limit setting
condition. Press down the knob to select it. You can also press When
continuously or enable the touch screen to select it. The limits conditions include
"In Limits" and "Out Limits".
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- In Limits: when the voltage value is within the limits, you can enable or

disable the beeper to sound an alarm.

- Out Limits: when the voltage value is outside of the limits, you can enable

or disable the beeper to sound an alarm.

• Upper/Lower Limit Setting

Press Upper, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the upper limit of the voltage.

Press Lower, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the lower limit of the voltage.

10.2 Frequency Counter
The frequency counter analysis function provides frequency, period, or edge event
counter measurements on any analog channel.

Press  > Analyze > Counter to open the Frequency Counter setting menu, or

enable the touch screen and then tap the function navigation icon  at the lower-
left corner of the screen to open the function navigation. Then, tap the "Counter" icon

to open the frequency counter setting menu. You can also directly press  >
Counter on the front panel to enter the frequency counter setting menu. In addition,

You can also press  > Add, then in the displayed measurement category area,

rotate the multifunction knob  to select "Analyze", and then select "Counter" to
open the frequency counter setting menu.

10.2.1 To Enable or Disable the Frequency Counter

In the "Counter" setting menu, press Counter continuously to enable or disable the
frequency counter measurement. When enabled, the following figure is displayed.

Source Measurement Item Value  
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10.2.2 To Select the Measurement Source

Press Source, then rotate the multifunction knob  to select the desired source, and
then press down the knob to select the source. You can also press Source
continuously or enable the touch screen to select it. Analog channels (CH1-CH4),
digital channels (D0-D15), and EXT can all be selected as the source of the frequency
counter.

10.2.3 To Select the Measurement Item

The measurement items supported by the frequency counter of this oscilloscope
include Frequency, Period, and Totalize measurements. Wherein, Totalize indicates the
count of edge events on the signal.

Press Measure in the "Counter" menu, then rotate the multifunction knob  to
select the desired measurement item, and then press down the knob to select the
item. You can also press Measure continuously or enable the touch screen to tap the
desired measurement item and select it.

10.2.4 To Set the Resolution

For Period and Frequency measurements, you need to set the readout resolution.

Press Resolution, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the resolution. The range of resolution is from 3 bits to 6 bits. By
default, it is 5 bits.

NOTE

The greater the resolution, the longer the gate time. In this way, the measurement time will be

longer.

10.2.5 To Clear Count

When "Totalize" is selected under Measure, the oscilloscope measures the count of
edge events on the signal. At this time, press Clear Count to clear the measurement
results.

10.2.6 To Enable or Disable the Statistical Function

For Period and Frequency measurements, you can enable the frequency counter
statistical function. Press Statistic continuously to enable or disable the statistical
function. When enabled, the maximum value and minimum value will be displayed in
the frequency counter data, as shown in the following figure.
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Statistics
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11 Power Analysis (Option)
The oscilloscope provides an optional power analysis function, which can help you
easily analyze the efficiency and reliability of the switch-mode power supplies. With
the power analysis function, you can analyze the power quality and output ripple
noise of the input power.

11.1 Power Quality
By analyzing the power quality, you can test the quality of AC input lines. The specific
measurement parameters for power quality analysis include V_RMS, I_RMS, real
power, apparent power, reactive power, power factor, reference frequency, phase
angle, impedance, voltage crest factor, and current crest factor.

Press  > Analyze > Power Analyzer to open the power analysis setting menu,

or enable the touch screen and then tap the function navigation icon  at the lower-
left corner of the touch screen to enable the function navigation. Then, tap the

"Power" icon to open the power analysis setting menu. You can also press  >
Add, then in the displayed parameter measurement category area, rotate the

multifunction knob  to select the "Analyze" tab, then select "UPA" to open the
power analysis setting menu.

• Select the Analysis Type

In the power analysis setting menu, press Analysis Type and rotate the

multifunction knob  to select "Power Quality", and then press down the knob
to select it. You can also press Analysis Type continuously or enable the touch
screen to select the desired analysis type.

• Set the Power Quality Analysis Source

In the power analysis setting menu, press Source to enter the source setting
menu.

- Press Voltage and rotate the multifunction knob  to select the channel

(CH1-CH4) for acquiring voltage. Press down the knob to select it. You can

also press Voltage continuously or enable the touch screen to select the

channel.

- Press Current and rotate the multifunction knob  to select the channel

(CH1-CH4) for acquiring current. Press down the knob to select it. You can
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also press Current continuously or enable the touch screen to select the

channel.

- Press Freq. Ref continuously to select "Voltage" or "Current" as the

frequency reference.

• Set the Reference Level

Press Ref Levels (level of the frequency reference channel) to enter the reference
level setting menu.

- Press Type, rotate the multifunction knob  to set the reference level

display type to "Percent(%)" or "Absolute", and then press down the knob.

You can also press Type continuously or enable the touch screen to select

the type.

- Press Upper, then rotate the multifunction knob  or use the pop-up

numeric keypad to set the upper limit value. Reducing the upper limit to the

current middle value will automatically reduce the middle value and lower

limit to keep them lower than the upper limit.

- Press Mid, then rotate the multifunction knob  or use the numeric

keypad to set the middle value. The middle value is limited by the settings

of the upper limit and lower limit.

- Press Lower, then rotate the multifunction knob  or use the numeric

keypad to set the lower limit. Increasing the lower limit to the current

middle value will automatically increase the middle value and upper limit to

keep them higher than the lower limit.

- Press Default, and then the upper limit, middle value, and lower limit will

be restored to the defaults.

• Set Count

Press Count, then rotate the multifunction knob  or use the numeric keypad
to set the number of statistical times for power quality analysis. Its range is from
2 to 5000. By default, it is 1000.

• Reset
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Press Reset Stat. to clear the current data and execute statistics on the
measurement results again.

• Open or Close the Results Display Window

Press Display continuously to enable or disable the display of the results. When
enabled, the statistical results will be displayed on the screen, as shown in the

figure below. You can also enable the touch screen to tap the icon  at the
right-upper corner of the statistical results window to close it.

NOTE

If you select "ON" under Display, the multiplication operation will be automatically

enabled in the Math operation.

• View the Connection Diagram

Press Tips, and then the connection diagram of the power quality analysis is
displayed on the screen. Please connect the cables according to the connection
method as shown in Figure 11.1 . Press Tips again or enable the touch screen to

tap the icon  at the right-upper corner of the connection diagram window to
close it.

Figure 11.1 Connection Diagram of Power Quality Analysis
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11.2 Ripple
Power ripple is an important parameter for evaluating DC power supply, which
indicates the ripple quantity of the output DC voltage. The ripple analysis can
measure the current value, average value, minimum value, maximum value, standard
deviation, and count value of the ripples on the power output terminal.

NOTE

The 1X probe is recommended for the ripple measurement. For example, PVP2150 or PVP2350.

• Select the Analysis Type

In the power analysis setting menu, press Analysis Type and rotate the

multifunction knob  to select "Ripple", and then press down the knob to select
it. You can also press Analysis Type continuously or enable the touch screen to
select the desired analysis type.

• Set the Ripple Analysis Source

Press Source, and rotate the multifunction knob  to select the ripple analysis
source (CH1-CH4), then press down the knob to select the source. You can also
press Source continuously or enable the touch screen to select it.

• Set Count

Press Count, then rotate the multifunction knob  or use the numeric keypad
to set the number of statistical times for ripple analysis. Its range is from 2 to
5000. By default, it is 1000.

• Reset

Press Reset Stat. to clear the current data and execute statistics on the
measurement results again.

• Open or Close the Results Display Window

Press Display continuously to enable or disable the display of the results. When
enabled, the statistical results will be displayed on the screen, as shown in the

figure below. You can also enable the touch screen to tap the icon  at the
right-upper corner of the statistical results window to close it.

• View the Connection Diagram

Press Tips, and then the connection diagram of the Ripple analysis is displayed
on the screen. Please connect the cables according the connection method as
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shown in Figure 11.2 . Press Tips again or enable the touch screen to tap the

icon  at the right-upper corner of the connection diagram window to close it.

Figure 11.2 Connection Diagram of Ripple Analysis
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12 Histogram Analysis
This series oscilloscope supports the standard histogram analysis function, enabling
you to judge the trend of waveforms, and quickly locate the potential problems of the
signal.

12.1 To Enable or Disable the Histogram Function
The histogram analysis function supported by this series is available to provide a
statistical view of waveforms or measurement results. It can be classified into
horizontal histogram, vertical histogram, and measurement histogram. With the on-
going acquisition and measurement of the waveforms, the height of the bar graph
will change within the set range of the histogram window to indicate the number of
times for data statistics.

You can go to the "Histogram" setting menu through the following four ways:

• On the front panel, press  > Analyze > Histogram to enter the histogram

setting menu.

• Enable the touch screen and then tap the function navigation icon  at the

lower-left corner of the touch screen to enable the function navigation. Then tap

the "Histogram" icon, and the histogram setting menu is displayed at the right

section of the screen.

• Enable the touch screen and tap the auto measurement label "MEASURE" at the

top of the screen to enter the measurement setting menu. In the measurement

category area, rotate the multifunction knob  to select the "Analyze" option

and then press down the knob to select it. You can also tap the "Analyze" option

to select it. In the measurement parameter area, rotate the multifunction knob

 to select the "Histogram" option and then press down the knob to select it.

You can also tap the "Histogram" option to select it and then enter the

"Histogram" setting menu.

• Refer to descriptions in "Rectangle Drawing" to enter the "Histogram" setting

menu.

 Histogram Analysis

Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved. 209



In the "Histogram" setting menu, press Enable continuously to enable or disable the
histogram analysis function.

TIP

To record peaks or glitches in the histogram data, please always enable the histogram function.

12.2 To Select the Histogram Type
The histogram includes the following three types:

• Horizontal: displays the number of times for statistics making in the forms of

columns in the histogram bar graph at the bottom of the graticule.

• Vertical: displays the number of times for statistics making in the forms of rows

in the histogram bar graph at the left of the graticule.

• Measure: displays the number of times for statistics of the measurement results

in the forms of columns in the histogram bar graph at the bottom of the

graticule.

Press Type, then rotate the multifunction knob  to select the desired histogram
type, and then press down the knob to select the type. You can also press Type
continuously or enable the touch screen to select the type.

12.3 To Select the Histogram Source
If "Horizontal" or "Vertical" is selected under Type, you need to set the source (CH1-

CH4). Press Source, then use the multifunction knob  to select the desired source,
and then press down the knob to select the source. You can also press Source
continuously or enable the touch screen to select it.

12.4 To Set the Measurement Items
When you select "Measure" as the histogram type, press Measure > Add on the front
panel or tap the auto measurement label "MEASURE" at the top of the screen to enter
the measurement setting menu, and then add one or multiple measurement items. At
this time, the added measurement item(s) can be served as the measurement
histogram source(s) and displayed in the Item menu.
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12.5 To Set the Histogram Height
The histogram height indicates the number of grids the histogram bar graph should

use on the screen. Press Height, then rotate the multifunction knob  or use the
pop-up numeric keypad to set the height. The available range of height is from 1 to 4.
By default, it is 2.

12.6 To Set the Histogram Range
When "Horizontal" or "Vertical" is selected under Type, you need to set the window
range. Set "Left Limit", "Right Limit", "Top Limit", and "Bottom Limit" respectively to
adjust the size and position of the histogram window. Press Range to enter the sub-
menu of histogram range. Then press the corresponding softkey and rotate the

multifunction knob  to set their values.

NOTE

The adjustment for the horizontal time base and vertical scale will not affect the time base of

the histogram range, but only shows variation with the scale.

12.7 To Enable or Disable the Statistical Function
Press Statistic to enable or disable statistical function. When the statistical function is
enabled, the statistical results of the histogram data will be displayed, as shown in the
following figure. Note: when you select "Measure" under "Type", the statistical data
results also include the parameter XScale.

• Sum: indicates the sum of all bins (buckets) in the histogram.

• Peaks: indicates the maximum number of hits in any single bin.

• Max: indicates the value that corresponds to the maximum bin that has any hits.
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• Min: indicates the value that corresponds to the minimum bin that has any hits.

• Pk_Pk: indicates the Delta between the max. value and the min. value.

• Mean: indicates the average value of the histogram.

• Median: indicates the median value of the histogram.

• Mode: indicates the mode value of the histogram.

• Bin width: indicates the width of each bin (bucket) in the histogram.

• Sigma: indicates the standard deviation of the histogram.

• Rsd+: RSD is an abbreviation for relative standard deviation. It is calculated

based on the formula (Mean + (2 x Sigma/1000))/(Mean). Wherein, Mean

indicates the average value of the histogram, and Sigma indicates the standard

deviation of the histogram.

• Rsd-: RSD is an abbreviation for relative standard deviation. It is calculated based

on the formula (Mean - (2 x Sigma/1000))/(Mean). Wherein, Mean indicates the

average value of the histogram, and Sigma indicates the standard deviation of

the histogram.

• XScale: indicates the horizontal scale of the histogram. It is 100 times the value

of Bin width.

12.8 To Reset
Press Reset to reset the statistical data and restart to make statistics.
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13 Real-time Eye Diagram and Jitter Analysis
(Option)
This series oscilloscope provides the real-time eye diagram and measurement with
the clock recovery function. The flexible and convenient jitter measurement and
analysis enable the users to instinctively understand the strong and weak Inter-
Symbol Interference in the system, so as to accurately and quickly make deterministic
jitter measurement for the high-speed serial signal.

If you have purchased and activated the MSO8000-JITTER option, the oscilloscope
also supports real-time eye diagram and jitter analysis functions.

13.1 Real-time Eye Analysis
An eye diagram is a view of a signal. A real- time eye accomplishes this by acquiring
data, performing clock recovery, then superimposing (folding) successive unit
intervals within a single plot. This is a statistical view in the form of a color grade. The
eye analysis function is usually used to observe the waveforms of the Receive signal
to analyze the impact of inter-symbol interference (ISI) and noise on the system
performance.

NOTE

The eye diagram can only be obtained when the horizontal time base is less than or equal to 1

µs/div.

You can go to the "Eye" setting menu through the following three ways:

• On the front panel, press  > Analyze > Eye to enter the eye setting menu.

• You can also enable the touch screen and then tap the function navigation icon

 at the lower-left corner of the screen to open the function navigation. Then,

tap the "Eye" icon to open the "Eye" setting menu.

• Enable the touch screen and tap the auto measurement label "MEASURE" at the

top of the screen to enter the measurement setting menu. In the measurement

category area, rotate the multifunction knob  to select the "Analyze" tab and

then press down the knob to select it. You can also tap the "Analyze" tab to

select it. In the measurement parameter area, rotate the multifunction knob 
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to select "Eye" and then press down the knob to select it. You can also tap to

select "Eye" to enter the "Eye" setting menu.

13.1.1 To Enable or Disable the Eye Analysis Function

In the "Eye" setting menu, press Eye continuously to enable or disable the eye
diagram analysis function.

13.1.2 To Select the Source of the Eye Diagram

Press Source in the "Eye" setting menu, then use the multifunction knob  to select
the desired eye source, and then press down the knob to select the source. You can
also press Source continuously or enable the touch screen to select it. The analog
channel (CH1-CH4) can be selected to be the eye source.

13.1.3 Threshold Settings

In the "Eye" setting menu, press Threshold to enter the threshold setting menu.

• Set the High Threshold

Press HighThres, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the high threshold.

NOTE

If you reduce the high threshold to a value below the set middle threshold, the

oscilloscope will adjust the high threshold automatically to make it greater than the

middle threshold.

• Set the Middle Threshold

Press MidThres, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the middle threshold.

NOTE

The middle threshold is limited by the set low threshold and high threshold.

• Set the Low Threshold

Press LowThres, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the low threshold.

NOTE

If you increase the low threshold to a value above the set middle threshold, the

oscilloscope will decrease the low threshold automatically to make it smaller than the

middle threshold.
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13.1.4 To Set Clock Recovery

The clock recovery provides an ideal clock for comparison to actual signal edges.

In the "Eye" setting menu, press Clock Recovery to enter the clock recovery menu.
This oscilloscope supports several clock recovery methods, including constant clock,
phase-locked loop (PLL), and external clock.

1. Set the Constant Clock Recovery

Press RecoveryType, and rotate the multifunction knob  to select "Constant",
and then press down the knob to select it. You can also press RecoveryType
continuously or enable the touch screen to select it.

- Set the data rate type

The data rate type for Constant includes Manual, Semi-Auto, and Auto.

- Manual: recovers the clock by the data rate input manually.

- Semi-Auto: recovers the clock by the manually preset data rate and the

signal edge.

- Auto: recovers the clock based on the narrowest pulse of the signal.

Press Type, and rotate the multifunction knob  to select the desired data rate
type, and then press down the knob to select it. You can also press Type
continuously or enable the touch screen to select it.

- Set the data rate

Press Data Rate, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the data rate.

NOTE

When the data rate type is set to Auto, the Data Rate menu is grayed out and disabled,

and only the automatically recovered frequency of the ideal clock can be displayed

2. Set the Phase-Locked Loop (PLL) Recovery

Press RecoveryType, and rotate the multifunction knob  to select "PLL", and
then press down the knob to select it. You can also press RecoveryType
continuously or enable the touch screen to select it.

- Set the data rate

Press Data Rate, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the data rate.
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- Set the PLL order

This oscilloscope supports first-order PLL and second-order PLL. Press PLL

Order, and rotate the multifunction knob  to select the order number and
then press down the knob to select it. You can also press PLL Order
continuously or enable the touch screen to select it.

- Set the loop BW

Press Loop BW, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the loop bandwidth.

- Set the damping factor

When PLL order is set to "2nd Order", you need to set the damping factor. It is
the damping factor of the transfer function. Press DampFactor, then rotate the

multifunction knob  or use the pop-up numeric keypad to set the damping
factor.

The typical damping factor is 1.0 and 0.707. The former is critically damped, and
the latter is the ideal or optimal value.

3. Set the External Clock Recovery

Press RecoveryType, and rotate the multifunction knob  to select "Explicit", and
then press down the knob to select it. You can also press RecoveryType
continuously or enable the touch screen to select it.

Press Source, then use the multifunction knob  to select the desired source, and
then press down the knob to select the source. You can also press Source
continuously or enable the touch screen to select it. The analog channel (CH1-
CH4) can be selected to be the source of the external clock.

13.1.5 To Enable or Disable the Eye Measurement Result

In the "Eye" setting menu, press Result continuously to enable or disable the display
of the eye measurement result. When it is enabled, the statistical results of the eye
measurement data will be displayed at the upper-left corner of the screen, as shown
in the following figure. You can enable the touch screen, and drag the statistical
results to any place where you want to put it for view on the screen.
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Wherein,

One: indicates "1" level.

Zero: indicates "0" level.

Eye Width: indicates the width of an eye diagram.

Eye Height: indicates the height of an eye diagram.

Eye Amp: indicates the amplitude of an eye diagram.

Cross: indicates the crossing percentage of an eye diagram.

Q Factor: indicates the Q factor.

The parameters of the eye measurement are shown in Figure 13.1 .

Figure 13.1 Diagram of Eye Measurement Parameters

13.1.6 To Reset Color

Press Reset Color to clear the color level counter.

13.2 Jitter Analysis
The jitter analysis function is mainly used to analyze the integrity of the high-speed
serial signal and measure the variance of a measurement over time. The measurement

 Real-time Eye Diagram and Jitter Analysis

(Option)

Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved. 217



item includes TIE, Cycle to Cycle, +Width to +Width, and –Width to -Width. Wherein,
TIE indicates time interval error. The TIE measurement compares the edges in a data
signal with the edges in an ideal data signal determined by the clock recovery feature
to generate error statistics.

You can go to the "Jitter" setting menu through the following three ways:

• On the front panel, press  > Analyze > Jitter to enter the jitter setting

menu.

• You can also enable the touch screen and then tap the function navigation icon

 at the lower-left corner of the screen to open the function navigation. Then,

tap the "Jitter" icon to open the "Jitter" setting menu.

• Enable the touch screen and tap the auto measurement label "MEASURE" at the

top of the screen to enter the measurement setting menu. In the measurement

category area, rotate the multifunction knob  to select the "Analyze" tab and

then press down the knob to select it. You can also tap the "Analyze" tab to

select it. In the measurement parameter area, rotate the multifunction knob 

to select "Jitter" and then press down the knob to select it. You can also tap to

select "Jitter" to enter the "Jitter" setting menu.

13.2.1 To Enable or Disable the Jitter Function

In the jitter setting menu, press Enable continuously to enable or disable the jitter
analysis function. When the jitter analysis function and the jitter trend are enabled,
Math3 trend operation function is enabled by default and the trend graph is
displayed on the screen.

13.2.2 To Select the Jitter Source

Press Source in the "Jitter" setting menu, then use the multifunction knob  to
select the desired jitter source, and then press down the knob to select the source.
You can also press Source continuously or enable the touch screen to select it. The
analog channel (CH1-CH4) can be selected to be the jitter source.

13.2.3 Threshold Settings

For setting methods of the jitter threshold, refer to descriptions in "Threshold
Settings" in the "Real-time Eye Analysis" section.
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13.2.4 To Set Clock Recovery

For setting methods of the clock recovery in the jitter, refer to descriptions in "To Set
Clock Recovery" in the "Real-time Eye Analysis" section.

NOTE

When the measurement item is "TIE", you need to set the clock recovery. For other

measurement items, you do not need to set the clock recovery.

13.2.5 To Set the Jitter Measurement

Press Measure to enter the jitter measurement menu. You can set the jitter
measurement item and the graph display mode of the jitter measurement results.

• Set the Jitter Measurement Item

The jitter measurement items supported by this oscilloscope include TIE, Cycle to
Cycle, +Width to +Width, and –Width to -Width.

Press Item, then rotate the multifunction knob  to select desired
measurement item, and then press down the knob to select the item. You can
also press Item continuously or enable the touch screen to select it.

• TIE

Compares edges in a signal under test with the edges in an ideal signal
determined by the clock recovery feature. Then, all the signal intervals are
measured based on the ideal data rate to generate the error statistics.

• Cycle to Cycle

Measures the first cycle and then subtracts the first cycle from the second cycle.
The measurement is made according to this rule.
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• +Width to +Width

The +Width to +Width jitter measurement subtracts the first cycle's positive
pulse width from the second cycle's positive pulse width for the first
measurement result. The +Width to +Width jitter measurement subtracts the
second cycle's positive pulse width from the third cycle's positive pulse width for
the second measurement result, and so on, until all of the cycles of the
waveforms have been measured.

• -Width to -Width

The -Width to -Width jitter measurement subtracts the first cycle's negative
pulse width from the second cycle's negative pulse width for the first
measurement result. The -Width to -Width jitter measurement subtracts the
second cycle's negative pulse width from the third cycle's negative pulse width
for the second measurement result, and so on, until all of the cycles of the
waveforms have been measured.
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• Jitter Edge

When the measurement item is "TIE"　or "Cycle to Cycle", you need to set the
edge of the measurement signal. The edges include Rising, Falling, and Either.

Press Slope, then rotate the multifunction knob  to select the desired edge,
and then press down the knob to select it. You can also press Slope continuously
or enable the touch screen to select it.

• Jitter Trend Graph

The trend graph can display the trend of the jitter measurement results. The data
obtained from the waveforms of the same frame are generated to form a curve,
which enables users to find out the cause for jitter.

Press Trend continuously to enable or disable the display of the trend graph.

NOTE

When the clock recovery method is set to "PLL", the PLL system cannot reach the

expected ideal clock frequency until it reaches the specified lock time. During the lock

time, the TIE jitter measurement results based on the ideal recovery clock are incorrect.

The data produced during this time will be discarded in data processing. Therefore, in the

TIE jitter trend graph based on the PLL recovery, part of trend graph at the left section of

the screen will be lost. When a message "Invalid settings" is displayed below the trend

graph, please modify the loop bandwidth, the horizontal timebase, or other related

settings to make valid measurements.

• Jitter Histogram

The histogram shows the distribution of the jitter measurement results. Gaussian
distributions indicates random jitter, and non-Gaussian distributions indicate the
deterministic jitter.

Press Histogram continuously to enable or disable the display of the histogram.

NOTE
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When you select the specified measurement item and enable the display of the

histogram, the selected item will be displayed under the Item menu of the Histogram

setting menu simultaneously. Meanwhile, the jitter analysis function in the histogram

setting menu will also be enabled. The histogram type will be switched to Jitter. At this

time, the statistical count and distribution of the jitter measurement results will be

displayed in columns in the bar histogram at the bottom of the screen.

• Auto Setting

Used to configure the scale of the trend graph automatically.

Press Auto Setting, and then the vertical scale and offset of the trend graph will
be automatically adjusted to optimal values based on the current configurations,
so that users can get a better observation of the results.

13.2.6 To Enable or Disable the Jitter Measurement Result

In the jitter setting menu, press Result continuously to enable or disable the display
of the jitter measurement result. When enabled, the jitter measurement data results
will be displayed on the screen, as shown in the following figure. You can enable the
touch screen to drag the jitter measurement data results to any place for view.

13.2.7 To Reset Statistics

In the jitter setting menu, press Reset to reset the statistics of the jitter measurement
result.
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14 Digital Channel
This series oscilloscope provides the standard the logic analyzer (LA) function, and it
has 16 digital channels. The default channel label is D15-D0. The oscilloscope
compares the voltages acquired in each sample with the preset logic threshold. If the
voltage of the sample point is greater than the threshold, it will be stored as logic 1;
otherwise, it will be stored as logic 0. The oscilloscope displays logic levels ("1" and
"0") in the form of a graph for you to easily detect and analyze the errors in circuit
design (hardware design and software design).

Before using the digital channels, connect the oscilloscope and the device under test
using RPL2316 logic probe provided in the accessories. To apply to different
application scenarios, RPL2316 provides three connection methods to connect the
signal under test. For details, refer to RPL2316 Logic Probe User Guide.

NOTE

The digital channel input terminal does not support hot plugging. Please do not insert or pull

out the logic probe when the instrument is in power-on state.

14.1 To Select the Digital Channel

Press  on the front panel or enable the touch screen to tap the LA status label at
the bottom of the screen to enter LA setting menu. Press Select to open the channel

menu, and rotate the multifunction knob  to select the channel. You can also press
Select continuously or enable the touch screen to select it.

• Select any of the digital channels (D0-D15). The channel label and waveform of

the selected channel are displayed in red.

• Select the user-defined group: selects any group of the channels from the four

user-defined groups. The labels and the waveforms of all the channels in the

selected channel group will be indicated in red.

NOTE

Only the enabled digital channel can be selected, and only the user-defined channel group

that has been grouped can be available.

For how to enable the digital channel/group, refer to descriptions in "To Enable/
Disable the Digital Channel".

For how to define the user-defined group, refer to refer to descriptions in "Group
Setting".
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14.2 To Enable/Disable the Digital Channel
Press On/Off to enter the on/off sub-menu of the digital channel.

• Enable/disable the channels (D7-D0) simultaneously

Press D7-D0 continuously to enable or disable the channels (D7-D0). You can
also enable the touch screen and tap the LA status area. Then the channel and
threshold setting interface is displayed, as shown in the figure below. Tap "D7-

D0" to enable or disable D7-D0 channels. Tap the close icon  at the upper-
right corner of the interface to close the interface; or tap the LA status label at
the bottom of the screen to close the interface.

• Enable/disable the channels (D15-D8) simultaneously

Press D15-D8 continuously to enable or disable the channels (D15-D8). You can
also enable the touch screen and tap the LA status area. Then the channel and
threshold setting interface is displayed. Tap "D15-D8" to enable or disable D15-
D8 channels.

• Enable/disable a single digital channel

Press Dx On/Off to open the channel selection list. Rotate the multi-function

knob  to select a channel, and then press down the knob  to enable or
disable it. You can also press Dx On/Off continuously to switch to select any

channel, and press down the multifunction knob  to enable or disable the
channel. You can also enable the touch screen to enable or disable the selected
channel. In addition, You can also enable the touch screen and tap the LA status
area. Then the channel and threshold setting interface is displayed. Tap a single
digital channel to enable or disable it.

NOTE

After pressing D7-D0 to enable or disable D7-D0, you can still disable or enable any

channel among D7-D0 through the Dx On/Off key. After pressing D7-D0 to enable D7-

D0 channels, the D0-D7 channels under Dx On/Off are enabled automatically. The same

is true for D15-D8 channels.
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• Enable or Disable User-defined Channel GroupPress Group On/Off, then

rotate the multifunction knob  to select the specified channel group. Press
down the knob to enable or disable all the channels in this channel group.

You can also enable the touch screen to tap the specified group and select it.

The enabled channel groups are marked with , and the disabled channel

groups are marked with .

NOTE

This function is only valid when the channels have been grouped by users. For how to

carry out group settings, refer to descriptions in "Group Setting".

14.3 To Set the Threshold
The threshold levels of channels D7-D0 and channels D15-D8 can be set separately
according to your needs. Press Threshold to enter the threshold setting menu. When
the voltage of the input signal is greater than the currently set threshold, it is treated
as logic 1; otherwise, it is treated as logic 0.

Press D7-D0 or D15-D8 respectively to open the threshold selection list and select
the preset threshold. The available preset values include TTL(1.4 V), CMOS5.0(2.5 V),
CMOS3.3(1.65 V), CMOS2.5(1.25 V), CMOS1.8(0.9 V), ECL(-1.3 V), PECL(3.7 V),
LVDS(1.2 V), and 0.00 V. You can also press D7-D0 or D15-D8 respectively, then rotate

the multifunction knob  with a small step value or use the numeric keypad to set
the desired threshold.

Besides, you can also enable the touch screen and tap the LA status area. Then the
channel and threshold setting interface is displayed. You can select the channel and

set the threshold in this pop-up interface. Tap the drop-down button ( ) of
Threshold to select the preset threshold from the drop-down list. Also you can tap the
input field of Threshold to input the value with the pop-up numeric keypad.

14.4 Auto Arrangement Setting
Press Arrange to select the waveform order mode of the currently selected channels
on the screen. You can select "D0-D15" or "D15-D0", By default, it is "D15-D0".

• D0-D15: the waveforms on the screen are D0-D15 in sequence from top to

bottom.

• D15-D0: the waveforms on the screen are D15-D0 in sequence from top to

bottom.
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14.5 To Set the Waveform Display Size

Press Size, then use the multifunction knob  to select the desired waveform display
size, and then press down the knob to select it. You can also press Size continuously
or enable the touch screen to select it. The available display sizes are Small, Medium,
and Large.

NOTE

"Large" is only available when the number of currently enabled channels is less than or equal

to 8.

14.6 To Set the Label
By default, the instrument takes D0-D15 as the channel label of the 16 digital
channels. You can set a user-defined label for each digital channel to easily
differentiate the digital channels. You can use the preset label or input a label
manually. Press Label to enter the label setting menu.

• Enable or disable the label display

Press Display continuously to enable or disable the display of the channel label.
If it is enabled, the label will be displayed at the left side of the waveform.

• Select a specified digital channel

Press Select and rotate the multifunction knob  to select the desired digital
channel that needs a label. You can also press Select continuously or enable the
touch screen to select the channel. Select any channel from D0-D15.

• Use preset labels

Press Library to select a preset label. The available preset labels include ACK,
ADO, ADDR, BIT, CAS, CLK, CS, DATA, HALT, INT, LOAD, NMI, OUT, PAS, PIN, RDY,
RST, RX, TX, WR, MISO, and D0-D15.

• Input a label manually

Press Label to open the label input interface. You can input the label manually.
For details, refer to descriptions in "Channel Label".

14.7 Group Setting
Press On/Off > Group to enter the user-defined group setting menu. You can
randomly grouping or ungrouping any of the 16 digital channels. You can also directly
press More to enter the menu to group or ungroup channels according to your
needs.
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• Group:

For grouping, the operations for the four user-defined groups (Group1, Group2,
Group3, and Group4) are the same. Here take Group1 as an example.

Press Group1 to open the D0-D15 channel selection list (the status icon is

located at the left side of each channel). Rotate the multifunction knob  or
press Group1 continuously to select the channel(s) to be added to Group1.

Then, press down the multifunction knob  to add the selected channel(s) to
Group1. The channel(s) that has/have been added to Group1 is/are marked with

the status icon , and the channel(s) that has/have not been added to Group1

is/are marked with the status icon .

Use the same method to group the other channels. Each channel can only be
added to one single group, and the channels that have been add to other group
cannot be selected. You can perform group operation on 16 digital channels
(D0-D15).

• Ungroup:

Press UnGroup to open the list. Rotate the multifunction knob  or press
UnGroup continuously to select any channel group, then press down the knob

 to ungroup the channels.

NOTE

- You can only ungroup the digital channels.

- If no group is set, the UnGroup menu and the Group On/Off menu are grayed out

and disabled.

14.8 Waveform Color of the Digital Channel
When the digital channel is enabled, its corresponding waveforms and label are
displayed on the screen. This oscilloscope supports setting the display color of the
high logic level, low logic level, and edges.

Press More > Color to enter the waveform color setting menu.

• Press High, and rotate the multifunction knob  to set the display color of the

high logic level. Press down the knob to select the color. You can also press High

continuously or enable the touch screen to select it.

• Press Edge, and rotate the multifunction knob  to set the edge color. Press

down the knob to select it. You can also press Edge continuously or enable the

touch screen to select it.
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• Press Low, and rotate the multifunction knob  to set the display color of the

low logic level. Press down the knob to select it. You can also press Low

continuously or enable the touch screen to select it.
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15 Protocol Decoding
You can use the protocol analysis to discover errors, debug hardware, and accelerate
development easily, ensuring you to accomplish the projects with high speed and
good quality. Protocol decoding is the basis of protocol analysis. Only protocol
analyses with correct protocol decoding are acceptable, and only correct protocol
decoding can identify more error information. This series oscilloscope provides four
bus decoding modules (Decode 1, Decode 2, Decode 3, and Decode 4) to make
common protocol decoding (including Parallel (standard), RS232 (option), I2C
(option), SPI (option), LIN (option), CAN (option), FlexRay (option), I2S (option), and
1553B (option)) for the input signals of the analog channels (CH1-CH4) and the digital
channels (D0-D15). As the decoding functions and setting methods of Decode1,
Decode2, Decode3, and Decode4 are the same, this chapter takes Decode1 as an
example for illustration.

Press  on the front panel to open the decode setting menu, or enable the touch

screen to tap the function navigation icon  at the lower-left corner of the screen to
open the function navigation. Then, tap the "Decode" icon to open the decode
setting menu.

To obtain the decoding option information, refer to Appendix A: Options and
Accessories.

If you have purchased the decoding option, activate it according the descriptions in
"To View the Option and the Option Installation".

15.1 Parallel Decoding
Parallel bus consists of clock line and data line. As shown in the figure below, CLK is
the clock line, whereas Bit0 and Bit1 are the 0 bit and 1st bit on the data line
respectively. The oscilloscope will sample the channel data on the rising edge, falling
edge, or the rising/falling edge of the clock and judge each data point (logic "1" or
logic "0") according to the preset threshold level.
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Figure 15.1 Schematic Diagram of Parallel Decoding

In the decode setting menu, press Decode1 > Bus Type, then rotate the

multifunction knob  to select "Parallel". Press down the knob  to select it. You
can also press Bus Type continuously or enable the touch screen to select it.

1. Enable or Disable the Bus

Press Bus Status continuously to enable or disable the decoding function.

2. Set the Clock Line (CLK)

Press Clock to enter the clock line setting menu.

- Set the clock channel

Press Clock, then rotate the multifunction knob  to select any clock channel.
Press down the knob to select it. You can also press Clock continuously or
enable the touch screen to select it. The analog channel (CH1-CH4) and digital
channel (D0-D15) can all be selected as the clock source. If "OFF" is selected, no
clock channel is set, and sampling is performed when a hop occurs to the data
of the data channel during decoding.

- Set the clock edge type

Press CLK Edge, then rotate the multifunction knob  to select clock edge
type. Press down the knob to select it. You can also press CLK Edge
continuously or enable the touch screen to select it. You can select to sample

the channel data on the rising edge ( ), falling edge ( ), or both edges

( ) of the clock signal.

Rising : samples the channel data on the rising edge of the clock.

Falling : samples the channel data on the falling edge of the clock.

Both : samples the channel data on either the rising edge or the falling
edge of the clock.
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- Set the threshold

When the clock signal is an analog channel (CH1-CH4), you need to set a

threshold. Press Threshold, then rotate the multifunction knob  or use the
pop-up numeric keypad to set the threshold.

3. Set the Bus Parameters

Press Bus to enter the bus setting menu.

- Set the bus

Press BUS to select the digital bus for Parallel decoding, as shown in the
following table.

Bus Width Bit X
Chann
el

Remarks

CH1 1 0 CH1
Width, Bit X, and CH are set
automatically, and you cannot
modify them.

CH2 1 0 CH2
Width, Bit X, and CH are set
automatically, and you cannot
modify them.

CH3 1 0 CH3
Width, Bit X, and CH are set
automatically, and you cannot
modify them.

CH4 1 0 CH4
Width, Bit X, and CH are set
automatically, and you cannot
modify them.

D7-D0 8
0
(default)

D0
(defaul
t)

Bit0 to Bit7 are set to D7 to D0
respectively. Width is set
automatically, and you cannot
modify it.

D15-D8 8
0
(default)

D8
(defaul
t)

Bit0 to Bit7 are set to D15 to D8
respectively. Width is set
automatically, and you cannot
modify it.

D15-D0 16
0
(default)

D0
(defaul
t)

Bit0 to Bit15 are set to D15 to D0
respectively. Width is set
automatically, and you cannot
modify it.
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Bus Width Bit X
Chann
el

Remarks

D0-D7 8
0
(default)

D7
(defaul
t)

Bit0 to Bit7 are set to D0 to D7
respectively. Width is set
automatically, and you cannot
modify it.

D8-D15 8
0
(default)

D15
(defaul
t)

Bit0 to Bit7 are set to D8 to D15
respectively. Width is set
automatically, and you cannot
modify it.

D0-D15 16
0
(default)

D15
(defaul
t)

Bit0 to Bit15 are set to D0 to D15
respectively. Width is set
automatically, and you cannot
modify it.

User 1 to 20
0
(Default)

— -

- Set the width

When BUS is set to "User", you can set the bus width. Press Width, then rotate

the multifunction knob  or use the pop-up numeric keypad to set the width.
The available range is from 1 to 20.

- Specify a data channel for each bit

When BUS is set to any digital channel, you can specify a data channel for each
bit.

Press Bit X, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the bit of the channel. By default, 0 is selected. Its available range
is from 0 to (width - 1).

Press CH, then rotate the multifunction knob  to select the desired channel
source, and then press down the knob to select it. You can also press CH
continuously or enable the touch screen to select it. The analog channel (CH1-
CH4) and digital channel (D0-D15) can all be selected as the channel source.

- Set the threshold level

To judge logic "1" and logic "0" of the buses, you need to set a threshold for
each analog channel (CH1-CH4). When the channel signal amplitude is greater
than the preset threshold, it is judged as logic "1"; otherwise logic "0". Press

Threshold, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the threshold.
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- Set the endian

Press Endian continuously to select "Normal" or "Invert" as the endian of the
bus.

- Set the polarity

Press Polarity continuously to select Positive  or Negative  as the polarity
for data decoding.

4. Set Display-related Parameters

Press Display to enter the display setting menu.

- Set the display format

Press Format, rotate the multifunction knob  to select the display format of
the bus data. Then, press down the knob to select it. You can also press Format
continuously or enable the touch screen to select it. The available formats
include Hex, Dec, Bin, and ASCII.

- Adjust the vertical position of the bus

Press Position, and then rotate the multifunction knob  to adjust the vertical

display position of the bus. You can also rotate Wave Vertical  POSITION to
adjust the vertical display position of the bus.

- Set the label display

Press Label to enable or disable the label display of the Parallel decoding bus.
When enabled, the bus label "Parallel" will be displayed at the upper-left side of
the bus (when the bus display is enabled).

- Set parameters for the event table

Press Event Table to enter the event table setting menu. The event table
displays the decoded data and the corresponding decoding information in time
order in the form of a table. It can be used to observe relatively longer decoded
data. The decoding information includes the decoded data, the corresponding
line number, and time information.
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- Open or close the event table: Press Event Table continuously to enable or

disable the display of the event table. When enabled, the following event

table as shown in Figure 15.2 is displayed. You can also enable the touch

screen to tap the icon  at the right-upper corner of the event table to close

it.

Parallel Bus

Event Table

Line Number Time Decoded DataDecode Name

Figure 15.2 Parallel Decoding Event Table

NOTE

- When you adjust the horizontal time base, the waveform displayed on the screen

will also change, and the total number of lines containing the decoding

information in the event table will also be changed.

- The displayed decoded data information in the bus is related to the value of the

horizontal time base. Reducing the horizontal time base can help you view the

detailed information.

- Set the event table format: Press Format, rotate the multifunction knob 

to select the display format of "Data" in the event table. Then, press down

the knob to select it. You can also press Format continuously or enable the

touch screen to select it. The available formats include Hex, Dec, Bin, and

ASC.

- Set the view type: Press View, rotate the multifunction knob  to select the

form of the event table to be viewed. Then, press down the knob to select it.

You can also press View continuously or enable the touch screen to select it.
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The available choices include "Packets", "Details", and "Payload". You can

also tap "Packets", "Details", or "Payload" at the top of the event table to

select it.

If you select "Packets", time and decoded data are displayed in the event
table. If you select "Details", the detailed data in the specified row will be
displayed in the event table. If "…" appears in the row of data, it indicates
that the decoded data are not fully displayed. At this time, you can view the
details in the "Packets" view. If you select "Payload", all data in the specified
column will be displayed in the event table. If "…" appears in the specified
column of data, it indicates that the decoded data are not fully displayed. At
this time, you can view the details in the "Packets" view.

- Export: If you select "Packets", you can export time and the corresponding

decoded data. Press Export, then the save setting interface is displayed. You

can export the data table of the packet to the internal memory or the

external USB storage device (when detected) in CSV format. For detailed

saving operation, refer to descriptions in "Store and Load".

- Jump to: Set the operating status of the oscilloscope to "STOP". Then, select

the data of the specified time from the event table. Press Jump to and the

specified data waveforms are displayed in the center of the screen.

- Decode: The setting of this menu enables you to quickly view the

corresponding event tables of four decode modules (Decode1, Decode2,

Decode3, and Decode4). Press Decode, then use the multifunction knob 

to select a decode module, then press down the knob to select it. You can

also press Decode continuously or enable the touch screen to select it.

5. Set the Noise Rejection

Press Settings > Noise Reject to enable or disable the noise rejection function.
Noise rejection can remove the data that last not enough time on the bus and
eliminate the burst glitch in the actual circuit. When the noise rejection is enabled,

press Reject Time, rotate the multifunction knob  or use the pop-up numeric
keypad to set the desired rejection time. The available range is from 0 s to 1 s.
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15.2 RS232 Decoding (Option)
RS232 serial bus consists of the transmitting data line (TX) and the receiving data line
(RX).

Figure 15.3 Schematic Diagram of RS232 Serial Bus

The industry standard of RS232 uses "Negative Logic", i.g. high level is logic "0" and
low level is logic "1".

Figure 15.4 Schematic Diagram of Negative Logic

In RS232, baud rate is used to represent the transmission rate (namely bits per
second) of the data.

You need to set the start bit, data bits, check bit (optional), and stop bits for each
frame of data.

Start Bit: indicates when to output data.

Data Bit: indicates the number of data bits actually contained in each frame of data.

Check Bit: used to check whether the data are properly transmitted.
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Stop Bit: indicates when to stop outputting data.

In the decode setting menu, press Decode1 > Bus Type, then rotate the

multifunction knob  to select "RS232". Press down the knob to select it. You can
also press Bus Type continuously or enable the touch screen to select it.

1. Enable or Disable the Bus

Press Bus Status continuously to enable or disable the decoding function.

2. Quickly Apply RS232 Trigger Settings to RS232 Decoding

Press Copy Trig to copy the current RS232 trigger settings and apply them to
RS232 decoding function (set the corresponding RS232 decoding parameters
automatically). For source channels, copy the source channel of the trigger to the
Tx source channel of the decoding. For analog channels, the threshold level
settings will also be copied.

3. Set the Baud Rate

Three methods are available for setting the baud rate:

- Press Baud, then set the user-defined baud rate with the displayed numeric

keypad.

- Press Baud, then select the preset baud rate from the drop-down list. The

available baud rates include 50 bps, 75 bps, 110 bps, 134 bps, 150 bps, 300 bps,

and etc.

- Press Baud, then rotate the multifunction knob  to adjust the baud rate at a

small step size. The step size is different for adjusting different baud rates.

4. Set the Source

Press Sources to enter the signal setting menu.

- Set the Tx source and the threshold

- Press Tx, then rotate the multifunction knob  to select the desired channel,

and press down the knob to select it. You can also press Tx continuously or

enable the touch screen to select it. The available channels include OFF, CH1-

CH4, and D0-D15.

- When you select the analog channel (CH1-CH4), press Threshold, then

rotate the multifunction knob  or use the pop-up numeric keypad to set
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the threshold of the Tx source channel. When you modify the threshold of

the Tx source channel, a dotted line displaying the current threshold level is

displayed on the screen. It disappears in about 2 s after you stop modifying

the threshold.

- Set the Rx source and the threshold

Use the same method to select the Rx source and set the threshold (available
only when the Rx source channel is set to an analog channel (CH1-CH4)).

NOTE

The source channels of Tx and Rx cannot be set to "OFF" at the same time.

- Set the polarity

Press Polarity continuously to set Positive  or Negative  as the
polarity for data decoding.

- Positive: Uses negative logic. High level is logic "0" and low level is logic "1".

- Negative: Uses positive logic. High level is logic "1” and low level is logic

"0".

5. Set the Data Package

Press Settings to enter the data package setting menu.

- Data

Press Data and rotate the multifunction knob  to set the number of data bits
actually contained in each frame of data. Then, press down the knob to select it.
You can also press Data continuously or enable the touch screen to select it.
The available data bits are 5 bits, 6 bits, 7 bits, 8 bits, and 9 bits.

- Parity

Used to check whether the data are properly transmitted. Press Parity, and

rotate the multifunction knob  to select the desired parity mode, then press
down the knob to select it. You can also press Parity continuously or enable the
touch screen to select it.

- None: indicates that no check bit appears during the transmission.

- Even: indicates that the total number of "1" in the data bit and check bit is an

even number. For example, when 0x55 (01010101) is sent, "0" should be

added to the check bit.
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- Odd: indicates that the total number of "1" in the data bit and check bit is an

odd number. For example, when 0x55 (01010101) is sent, "1" should be

added to the check bit.

- Stop Bit

Press Stop Bit, and rotate the multifunction knob  to set the stop bits after
each frame of data. You can also press Stop Bit continuously or enable the
touch screen to select it. It can be set to 1 bit, 1.5 bits, or 2 bits.

- Endian

Press Endian to select "LSB" or "MSB". By default, it is "LSB".

LSB: indicates Least Significant Bit transmission sequence, i.g. the lowest bit of
the data is transmitted first.

MSB: indicates Most Significant Bit transmission sequence, i.g. the highest bit of
the data is transmitted first.

LSB MSB

- Package

Press Package to enable or disable the package display in data transmission.
When enabled, several data blocks will be combined based on the separator.

- Separator

Press Separator, and rotate the multifunction knob  to select the desired
package separator in data transmission, then press down the knob to select it.
You can also press Separator continuously or enable the touch screen to select
it. It can be set to 0A(LF), 0D(CR), 20(SP), or 0(NUL).

6. Set Display-related Parameters

Press Display to enter the display setting menu.

- Set the display format

Press Format, rotate the multifunction knob  to select the display format of
the bus data. Then, press down the knob to select it. You can also press Format
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continuously or enable the touch screen to select it. The available formats
include Hex, Dec, Bin, and ASCII.

- Adjust the vertical position of the bus

Press Position, and then rotate the multifunction knob  to adjust the vertical

display position of the bus. You can also rotate Wave Vertical  POSITION to
adjust the vertical display position of the bus.

- Set the label display

Press Label to enable or disable the label display of the RS232 decoding bus.
When enabled, the bus label "RS232-TX" and/or "RS232-RX" will be displayed at
the upper-left side of the bus (when the bus display is enabled).

- Set parameters for the event table

Press Event Table to enter the event table setting menu. The event table
displays the decoded data and the corresponding decoding information in time
order in the form of a table. It can be used to observe relatively longer decoded
data. The decoding information includes the decoded data (Tx and/or Rx), the
corresponding line number, time, and error information (Tx and/or Rx).

NOTE

When the Tx and Rx source channels are set to "OFF", information of the data line is not

displayed in the data table.

- Open or close the event table: Press Event Table continuously to enable or

disable the display of the event table. You can also enable the touch screen

to tap the icon  at the right-upper corner of the event table to close it.

NOTE

- When you adjust the horizontal time base, the waveform displayed on the screen

will also change, and the total number of lines containing the decoding

information in the event table will also be changed.

- The displayed decoded data information in the bus is related to the value of the

horizontal time base. Reducing the horizontal time base can help you view the

detailed information.

- Set the event table format: Press Format, rotate the multifunction knob 

to select the display format of "Data" (Tx and/or Rx) in the event table. Then,

press down the knob to select it. You can also press Format continuously or

enable the touch screen to select it. The available formats include Hex, Dec,

Bin, and ASC.
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- Set the view type: Press View, rotate the multifunction knob  to select the

form of the event table to be viewed. Then, press down the knob to select it.

You can also press View continuously or enable the touch screen to select it.

The available choices include "Packets", "Details", and "Payload". You can

also tap "Packets", "Details", or "Payload" at the top of the event table to

select it.

If you select "Packets", the decoded data (Tx and/or Rx), time, and error
information (Tx and/or Rx) are displayed in the event table. If you select
"Details", the detailed data in the specified row will be displayed in the event
table. If "…" appears in the row of data, it indicates that the decoded data are
not fully displayed. At this time, you can view the details in the "Packets"
view. If you select "Payload", all data in the specified column will be
displayed in the event table. If "…" appears in the specified column of data, it
indicates that the decoded data are not fully displayed. At this time, you can
view the details in the "Packets" view.

- Export: If you select "Packets", you can export time and the corresponding

decoded data. Press Export, then the save setting interface is displayed. You

can export the data table of the packet to the internal memory or the

external USB storage device (when detected) in CSV format. For detailed

saving operation, refer to descriptions in "Store and Load".

- Jump to: Set the operating status of the oscilloscope to "STOP". Then, select

the data of the specified time from the event table. Press Jump to and the

specified data waveforms are displayed in the center of the screen.

- Decode: The setting of this menu enables you to quickly view the

corresponding event tables of four decode modules (Decode1, Decode2,

Decode3, and Decode4). Press Decode, then use the multifunction knob 

to select a decode module, then press down the knob to select it. You can

also press Decode continuously or enable the touch screen to select it.

7. Error Expressions in Decoding

In RS232 decoding, parity error and/or EOF (end of frame) error may occur.

- Parity error
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When a parity error is detected during the decoding, red error report
information will be displayed. For example, when "none" is chosen for the parity
on the transmitter and "odd" is chosen for the parity on the decoder, the

following parity error information  (its display form is related to the value of
the horizontal time base) occurs, as shown in the figure below. Wherein, the
number of 1s in the 8-digit figure (01001111, LSB) is an odd number, and the
parity bit should be 0. However, the parity bit detected on the Tx is 1; thus a
parity error occurs.

- EOF error

This error is generated when the EOF condition is not met. For example, if the
Stop Bit is set to 1.5, but the actual stop bits is less than 1.5 bits, then the red

error report information  (its display form is related to the value of the
horizontal time base) is displayed in the following figure.
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- Parity error and EOF error

When both the parity error and the EOF error are detected, the error report
information (its display form is related to the value of the horizontal time base),
as shown in the following figure, will be displayed.

15.3 I2C Decoding (Option)
I2C serial bus consists of the clock line (SCL) and the data line (SDA).

SCL: samples SDA on the of rising or falling edge of the clock.

SDA: indicates the data channel.

Figure 15.5 I2C Serial Bus

In the decode setting menu, press Decode1 > Bus Type, then rotate the

multifunction knob  to select "I2C". Press down the knob to select it. You can also
press Bus Type continuously or enable the touch screen to select it.

1. Enable or Disable the Bus

Press Bus Status continuously to enable or disable the decoding function.

2. Quickly Apply I2C Trigger Settings to I2C Decoding

Press Copy Trig to copy the current I2C trigger settings (SCL and SDA) and apply
them to I2C decoding function (SCL and SDA). For analog channels, the threshold
level settings will also be copied.

3. Set the Source

Press Sources to enter the signal setting menu.
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- Set the clock channel source and the threshold

- Press SCL, rotate the multifunction knob  to select the desired source of

the clock channel, and then press down the knob it. You can also press SCL

continuously or enable the touch screen to select it. You can select CH1-CH4

or D0-D15.

- When you select the analog channel (CH1-CH4), press SCL Thre, then rotate

the multifunction knob  or use the pop-up numeric keypad to set the

threshold of the clock channel. When you modify the threshold of the clock

channel, a dotted line displaying the current threshold level is displayed on

the screen. It disappears in about 2 s after you stop modifying the threshold.

- Set the data channel source and the threshold

Use the same method to select the source of the data channel and set the
threshold (only when the source of the data channel is set to an analog channel
(CH1-CH4)).

- Exchange sources

Press Exchange continuously to select "SCL/SDA" or "SDA/SCL" to exchange
the sources of the current clock channel and data channel.

4. Specify whether to include/exclude the "R/W" bit in/from the address

information

For I2C bus, each frame of data starts with the address information. The address
information includes the read address and the write address. Press R/W
continuously to select whether to include the "R/W" bit in the address information.
When "With" is selected, the "R/W" bit will be included in the address information
and located at the lowest bit; when "Without" is selected, the "R/W" bit will not be
included in the address information.

5. Set Display-related Parameters

Press Display to enter the display setting menu.

- Set the display format

Press Format, rotate the multifunction knob  to select the display format of
the bus data. Then, press down the knob to select it. You can also press Format
continuously or enable the touch screen to select it. The available formats
include Hex, Dec, Bin, and ASCII.
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- Adjust the vertical position of the bus

Press Position, and then rotate the multifunction knob  to adjust the vertical

display position of the bus. You can also rotate Wave Vertical  POSITIONto
adjust the vertical display position of the bus.

- Set the label display

Press Label to enable or disable the label display of the I2C decoding bus.
When enabled, the bus label "I2C" will be displayed at the upper-left side of the
bus (when the bus display is enabled).

- Set parameters for the event table

Press Event Table to enter the event table setting menu. The event table
displays the decoded data and the corresponding decoding information in time
order in the form of a table. It can be used to observe relatively longer decoded
data. The decoding information includes the decoded data, the corresponding
line number, time, R/W bit, address information, and acknowledgement
information.

- Open or close the event table: Press Event Table continuously to enable or

disable the display of the event table. When enabled, the following event

table as shown in Figure 15.6 is displayed. You can also enable the touch

screen to tap the icon  at the right-upper corner of the event table to close

it.

I2C Bus

Event Table

Line Number Time AcknowledgementDecode Data  R/W Bit Address    

Figure 15.6 I2C Decoding Event Table

NOTE
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- When you adjust the horizontal time base, the waveform displayed on the screen

will also change, and the total number of lines containing the decoding

information in the event table will also be changed.

- The displayed decoded data information in the bus is related to the value of the

horizontal time base. Reducing the horizontal time base can help you view the

detailed information.

- Set the event table format: Press Format, rotate the multifunction knob 

to select the display format of "Data" in the event table. Then, press down

the knob to select it. You can also press Format continuously or enable the

touch screen to select it. The available formats include Hex, Dec, Bin, and

ASC.

- Set the view type: Press View, rotate the multifunction knob  to select the

form of the event table to be viewed. Then, press down the knob to select it.

You can also press View continuously or enable the touch screen to select it.

The available choices include "Packets", "Details", and "Payload". You can

also tap "Packets", "Details", or "Payload" at the top of the event table to

select it.

If you select "Packets", the decoded data, time, and other information are
displayed in the event table. If you select "Details", the detailed data in the
specified row will be displayed in the event table. If "…" appears in the row of
data, it indicates that the decoded data are not fully displayed. At this time,
you can view the details in the "Packets" view. If you select "Payload", all data
in the specified column will be displayed in the event table. If "…" appears in
the specified column of data, it indicates that the decoded data are not fully
displayed. At this time, you can view the details in the "Packets" view.

- Export: If you select "Packets", you can export time and the corresponding

decoded data. Press Export, then the save setting interface is displayed. You

can export the data table of the packet to the internal memory or the

external USB storage device (when detected) in CSV format. For detailed

saving operation, refer to descriptions in "Store and Load".

- Jump to: Set the operating status of the oscilloscope to "STOP". Then, select

the data of the specified time from the event table. Press Jump to and the

specified data waveforms are displayed in the center of the screen.

 Protocol Decoding

246 Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved.



- Decode: The setting of this menu enables you to quickly view the

corresponding event tables of four decode modules (Decode1, Decode2,

Decode3, and Decode4). Press Decode, then use the multifunction knob 

to select a decode module, then press down the knob to select it. You can

also press Decode continuously or enable the touch screen to select it.

6. Address Information in Decoding

For I2C bus, each frame of data starts with the address information (read address
and write address). In the address information, "Read" indicates the read address

( ) and "Write" indicates the write address ( ). You can decide
whether to include or exclude the "R/W" bit for the address information.

Address Information (Read Address)

7. Error Expressions in Decoding

In I2C decoding, when ACK (acknowledgment) is 1, ACK error occurs. When the

detected ACK is 1, red error report information  (the display form is related to
the value of the horizontal time base) is displayed.
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The detected ACK is 1

15.4 SPI Decoding (Option)
SPI bus is based on the master— slave configuration and usually consists of chip
select line (CS), clock line (CLK), and data line (SDA). Wherein, the data lines include
the master input/slave output (MISO) data line and master output/slave input (MOSI)
data line. The oscilloscope samples the channel data on the rising or falling edge of
the clock signal (if the source is an analog channel, the oscilloscope will also judge
each data point (logic "1" or logic "0") according to the preset threshold level).

Figure 15.7 SPI Serial Bus

In the decode setting menu, press Decode1 > Bus Type, then rotate the

multifunction knob  to select "SPI". Press down the knob to select it. You can also
press Bus Type continuously or enable the touch screen to select it.

1. Enable or Disable the Bus

Press Bus Status continuously to enable or disable the decoding function.

2. Quickly Apply SPI Trigger Settings to SPI Decoding
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Press Copy Trig to copy the SPI trigger settings and apply them to SPI decoding
function (set the corresponding SPI decoding parameters automatically). The
settings that can be copied include CS/timeout mode, CLK, CLK, MISO, MOSI,
Width, and etc. For analog channels, the threshold level settings will also be
copied.

3. Set the ModePress Mode to enter the mode setting menu.

Press Mode continuously to select "Timeout" or "CS".

- Timeout:

you can perform frame synchronization according to the timeout, and the
timeout value must be greater than half of the clock cycle. Press Timeout, and

then rotate the multifunction knob  or use the pop-up numeric keypad to set
the timeout value. The adjustable range of the timeout value is from 8 ns to 10
s. By default, it is 1 μs.

- CS:

contains a chip select line (CS). You can perform frame synchronization
according to CS. When "CS" is selected,

- Press CS, then rotate the multifunction knob  to select the desired

channel, and then press down the knob to select it. You can also press CS

continuously or enable the touch screen to select it. The analog channel

(CH1-CH4) or digital channel (D0-D15) can all be selected as the CS channel.

- Press CS Polarity continuously to select Positive  or Negative  as

the polarity for CS channel.

- When you select the analog channel (CH1-CH4) as the CS channel, press

Threshold, then rotate the multifunction knob  or use the pop-up

numeric keypad to set the threshold.

4. Set the Source

Press Sources to enter the signal setting menu.

- Set the CLK

- Press CLK, then rotate the multifunction knob  to select the desired source

of the clock channel, and then press down the knob to select it. You can also
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press CLK continuously or enable the touch screen to select it. The analog

channel (CH1-CH4) or digital channel (D0-D15) can all be selected.

- When you select the analog channel (CH1-CH4), press Threshold below CLK,

then rotate the multifunction knob  or use the numeric keypad to set the

threshold of the clock channel.

- Press Slope to set the instrument to sample MISO and MOSI on the rising

edge ( ) or the falling edge ( ) of CLK.

- Set MISO and MOSI

- Press MISO, then rotate the multifunction knob  to select the MISO data

channel, and then press down the knob to select it. You can also press MISO

continuously or enable the touch screen to select it. The available channels

include OFF, analog channels (CH1-CH4), and digital channels (D0-D15).

When you select the analog channel (CH1-CH4), press Threshold below

MISO, then rotate the multifunction knob  or use the numeric keypad to

set the threshold of the MISO data channel.

- Press MOSI, then rotate the multifunction knob  to select the MOSI data

channel, and then press down the knob to select it. You can also press MOSI

continuously or enable the touch screen to select it. The available channels

include OFF, analog channels (CH1-CH4), and digital channels (D0-D15).

When you select the analog channel (CH1-CH4), press Threshold below

MOSI, then rotate the multifunction knob  or use the numeric keypad to

set the threshold of the MOSI data channel.

NOTE

The source channels of MISO and MOSI cannot be set to "OFF" at the same time.

5. Set the Data Parameters

Press Settings to enter the data setting menu.

- Set the endian

Press Endian to select "LSB" or "MSB". By default, it is MSB
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LSB: indicates Least Significant Bit transmission sequence, i.g. the lowest bit of
the data is transmitted first.

MSB: indicates Most Significant Bit transmission sequence, i.g. the highest bit of
the data is transmitted first.

- Set the polarity

Press Polarity continuously to select Positive  or Negative  as the polarity
for data decoding.

- Set the width

Press Width, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the bits of each frame of data. The setting range is from 4 to 32.
By default, it is 8.

6. Set Display-related Parameters

Press Display to enter the display setting menu.

- Set the display format

Press Format, rotate the multifunction knob  to select the display format of
the bus data. Then, press down the knob to select it. You can also press Format
continuously or enable the touch screen to select it. The available formats
include Hex, Dec, Bin, and ASCII.

- Adjust the vertical position of the bus

Press Position, and then rotate the multifunction knob  to adjust the vertical

display position of the bus. You can also rotate Wave Vertical  POSITION to
adjust the vertical display position of the bus.

- Set the label display

Press Label to enable or disable the label display of the RS232 decoding bus.
When enabled, the bus label "SPI-MISO" and/or "SPI-MOSI" will be displayed at
the upper-left side of the bus (when the bus display is enabled).

- Set parameters for the event table

Press Event Table to enter the event table setting menu. The event table
displays the decoded data and the corresponding decoding information in time
order in the form of a table. It can be used to observe relatively longer decoded
data. The decoding information includes the decoded data (MISO and/or
MOSI), the corresponding line number, time, and error information (MISO
and/or MOSI).

NOTE
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When the source channel of MISO or MOSI is set to "OFF", information of the data line

is not displayed in the data table.

- Open or close the event table: Press Event Table continuously to enable or

disable the display of the event table. When enabled, the following event

table as shown in Figure 15.8 is displayed. You can also enable the touch

screen to tap the icon  at the right-upper corner of the event table to close

it.

SPI Bus

Event Table

Line Number Time MISO ErrorMISO Decode Data  MISO Decoding Data MISO Error

Figure 15.8 SPI Decoding Event Table

NOTE

- When you adjust the horizontal time base, the waveform displayed on the screen

will also change, and the total number of lines containing the decoding

information in the event table will also be changed.

- The displayed decoded data information in the bus is related to the value of the

horizontal time base. Reducing the horizontal time base can help you view the

detailed information.

- Set the event table format: Press Format, rotate the multifunction knob 

to select the display format of "Data" (MISO and/or MOSI) in the event table.

Then, press down the knob to select it. You can also press Format

continuously or enable the touch screen to select it. The available formats

include Hex, Dec, Bin, and ASC.

- Set the view type: Press View, rotate the multifunction knob  to select the

form of the event table to be viewed. Then, press down the knob to select it.

You can also press View continuously or enable the touch screen to select it.
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The available choices include "Packets", "Details", and "Payload". You can

also tap "Packets", "Details", or "Payload" at the top of the event table to

select it.

If you select "Packets", the decoded data (MISO and/or MOSI), time, and
error information (MISO and/or MOSI) are displayed in the event table. If
you select "Details", the detailed data in the specified row will be displayed
in the event table. If "…" appears in the row of data, it indicates that the
decoded data are not fully displayed. At this time, you can view the details in
the "Packets" view. If you select "Payload", all data in the specified column
will be displayed in the event table. If "…" appears in the specified column of
data, it indicates that the decoded data are not fully displayed. At this time,
you can view the details in the "Packets" view.

- Export: If you select "Packets", you can export time and the corresponding

decoded data. Press Export, then the save setting interface is displayed. You

can export the data table of the packet to the internal memory or the

external USB storage device (when detected) in CSV format. For detailed

saving operation, refer to descriptions in "Store and Load".

- Jump to: Set the operating status of the oscilloscope to "STOP". Then, select

the data of the specified time from the event table. Press Jump to and the

specified data waveforms are displayed in the center of the screen.

- Decode: The setting of this menu enables you to quickly view the

corresponding event tables of four decode modules (Decode1, Decode2,

Decode3, and Decode4). Press Decode, then use the multifunction knob 

to select a decode module, then press down the knob to select it. You can

also press Decode continuously or enable the touch screen to select it.

15.5 LIN Decoding (Option)
The oscilloscope samples the LIN signal, and judges each data point to be logic "1" or
logic "0" according to the preset threshold level. The LIN decoding is required to
specify the LIN　signal protocol version.

In the decode setting menu, press Decode1 > Bus Type, then rotate the

multifunction knob  to select "LIN". Press down the knob to select it. You can also
press Bus Type continuously or enable the touch screen to select it.
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1. Enable or Disable the Bus

Press Bus Status continuously to enable or disable the decoding function.

2. Quickly Apply LIN Trigger Settings to LIN Decoding

Press Copy Trig to copy the current LIN trigger settings and apply them to LIN
decoding function (set the corresponding LIN decoding parameters automatically).
For analog channels, the threshold level settings will also be copied.

3. Set the Source and the Threshold

- Press Source, rotate the multifunction knob  to select the desired source

channel, and then press down the knob it. You can also press Source

continuously or enable the touch screen to select it. You can select CH1-CH4 or

D0-D15.

- When you select the analog channel (CH1-CH4), press Threshold, then rotate

the multifunction knob  or use the pop-up numeric keypad to set the

threshold of the source channel. When you modify the threshold of the clock

channel, a dotted line displaying the current threshold level is displayed on the

screen. It disappears in about 2 s after you stop modifying the threshold.

4. Set the Signal

Press Settings to enter the signal setting menu.

- Set the baud rate

Three methods are available for setting the baud rate:

- Press Baud Rate, then set the user-defined baud rate with the displayed

numeric keypad.

- Press Baud Rate to select the preset baud rate. The available baud rates

include 2.4 kbps, 4.8 kbps, 9.6 kbps, 19.2 kbps, and etc.

- Press Baud Rate, then rotate the multifunction knob  to baud rate at a

small step of 1 bps.

- Set the parity bit

Press Parity bit continuously to select whether the data contain the parity bit.

- Set the protocol version
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Press Version, and rotate the multifunction knob  to select a protocol version
that matches the LIN bus signal. Then, press down the knob to select it. You can
also press Version continuously or enable the touch screen to select it. The
available versions include 1.X, 2.X, and Both.

5. Set Display-related Parameters

Press Display to enter the display setting menu.

- Set the display format

Press Format, rotate the multifunction knob  to select the display format of
the bus data. Then, press down the knob to select it. You can also press Format
continuously or enable the touch screen to select it. The available formats
include Hex, Dec, Bin, and ASCII.

- Adjust the vertical position of the bus

Press Position, and then rotate the multifunction knob  to adjust the vertical

display position of the bus. You can also rotate Wave Vertical  POSITION to
adjust the vertical display position of the bus.

- Set the label display

Press Label to enable or disable the label display of the LIN decoding bus.
When enabled, the bus label "LIN" will be displayed at the upper-left side of the
bus (when the bus display is enabled).

- Set parameters for the event table

Press Event Table to enter the event table setting menu. The event table
displays the decoded data and the corresponding decoding information in time
order in the form of a table. It can be used to observe relatively longer decoded
data. The decoding information includes the decoded data, the corresponding
line number, time, frame ID, cyclic redundancy check (CRC), and error
information.

- Open or close the event table: Press Event Table continuously to enable or

disable the display of the event table. When enabled, the following event

table as shown in Figure 15.9 is displayed. You can also enable the touch

screen to tap the icon  at the right-upper corner of the event table to close

it.
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LIN Bus

Event Table

Line Number Time ErrorCRC    Frame ID Decoded Data

Figure 15.9 LIN Decoding Event Table

NOTE

- When you adjust the horizontal time base, the waveform displayed on the screen

will also change, and the total number of lines containing the decoding

information in the event table will also be changed.

- The displayed decoded data information in the bus is related to the value of the

horizontal time base. Reducing the horizontal time base can help you view the

detailed information.

- Set the event table format: Press Format, rotate the multifunction knob 

to select the display format of "Data" in the event table. Then, press down

the knob to select it. You can also press Format continuously or enable the

touch screen to select it. The available formats include Hex, Dec, Bin, and

ASC.

- Set the view type: Press View, rotate the multifunction knob  to select the

form of the event table to be viewed. Then, press down the knob to select it.

You can also press View continuously or enable the touch screen to select it.

The available choices include "Packets", "Details", and "Payload". You can

also tap "Packets", "Details", or "Payload" at the top of the event table to

select it.

If you select "Packets", the decoded data, time, and other information are
displayed in the event table. If you select "Details", the detailed data in the
specified row will be displayed in the event table. If "…" appears in the row of
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data, it indicates that the decoded data are not fully displayed. At this time,
you can view the details in the "Packets" view. If you select "Payload", all data
in the specified column will be displayed in the event table. If "…" appears in
the specified column of data, it indicates that the decoded data are not fully
displayed. At this time, you can view the details in the "Packets" view.

- Export: If you select "Packets", you can export time and the corresponding

decoded data. Press Export, then the save setting interface is displayed. You

can export the data table of the packet to the internal memory or the

external USB storage device (when detected) in CSV format. For detailed

saving operation, refer to descriptions in "Store and Load".

- Jump to: Set the operating status of the oscilloscope to "STOP". Then, select

the data of the specified time from the event table. Press Jump to and the

specified data waveforms are displayed in the center of the screen.

- Decode: The setting of this menu enables you to quickly view the

corresponding event tables of four decode modules (Decode1, Decode2,

Decode3, and Decode4). Press Decode, then use the multifunction knob 

to select a decode module, then press down the knob to select it. You can

also press Decode continuously or enable the touch screen to select it.

6. Interpret the Decoded LIN Data

- Break (Sync Break): expressed in Hex, displayed as a pink patch.

- SYNC (Sync): expressed in Hex, displayed as a dark green patch.

- ID (Frame ID): expressed in Hex, displayed as a blue-green patch.

- Data (Data): Its display format is the same as that of the bus data (Hex, Dec, Bin,

or ASCII), displayed as a black patch.

- CRC (Cyclic Redundancy Check): expressed in Hex, displayed in light yellow-

green. When errors occur, it is displayed as a red patch.

Break Sync ID Data CRC

- Wakeup (wake up symbol): displayed as a tangerine patch.
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7. Error Expressions in Decoding

In LIN decoding, the parity error, checksum error, or sync error may occur.

- Parity error

If the parity error is detected, frame ID and parity bit (when the signal is set to
include the parity bit) will be displayed in red, as shown in the figure below.

Parity Error

- Checksum error

If the checksum error is detected, CRC is displayed in red, as shown in the figure
below.
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Checksum Error

- Sync error

If the sync error is detected, SYNC is displayed in red, as shown in the figure
below.

Sync Error
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15.6 CAN Decoding (Option)
The oscilloscope samples the CAN signal at the specified sample position, and judges
each data point to be logic "1" or logic "0" according to the preset threshold level.
You need to specify the CAN signal type and sample position for CAN decoding.

In the decode setting menu, press Decode1 > Bus Type, then rotate the

multifunction knob  to select "CAN". Press down the knob to select it. You can also
press Bus Type continuously or enable the touch screen to select it.

1. Enable or Disable the Bus

Press Bus Status continuously to enable or disable the decoding function.

2. Quickly Apply CAN Trigger Settings to CAN Decoding

Press Copy Trig to copy the current CAN trigger settings and apply them to CAN
decoding function (set the corresponding CAN decoding parameters
automatically). For analog channels, the threshold level settings will also be copied.

3. Set the Source and the Threshold

- Press Source, rotate the multifunction knob  to select the desired source

channel, and then press down the knob it. You can also press Source

continuously or enable the touch screen to select it. You can select CH1-CH4 or

D0-D15.

- When you select the analog channel (CH1-CH4), press Threshold, then rotate

the multifunction knob  or use the pop-up numeric keypad to set the

threshold of the source channel. When you modify the threshold of the clock

channel, a dotted line displaying the current threshold level is displayed on the

screen. It disappears in about 2 s after you stop modifying the threshold.

4. Set the Signal

Press Settings to enter the signal setting menu.

- Set the signal type

Press Signal and rotate the multifunction knob  to select a signal type that
matches the CAN bus signal. Press down the knob to select it. You can also
press Signal continuously or enable the touch screen to select it. The available
signal types include CAN_H, CAN_L, Rx, Tx, and Diff.

- CAN_H: indicates the actual CAN_H bus signal.
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- CAN_L: indicates the actual CAN_L bus signal.

- Rx: indicates the Receive signal from the CAN bus transceiver.

- Tx: indicates the Transmit signal from the CAN bus transceiver.

- DIFF: indicates the CAN differential bus signals connected to an analog

channel by using a differential probe. Connect the differential probe's

positive lead to the CAN_H bus signal and connect the negative lead to the

CAN_L bus signal.

- Specify the standard signal rate

Three methods are available for setting the baud rate:

- Press Baud, then set the user-defined baud rate with the displayed numeric

keypad.

- Press Baud to select the preset baud rate. The available baud rates include

10 kbps, 20 kbps, 33.3 kbps, 50 kbps, and etc.

- Press Baud, then rotate the multifunction knob  to adjust the baud rate at

a small step.

- Sample position

Sample position is a point within a bit’s time. The oscilloscope samples the bit
level at this point. The sample position is represented by the proportion of "the
time from the start of the bit to the sample point" to the "bit time", as shown in
the figure below.

  
One Bit

60%
70%

80%

Figure 15.10 Sample Position

Press Sample Position, then rotate the multifunction knob  or use the pop-
up numeric keypad to set the sample position. The settable range is from 10%
to 90%.
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- CAN-FD baud

Three methods are available for setting the CAN-FD baud rate:

- Press CAN-FD Baud, then set the user-defined baud rate with the displayed

numeric keypad.

- Press CAN-FD Baud to select the preset CAN-FD baud rate. The available

baud rates it 1 Mbps, 2 Mbps, 3 Mbps, 4 Mbps, and etc.

- Press CAN-FD Baud, then rotate the multifunction knob  to adjust the

CAN-FD baud rate at a small step.

- FD sample position

FD sample position is a dedicated parameter configured for the CAN-FD

decoding.Press FD Sample Position, then rotate the multifunction knob  or
use the pop-up numeric keypad to set the FD sample position. The settable
range is from 10% to 90%.

5. Set Display-related Parameters

Press Display to enter the display setting menu.

- Set the display format

Press Format, rotate the multifunction knob  to select the display format of
the bus data. Then, press down the knob to select it. You can also press Format
continuously or enable the touch screen to select it. The available formats
include Hex, Dec, Bin, and ASCII.

- Adjust the vertical position of the bus

Press Position, and then rotate the multifunction knob  to adjust the vertical

display position of the bus. You can also rotate Wave Vertical  POSITION to
adjust the vertical display position of the bus.

- Set the label display

Press Label to enable or disable the label display of the CAN decoding bus.
When enabled, the bus label "CAN" will be displayed at the upper-left side of
the bus (when the bus display is enabled).

- Set parameters for the event table

Press Event Table to enter the event table setting menu. The event table
displays the decoded data and the corresponding decoding information in time
order in the form of a table. It can be used to observe relatively longer decoded
data. The decoding information includes the decoded data, the corresponding
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line number, time, frame ID, data length code (DLC), cyclic redundancy check
(CRC), and Acknowledgement (ACK) information.

- Open or close the event table: Press Event Table continuously to enable or

disable the display of the event table. When enabled, the following event

table as shown in Figure 15.11 is displayed. You can also enable the touch

screen to tap the icon  at the right-upper corner of the event table to close

it.

CAN Bus

Event Table

Line Number Time ACKCRC    Frame ID DLC Decoded Data    

Figure 15.11 CAN Decoding Event Table

NOTE

- When you adjust the horizontal time base, the waveform displayed on the screen

will also change, and the total number of lines containing the decoding

information in the event table will also be changed.

- The displayed decoded data information in the bus is related to the value of the

horizontal time base. Reducing the horizontal time base can help you view the

detailed information.

- Set the event table format: Press Format, rotate the multifunction knob 

to select the display format of "Data" in the event table. Then, press down

the knob to select it. You can also press Format continuously or enable the

touch screen to select it. The available formats include Hex, Dec, Bin, and

ASC.

- Set the view type: Press View, rotate the multifunction knob  to select the

form of the event table to be viewed. Then, press down the knob to select it.
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You can also press View continuously or enable the touch screen to select it.

The available choices include "Packets", "Details", and "Payload". You can

also tap "Packets", "Details", or "Payload" at the top of the event table to

select it.

If you select "Packets", the decoded data, time, and other information are
displayed in the event table. If you select "Details", the detailed data in the
specified row will be displayed in the event table. If "…" appears in the row of
data, it indicates that the decoded data are not fully displayed. At this time,
you can view the details in the "Packets" view. If you select "Payload", all data
in the specified column will be displayed in the event table. If "…" appears in
the specified column of data, it indicates that the decoded data are not fully
displayed. At this time, you can view the details in the "Packets" view.

- Export: If you select "Packets", you can export time and the corresponding

decoded data. Press Export, then the save setting interface is displayed. You

can export the data table of the packet to the internal memory or the

external USB storage device (when detected) in CSV format. For detailed

saving operation, refer to descriptions in "Store and Load".

- Jump to: Set the operating status of the oscilloscope to "STOP". Then, select

the data of the specified time from the event table. Press Jump to and the

specified data waveforms are displayed in the center of the screen.

- Decode: The setting of this menu enables you to quickly view the

corresponding event tables of four decode modules (Decode1, Decode2,

Decode3, and Decode4). Press Decode, then use the multifunction knob 

to select a decode module, then press down the knob to select it. You can

also press Decode continuously or enable the touch screen to select it.

6. Interpret the Decoded CAN Data

- Frame ID: expressed in Hex, displayed as a dark yellow-green patch.

- DLC (Data Length Code): expressed in Hex, displayed as a blue-green patch.

- Data: Its display format is the same as that of the bus data (Hex, Dec, Bin, or

ASCII), displayed as a green patch.
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- CRC (Cyclic Redundancy Check): expressed in Hex, displayed in yellow-green.

When errors occur, it is displayed as a red patch.

- ACK (Acknowledgement): when effective, displayed as a light yellow-green

patch; when errors (ACK is detected to be 1) occur, displayed as a red patch.

Frame ID DLC ACKData CRC

- R (remote frame): displayed as a tangerine patch.

- Stuff (Bit filling error): displayed as a red patch.

15.7 FlexRay Decoding (Option)
FlexRay is a type of differential serial bus configured with three consecutive segments
(i.g. packet header, payload, and packet trailer). The oscilloscope samples the FlexRay
signal at the specified sample position and judges each data point as logic "1" or
logic "0" according to the preset threshold level. The FlexRay decoding is required to
specify the signal type and baud rate.

In the decode setting menu, press Decode1 > Bus Type, then rotate the

multifunction knob  to select "FlexRay". Press down the knob to select it. You can
also press Bus Type continuously or enable the touch screen to select it.

1. Enable or Disable the Bus

Press Bus Status continuously to enable or disable the decoding function.

2. Quickly Apply FlexRay Trigger Settings to FlexRay Decoding

Press Copy Trig to copy the current FlexRay trigger settings and apply them to
FlexRay decoding function (set the corresponding FlexRay decoding parameters
automatically). For analog channels, the threshold level settings will also be copied.

3. Set the Source and the Threshold

- Press Source, rotate the multifunction knob  to select the desired source

channel, and then press down the knob it. You can also press Source
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continuously or enable the touch screen to select it. You can select CH1-CH4 or

D0-D15.

- When you select the analog channel (CH1-CH4), press Threshold, then rotate

the multifunction knob  or use the pop-up numeric keypad to set the

threshold of the source channel. When you modify the threshold of the clock

channel, a dotted line displaying the current threshold level is displayed on the

screen. It disappears in about 2 s after you stop modifying the threshold.

4. Set the Signal

Press Settings to enter the signal setting menu.

- Select the channel

Press Channel to select a channel ("A" or "B") that matches the actual FlexRay
bus signal.

- Specify the signal rate

Press Baud to open the baud rate list (2.5 Mbps, 5 Mbps, and 10 Mbps), and
select a preset baud rate that matches the actual FlexRay　bus　signal. You can

also press Baud continuously, then rotate the multifunction knob  or use the
numeric keypad to set the desired baud rate.

- Set the signal type

Press Signal and rotate the multifunction knob  to select a signal type that
matches the actual FlexRay bus signal. Press down the knob to select it. You can
also press Signal continuously or enable the touch screen to select it. The
available signal types include BP, BM, and RX/TX.

- Sample position

Sample position is a point within a bit’s time. The oscilloscope samples the bit
level at this point. The sample position is represented by the proportion of "the
time from the start of the bit to the sample point" to the "bit time", as shown in
the figure below.
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One Bit

60%
70%

80%

Figure 15.12 Sample Position

Press Sample Position, then rotate the multifunction knob  or use the pop-
up numeric keypad to set the sample position. The settable range is from 10%
to 90%.

5. Set Display-related Parameters

Press Display to enter the display setting menu.

- Set the display format

Press Format, rotate the multifunction knob  to select the display format of
the bus data. Then, press down the knob to select it. You can also press Format
continuously or enable the touch screen to select it. The available formats
include Hex, Dec, Bin, and ASCII.

- Adjust the vertical position of the bus

Press Position, and then rotate the multifunction knob  to adjust the vertical

display position of the bus. You can also rotate Wave Vertical  POSITION to
adjust the vertical display position of the bus.

- Set the label display

Press Label to enable or disable the label display of the FlexRay decoding bus.
When enabled, the bus label "Flexray" will be displayed at the upper-left side of
the bus (when the bus display is enabled).

- Set parameters for the event table

Press Event Table to enter the event table setting menu. The event table
displays the decoded data and the corresponding decoding information in time
order in the form of a table. It can be used to observe relatively longer decoded
data. The decoding information includes the decoded data, the corresponding
line number, time, frame ID, and Payload Length (PL).
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- Open or close the event table: Press Event Table continuously to enable or

disable the display of the event table. When enabled, the following event

table as shown in Figure 15.13 is displayed. You can also enable the touch

screen to tap the icon  at the right-upper corner of the event table to close

it.

FlexRay Bus

Event Table

Line Number Time Frame CRCCycleFrame ID PL Decoded Data    Header CRC

Figure 15.13 FlexRay Decoding Event Table

NOTE

- When you adjust the horizontal time base, the waveform displayed on the screen

will also change, and the total number of lines containing the decoding

information in the event table will also be changed.

- The displayed decoded data information in the bus is related to the value of the

horizontal time base. Reducing the horizontal time base can help you view the

detailed information.

- Set the event table format: Press Format, rotate the multifunction knob 

to select the display format of "Data" in the event table. Then, press down

the knob to select it. You can also press Format continuously or enable the

touch screen to select it. The available formats include Hex, Dec, Bin, and

ASC.

- Set the view type: Press View, rotate the multifunction knob  to select the

form of the event table to be viewed. Then, press down the knob to select it.

You can also press View continuously or enable the touch screen to select it.

The available choices include "Packets", "Details", and "Payload". You can
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also tap "Packets", "Details", or "Payload" at the top of the event table to

select it.

If you select "Packets", the decoded data, time, and other information are
displayed in the event table. If you select "Details", the detailed data in the
specified row will be displayed in the event table. If "…" appears in the row of
data, it indicates that the decoded data are not fully displayed. At this time,
you can view the details in the "Packets" view. If you select "Payload", all data
in the specified column will be displayed in the event table. If "…" appears in
the specified column of data, it indicates that the decoded data are not fully
displayed. At this time, you can view the details in the "Packets" view.

- Export: If you select "Packets", you can export time and the corresponding

decoded data. Press Export, then the save setting interface is displayed. You

can export the data table of the packet to the internal memory or the

external USB storage device (when detected) in CSV format. For detailed

saving operation, refer to descriptions in "Store and Load".

- Jump to: Set the operating status of the oscilloscope to "STOP". Then, select

the data of the specified time from the event table. Press Jump to and the

specified data waveforms are displayed in the center of the screen.

- Decode: The setting of this menu enables you to quickly view the

corresponding event tables of four decode modules (Decode1, Decode2,

Decode3, and Decode4). Press Decode, then use the multifunction knob 

to select a decode module, then press down the knob to select it. You can

also press Decode continuously or enable the touch screen to select it.

6. Interpret the decoded FlexRay frame data

- TSS: transmission start sequence, displayed as a pink patch.

- Sync Frame: displayed as a deep pink patch.

- ID (Frame ID): expressed in Hex, displayed as a blue-green patch.

- PL (Payload Length): expressed in Hex, displayed as a dark blue patch.

- HCRC (Header Cyclic Redundancy Check): expressed in Hex, displayed in yellow-

green. When CRC errors occur, it is displayed as a red patch.

- CYC (Cycle Number): expressed in Hex, displayed as a light blue patch.
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- Data: Its display format is the same as that of the bus data (Hex, Dec, Bin, or

ASCII), displayed as a green patch.

- TCRC (Tail Cyclic Redundancy Check): expressed in Hex, displayed as a yellow-

green patch. When CRC errors occur, it is displayed as a red patch.

TSS Frame ID TCRCHCRC DataSync Frame PL CRC

15.8 I2S Decoding (Option)
The oscilloscope samples the I2S signal, and judges each data point to be logic "1" or
logic "0" according to the preset threshold level. I2S decoding is required to specify
the serial clock, channel signal, and the data's source channel. You need to set
Alignment, WS Low, and other parameters.

In the decode setting menu, press Decode1 > Bus Type, then rotate the

multifunction knob  to select "I2S". Press down the knob to select it. You can also
press Bus Type continuously or enable the touch screen to select it.

1. Enable or Disable the Bus

Press Bus Status continuously to enable or disable the decoding function.

2. Quickly Apply I2S Trigger Settings to I2S Decoding

Press Copy Trig to copy the current I2S trigger settings and apply them to I2S
decoding function (set the corresponding I2S decoding parameters automatically).
For analog channels, the threshold level settings will also be copied.

3. Set the Source

Press Sources to enter the signal setting menu.

- Set the serial clock channel source, threshold, and clock edge

- Press SCLK, rotate the multifunction knob  to select the desired source

channel, and then press down the knob it. You can also press SCLK

continuously or enable the touch screen to select it. You can select CH1-CH4

or D0-D15.

- When you select the analog channel (CH1-CH4), press SCLK Thre below

SCLK, then rotate the multifunction knob  or use the pop-up numeric
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keypad to set the SCLK threshold. When you modify the threshold of the

clock channel, a dotted line displaying the current threshold level is

displayed on the screen. It disappears in about 2 s after you stop modifying

the threshold.

- Press SCLK Edge continuously to select "Rising( )" or "Falling( )" as the

desired clock edge.

- Set the WS source and the threshold

- Press WS, and rotate the multifunction knob  to select the desired

channel, and then press down the knob to select it. You can also press WS

continuously or enable the touch screen to select it. You can select CH1-CH4

or D0-D15.

- When you select the analog channel (CH1-CH4), press WS Thre below WS,

then rotate the multifunction knob  or use the pop-up numeric keypad to

set the threshold of the WS signal. When you modify the WS threshold, a

dotted line displaying the current threshold level is displayed on the screen.

It disappears in about 2 s after you stop modifying the threshold.

- Set the data channel source and the threshold

- Press Data, then rotate the multifunction knob  to select the desired data

channel source, and then press down the knob to select it. You can also press

Data continuously or enable the touch screen to select it. You can select

CH1-CH4 or D0-D15.

- When you select the analog channel (CH1-CH4), press Data Thre below

Data, then rotate the multifunction knob  or use the pop-up numeric

keypad to set the threshold of the data signal. When you modify the data

threshold, a dotted line displaying the current threshold level is displayed on

the screen. It disappears in about 2 s after you stop modifying the threshold.

4. Set the Bus Parameters

Press Settings to enter the bus setting menu.
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- Set the word sizePress Word Size, then rotate the multifunction knob  or

use the pop-up numeric keypad to set the word size.

Its range is from 4 to 32.

- Set the receiver word size

Press Receive, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the receiver word size. Its range is from 4 to 32.

- Set the alignment mode

Press Alignment, and rotate the multifunction knob  to select the alignment
way for data signal. Then press down the knob to select it. You can also press
Alignment continuously or enable the touch screen to select it. The available
alignment ways include I2S, LJ, and RJ.

- Set the WS Low

Press WS Low continuously to select "Left" or "Right".

- Set the endian

Press Endian to select "LSB" or "MSB". By default, it is "LSB".

- Set the polarity

Press Data Polarity continuously to select Positive  or Negative  as the
polarity for data decoding.

5. Set Display-related Parameters

Press Display to enter the display setting menu.

- Set the display format

Press Format, rotate the multifunction knob  to select the display format of
the bus data. Then, press down the knob to select it. You can also press Format
continuously or enable the touch screen to select it. The available formats
include Hex, Dec, Bin, and ASCII.

- Adjust the vertical position of the bus

Press Position, and then rotate the multifunction knob  to adjust the vertical

display position of the bus. You can also rotate Wave Vertical  POSITION to
adjust the vertical display position of the bus.

- Set the label display
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Press Label to enable or disable the label display of the I2S decoding bus.
When enabled, the bus label "I2S" will be displayed at the upper-left side of the
bus (when the bus display is enabled).

- Set parameters for the event table

Press Event Table to enter the event table setting menu. The event table
displays the decoded data and the corresponding decoding information in time
order in the form of a table. It can be used to observe relatively longer decoded
data. The decoding information includes the decoded left channel data, right
channel data, the corresponding line number, and time.

- Open or close the event table: Press Event Table continuously to enable or

disable the display of the event table. When enabled, the following event

table as shown in Figure 15.14 is displayed. You can also enable the touch

screen to tap the icon  at the right-upper corner of the event table to close

it.

I2S Bus

Event Table

Line Number Time Right Channel DataLeft Channel Data

Figure 15.14 I2S Decoding Event Table

NOTE

- When you adjust the horizontal time base, the waveform displayed on the screen

will also change, and the total number of lines containing the decoding

information in the event table will also be changed.

- The displayed decoded data information in the bus is related to the value of the

horizontal time base. Reducing the horizontal time base can help you view the

detailed information.

- Set the event table format: Press Format, rotate the multifunction knob 

to select the display format of the decoded data. Then, press down the knob
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to select it. You can also press Format continuously or enable the touch

screen to select it. The available formats include Hex, Dec, Bin, and ASC.

- Set the view type: Press View, rotate the multifunction knob  to select the

form of the event table to be viewed. Then, press down the knob to select it.

You can also press View continuously or enable the touch screen to select it.

The available choices include "Packets", "Details", and "Payload". You can

also tap "Packets", "Details", or "Payload" at the top of the event table to

select it.

If you select "Packets", the decoded data, time, and other information are
displayed in the event table. If you select "Details", the detailed data in the
specified row will be displayed in the event table. If "…" appears in the row of
data, it indicates that the decoded data are not fully displayed. At this time,
you can view the details in the "Packets" view. If you select "Payload", all data
in the specified column will be displayed in the event table. If "…" appears in
the specified column of data, it indicates that the decoded data are not fully
displayed. At this time, you can view the details in the "Packets" view.

- Export: If you select "Packets", you can export time and the corresponding

decoded data. Press Export, then the save setting interface is displayed. You

can export the data table of the packet to the internal memory or the

external USB storage device (when detected) in CSV format. For detailed

saving operation, refer to descriptions in "Store and Load".

- Jump to: Set the operating status of the oscilloscope to "STOP". Then, select

the data of the specified time from the event table. Press Jump to and the

specified data waveforms are displayed in the center of the screen.

- Decode: The setting of this menu enables you to quickly view the

corresponding event tables of four decode modules (Decode1, Decode2,

Decode3, and Decode4). Press Decode, then use the multifunction knob 

to select a decode module, then press down the knob to select it. You can

also press Decode continuously or enable the touch screen to select it.

 Protocol Decoding

274 Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved.



15.9 1553B Decoding (Option)
The oscilloscope samples the 1553B signal, and judges each data point to be logic "1"
or logic "0" according to the preset threshold level. 1553B decoding is required to
specify the data channel source and the threshold.

In the decode setting menu, press Decode1 > Bus Type, then rotate the

multifunction knob  to select "1553B". Press down the knob to select it. You can
also press Bus Type continuously or enable the touch screen to select it.

1. Enable or Disable the Bus

Press Bus Status continuously to enable or disable the decoding function.

2. Quickly Apply 1553B Trigger Settings to 1553B Decoding

Press Copy Trig to copy the current 1553B trigger settings and apply them to
1553B decoding function (set the corresponding 1553B decoding parameters
automatically).

3. Set the Data Channel Source and the Threshold

- Press Data, then rotate the multifunction knob  to select the desired data

channel source, and then press down the knob to select it. You can also press

Data continuously or enable the touch screen to select it. The available

channels include CH1-CH4.

- Press Threshold, then rotate the multifunction knob  or use the pop-up

numeric keypad to set the threshold of the source channel. When you modify

the threshold of the channel, a dotted line displaying the current threshold level

is displayed on the screen. It disappears in about 2 s after you stop modifying

the threshold.

4. Set Display-related Parameters

Press Display to enter the display setting menu.

- Set the display format

Press Format, rotate the multifunction knob  to select the display format of
the bus data. Then, press down the knob to select it. You can also press Format
continuously or enable the touch screen to select it. The available formats
include Hex, Dec, Bin, and ASCII.

- Adjust the vertical position of the bus
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Press Position, and then rotate the multifunction knob  to adjust the vertical

display position of the bus. You can also rotate Wave Vertical  POSITION to
adjust the vertical display position of the bus.

- Set the label display

Press Label to enable or disable the label display of the 1553B decoding bus.
When enabled, the bus label "1553B" will be displayed at the upper-left side of
the bus (when the bus display is enabled).

- Set parameters for the event table

Press Event Table to enter the event table setting menu. The event table
displays the decoded data and the corresponding decoding information in time
order in the form of a table. It can be used to observe relatively longer decoded
data. The decoding information includes the decoded data, word type, the
corresponding line number, time, and error information.

- Open or close the event table: Press Event Table continuously to enable or

disable the display of the event table. When enabled, the following event

table as shown in Figure 15.15 is displayed. You can also enable the touch

screen to tap the icon  at the right-upper corner of the event table to close

it.

1553B Bus

Event Table

Line Number Time ErrorDataWord Type

Figure 15.15 1553B Decoding Event Table

NOTE

- When you adjust the horizontal time base, the waveform displayed on the screen

will also change, and the total number of lines containing the decoding

information in the event table will also be changed.
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- The displayed decoded data information in the bus is related to the value of the

horizontal time base. Reducing the horizontal time base can help you view the

detailed information.

- Set the event table format: Press Format, rotate the multifunction knob 

to select the display format of the decoded data. Then, press down the knob

to select it. You can also press Format continuously or enable the touch

screen to select it. The available formats include Hex, Dec, Bin, and ASC.

- Set the view type: Press View, rotate the multifunction knob  to select the

form of the event table to be viewed. Then, press down the knob to select it.

You can also press View continuously or enable the touch screen to select it.

The available choices include "Packets", "Details", and "Payload". You can

also tap "Packets", "Details", or "Payload" at the top of the event table to

select it.

If you select "Packets", the decoded data, time, and other information are
displayed in the event table. If you select "Details", the detailed data in the
specified row will be displayed in the event table. If "…" appears in the row of
data, it indicates that the decoded data are not fully displayed. At this time,
you can view the details in the "Packets" view. If you select "Payload", all data
in the specified column will be displayed in the event table. If "…" appears in
the specified column of data, it indicates that the decoded data are not fully
displayed. At this time, you can view the details in the "Packets" view.

- Export: If you select "Packets", you can export time and the corresponding

decoded data. Press Export, then the save setting interface is displayed. You

can export the data table of the packet to the internal memory or the

external USB storage device (when detected) in CSV format. For detailed

saving operation, refer to descriptions in "Store and Load".

- Jump to: Set the operating status of the oscilloscope to "STOP". Then, select

the data of the specified time from the event table. Press Jump to and the

specified data waveforms are displayed in the center of the screen.

- Decode: The setting of this menu enables you to quickly view the

corresponding event tables of four decode modules (Decode1, Decode2,

Decode3, and Decode4). Press Decode, then use the multifunction knob 
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to select a decode module, then press down the knob to select it. You can

also press Decode continuously or enable the touch screen to select it.

5. Interpret the Decoded 1553B Data

- C/S: command/status word. It is displayed as a blue-green patch.

- RTA: remote terminal address of the command/status word. It is displayed as a

tangerine patch.

- C/S data: the rest data value of the command/status word. Its display format is

the same as that of the bus data (Hex, Dec, Bin, or ASCII), displayed as a green

patch.

- Parity bit: displayed as a yellow-green patch; when errors occur, displayed as a

red patch.

- Data word data: data of the data word. Its display format is the same as that of

the bus data (Hex, Dec, Bin, or ASCII), displayed as a green patch.

C/S Word Parity BitParity Bit  Data WordRTA C/S Data
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16 Reference Waveform
This series oscilloscope provides 10 reference waveform positions (Ref1-Ref10). In the
actual test process, you can compare the signal waveform with the reference
waveform to locate the failure.

16.1 To Enable the Ref Function

Press  on the front panel to enable the reference waveform function, or enable

the touch screen and then tap the function navigation icon  at the lower-left corner
of the screen to open the function navigation. Then, tap the "Ref" icon to enable the
reference waveform function.

When the Ref function is enabled, you can select different color for each reference
waveform, set the source of each reference channel, adjust the vertical scale and
offset of the reference waveform, save the reference waveform to the internal or
external memory, and recall it when needed.

NOTE

When the horizontal time base is set to "XY", the reference waveform function is disabled.

16.2 To Select the Reference Channel

Press Current, rotate the multifunction knob  to select the reference waveform
channel (Ref1-Ref10). You can also press Current continuously or enable the touch
screen to select the reference waveform channel. By default, Ref1 is enabled.

16.3 To Select the Ref Source

Press Source, rotate the multifunction knob  to select the desired reference
waveform source (CH1-CH4, D0-D15, or Math1-Math4). You can also press Source
continuously or enable the touch screen to select the reference waveform source.

NOTE

Only the currently enabled channel can be selected as the source channel of the reference

waveform.
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16.4 To Adjust the Ref Waveform Display
After pressing SaveToRef, you can adjust the vertical scale and offset of the reference
waveform specified under Current.

Press VScale, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the vertical scale of the reference waveform. Press VOffset, then rotate

the multifunction knob  or use the pop-up numeric keypad to set the vertical offset
of the reference waveform. In the Ref function, You can also directly rotate Wave

Vertical  SCALE and Wave Vertical  POSITION respectively to modify the vertical
scale and the vertical offset.

16.5 To Save to Internal Memory
Press SaveToRef to save the displayed waveform for the specified source to the
internal memory as the reference waveform.

NOTE

This operation only saves the reference waveform to the volatile memory, and the waveform

will be cleared at power-off or restoring to the default settings.

16.6 To Clear the Display of the Reference Waveform
Press Clear to clear the display of the current reference waveform on the screen.
Meanwhile, the VScale and VOffset menus for the reference waveform are grayed

out and disabled. You can also press  on the front panel to clear the display of
the reference waveforms of all the reference channels.

NOTE

This operation only clears the display of the reference waveform on the screen, and the

reference waveform is still saved in the memory.

16.7 To View Details of the Reference Waveform
Press More > Details, and the detailed information about all the reference waveforms
will be displayed on the screen in the form of a list. Press Details again to close the

details list. You can also enable the touch screen to tap the icon  at the right-upper
corner of the table to close it.
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16.8 To Reset the Reference Waveform
Press More > Reset, and the reference waveform returns to the position where the
source channel waveform is located when the Save operation was executed.

16.9 To Set the Color of the Reference Waveform
This series oscilloscope provides five colors (gray, green, blue, red, and orange) to
mark the reference waveforms of different channels in order to distinguish them.

Press Color, and then rotate the multifunction knob  to select the color of the
reference waveform of the channel. You can also press Color continuously or enable
the touch screen to select it. The GND icon and the label at the left side of the
waveform of the currently selected channel will be filled with the specified color. For

example,  and .

16.10 To Set the Label
Press More > Label to enter the label setting menu. You can use the built-in label in
the library or manually input a label. Three input methods are available for you to
input a label name, including Chinese, English, and Traditional Chinese.

• Press Display continuously to enable or disable the display of the reference

waveform label. If it is enabled, the label will be displayed at the left side of the

waveform. If the current channel is REFn (n=1,2, …10), then the default label of

the reference waveform is REFn (n=1, 2, …10).
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• Press Library, and rotate the multifunction knob  to select the preset label,

and then press down the knob to select it. You can also press Library

continuously or enable the touch screen to select it. The available preset labels

include Default, ACK, ADDR, BIT, CLK, and etc.

• Press Label, and the label editing interface is automatically displayed. You can

input the label manually. For the label editing methods, refer to descriptions in

"Channel Label".

16.11 To Export to Internal or External Memory
You can save the current reference waveform to the internal memory or external USB
storage device. The file format of the reference waveform is "*.ref", "*.bin", or "*.csv".

Press More > Export to enter the reference waveform file saving interface. Please
refer to descriptions in "Store and Load" to save the reference waveform to the
internal or external memory. Only when the reference waveform is saved, can this
export function be valid.

NOTE

This series oscilloscope only supports the flash memory USB storage device of FAT32 format.

For the "*.bin" format file, refer to "Binary Data Format (.bin)".

16.12 To Import from Internal or External Memory
You can import the stored reference waveform file from the internal memory or
external USB storage device to the internal instrument and display the file on the
screen.

Press More > Import to enter the reference waveform file loading interface. Please
refer to descriptions in "Store and Load" to import the reference waveform to to the
instrument and display it on the screen.

NOTE

This series oscilloscope only supports the flash memory USB storage device of FAT32 format.
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17 Pass/Fail Test
During the product design and manufacturing process, you usually need to monitor
the variations of the signal or judge whether the product is up to standard. The pass/
fail test function of this series oscilloscope can accomplish this task perfectly.

17.1 To Enable or Disable the Pass/Fail Test Function

On the front panel, press  > PassFail to open the pass/fail test setting menu, or

enable the touch screen and then tap the function navigation icon  at the lower-
left corner of the screen to open the function navigation. Then, tap the "Pass/Fail"
icon to open the pass/fail test setting menu.

In the "Pass/Fail" setting menu, press Enable continuously to enable or disable the
pass/fail test function.

NOTE

The pass/fail test function cannot be enabled in the following conditions: when the time base

mode is "XY" or "ROLL"; when the delay sweep is enabled.

17.2 To Start or Stop the Pass/Fail Test Operation
After the Pass/Fail test function is enabled, press Operate continuously to start or
stop the test operation.

During the test process, the oscilloscope will test the waveforms, display the test
information, and output the test information based on the current of settings. You
can set the test mask, the display status of the test information, and the output form
of a pass/ failed test based on the selected source channel for the test. Then save the
test mask range to the internal or external memory, and then recall it when needed.
For the details, please refer to the following section.

NOTE

• Only when the pass/fail test function is enabled, can you start or stop the pass/fail test

operation, enable or disable the display of the test information, save and recall the test

mask range.

• After starting the test operation, you can neither modify the source channel nor adjust

the test mask.

17.3 To Select the Source
Before selecting the source, connect the signal under test to the analog channel input

terminal of the oscilloscope. Press Source, and rotate the multifunction knob  to
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select the desired source channel, and then press down the knob it. You can also
press Source continuously or enable the touch screen Select to select it. The available
output channels include CH1-CH4.

NOTE

Only the channels that have been enabled currently can be selected.

17.4 To Create a Mask
Press Mask > Create to self-define the mask of the pass/fail test. Press Range, then

rotate the multifunction knob  to select the range and then press down the knob
to select the range. You can also press Range continuously or enable the touch screen
to select it. You can select "Screen" or "Cursor" as the mask region. The default is
"Screen".

• If "Screen" is selected under Range, then the whole waveform display area is

considered to be the mask region. Press X Mask and Y Mask respectively, then

rotate the multifunction knob  or use with the pop-up numeric keypad to set

the horizontal tolerance range and vertical tolerance range. During the

adjustment, you can see the outline of the current mask. Then press Create to

apply the currently created mask (the region not covered by blue within the

screen).

• If "Cursor" is selected, two cursors (used to specify the current test mask range)

will be displayed on the screen. Cursor A is at the left and Cursor B is at the right.

Press CursorA and CursorB, and rotate the multifunction knob  to adjust the

positions of both Cursor A and Cursor B, respectively. Also you can press

CursorAB and rotate the multifunction knob  to adjust the two cursors

synchronously (the horizontal spacing between Cursor A and Cursor B remains

unchanged). Then refer to the above methods to adjust the horizontal and

vertical tolerance ranges, as well as create a mask (the region not covered by

blue within the cursor region).
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17.5 To Save a Mask
When the pass/fail test function is enabled, you can save the current test mask range
to the internal memory or external USB storage device (when detected) in "*.pf"
format.

Press Mask > Save to enter the file saving interface. Please refer to descriptions in
"Store and Load" to save the test mask file to the internal or external memory.

17.6 To Load a Mask
When the pass/fail test function is enabled, you can load the test mask files from the
internal memory or external USB storage device (when detected) and apply them to
the current pass/fail test function.

Press Mask > Load to enter the file loading interface. Please refer to descriptions in 
Store and Load to load the specified test mask files (in *.pf format) and apply them to
the current pass/fail test function.

17.7 To Set the Output Form of the Test Results
In the Option menu, you can set what the oscilloscope will execute when test results
are detected according to your needs.

• Set the output event and Aux output

- Press Output Event, then rotate the multifunction knob  to select "Fail"

or "Pass". Press down the knob to select it. You can also press Output Event

continuously or enable the touch screen to select it.

- Press Aux Output continuously to enable or disable the Aux output. If Aux

Output is enabled, press  > System, the AUX Out menu is

automatically set to "PassFail". When a successful or failed event test is

detected, a pulse will be output from the rear-panel [TRIG OUT] connector.

If Aux Output is disabled, press  > System, the AUX Out menu is

automatically set to "TrigOut", and the output of the rear-panel [TRIG OUT]

connector is irrelevant with the pass/fail test.

• Set the Output Polarity and Output Pulse Width
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Press Polarity continuously to select "Positive" or "Negative", then press Pulse,

rotate the multifunction knob  or use the numeric keypad to set the pulse
width. Its range is from 100 ns to 10 ms. By default, it is 1 μs.

• Set the Error Action

Press Err Action, and rotate the multifunction knob  to set the operation that
the oscilloscope will execute once a failed test is detected. Press down the knob
to select it. You can also press Err Action continuously and press down the

multifunction knob  to select it. Also, you can enable the touch screen to
select it.

- Stop: indicates stopping test when a a pass/fail test event is found.

- Beeper: indicates that the beeper sounds an alarm when a pass/fail test

event is found (irrelevant with the on/off status of the beeper).

- Screenshot: performs the screenshot operation when a pass/fail test event

is found. If an external storage device is detected, the screenshot will be

saved to the external storage device directly. Otherwise, it will be saved to

the local disk.

NOTE

If "Screenshot" is selected, "Stop" action will be executed forcibly. The test will be

stopped automatically. After the Screenshot operation is completed, the test will

continue.

17.8 To Enable or Disable the Display of the Statistics of
the Test Results
Press Information continuously to enable or disable the display of the statistics of the

test results. You can also enable the touch screen to tap the icon  at the right-upper
corner of the statistics window to close it.

The test results statistics include the number of failed frames, the number of
successful frames, and total number of frames, as shown in the figure below.
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17.9 To Reset Statistics
Press Reset to clear the current test results and execute statistics on the test results
again.
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18 Waveform Recording and Playing
Waveform recording/playing function can play the recorded waveforms of the analog
input channels (CH1-CH4) and the digital channels (D0-D15), enabling you to analyze
the waveforms better.

NOTE

The horizontal time base must be set to YT mode during waveform recording.

18.1 Common Settings

Press  > Record to enter the waveform recording setting menu. You can also

enable the touch screen and then tap the function navigation icon  at the lower-
left corner of the screen to open the function navigation. Then, tap the "Record" icon
to open the waveform recording setting menu.

1. Record

Press Record continuously to enable or disable the waveform recording function.
Before recording the waveform, you can refer to descriptions in "Record Options"
to set the waveform recording parameters. Press Record to start recording the

waveforms. Then the record icon turns  from . During the recording, the
current real-time recording information is displayed on the screen, as shown in 
Figure 18.1 . In the figure, the data at the left side of the slash is the current frame.
Its value changes constantly (the value under the Current menu is changing
constantly too). The data at the right of the slash indicate the number of frames for
recording. The time difference ΔT at the upper-right corner indicates the time
different between the current frame and the first frame. After the recording is

completed, the recording marker " " turns out to be " " and recording stops
automatically. During recording, you can also press Record again to suspend
recording manually.
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Current Frame Recording Frames

Time Difference

Figure 18.1 Recording Process

2. Play

Press Playing to start playing the recorded waveforms. " " automatically turns

out to be " ". For details about playing, refer to descriptions in "Play Options".
During waveform playing, the current frame changes accordingly (the value of the

parameter Current changes accordingly). After playing is completed, " "

automatically turns out to be " " automatically. During playing, you can also press
Playing again to suspend playing manually.

3. Current Frame

Press Current, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the current frame. At this time, the waveform of the current frame is
displayed on the screen.

4. Set Transition

Press Jump To continuously to select to jump to the recorded end frame (  Last) or

the recorded start frame (  First). For settings of the start and end frames, refer to
descriptions in "Play Options".

18.2 Record Options
During the waveform recording, the oscilloscope records the waveforms of the
currently enabled channel at a specified interval until you manually stops the
recording operation or the number of recorded frames has reached the set value.

NOTE

Before starting the recording operation, turn on the desired channel and adjust the waveform

display to the desired state. When starting the recording operation, you can neither enable/

disable the channel output nor adjust the waveform display.
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Before recording the waveforms, you can press More > Setting to select "Record" to
set the following parameters.

1. Interval

The recording interval indicates the time interval between the frames during the
recording process.

Press Interval, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the time interval between frames. The available range is from 10 ns
to 10 s.

2. Frames

The recording frames refer to the number of frames that can be recorded actually.
After starting the recording operation, the oscilloscope stops the recording
operation automatically when the number of recorded frames reaches the set
value.

Press Frames, then rotate the multifunction knob  or use the numeric keypad to
set the number of recorded frames. The available range is from 1 to the maximum
number of frames that can be recorded currently (available in the Max Frames
menu). Press Set to Max to set the number of recorded waveform frames to the
maximum number of frames automatically.

3. Max Frames

The menu shows the maximum number of frames that can be recorded currently.
As the capacity of the waveform memory is fixed, the more the number of points
each frame of waveform has, the less the number of waveform frames that can be
recorded. Therefore, the maximum number of recorded frames is related to the
currently selected "memory depth" (refer to "Memory Depth"). The current
memory depth refers to the number of waveform points per frame. Memory Depth
= Sample Rate x Horizontal Time Base x Number of Grids in the Horizontal
Direction. Therefore, the maximum number of frames of waveform recording is
also related to the "Sample Rate" and "Horizontal Time Base". This oscilloscope
supports up to 450,000 frames of real-time and ceaseless waveforms recording.

4. Beeper

Press Beeper continuously to set whether the beeper sounds when the recording
is completed.

• On : the beeper sounds at the end of recording.

• Off : the beeper does not sound at the end of recording.
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18.3 Play Options
Waveform playing function can play back the waveforms currently recorded. Before
playing back the waveforms, you can press More > Setting to select "Play" to set the
following parameters.

1. Play Mode

Press Mode continuously to set the playback mode to cycle  or single .

- : plays from the start frame to the end frame, then such playback

operation is repeated until you stop it manually.

- : plays from the start frame to the end frame, and then stops

automatically.

2. Playback Sequence

Press Sequence continuously to select the playback sequence to (playback

clockwise) or (playback counterclockwise).

- : plays from the start frame to the end frame.

- : plays from the end frame to the start frame.

3. Interval

The playback interval indicates the time interval between the frames during the
playing process.

Press Interval, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the time interval between frames. The available range is from 5 ms
to 10 s.

4. Start Frame

Press Start Frame, then rotate the multifunction knob  or use the numeric
keypad to set the start frame for playing back the waveforms. The default is 1, and
the maximum value is the maximum number of recorded frames.

5. End Frame

Press End Frame, and then rotate the multifunction knob  or use the pop-up
numeric keypad to set the end frame of playback. The default is the number of
frames of the recorded waveforms.
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19 Search and Navigation Function
The search function allows you to search for relevant events based on the search
condition that you set. The navigation function includes the recording&playing
navigation, time navigation, and event navigation.

19.1 Search Function
The search function enables you to search the Edge trigger, Pulse trigger, Runt trigger,

Slope trigger, RS232 trigger, I2C trigger, or SPI trigger. Press  on the front panel
to enable the search setting menu. You can also enable the touch screen and then tap

the function navigation icon  at the lower-left corner of the screen to open the
function navigation. Then, tap the "Search" icon to open the search setting menu.

1. Enable or Disable the Search Function

Press Search continuously to enable or disable the search function.

2. Select the Search Type and Set the Parameters

Press Type, and rotate the multifunction knob  to select the desired type (Edge,
Pulse, Runt, Slope, RS232, I2C, or Slope). You can also press Type continuously or
enable the touch screen to select it.

- Edge search: sets the search type to "Edge". For Edge Setup menu settings,

refer to descriptions in "Edge Trigger". Press Threshold to enter the threshold

setting menu. Rotate the multifunction knob  or use the pop-up numeric

keypad to set the threshold.

- Pulse trigger search: sets the search type to "Pulse". For Pulse Setup menu

settings, refer to descriptions in "Pulse Trigger". Press Threshold to enter the

threshold setting menu. Rotate the multifunction knob  or use the pop-up

numeric keypad to set the threshold.

- Runt search: sets the search type to "Runt". For Runt Setup menu settings,

refer to descriptions in "Runt Trigger". Press Threshold to enter the threshold

setting menu. Rotate the multifunction knob  or use the pop-up numeric

keypad to set Threshold A and Threshold B.
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- Slope trigger search: sets the search type to "Slope". For Slope Setup menu

settings, refer to descriptions in "Slope Trigger". Press Threshold to enter the

threshold setting menu. Rotate the multifunction knob  or use the pop-up

numeric keypad to set Threshold A and Threshold B.

- RS232 trigger search: sets the search type to "RS232". For RS232 Setup menu

settings, refer to descriptions in "RS232 Trigger (Option)". Press Threshold to

enter the threshold setting menu. Rotate the multifunction knob  or use the

pop-up numeric keypad to set the threshold.

- I2C trigger search: sets the search type to "I2C". For I2C Setup menu settings,

refer to descriptions in "I2C Trigger (Option)". Press Threshold to enter the

threshold setting menu. Rotate the multifunction knob  or use the pop-up

numeric keypad to set the SCL and SDA thresholds.

- SPI trigger search: sets the search type to "SPI". For SPI Setup menu settings,

refer to descriptions in "SPI Trigger (Option)". Press Threshold to enter the

threshold setting menu. Rotate the multifunction knob  or use the pop-up

numeric keypad to set the CLK, MISO, and CS thresholds.

3. Copy Trigger

- Copy to Trigger

Press More > To Trigger to copy the selected search type settings to the same
trigger type. For example, if the current search type is "Edge", press To Trigger
to copy the edge search settings to the "Edge Trigger" settings.

- Copy from Trigger

Press More > From Trigger to copy the trigger settings of the selected search
type to the search settings. For example, if the current search type is "Edge
Trigger", press From Trigger to copy the Edge trigger settings to the "Edge"
search settings.

NOTE

If you select "From Trigger", you need to set the search type first, and then copy the

trigger type settings from the trigger menu.

4. Open or Close the Mark Table
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Press MarkTable continuously to enable or disable the display of the mark table.
The mark table is shown as below. You can also enable the touch screen to tap the

icon  at the right-upper corner of the table to close it.

5. Navigation

Press Navigation, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the event No. to navigate the event. You can also use the
navigation combination keys to make navigations at a step of 1. For details, refer
to descriptions in "Navigation Function".

6. Save

You can save the event mark data to the internal memory or external USB storage
device in "*.csv" format.

Press More > Save events to enter the file saving interface. Please refer to
descriptions in "Store and Load" to save the event mark data to the internal or
external memory.

NOTE

This series oscilloscope only supports the flash memory USB storage device of FAT32

format.

19.2 Navigation Function
The navigation function includes the recording&playing navigation, time navigation,
and event navigation. In the horizontal control area (Horizontal) on the front panel,
the navigation combination keys are shown as follow:
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• Recoding&Playing Navigation

When you enable the waveform recording function and complete the waveform
recording operation, press the navigation combination keys to play the recorded

waveforms. Press  to play the recorded waveforms in reverse order; press 

to play the recorded waveforms in normal order; press  to stop playing.

• Time Navigation

After the data acquisition stops, use the navigation combination keys to play the

captured data waveforms in a fast and continuous way. Press  to play the

previous recorded waveforms; press  to play the next recorded waveforms;

press  to stop playing. Besides, press  or  repeatedly can accelerate the
playing of the waveforms, so that you can quickly locate the acquired data
waveforms.

NOTE

The time navigation function is only available when the time base mode is "YT" and the

instrument stays in "STOP" status.

• Event Navigation

When you enable the navigation function and complete the event search, you can use
the navigation combination keys to quickly navigate the specific event in the event

mark table. Press  to navigate to the previous event (the serial number in the mark

table decreases); press  to navigate to the next event (the serial number in the

mark table increases); the  key is disabled in the event navigation.
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20 Display Control
In the "display" setting menu, you can set the parameters such as the waveform
display type, persistence time, intensity, grid type, grid brightness, and etc.

20.1 To Select the Display Type

Press  to enter the display control setting menu. Press Type continuously to set
the waveform display mode to "Vector" or "Dots".

• Vector: the sample points are connected by lines and displayed. In most cases,

this mode can provide the most vivid waveform for you to view the steep edge

of the waveform (such as square waveform).

• Dots: the sample points are displayed directly. You can directly view each sample

point and use the cursor to measure the X Value and Y values of the sample

point.

Vector Display Dots Display

20.2 To Set the Persistence Time

Press Persis.Time, and rotate the multifunction knob  to set the persistence time
for the oscilloscope and then press down the knob to select it. You can also press
Persis.Time continuously or enable the touch screen to select it. The available values
are Min, specific values (i.g. 100 ms, 200 ms, 500 ms, 1 s, 2 s, 5 s, 10 s), and Infinite.

In the following part, a frequency sweep signal of the sine waveform is used to show
the waveform effects in different persistence times.

1. Min

Enables you to view waveform changing in high refresh rate.

2. Specific Values
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Enables to view glitches that change relatively slowly or glitches with lower
occurrence probability. The persistence time can be set to 100 ms, 200 ms, 500 ms,
1 s, 2 s, 5 s, or 10 s.

3. Infinite

In this mode, the oscilloscope displays the waveform newly acquired without
clearing the waveforms acquired formerly. The waveforms acquired formerly will
be displayed in relatively low-brightness color and the newly acquired waveforms
will be displayed in normal brightness and color. Infinite persistence can be used
to measure noise and jitter and to capture incidental events.

20.3 To Set the Waveform Intensity

Press Intensity, then rotate the multifunction knob  at a small step value or use the
pop-up numeric keypad to set the waveform intensity. Note that in the non-menu

operation mode, you can also rotate the multifunction knob  to adjust the
waveform intensity of the channel. The default is 50%, and the range available is from
1% to 100%.

20.4 To Set the Screen Grid

Press Grid, and rotate the multifunction knob  to set the grid type and then press
down the knob to select it. You can also press Grid continuously or enable the touch
screen to select it. You can select FULL, HALF, NONE, or IRE.

• FULL: turns the background grid and coordinate on.

• HALF: turns the background grid off.

• NONE: turns the background grid and coordinate off.

• IRE: only available for testing the video signal (i.g. the trigger type is set to

"Video" trigger, and the vertical scale is set to 140 mV).

When "IRE" is selected, the screen displays the vertical graticule in IRE and marks
it at the left side of the screen. Its range is from -40 IRE to +100 IRE. Meanwhile,
0.35 V and 0.7 V levels are displayed at the right side of the screen, as shown in
the following figure.
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20.5 To Set the Grid Brightness

Press Brightness, then rotate the multifunction knob  at a small step value or the
pop-up numeric keypad to set the grid brightness. The default is 20%, and the range
available is from 1% to 100%.

20.6 Show Scale
Press Show Scale continuously to enable or disable the scale display on the screen.
By default, it is OFF.

NOTE

When the digital channel is enabled, the scale in the vertical direction is hidden automatically.

20.7 Color Grade
Press More > Color Grade to enable or disable the color grade display of the
waveforms on the screen. By default, it is OFF. When enabled, different colors are
displayed on the screen to indicate the times of data acquisition or acquisition
probability.

20.8 Waveform Freeze
Press More > Waveform Freeze to enable or disable waveform freeze function.
When enabled, the oscilloscope displays the waveform after multiple sampling and
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superposition when sampling is stopped by pressing the front-panel  key. If
disabled, the last triggered waveform is displayed.
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21 Function/Arbitrary Waveform Generator
(Option)
With an optional configuration of built-in dual-channel, 25 MHz Function/Arbitrary
Waveform Generator, this series integrates the Function/Arbitrary Waveform
Generator and the oscilloscope into one, thus providing great convenience for
engineers who need to use the Function/Arbitrary Waveform Generator and
oscilloscope at the same time. This chapter introduces how to use the built-in
Function/Arbitrary Waveform Generator option. As the functions and setting methods
of the two channels of the Function/Arbitrary Waveform Generator are the same, this
chapter takes GI as an example to illustrate.

21.1 To Output Basic Waveforms

Press  on the front panel or enable the touch screen to tap the GI label at the
bottom of the screen to enable/disable the output of the [GI] connector on the front
panel. Then the Function/Arbitrary Waveform Generator setting menu is displayed.
The built-in Function/Arbitrary Waveform Generator can output a variety of basic
waveforms, including Sine, Square, Ramp, Pulse, DC, Noise, Sinc, Exp.Rise, Exp.Fall,
ECG, Gauss, Lorentz, Haversine, and Arb.

21.1.1 To Output Sine

Press Wave, then use the multifunction knob  to select "Sine" and then press down
the knob to select the waveform. You can also press Wave continuously or enable the
touch screen to select it. At this time, you can set the parameters for the Sine
waveform.

• Set the Frequency or Period

First press Frequency or Period, rotate the multifunction knob  to select
"Frequency" or "Period". You can also press Frequency or Period continuously or

enable the touch screen to select it. Rotate the multifunction knob  or use the
pop-up numeric keypad to set the frequency or period of the current signal.
Different waveforms have different frequency or period (reciprocal of the
frequency) ranges.

Sine: 100 mHz to 25 MHz

Square: 100 mHz to 15 MHz

Ramp: 100 mHz to 100 kHz

Pulse: 100 mHz to 1 MHz

DC and Noise: no frequency parameter
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• Set the Amplitude or High Level

First press Amplitude or High Level, then rotate the multifunction knob  to
select "Amplitude" or "High Level". You can also press Amplitude or High Level
continuously to select it. Enable the touch screen to select it. Rotate the

multifunction knob  or use the pop-up numeric keypad to set the amplitude
or high level of the current signal. Note that if you select "Amplitude" for this
menu, then the menu below Amplitude is automatically turns out to be "Offset";
if you select "High Level" for this menu, then the menu below High Level is
automatically turns out to be "Low Level". When the impedance is set to HighZ,
its range is from 20 mVpp to 5 Vpp; when the impedance is set to 50 Ω, its range
is from 10 mVpp to 2.5 Vpp.

• Set the Offset or Low Level

First press Offset or Low Level, then rotate the multifunction knob  to select
"Offset" or "Low Level". You can also press Offset or Low Level continuously to

select it. Enable the touch screen to select it. Rotate the multifunction knob  or
use the pop-up numeric keypad to set the offset or low level of the current
signal. When the impedance is HighZ, its range is from (-2.5 V + the current
amplitude/2) to (2.5 V - the current amplitude/2); when the impedance is set to
50 Ω, its range is from (-1.25 V + the current amplitude/2) to 1.25 V - the current
amplitude/2).

• Set the Start Phase

Press Start Phase, then rotate the multifunction knob  or use the numeric
keypad to set the start phase of the current signal. Its available range is from 0°
to 360°.

• Align Phase

Pressing Align Phase will re-configure the two channels to output according to
the preset frequency and phase. For two signals whose frequencies are the same
or in multiple relationship, this operation can align their phases. Use the
oscilloscope to acquire the waveforms of the two channels and stably display the
waveforms. After switching the channel status, the phase deviation between the
two waveforms is changed. At this time, press Align Phase, then the phase
deviation shown on the oscilloscope will restore to the current phase deviation
between the two waveforms automatically.

• Set Other Parameters

Press Settings to enter the other parameter setting menu. You can set the
parameters such as modulation, sweep, burst, and impedance.

- Modulation, sweep, and burst

 Function/Arbitrary Waveform Generator (Option)

Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved. 301



For details about modulation, sweep, and burst, refer to descriptions in
"Modulation", "Sweep", and "Burst".

NOTE

When "Pulse", "DC", or "Noise" is selected under Wave, this menu is not available.

- Set the impedance

Press Impedance continuously to set the output impedance of the
Function/Arbitrary Waveform Generator. It you can be set to "HighZ" or
"50Ω".

21.1.2 To Output Square

Press Wave, then use the multifunction knob  to select "Square" and then press
down the knob to select the waveform. You can also press Wave continuously or
enable the touch screen to select it. At this time, you can set the parameters for the
Square waveform. For setting methods, refer to descriptions in "To Output Sine". The
duty cycle of the square waveform is a fixed value 50%.

21.1.3 To Output Ramp

Press Wave, then use the multifunction knob  to select "Ramp", and then press
down the knob to select the waveform. You can also press Wave continuously or
enable the touch screen to select it. At this time, you can set the parameters for the
ramp waveform. For setting methods, refer to descriptions in "To Output Sine". This
section only introduces "Symmetry".

SymmetrySymmetry is defined as the percentage that the rising period of ramp takes
up in the whole period (as shown in the figure below).

Figure 21.1 Symmetry Definition

Press Settings > Symmetry, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the symmetry of the ramp waveform. The settable range is
from 1% to 100%.
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21.1.4 To Output Pulse

Press Wave, then use the multifunction knob  to select "Pulse" and then press
down the knob to select the waveform. You can also press Wave continuously or
enable the touch screen to select it. At this time, you can set the parameters for the
Pulse. For setting methods, refer to descriptions in "To Output Sine". This section only
introduces "Duty Cycle".

Duty Cycle is defined as the percentage that the high level takes up in the whole
pulse period.

Figure 21.2 Duty Cycle Definition

Press Settings > Duty Cycle, then rotate the multifunction knob  or use the pop-
up numeric keypad to set the duty cycle of the current signal. Its settable range is
from 10% to 90%.

21.1.5 To Output DC

Press Wave, then use the multifunction knob  to select "DC" and then press down
the knob to select the waveform. You can also press Wave continuously or enable the
touch screen to select it. At this time, you can set the offset and impedance of the DC
signal.

• Set the Offset

Press Offset, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the offset of the current signal. When the current impedance is set
to HighZ, the settable range is from -2.5 V to +2.5 V; when the impedance is set
to 50 Ω, the settable range is from -1.25 V to +1.25 V.

• Set the impedance

Press Impedance continuously to set the output impedance of the Function/
Arbitrary Waveform Generator. It can be set to "HighZ" or "50Ω".
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21.1.6 To Output Noise

Press Wave, then use the multifunction knob  to select "Noise" and then press
down the knob to select the waveform. You can also press Wave continuously or
enable the touch screen to select it. At this time, you can set the Amplitude/High
Level, Offset/Low Level, and Impedance of the Noise signal.

1. Set the Amplitude or High Level

First press Amplitude or High Level, then rotate the multifunction knob  to
select "Amplitude" or "High Level". You can also press Amplitude or High Level
continuously to select it. Enable the touch screen to select it. Rotate the

multifunction knob  or use the pop-up numeric keypad to set the amplitude or
high level of the current signal. Note that if you select "Amplitude" for this menu,
then the menu below Amplitude is automatically turns out to be "Offset"; if you
select "High Level" for this menu, then the menu below High Level is automatically
turns out to be "Low Level".

2. Set the Offset or Low Level

First press Offset or Low Level, then rotate the multifunction knob  to select
"Offset" or "Low Level". You can also press Offset or Low Level continuously to

select it. Enable the touch screen to select it. Rotate the multifunction knob  or
use the pop-up numeric keypad to set the offset or low level of the current signal.

3. Set the Impedance

Press Impedance continuously to set the output impedance of the Function/
Arbitrary Waveform Generator. It can be set to "HighZ" or "50Ω".

21.1.7 Sinc

Press Wave, then use the multifunction knob  to select "Sinc" and then press down
the knob to select the waveform. You can also press Wave continuously or enable the
touch screen to select it. At this time, you can set the parameters for the Sinc
waveform (as shown in the figure below). For setting methods, refer to descriptions in
"To Output Sine".
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Figure 21.3 Sinc

21.1.8 Exp.Rise

Press Wave, then use the multifunction knob  to select "Exp.Rise" and then press
down the knob to select the waveform. You can also press Wave continuously or
enable the touch screen to select it. At this time, you can set the parameters for the
Exp.Rise waveform (as shown in the figure below). For setting methods, refer to
descriptions in "To Output Sine".

Figure 21.4 Exp.Rise
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21.1.9 Exp.Fall

Press Wave, then use the multifunction knob  to select "Exp.Fall" and then press
down the knob to select the waveform. You can also press Wave continuously or
enable the touch screen to select it. At this time, you can set the parameters for the
Exp.Fall waveform (as shown in the figure below). For setting methods, refer to
descriptions in "To Output Sine".

Figure 21.5 Exp.Fall

21.1.10 ECG

Press Wave, then use the multifunction knob  to select "ECG" and then press down
the knob to select the waveform. You can also press Wave continuously or enable the
touch screen to select it. At this time, you can set the parameters for the ECG
waveform (as shown in the figure below). For setting methods, refer to descriptions in
"To Output Sine".
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Figure 21.6 ECG

21.1.11 Gauss

Press Wave, then use the multifunction knob  to select "Gauss" and then press
down the knob to select the waveform. You can also press Wave continuously or
enable the touch screen to select it. At this time, you can set the parameters for the
Gauss waveform (as shown in the figure below). For setting methods, refer to
descriptions in "To Output Sine".
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Figure 21.7 Gauss

21.1.12 Lorentz

Press Wave, then use the multifunction knob  to select "Lorentz", and then press
down the knob to select the waveform. You can also press Wave continuously or
enable the touch screen to select it. At this time, you can set the parameters for the
Lorentz waveform (as shown in the figure below). For setting methods, refer to
descriptions in "To Output Sine".
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Figure 21.8 Lorentz

21.1.13 Haversine

Press Wave, then use the multifunction knob  to select "Haversine" and then press
down the knob to select the waveform. You can also press Wave continuously or
enable the touch screen to select it. At this time, you can set the parameters for the
Haversine waveform (as shown in the figure below). For setting methods, refer to
descriptions in "To Output Sine".
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Figure 21.9 Haversine

21.2 To Output the Arbitrary Waveform
This series oscilloscope allows you to define the arbitrary waveform and save it to the
internal or external memory. The user-defined waveform can contain 2 to 16,384 data
points (i.g. 2 pts to 16 kpts).

Press Wave, then use the multifunction knob  to select "Arb", and then press down
the knob to select the waveform. You can also press Wave continuously or enable the
touch screen to select it. At this time, you can set the parameters for the arbitrary
waveform.

21.2.1 To Load the Channel and Waveform

1. Load the Channel

Press Load from CH to enter the channel loading menu. You can set the channel
signal required to be loaded.

- Channel selection

Press Channel and rotate the multifunction knob  to select the desired
channel (CH1-CH4), and then press down the knob to select it. You can also
press Channel continuously or enable the touch screen to select it.

- Set the waveform range
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Press Region continuously to select to load the waveforms in the "Cursor" or
"Screen" region. When "Cursor" is selected, press Cursor A or Cursor B and

rotate the multifunction knob  to adjust the positions of the two cursors

respectively; or press Cursor AB and rotate the multifunction knob  to adjust
the positions of cursors A at the same time to determine the waveform range.

- Load

Press Load to load the set channel signal.

2. Load the Waveform

Press Load Stored to enter the waveform loading interface. You can select the
stored waveforms from the internal memory or the external memory. The
waveform file is suffixed with "*.arb". Then, press Load to load the selected
waveform. For details, refer to descriptions in "Store and Load".

21.2.2 To Create the Waveforms

You can create arbitrary waveforms according to your needs. Press Create to enter
the waveform creation menu. Meanwhile, the waveform editor is displayed on the
screen.

• Set the frequency or period

First press Frequency or Period, rotate the multifunction knob  to select
"Frequency" or "Period". You can also press Frequency or Period continuously or

enable the touch screen to select it. Rotate the multifunction knob  or use the
pop-up numeric keypad to set the frequency or period of the current signal.

• Set the amplitude or high level

First press Amplitude or High Level, then rotate the multifunction knob  to
select "Amplitude" or "High Level". You can also press Amplitude or High Level
continuously to select it. Enable the touch screen to select it. Rotate the

multifunction knob  or use the pop-up numeric keypad to set the amplitude
or high level of the current signal. Note that if you select "Amplitude" for this
menu, then the menu below Amplitude is automatically turns out to be "Offset";
if you select "High Level" for this menu, then the menu below High Level is
automatically turns out to be "Low Level".

• Set the offset or low level

First press Offset or Low Level, then rotate the multifunction knob  to select
"Offset" or "Low Level". You can also press Offset or Low Level continuously to

select it. Enable the touch screen to select it. Rotate the multifunction knob  or
use the pop-up numeric keypad to set the offset or low level of the current
signal.
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• Set the initial points

The initial number of points indicates the number of editable points. By default,
the number of editable points of arbitrary waveforms created can be preset to 2.
Point 1 is fixed at 0 s and Point 2 is fixed at the middle of the period. Press Init

Points, then rotate the multifunction knob  or use the numeric keypad to set
the number of editable points for the arbitrary waveform. The arbitrary
waveform can contain up to 16,384 (16 kpts) points.

• Linear interpolation

Press Linear Interp continuously to enable or disable the linear interpolation
between the defined points of the waveform.

- ON: the waveform editor connects two points using a straight line.

- OFF: the waveform editor will keep a constant voltage level between two

points and create a ladder-like waveform.

• Edit points

Press Edit Points to enter the point editing menu. You can specify a voltage
value for each waveform point to define the waveforms.

- Current Point

Press PointX, then rotate the multifunction knob  or use the numeric
keypad to select the points to be edited. The available range is from 1 to
the number of initial points.

- Voltage

Press Voltage, then rotate the multifunction knob  or use the numeric
keypad to set the voltage value of the current point. Its available range is
from -2.5 V to +2.5 V.

- Insert

Press Insert to insert a new editable point between the current point and
the next point. The number of initial points adds 1 automatically. You can
press Insert continuously to increase the editable points gradually.

- Delete

Press Delete to delete the current point from the waveform, and connect
the remaining points using the current interpolation mode.

NOTE

- Zoom
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Press Zoom continuously to enable or disable the zoom function of
horizontal time base.

- Apply

Press Apply to apply the current settings for the currently edited arbitrary
waveforms and output the edited waveforms.

• Save the arbitrary waveform

Press Save to enter the file saving interface. Please refer to descriptions in "Store
and Load" to save the currently edited waveform file to the internal or external
memory in ".arb" format (you can overwrite the original file or save the currently
edited waveform).

21.2.3 To Edit the Waveforms

You can edit the waveforms in the current volatile memory. Press Edit to enter the
waveform editing menu.

• Set the frequency or period

First press Frequency or Period, rotate the multifunction knob  to select
"Frequency" or "Period". You can also press Frequency or Period continuously or

enable the touch screen to select it. Rotate the multifunction knob  or use the
pop-up numeric keypad to set the frequency or period of the current signal.

• Set the amplitude or high level

First press Amplitude or High Level, then rotate the multifunction knob  to
select "Amplitude" or "High Level". You can also press Amplitude or High Level
continuously to select it. Enable the touch screen to select it. Rotate the

multifunction knob  or use the pop-up numeric keypad to set the amplitude
or high level of the current signal. Note that if you select "Amplitude" for this
menu, then the menu below Amplitude is automatically turns out to be "Offset";
if you select "High Level" for this menu, then the menu below High Level is
automatically turns out to be "Low Level".

• Set the offset or low level

First press Offset or Low Level, then rotate the multifunction knob  to select
"Offset" or "Low Level". You can also press Offset or Low Level continuously to

select it. Enable the touch screen to select it. Rotate the multifunction knob  or
use the pop-up numeric keypad to set the offset or low level of the current
signal.

• Linear interpolation
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Press Linear Interp continuously to enable or disable the linear interpolation
between the defined points of the waveform.

- ON: the waveform editor connects two points using a straight line.

- OFF: disables the linear interpolation. The waveform editor will keep a

constant voltage level between two points and create a ladder-like

waveform.

• Edit points

Press Edit Points to enter the point editing menu. You can specify a voltage
value for each waveform point to define the waveforms.

- Current Point

Press PointX, then rotate the multifunction knob  or use the numeric
keypad to select the points to be edited. The available range is from 1 to
the number of initial points.

- Voltage

Press Voltage, then rotate the multifunction knob  or use the numeric
keypad to set the voltage value of the current point. Its available range is
from -2.5 V to +2.5 V.

- Insert

Press Insert to insert a new editable point between the current point and
the next point. The number of initial points adds 1 automatically. You can
press Insert continuously to increase the editable points gradually.

- Delete

Press Delete to delete the current point from the waveform, and connect
the remaining points using the current interpolation mode.

NOTE

- Zoom

Press Zoom continuously to enable or disable the zoom function of
horizontal time base.

- Apply

Press Apply to apply the current settings for the currently edited arbitrary
waveforms and output the edited waveforms.

• Save the arbitrary waveform
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Press Save to enter the file saving interface. Please refer to descriptions in "Store
and Load" to save the currently edited waveform file to the internal or external
memory in ".arb" format (you can overwrite the original file or save the currently
edited waveform).

21.3 Modulation
The built-in Function/Arbitrary Waveform Generator supports amplitude modulation
(AM), frequency modulation (FM), and frequency-shift keying modulation (FSK). A
modulated waveform consists of a carrier waveform and a modulating waveform. The
carrier waveform is the waveform output from the Function/Arbitrary Waveform
Generator, and the modulating signal can be the built-in sine, square, triangle
waveform, or noise signal.

Press Settings > Type, and rotate the multifunction knob  to select "Modulation"
and then press down the knob to select it. You can also press Type continuously or
enable the touch screen to select it.

Press Type, rotate the multifunction knob  to select the desired modulation type,
and then press down the knob to select it. You can also press Type continuously or
enable the touch screen to select it. The available modulation types include AM, FM,
and FSK.

21.3.1 AM

AM (Amplitude Modulation), namely the amplitude of the carrier waveform changes
with that of the modulating waveform, as shown in the figure below.

Modulating Signal

Carrier Signal

Modulated Waveform

Figure 21.10 AM
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1. Select the Modulating Waveform

Press Waveform, and rotate the multifunction knob  to select the desired
modulating waveform, and then press down the knob to select it. You can also
press Waveform continuously or enable the touch screen to select it. The available
modulating waveforms include sine, square, triangle waveform, and noise.

2. Set the Modulation Frequency

Press Frequency, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the frequency of the modulation signal. The available range
is from 1 Hz to 50 kHz.

3. Set the Modulation Depth

The modulation depth refers to the strength of the AM and is expressed in

percentage. Press AM Depth, then rotate the multifunction knob  or use the
pop-up numeric keypad to set the modulation depth of the modulating waveform.
The available range is from 0% to 120%. When it is set to 0%, the output amplitude
is half of the carrier amplitude. When it is set to 100%, the output amplitude
equals the carrier amplitude. When it is set to a value greater than 100%, envelop
distortion will occur which must be avoided in actual circuit; at this point, the
output of the instrument will not exceed 2.5 Vpp (on the 50 Ω load).

21.3.2 FM

FM (Frequency Modulation), namely the frequency of the carrier waveform changes
with that of the modulating waveform, as shown in the figure below.

Modulating Signal

Carrier Signal

Modulated Waveform

Figure 21.11 FM
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1. Select the Modulating Waveform

Press Waveform, and rotate the multifunction knob  to select the desired
modulating waveform, and then press down the knob to select it. You can also
press Waveform continuously or enable the touch screen to select it. The available
modulating waveforms include sine, square, triangle waveform, and noise.

2. Set the Modulation Frequency

Press Frequency, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the frequency of the modulation signal. The available range
is from 1 Hz to 50 kHz.

3. Set the Frequency Deviation

Press Deviation, then rotate the multifunction knob  or use the numeric keypad
to set the frequency deviation of modulating waveform from the carrier frequency.
The settable frequency range is from 1 Hz to to the current frequency of the carrier
waveform.

21.3.3 FSK

FSK (Frequency-shift Keying) is a modulation method that uses the digital signal to
control the carrier frequency changes. It is one of the methods that have been early
used in information transmission. Its advantages lie in good performance in anti-
noise and anti-attenuation, and it has been widely used in in low and medium rate of
data transmission.

1. Set the Modulation Polarity

Press Polarity continuously to select "Positive" or "Negative" of the modulating
waveform to control the frequency output.

2. Set the Modulating Rate

Press FSK Rate, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the frequency of the modulation signal. The available range is from 1
Hz to 50 kHz.

3. Set the Hopping Frequency

Hopping frequency indicates the frequency of the modulating waveform. The
range of the hopping frequency is from 100 mHz to the maximum frequency of
the carrier waveform. By default, it is 10 kHz. Press Hop Freq, then rotate the

multifunction knob  or use the pop-up numeric keypad to set the hopping
frequency.
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21.4 Sweep
The built-in Function/Arbitrary Waveform Generator supports the sweep function. In
the sweep mode, the Function/Arbitrary Waveform Generator outputs from the start
frequency to the end frequency at a specified sweep time. It supports three sweep
modes: Linear, Log, and Step. You are allowed to set the the parameters such as Start
Keep, End Keep, and Return Time. Internal and Manual trigger sources are supported.
The sweep output is available for Sine, Square, Ramp, and Arb waveforms (DC
excluded).

Press Settings > Type, and rotate the multifunction knob  to select "Sweep" and
then press down the knob to select it. You can also press Type continuously or enable
the touch screen to select it.

1. Sets the Sweep Type

Press Sweep Type, and rotate the multifunction knob  to select the desired
sweep type, and then press down the knob to select it. You can also press Sweep
Type continuously or enable the touch screen to select it. The available sweep
types include Linear, Log, and Step.

- Linear: the frequency of the signal changes linearly.

- Log: the frequency of the signal changes in log form.

- Step: the frequency of the signal changes with ladder-like step.

2. Sweep Settings

Press Settings to enter the sweep setting menu.

- Set start frequency and end frequency

Start frequency and end frequency indicate the upper and lower limits of the
sweep frequency. Function/Arbitrary Waveform Generator always sweeps from
the start frequency to the end frequency, and then returns back to the start
frequency.

- When start frequency is smaller than the end frequency, the Function/

Arbitrary Waveform Generator sweeps from low frequency to high frequency.

- When start frequency is greater than the end frequency, the Function/

Arbitrary Waveform Generator sweeps from high frequency to low frequency.

- When start frequency is equal to the end frequency, the Function/Arbitrary

Waveform Generator outputs at a fixed frequency.
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Press Start Freq, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the start frequency. Press End Freq, then rotate the

multifunction knob  or use the pop-up numeric keypad to set the end
frequency. By default, the start frequency is 100 Hz, and the end frequency is
1 kHz. The ranges of start frequency and end frequency for different sweep
waveforms are different. The generator will restart to sweep and output from
the specified "Start Frequency" after "Start Frequency" or "End Freq" is
modified.

- Start Keep

Start keep indicates the time that the output signal keeps outputting at the
"Start Freq" after the sweep starts. After the start keep time expires, the
generator will continue outputting with varied frequencies according to the
current sweep type.

Press Start Keep, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the start keep time. The default is 0 s, and the range is
from 0 s to 500 s.

- End Keep

End Keep indicates the time that the output signal continues outputting at the
"End Freq" after the generator sweeps from "Start Freq" to "End Freq".

Press End Keep, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the end keep time. The default is 0 s, and the range is
from 0 s to 500 s.

- Set the step

When the sweep type is set to "Step", this menu is enabled and can be settable.

Press Step number, then rotate the multifunction knob  or use the numeric
keypad to set the step value. By default, it is 2. Its available range is from 2 to
1,000.

- Set the trigger source

The trigger sources of the sweep can be Internal or Manual. The generator will
generate a sweep output when a trigger signal is received, and then it waits for
the next trigger signal.

Press Trig Source and rotate the multifunction knob  to select the desired
trigger source, and then press down the knob to select it. You can also press
Trig Source continuously or enable the touch screen to select it. The available
trigger sources include Internal or Manual.

- Internal: The Function/Arbitrary Waveform Generator outputs continuous

sweep waveform.
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- Manual: when you press Manual Trig one time, one sweep is immediately

launched for the corresponding channel.

3. Set the Sweep Time

Press Sweep Time, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the sweep time. By default, it is 1 s. Its available range is
from 1 ms to 500 s. The generator will restart to sweep and output from the
specified "Start Frequency" after the sweep time is modified.

4. Set the Return Time

Return time indicates the time that the output signal restores from "End Freq" to
"Start Freq" after the Function/Arbitrary Waveform Generator sweeps from "Start
Freq" to "End Freq" and till the "End Keep" time expires.

Press Return Time, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the return time. By default, it is 0 s. Its available range is
from 0 s to 500 s.

21.5 Burst
The built-in Function/Arbitrary Waveform Generator of this series oscilloscope
supports outputting the burst waveforms with a specified number of cycles. It
supports using internal and manual trigger sources to control the output of the burst
waveforms. Two burst types are supported: N Cycle and Infinite.

Press Settings > Type, and rotate the multifunction knob  to select "Burst", and
then press down the knob to select it. You can also press Type continuously or enable
the touch screen to select it.

1. Set the Burst Type

Press Burst Type, and rotate the multifunction knob  to select the desired burst
type, and then press down the knob to select it. You can also press Burst Type
continuously or enable the touch screen to select it. The available burst types
include N Cycle and Infinite.

- N Cycle: outputs the burst waveforms with a specified number of cycles once

receiving the trigger signal.

- Infinite: sets the number of cycles to Infinite. It outputs continuous waveforms

once receiving the trigger signal.

2. Set the Number of Cycles

When the burst type is set to "N Cycle", you need to set the number of cycles.
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Press Cycles, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the cycle count. For the Infinite burst type, the Cycles menu is
disabled and grayed out.

3. Set the Burst Delay

Burst delay indicates the time from when receiving the trigger signal to starting to
output N Cycle of bursts or Infinite burst.

Press Delay, then rotate the multifunction knob  or use the pop-up numeric
keypad to set the burst delay. The setting range of the delay time is related to the
burst cycle count.

4. Burst Setting

Press Settings to enter the burst setting menu.

- Set the trigger source

The trigger sources of the burst can be Internal or Manual. The generator will
generate a burst output when a trigger signal is received, and then it waits for
the next trigger signal.

Press Trig Source and rotate the multifunction knob  to select the desired
trigger source, and then press down the knob to select it. You can also press
Trig Source continuously or enable the touch screen to select it. The available
trigger sources include Internal and Manual. For the Infinite burst type, the Trig
Source menu is disabled and grayed out. You can only perform the manual
trigger.

- Internal: The Function/Arbitrary Waveform Generator outputs continuous N

cycle.

- Manual: when you press Manual Trig one time, one burst output is

immediately launched for the corresponding channel. For the Infinite burst

type, the Cycles menu is disabled and grayed out.

- Set the burst period

It is defined as the time from the beginning of one burst to that of another
burst.

Press Burst Period, then rotate the multifunction knob  or use the pop-up
numeric keypad to set the burst period. The setting range is from 2 ms to 500 s.
By default, it is 10 ms.
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22 Store and Load
You can save the current setups, waveforms, screen image, and parameters of the
oscilloscope to the internal memory or external USB storage device (such as USB
storage device) in various formats and load the stored setups or waveforms when
needed.

You can also copy, delete, or rename the specified type of file from the internal
memory or external USB storage device via the disk management menu.

NOTE

This series oscilloscope only supports the flash memory USB storage device of FAT32 format.

22.1 Storage System

Press  on the front panel to enter the store and load setting interface. This
oscilloscope provides three USB HOST interfaces on the front panel and one USB
HOST interface on the rear panel, which can all be connected to the USB storage
device for external storage. The USB storage devices connected are marked as
"Removable USB Disk (D)", "Removable USB Disk (E)", "Removable USB Disk (F)",
"Removable USB Disk (G)", and etc.

22.2 Storage Type
The file types for storage include image, waveform, and setups. The storage
descriptions of each type are as follows.

1. Image

Press Save Image > Format, and then rotate the multifunction knob  to select
the image type. You can also press Format continuously or enable the touch
screen to select it. Save the screen image to the internal or external memory in
".png", ".bmp", ".jpg", or ".tif" format.

After selecting this type:

- Press File Name to input the file name to be saved. For filename input, refer to

descriptions in "To Create a Folder". Press  > More > Auto Name to select

"ON", then the filename is generated automatically. If the filename that you

input is the same as the existing filename, a prompt message will be displayed,
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reminding you that the existing file will be overwritten and asking you whether

to continue or not.

- Press Invert to enable or disable the invert function.

- Press Color to select the desired storage color. It can be set to "Gray" or

"Color".

- Press NewFolder to create a new storage folder. For details, refer to

descriptions , in "To Create a Folder".

- Press Window to enable or disable the display of the disk management

interface.

- Press Save to save the set image file. Press  > More > Header to select

"ON" or "OFF". If you select "ON", the instrument model, firmware version

number, serial number, and the image creation date will be displayed in the

header of the image when you save the image file.

TIP

After a USB storage device (FAT32, Flash type) is connected, press  on the front panel

to save the file to the internal or external USB storage device. By default, it is saved to

the external storage device.

2. WavePress Save Wave to enter the waveform storage setting interface. Save the

main setting information (e.g. "On/Off" state of the channel, vertical scale, and

horizontal time base) and waveform data of all enabled channels (analog channel

and digital channel) to the internal or external memory.

After selecting this type:

- Press Data Source to select "Screen" or "Memory".

- Press Format to select waveform storage, such as "*.bin", "*.cvs", and "*.wfm"

(when "Memory" is selected under Data Source).

- Press File Name to input the file name to be saved. For filename input, refer to

descriptions in "To Create a Folder". Press  > More > Auto Name to select
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"ON", then the filename is generated automatically. If the filename that you

input is the same as the existing filename, a prompt message will be displayed,

reminding you that the existing file will be overwritten and asking you whether

to continue or not.

- Press Channel, then the available storage channels include CH1-CH4 and D0-

D15. Only when you select "Memory" under Data Source and the format is

"*.bin" or "*.cvs", can you set the storage channel.

- Press NewFolder to create a new storage folder. For details, refer to

descriptions , in "To Create a Folder".

- Press Save to save the set waveform file.

- Press More > Window to enable or disable the display of the disk management

interface.

- Press More > Time information to enable or disable the display of the time

information in the waveform data. If enabled, the time information for the

waveform data will be displayed. If disabled, the time information for the

waveform data will not be displayed.

3. SetupPress Save Setup to enter the setup setting interface.

Save the settings of the oscilloscope to the internal or external memory in "*.stp"
format. When loading, the stored settings can be recalled.

After selecting this type:

- Press File Name to input the file name to be saved. For filename input, refer to

descriptions in "To Create a Folder". Press  > More > Auto Name to select

"ON", then the filename is generated automatically. If the filename that you

input is the same as the existing filename, a prompt message will be displayed,

reminding you that the existing file will be overwritten and asking you whether

to continue or not.

- Press NewFolder to create a new storage folder. For details, refer to

descriptions , in "To Create a Folder".
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- Press Window to enable or disable the display of the disk management

interface.

- Press Save to save the set setup file.

22.2.1 Binary Data Format (.bin)

Binary data format stores waveform data in binary format and provides data headers
that describe these data. As data are displayed in binary format, its file size is much
more smaller than that in ASCII format. If several channels are enabled, then all the
displayed channels will be saved (save the first channel then save the second, and
then it goes on like this until all the displayed channels are saved).

In BIN file format, the data are displayed as follows:

• CH1 Data

• CH2 Data

• CH3 Data

• CH4 Data

• Digital Channel Data

• Math Waveform Data

Binary Header Format

1. File Header

There is only one file header in a binary file. The file header contains the following
information.

Cookie
Two-byte characters, RG, indicating that the file is the RIGOL
binary data file format.

Version Two-byte, indicating the file version.

File Size
A 4-byte integer, indicating the number of bytes in the file. It
includes the header.

Number of
Waveforms

A 4-byte integer, indicating the number of waveforms that are
stored in the file.

2. Waveform Header

It is possible to store several waveforms in the file. Each stored waveform has a
waveform header. When several channels are stored, each channel can be
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considered as a separate waveform. The waveform header contains the
information about the type of waveform data that are stored following the
waveform data header.

Header Size A 4-byte integer, indicating the number of bytes in the header.

Waveform
Type

A 4-byte integer, indicating the type of the waveform stored in the
file.

0 = Unknown

1 = Normal

2 = Peak Detection

3 = Average

4 = Not Used

5 = Not Used

6 = Logic

Number of
Waveform
Buffers

A 4-byte integer, indicating the number of waveform buffers
required to read the data.

Number of
Points

A 4-byte integer, indicating the number of waveform points in the
data.

Count

A 4-byte integer, indicating the number of hits at each time interval
during waveform recording when using a certain sample mode (e.g.
Average) to create the waveforms. For example, when averaging, a
count of 4 indicates that each waveform data point in the
waveform recording has been averaged at least 4 times. The
default value is 0.

X Display
Range

A 4-byte float, indicating the X-axis duration of the waveform that
is displayed. For time-domain waveforms,

it indicates the duration of time across the display. If the value is
zero, then no data has been acquired.

X Display
Origin

An 8-byte double, indicating the X-axis value at the left edge of the
screen. For time-domain waveforms, it indicates the time at the
start of the display. The value is treated as a double precision 64-bit
float point number. If the value is zero, then no data has been
acquired.

X Increment
An 8-byte double, indicating the duration between data points on
the X axis.
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Header Size A 4-byte integer, indicating the number of bytes in the header.

For time-domain waveforms, it indicates the time between points.

If the value is zero, then no data has been acquired.

X Origin

An 8-byte double, indicating the X-axis value of the first data point
in the data recording. For time-domain waveforms, it indicates the
time of the first point. The value is treated as a double precision 64-
bit float point number. If the value is zero, then no data has been
acquired.

X Units

A 4-byte integer, indicating the unit of measurement for X values in
the acquired data.

0 = Unknown

1 = Volts (V)

2 = Seconds (s)

3 = Constant

4 = Amps (A)

5 = dB

6 = Hz

Y Units
A 4-byte integer, indicating the unit of measurement for Y values in
the acquired data. The possible values are listed above under X
Units.

Date A 16-byte character array, not used

Time A 16-byte character array, not used

Frame

A 24-byte character array, indicating the model number and serial
number of the oscilloscope in the format:

MODEL#:SERIAL#.

Waveform
Label

A 16-byte character array that contains the label assigned to the
waveform.

3. Waveform Data Header

A waveform may have multiple data sets. Each waveform data set has a waveform
data header. The waveform data header consists of information about the
waveform data set. The header is stored before the data set.
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Header Size
A 4-byte integer, indicating the number of bytes in the
waveform data header.

Buffer Type

A 2-byte integer, indicating the type of the waveform data
stored in the file.

0 = Unknown

1 = Normal 32-bit float data

2 = Maximum float data

3 = Minimum float data

4 = Not Used

5 = Not Used

6 = Digital unsigned 8-bit character data (for digital
channels)

Bytes Per Point
A 2-byte short integer, indicating the number of bytes per
data point.

Buffer Size
A 4-byte integer, indicating the size of the buffer required
to hold the data points.

22.3 Load Type
This oscilloscope provides two load types: waveform load and setup load. The
descriptions of each load type are as follows.

1. Waveform Load

Press Load Wave to load the waveforms from the internal memory or the external
USB disk. The default file type is "*.wfm" and no other options are available. Select
the file to be loaded from the memory, then press Load to load the selected file.

2. Load Setup

Press Load Setup to load the setups from the internal memory or the external USB
disk. The default file type is "*.stp", and no other options are available. Select the file
to be loaded from the memory, then press Load to load the selected file.

22.4 Internal Storage and Load
The internal memory supports the storage and load of the image file, waveform file,
setup file, reference waveform file, and pass/fail test mask file.

1. Save the Specified Oscilloscope Setting to the Internal Memory (Take Save
Setup as an Example)
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a. Connect a signal to the oscilloscope and obtain stable display of waveforms.

b. Press  > Save Setup to enter the setup storage interface. The disk

management interface is displayed automatically. By default, "Local Disk(C)" is

selected.

c. Rotate the multifunction knob  or enable the touch screen to open the

internal memory storage interface.

d. Rotate the multifunction knob  to select the desired storage location, and

then press down the knob to open it. You can also enable the touch screen to

select the storage location. Rotate the multifunction knob  and select ,

press down the knob or enable the touch screen to tap  to go to the

previous location. Besides, you can also press NewFolder to create a new

storage folder. For details, refer to descriptions in "To Create a Folder".

e. Press File Name to name the setup file for storage. For details, refer to

descriptions in "To Create a Folder". Press  > More > Auto Name to select

"ON", then the filename is generated automatically. If the filename that you

input is the same as the existing filename, a prompt message will be displayed,

reminding you that the existing file will be overwritten and asking you whether

to continue or not.

f. Press Save to save the setup file to the selected folder in "*stp" format.

TIP

- After saving the reference waveform, press  > More > Export to enter the disk

management interface of reference waveform file storage.

- Press  > PassFail to enable the pass/fail test function. Then press Mask > Save to

enter the disk management interface of pass/fail test mask file storage.

2. Load the Setup File from the Internal Memory (Take Load Setup as an
Example)
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a. Press  > Load Setup to enter the setup load interface. The disk

management interface is displayed automatically. By default, "Local Disk(C)" is

selected.

b. Rotate the multifunction knob  or enable the touch screen to open the

internal memory storage interface.

c. Rotate the multifunction knob  to select the desired load location, and then

press down the knob to open it. You can also enable the touch screen to select

the location. Rotate the multifunction knob  and select , press down the

knob or enable the touch screen to tap  to go to the previous location.

d. Rotate the multifunction knob  to select the file to be loaded (the default file

type is in "*stp" format), then the Load menu is enabled. Press Load to load the

selected file. You can also enable the touch screen to operate.

TIP

- Press  > More > Import to enter the disk management interface of reference

waveform file load.

- Press  > PassFail to enable the pass/fail test function. Then press Mask > Load to

enter the disk management interface of pass/fail test mask file load.

22.5 External Storage and Load
Before external storage and load, ensure that the USB disk is properly connected. The
external memory supports image save, waveform saving, setup saving, waveform
loading, and setup loading.

1. Save the Specified Type of File in the External USB Storage Device (Take

Waveform Saving as an Example)

a. Connect a signal to the oscilloscope and obtain stable display of waveforms.

b. Press  > Save Wave to enter the waveform storage interface. The disk

management interface is displayed automatically.
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c. Rotate the multifunction knob  to select "Removable USB Disk (D/E/F/G...)",

press down the knob to open the external disk storage interface. You can also

enable the touch screen to select the storage location. Rotate the multifunction

knob  and select , press down the knob or enable the touch screen to

tap  to go to the previous location. Besides, you can also press NewFolder

to create a new storage folder. For details, refer to descriptions in "To Create a

Folder".

d. To set the waveform saving, refer to descriptions of "Wave" in "Storage Type".

e. Press Save to save the waveform file to the selected folder in the specified save

format.

2. Load the Specified Type of File from the External USB Storage Device (Take

Waveform Loading as an Example)

a. Press  > Load Wave to enter the waveform loading interface. The disk

management interface is displayed automatically.

b. Rotate the multifunction knob  to select "Removable USB Disk (D/E/F/G...)",

press down the knob to open the external disk storage interface. You can also

enable the touch screen to select the load location. Rotate the multifunction

knob  and select , press down the knob or enable the touch screen to

tap  to go to the previous location.

c. Rotate the multifunction knob  to select the file to be loaded, then the Load

menu is enabled. Press Load to load the selected file. You can also enable the

touch screen to operate.

22.6 Disk Management

Press  > Disk to turn on the disk management interface as shown in Figure

22.1 . Rotate the multifunction knob  to select the desired disk. The disk currently
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selected is displayed in red shading. Press down the knob  to open the selected
disk. You can also enable the touch screen to select the disk.

Figure 22.1 Disk Management Interface

22.6.1 To Select the File Type

Except the image storage, waveform storage, and setup storage, the oscilloscope can
also display files for advanced applications,

Press  > Disk > File Type, rotate the multifunction knob  to select the desired
file type. The default is "*.*". Under the current path, only the file whose suffix of its
file name matches that of the file type selected will be displayed in the current path.

22.6.2 To Create a Folder

Before using the external storage device, make sure that a USB storage device (FAT32
format, flash memory) is connected correctly.

In the disk management interface, rotate the multifunction knob  or enable the
touch screen to select the storage location. By default, the internal memory "Local
Disk(C)" is selected. Press NewFolder to enter the interface, as shown in Figure 22.2 .
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Figure 22.2 Create a Folder

This oscilloscope supports Chinese/English input method. The length of folder name
is limited to 22 bytes (one Chinese character occupies two bytes). The following part
introduces how to input a folder name using Chinese/English input method.

TIP

During the name input, rotate the multifunction knob  to select the desired contents. Press

down the knob  to input the desired contents. You can also enable the touch screen and tap

the desired contents to select it.

English Input Method

For example, create a folder with the name "Filename".

Name Input Area Letter Input Area Virtual Keypad

Upper/Lower Case Switch

Input Method Switch

1. Select English Input Method

If the current input method is "En/中/繁", please go to Step 2. If the current input

method is "中/繁/En" or "繁/En/中", rotate the multifunction knob  to select the
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input switch key and press the knob  continuously to switch to "En/中/繁". "En"
is located first and highlighted.

2. Clear the Name Input Area

If there is no character in the "Name Input Area", please go to Step 3. If there are

characters in the "Name Input Area", rotate the multifunction knob  to select the

Delete key  to delete all the characters in the name input area in order.

3. Input the First Character "F"

a. If the current setting is uppercase input, please go to Step 2. If the current

setting is lowercase input, rotate the multifunction knob  to select "Caps" and

press down the knob to switch to the uppercase input.

b. Rotate the multifunction knob  to select "F" and press down the knob. The

character is displayed in the input area.

4. Input the Other Characters

Use the same method to input the remaining letters "ilename" by referring to Step
3. Pay attention to the upper-lower case of the letters when inputting them.

5. Modify or Delete the Unwanted Characters that Have Been Entered

While entering a value, you can modify or delete the unwanted character if

necessary. To delete the input characters, rotate the multifunction knob  in the

virtual keypad to select the delete key . Press down the key to delete the
characters. To modify the characters that have been input, delete the unwanted
characters first and then input the new characters. If the character to be modified
is in the middle, press the delete key to delete the characters starting from the last
one to the character to be modified, then input the new character again.

If the touch screen is enabled, tap to directly move the cursor to the character
required to be modified or deleted, and then input the desired character again or
delete the unwanted character.

TIP

If characters already exist in the letter input area, when you rotate the multifunction knob

 to delete the characters in the name input area, the characters in the letter input area

will be deleted first.

6. After finishing the input, rotate the multifunction knob  and press OK. The

oscilloscope will create a folder or a specified type of file with this name under the

current path.
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Simplified Chinese (Traditional Chinese) Input Method

For example, create a file folder with the name "文件名". Note that the input method
of traditional Chinese is the same as that of the simplified Chinese.

Pinyin Input Area Chinese Character Selecting Area

1. Select Chinese Input Method

If the current input method is "中/繁/En", please go to Step 2. If the current input

method is "En/中/繁" or "繁/En/中", rotate the multifunction knob  to select the

input switch key and press the knob  continuously to switch to "中/繁/En". "中" is
located first and highlighted.

2. Clear the Pinyin Input Area and Name Input AreaIf there is no character in the

"Pinyin Input Area" and "Name Input Area", please go to Step 3. If there are

characters in the "Name Input Area" and "Pinyin Input Area", rotate the

multifunction knob  to select the Delete key  to delete all the characters in

the name input area in order.

3. Input the first Chinese character "文"

a. Input the pinyin "wen" in the "Pinyin Input Area"Rotate the multifunction knob

 to select the first letter "w" in the pinyin "wen" and press down the knob to

input "w" in the "Pinyin Input Area".

Use the same method to input the remaining letters "en" in the pinyin "wen".
After finishing the input, the Chinese characters available are displayed in the
"Chinese Character Selecting Area".
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b. Select the desired Chinese character from the "Chinese Character Selecting

Area"

Rotate the multifunction knob  to select "文", and press down the knob, then
"文" is input in the "Name Input Area". If the Chinese character is not found in

the current page, press  to go to the next page until you find the desired
character.

4. Input the Other Characters

Refer to Step 3 and use the same method to input the remaining Chinese
characters "件名" in sequence.

5. Modify or delete the unwanted characters that have been entered

When inputting the name, you can modify or delete the filename characters input
in the "Name Input Area" as well as delete the pinyin characters input in the
"Pinyin Input Area". To delete the input characters, rotate the multifunction knob

 in the virtual keypad to select the delete key . Press down the key to delete
the characters. To modify the characters that have been input, delete the unwanted
characters first and then input the new characters. If the character to be modified
is in the middle, press the delete key to delete the characters starting from the last
one to the character to be modified, then input the new character again.

If the touch screen is enabled, tap to directly move the cursor to the character
required to be modified or deleted, and then input the desired character again or
delete the unwanted character.

TIP

If characters already exist in the Pinyin input area, when you rotate the multifunction knob

 to delete the characters in the name input area, the characters in the Pinyin input area

will be deleted first.

6. After finishing the input, rotate the multifunction knob  and press OK. The

oscilloscope will create a folder or a specified type of file with this name under the

current path.

22.6.3 To Delete a File or Folder

1. Delete a File or Folder from the Internal Memory

a. Press  > Disk, and rotate the multifunction knob  to select the internal

memory "Local Disk(C)". Press down the knob to open it.
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b. Rotate the multifunction knob  to select the file or the folder to be deleted.

c. Press Delete, and then a confirmation dialog box is displayed. Tap to select

"Yes" to delete the file or folder.

2. Delete a File or Folder from the External Memory

a. Press  > Disk, and rotate the multifunction knob  to select the external

memory. Press down the knob to open it.

b. Rotate the multifunction knob  to select the file or the folder to be deleted.

c. Press Delete, and then a confirmation dialog box is displayed. Tap to select

"Yes" to delete the file or folder.

TIP

• When you delete a directory where a file or a folder exists, the directory cannot be

deleted.

• The touch screen function only allows you to select the folder and open it, but you are

unable to delete the folder with the touch screen operation.

22.6.4 To Copy and Paste a File or Folder

1. Press  > Disk, and rotate the multifunction knob  to select the internal

memory or external memory. Press down the knob to open it.

2. Rotate the multifunction knob  to select the file or folder to be copied and

pasted.

3. Press Copy to copy the selected file or folder.

4. Select the destination folder, then press Paste to paste the selected file or folder.

TIP

• If the destination folder has the same file or folder that you want to paste, then a prompt

message "File or directory exists" is displayed. You are not allowed to execute the copy

and paste operation.

• The touch screen function only allows you to select the folder and open it, but you are

unable to copy the folder with the touch screen operation.
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22.6.5 To Rename a File or Folder

1. Press  > Disk, and rotate the multifunction knob  to select the internal

memory or external memory. Press down the knob to open it.

2. Rotate the multifunction knob  to select the file to be renamed.

3. Press Rename, and then the filename input interface is displayed. For the filename

input method, refer to descriptions in "To Create a Folder".

TIP

The touch screen function only allows you to select the folder and open it. You are unable to

rename the folder with the touch screen operation.

22.6.6 To Clear the Internal Memory Safely

1. Press  > Disk, and rotate the multifunction knob  to select the internal

memory "Local Disk(C)". Press down the knob to open it.

2. Press SecurityClear, and then a prompt message for confirming security clear is

displayed.

3. Press OK to clear all the saved files from the internal disk.

22.7 Factory Settings

Press  on the front panel, then a prompt message "Restore default settings?"
is displayed. Press OK or tap OK to restore the instrument to its factory default
settings, as shown in the table below.

Table 22.4 Factory Settings

Parameter Factory Settings

Horizontal

Horizontal Time Base 1 μs

Horizontal Position 0 s
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Parameter Factory Settings

Delayed Sweep Off

Timebase Mode YT

Fine Off

Horizontal Expansion Center

Vertical

VScale 100 mV

VOffset 0 V

CH1 On

CH2 Off

CH3 Off

CH4 Off

Channel Coupling DC

BW Limit OFF

Attenuation 1X

Input Impedance 1 MΩ

Invert Off

Fine Off

Channel Unit [V]

Display Label Off

Ch-Ch Skew 0 s

Offset Cal 0 V

Acquire

Acquisition Mode Normal

Memory Depth Auto
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Parameter Factory Settings

Anti-Aliasing Off

Trigger

Trigger Type Edge Trigger

Source Selection CH1

Edge Type Rising

Trigger Mode Auto

Trigger Coupling DC

Trigger Holdoff 8 ns

Noise Rejection Off

Display

Display Type Vector

Persistence Time Min

Intensity 50%

Grid FULL

Grid Brightness 20%

Show Scale Off

Color Grade Off

Waveform Freeze On

Screen Saver Off

Dual-channel Function/Arbitrary Waveform Generator (GI or GII)[1]

GI Off

GII Off

Status Display Off

GI/GII
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Parameter Factory Settings

Wave Sine

Output Off

Freq 1 kHz

Amplitude 500mV

Offset 0 V

Start Phase 0°

Setting Type Off

Impedance HighZ

Cursor

Mode Off

Manual

Select Y

Source CH1

AY 100 mV

BY -100 mV

Vertical Unit Source

Hori. Unit s

Region Main

Track

AX Source CH1

BX Source CH1

AX -1 μs

BX 1 μs

Track X
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Parameter Factory Settings

XY

AX -233.3mV

BX 100 mV

AY -233.3mV

BY -100 mV

Measure

Indicator Off

Storage

Auto Name On

Header On

Save Image

Format *.png

Invert Off

Color Color

Window Show

Save Wave

Data Source Screen

Format *.csv

Window Show

Save Setup

File Type *.stp

Window Show

Load Wave

File Type *.wfm
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Parameter Factory Settings

Load Setup

File Type *.stp

Disk

File Type *.*

Utility

Sound Off

PassFail

Enable Off

Source CH1

Operate Stop

Range Screen

X Mask 0.24 div

Y Mask 0.48 div

Load Type *.pf

Save Type *.pf

File Name RigolDS0

Window Show

Indicator Off

Aux Output Off

Output Event Fail

Polarity Positive

Pulse 1 μs

Err Action None

Record
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Parameter Factory Settings

Waveform Recording OFF

Record

Play

Record

Interval 10 ns

Frames 1,000

Max Frames 9175

Beeper

Current 0

Play

Mode

Sequence

Interval 100 ms

Current 0

Jump To First 

Parameter Factory Settings

Save

Start Frame 1

System

Power On Default

Power status Switch On

AUX Out TrigOut
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Parameter Factory Settings

Key Locker Unlocked

HDMI Output Off

HDMI Resolution 1280x720

SelfCal

Window Open

Auto Config

Peak to Peak Off

CH All

Overlay Off

Coupling Off

Printer

Copies 1

Paper Size A4

Ink Saver ON

Printer HP/Laserjet

Email

Attachment Screen

Quick Settings

Operation Save Image

Format *.png

Invert Off

Color Color

Math

Invert Off

 Store and Load

Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved. 345



Parameter Factory Settings

Expand GND

Display Label Off

Library ADD

Label Editing ADD

A+B

Operation Off

SourceA CH1

SourceB CH1

Offset 0 V

Scale 500 mV

A-B

Operation Off

SourceA CH1

SourceB CH1

Offset 0 V

Scale 500 mV

A×B

Operation Off

SourceA CH1

SourceB CH1

Offset 0 U

Scale 500 mU

A÷B

Operation Off
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Parameter Factory Settings

SourceA CH1

SourceB CH1

Offset 0 U

Scale 500 mU

FFT

Operation Off

Source CH1

Offset 0 dBV

Scale 2 dBV

Unit dBm/dBV

X Start-End

Start Freq 0 Hz

Stop Freq 10 MHz

Window Function Hanning

Display Label Off

Peak Search Off

Peak Number 5

Threshold 5.5 dB

Excursion 1.8 dB

Table Order Amp Order

A&&B

Operation Off

SourceA CH1

SourceB CH1
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Parameter Factory Settings

Wave Size Medium

Thre.CH1 0 V

Thre.CH2 0 V

Thre.CH3 0 V

Thre.CH4 0 V

Sensitivity 0.3 Div

A||B

Operation Off

SourceA CH1

SourceB CH1

Wave Size Medium

Thre.CH1 0 V

Thre.CH2 0 V

Thre.CH3 0 V

Thre.CH4 0 V

Sensitivity 0.3 Div

A^B

Operation Off

SourceA CH1

SourceB CH1

Wave Size Medium

Thre.CH1 0 V

Thre.CH2 0 V

Thre.CH3 0 V
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Parameter Factory Settings

Thre.CH4 0 V

Sensitivity 0.3 Div

!A

Operation Off

SourceA CH1

Wave Size Medium

Thre.CH1 0 V

Thre.CH2 0 V

Thre.CH3 0 V

Thre.CH4 0 V

Sensitivity 0.3 Div

Intg

Operation Off

Source CH1

Offset 0 v*s

Scale 500 mv*s

Bias 0

Invert Off

Diff

Operation Off

Source CH1

Offset 0 v/s

Scale 500 mv/s

Smooth 5
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Parameter Factory Settings

Invert Off

Sqrt

Operation Off

Source CH1

Offset 0 U

Scale 500 mU

Invert Off

Lg

Operation Off

Source CH1

Offset 0 U

Scale 500 mU

Invert Off

Ln

Operation Off

Source CH1

Offset 0 U

Scale 500 mU

Invert Off

Exp

Operation Off

Source CH1

Offset 0 U

Scale 500 mU
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Parameter Factory Settings

Invert Off

Abs

Operation Off

Source CH1

Offset 0 U

Scale 500 mV

Invert Off

Low Pass

Operation Off

Source CH1

Offset 0 V

Scale 500 mV

ωc 50 MHz

Invert Off

High Pass

Operation Off

Source CH1

Offset 0 V

Scale 500 mV

ωc 50 MHz

Invert Off

Band Pass

Operation Off

Source CH1
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Parameter Factory Settings

Offset 0 V

Scale 500 mV

ωc1 50 MHz

ωc2 100 MHz

Invert Off

Band Stop

Operation Off

Source CH1

Offset 0 V

Scale 500 mV

ωc1 50 MHz

ωc2 100 MHz

Invert Off

AX+B

Operation Off

Source CH1

Offset 0 V

Scale 500 mV

A 1

B 0

Invert Off

Average

Operation Off

Source CH1
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Parameter Factory Settings

Avg Number 2

Offset 0 V

Scale 500 mV

Invert Off

Logic Analyzer (LA)

Select None

D7-D0 Off

D15-D8 Off

Wave Size Medium

Arrange D15-D0

Threshold

D7-D0 1.4 V

D15-D8 1.4 V

Label

Display Off

Select D0

Label D0

Decode

Bus Type Parallel

Bus Status Off

Format Hex

Label On

Event Table Off
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Parameter Factory Settings

Noise Rejection Off

CLK Off

RS232

Bus Status Off

Baud 9.6 kbps

Tx CH1

Threshold 0 V

Rx OFF

Polarity

Endian LSB

Data 8 bits

Stop Bit 1 bit

Parity None

Package Off

Separator 0(NUT)

I2C

Bus Status Off

CLK CH1

SCL Thre 0 V

SDA CH2

SDA Thre 0 V

Exchange SCL/SDA

R/W Without

SPI
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Parameter Factory Settings

Bus Status Off

Mode Timeout

Timeout 1 μs

CLK CH1

Threshold 0 V

Edge Type Rising

MISO CH2

Threshold 0 V

MOSI OFF

Polarity

Width 8

Endian MSB

LIN

Bus Status Off

Source CH1

Threshold 0 V

Baud Rate 19.2 kbps

Parity Without

Version Both

CAN

Bus Status Off

Source CH1

Threshold 0 V
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Parameter Factory Settings

Signal CAN_L

Baud 1 Mbps

FD Baud 1 Mbps

Sample Position 50%

FD Sample Position 50%

FlexRay

Bus Status Off

Source CH1

Threshold 0 V

Channel Selection A

Baud Rate 10 Mbps

Signal Type BP

Sample Position 50%

I2S

Bus Status Off

SCLK CH1

Threshold 0 V

SCLK Edge Rising

WS CH2

Threshold 0 V

Data CH3

Threshold 0 V

Word Size 4

Receive 4
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Parameter Factory Settings

Alignment I2S

WS Low Left

Endian MSB

Data Polarity

1553B

Bus Status Off

Data CH1

Threshold 0 V

Ref

Current Ref1

Source CH1

VScale 1V

VOffset 0 V

Color Orange

Label Display OFF

Library Default

Label REF1

NOTE

[1]: It is only available for the model installed with the MSO8000-AWG option.
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23 System Utility Function Setting
In the system function setting menu, you can set the parameters for the remote
interface and the system-related parameters.

23.1 Remote Interface Configuration
MSO8000 series can communicate with the PC via the USB, LAN, or GPIB (requiring to
work with RIGOL's USB-GPIB adaptor) interface. Before using the remote interfaces,
configure the corresponding interface according to the introductions in the following
section.

23.1.1 LAN Configuration

Before using the LAN bus, use a network cable to connect the oscilloscope to your
local area network. The network interface of the oscilloscope is on the rear panel.

Press  > IO > LAN to open the LAN setting interface, as shown in the following
figure. You can view the current network settings and configure the network
parameters.

Network Status

Current IP Config. Type
MAC Address

VISA Descriptor

IP Config. Type

Network Parameters

Web Control Info.

Figure 23.1 Network Connection Setting Interface

Network Status

Different prompts will be displayed according to the current network connection
status.

• Network Config Succeeded!

• Acquiring IP...

• IP Conflict!

• Disconnected!
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• DHCP Config Failed

• Read Status Fail!

• Connected!

• Invalid IP

• IP lost

• Please wait...

IP Configuration Type

The configuration type of the IP address can be DHCP, Auto IP, or Static IP. In different
IP configuration types, the configurations for IP address and other network
parameters are different.

DHCP

Press IP Config Type, then rotate the multi-function knob  or press IP Config Type

continuously to select "DHCP". Press down the knob  to select it. You can also
enable the touch screen to select it. When DHPC is valid, the DHCP server in the
current network will assign the network parameters (e.g. IP address, Subnet, Gateway,
and DNS) for the oscilloscope.

Auto IP

Press IP Config Type, then rotate the multi-function knob  or press IP Config Type

continuously to select "Auto IP". Press down the knob  to select it. You can also
enable the touch screen to select it. In auto IP mode, the oscilloscope will get the IP
address (ranging from 169.254.0.1 to 169.254.255.254) and the subnet mask
(255.255.0.0) automatically according to the current network configuration. The "Auto
IP" works only when "DHCP" is not selected or connection is failed.

Static IP

Press IP Config Type, then rotate the multi-function knob  or press IP Config Type

continuously to select "Static IP". Press down the knob  to select it. You can also
enable the touch screen to select it. Note: when this type is valid, you need to disable
DHCP and Auto IP manually. At this time, the "IP", "SubMask", "Gateway", and "DNS"
menu items are added. Thus, you can self-define the network parameters (e.g. IP
address) of the oscilloscope.

1. Set the IP Address

The format of the IP address is nnn.nnn.nnn.nnn. The range of the first segment
(nnn) of the address is from 0 to 255 (except 127); wherein, the valid range is from
0 to 223. The range for the other three segments is from 0 to 255. You are
recommended to ask your network administrator for an IP address available.
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Press IP, and then the numeric keypad is displayed. Input the desired IP address
with the numeric keypad. This setting will be saved to the non-volatile memory; if
"Power On" is set to "Last", then DHCP and Auto IP are disabled at the next power-
on. The oscilloscope will load the preset IP address automatically.

2. Set the Subnet Mask

The format of the subnet mask is nnn.nnn.nnn.nnn. Wherein, the range of "nnn" is
from 0 to 255. You are recommended to ask your network administrator for a
subnet mask available.

Press SubMask, and then the numeric keypad is displayed. Input the desired
subnet mask with the numeric keypad. This setting will be saved in the non-volatile
memory; if "Power On" is set to "Last", then DHCP and Auto IP are disabled at the
next power-on. The oscilloscope will load the preset subnet mask automatically.

3. Set the Gateway

You can can set this parameter in Static IP mode.

The format of the gateway is nnn.nnn.nnn.nnn. The range of the first segment
(nnn) is from 0 to 223 (except 127), and the range for the other three segments is
from 0 to 255. You are recommended to ask your network administrator for a gate
address available.

Press Gateway, and then the numeric keypad is displayed. Input the desired
subnet mask with the numeric keypad. This setting will be saved in the non-volatile
memory; if "Power On" is set to "Last", then DHCP and Auto IP are disabled at the
next power-on. The instrument will load the preset gateway automatically.

4. Set the DNS

You can set this parameter in Static IP mode.

The format of the DNS address is "nnn.nnn.nnn.nnn". The range for the first
segment (nnn) of the address is from 0 to 223 (except 127); and the range for the
other three segments is from 0 to 255. You are recommended to ask your network
administrator for an address available.

Press DNS, and then the numeric keypad is displayed. Input the desired DNS
address with the numeric keypad. Generally, you do not need to set the DNS,
therefore this parameter setting can be ignored.

TIP

• When the three IP configuration types are all turned on, the priority of the parameter

configuration from high to low is "DHCP", "Auto IP", and "Static IP".

• The three IP configuration types cannot be all turned off at the same time.

Apply the Network Parameter Setting

Press Apply to validate the current network parameter setting.

MAC Address
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For each oscilloscope, the MAC address is unique. When assigning the IP address for
the oscilloscope, the system uses the MAC address to identify the instrument.

VISA Address

Displays the VISA address currently used by the oscilloscope.

Web Control Information

Displays the user name and password for network configuration of the oscilloscope
through the LXI webpage.

TIP

Connect the oscilloscope to the local area network. Start up Ultra Sigma, and then right-click

the resource name and select "LXI-Web" to load the LXI webpage. You can also directly input

the IP address of the oscilloscope in the address bar of the PC browser to load the LXI

webpage.

23.1.2 To Set mDNS

Press mDNS continuously to enable or disable the multicast Domain Name System
(mDNS). This system is used to provide the function of DNS server for service
discovery in a small network without a DNS server.

23.1.3 To Set the Host Name

Press Host Name to input the host name. For the host name input method, refer to
relevant descriptions in "To Create a Folder".

23.1.4 To Set the GPIB address

Before using the GPIB interface, use the USB-GPIB interface converter (an option that
requires to be ordered separately) to extend the GPIB interface, and then use the GPIB
cable to connect the instrument to the PC.

Press  > IO > GPIB, then rotate the multifunction knob  directly to set the
GPIB address or use the pop-up numeric keypad to input the GPIB address. Its
settable range is from 1 to 30. By default, it is 1.

23.1.5 To Set HDMI

Sets the status and parameters of the HDMI video output interface on the rear panel.
Note that only when the HDMI interface is available, can this menu be enabled.

Press HDMI to enter the HDMI setting menu.

• Press Output continuously to enable or disable the video output.
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- ON: You can connect the instrument to an external display via this interface

to better observe the waveform display clearly from the external display.

- OFF: disables the interface.

• Press Resolution to set the screen resolution. The available resolution includes

640x480, 720x480, and 1280x720.

23.1.6 USB Connection

The oscilloscope can communicate with a PC via the USB DEVICE interface on the rear
panel. No parameters are required to be configured.

23.2 System-related

23.2.1 Beeper

When the beeper is enabled, you can hear the sound of the beeper when you
perform the following operations:

• Press a key or a menu key on front panel

• Enable the touch screen

• When a prompt message is displayed

Press  and then press Beeper continuously to select "ON" ( ) or "OFF" ( ). By
default, it is OFF.

23.2.2 Language

This oscilloscope supports menus in multiple languages. Both Chinese and English are
available for the display of the help information, prompt messages, and interface.

Press  > Language, then rotate the multifunction knob  to select the desired
language, and then press down the knob to select it. You can also press Language
continuously to select the language or enable the touch screen to tap the desired
language and select it.

23.2.3 System Information

Press  > System > About to view the system information of the oscilloscope,
including the manufacturer, product model and serial number, firmware etc., etc.
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You can also view the system information of the oscilloscope in the "Help" system
menu.

23.2.4 Power On

You can set the system configuration to be recalled when the oscilloscope is powered
on again after power-off.

Press  > System, and then press Power On continuously to select "Last" or
"Default". By default, it is "Default".

• Last: returns to the setting of the system at last power-off.

• Default: returns to the factory setting of the system.

23.2.5 Power Status

Use the power line to connect the oscilloscope to the AC power and then turn on the
power switch to power on the instrument. You can set the power status after it is
powered on.

Press  > System, and then press Power status to select "Switch On" or "Switch
Off".

• Switch off: after the oscilloscope is connected to power, you need to press the

Power key on the front panel to power on the instrument.

• Switch On: After the the oscilloscope is connected to power, it will be powered

on immediately.

NOTE

Whatever the option you select, you still can press the Power key on the front panel to turn on

or off the instrument.

23.2.6 Aux Output

Users can set the type of the signal output from the [TRIG OUT] connector on the
rear panel.

Press  > System, and then press AUX Out continuously to select "TrigOut" or
"PassFail".

• TrigOut:

After this type is selected, at each trigger (hardware trigger), the oscilloscope
outputs a signal from the [TRIG OUT] connector on the rear panel that can
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reflect the current capture rate of the oscilloscope. If this signal is connected to a
waveform display device to measure the frequency, the found measurement
result is the same as the current capture rate.

• PassFail:

When this type is selected, the instrument can output a positive or negative
pulse via the [TRIG OUT] connector when a successful or failed event is
detected. Refer to descriptions in To Set the Output Form of the Test Results.
When you enable the Aux output, the AUX Out menu is automatically set to
"PassFail". When the AUX Out menu is set to "TrigOut", then in the pass/fail test
menu, the Aux Out function is automatically disabled.

23.2.7 Ref Clock

This oscilloscope can output the internal 10 MHz sample clock signal from the rear-
panel [10M In/Out] connector, and it can also receive the external 10 MHz clock
signal from the connector. This function can be used to synchronize multiple
oscilloscopes.

Press  > System > Ref Clock, then rotate the multifunction knob  to select
the desired clock type. Press down the knob to select it. You can also press Ref Clock
continuously or enable the touch screen to select it.

• OFF: disables the reference clock function.

• Clock Output. The instrument outputs the internal 10 MHz clock signal from the

rear-panel [10M In/Out] connector.

• Clock Input. The oscilloscope receives the external 10 MHz clock signal from the

rear-panel [10M In/Out] connector.

23.2.8 Help Menu

Press  > System > Help, and then the "Help" menu is displayed on the screen.

You can also use the touch screen function , tap the navigation icon  at the lower-
left corner of the touch screen to enable the function navigation. Tap the "Help" icon,
and then the "Help" menu is displayed on the screen.

• Press About to view the system information of the oscilloscope.

• Press Content to enter the built-in help system.

• Press Option list to view the name of the installed option and other detailed

information about the option from the option list.
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• Press Option install to install the desired option. For detailed installation

procedures, refer to descriptions in "To View the Option and the Option

Installation".

• Press Online upgrade to perform online upgrading for the system software. For

the method of online upgrade, refer to "Rear Panel Overview".

NOTE

If you connect the oscilloscope to the network via the LAN interface, every Monday you

power on the instrument, the oscilloscope will check whether the latest version of the

upgrade software is available on the RIGOL official website (www.rigol.com). If yes, a red

spot appears at the upper-left corner of the Online upgrade menu, prompting you that

the latest upgrade version is available and you can perform online upgrade.

• Press Local upgrade or enable the touch screen to tap "Local upgrade", then a

dialog box "Upgrade system firmware?" is displayed. Tap OK to perform local

upgrading for the system software (required to insert the USB disk that contains

the software installation package); tap Cancel to cancel local upgrading

operation.

23.2.9 SelfCal

The self-calibration program can quickly make the oscilloscope to work in an optimal
state to get the precise measurement results. You can perform self-calibration at any
time, especially when the changes of the ambient temperature reach or above 5℃.
Make sure that the oscilloscope has been warmed up or operating for more than 30
minutes before the self-calibration.

Disconnect all the input channels, and then press  > System > SelfCal, and the
self-calibration interface is displayed, as shown in the following figure.
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Figure 23.2 SelfCal

• Press Start, and then the oscilloscope will start to execute the self-calibration

program.

• After starting the self-calibration program, the Exit menu is no longer grayed

out and is enabled. Press Exit to cancel self-calibration operation at any time.

• Press Window continuously to open or close the self-calibration information

window. You can also enable the touch screen to tap the icon  at the right-

upper corner of the self-calibration information window to close it.

NOTE

During the self-calibration process, most of the keys are disabled.

23.2.10 Auto Config

You can set the parameters for the  menu.

Press  > More > Auto Config, and set the parameters for the  key. For
detailed settings, refer to descriptions in "Quick Measurement after AUTO".

23.2.11 Print Setting

Connect the oscilloscope to the local area network via the network cable. This series
supports printing the whole screen to the network printer. You can connect the
oscilloscope to the printer directly via the [USB DEVICE] interface on the rear panel.
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Then, you can set the print parameter on the oscilloscope to control the printer to
output the corresponding picture.

Press  > More > Printer to enter the printer setting menu. After the printer is
properly connected, you need to set the network configurations for printing, and then
set the printer parameters.

1. Network Configuration

Press Setting to enter the network configuration menu.

- Select the printer

Press Printer, then rotate the multifunction knob  to select the printer model.
Press down the knob to select it. You can also press Printer continuously or
enable the touch screen to select it.

- Set the IP address

Press Printer IP, then rotate the multifunction knob  to set each segment of
the IP address for the printer. Press down the knob to confirm the setting for
each segment of the address. At this time, the cursor moves to the next
segment automatically. You can also press Printer IP continuously to switch the

segment position, and then rotate the multifunction knob  to set it. You can
also enable the touch screen to switch the address segment.

- Set the port

Press Printer Port, then directly rotate the multifunction knob  to adjust the
port number or use the pop-up numeric keypad to input the port number.

- Network test

Press Test to test whether the network is connected. If connected, a prompt
message "Network connected" is displayed.

- Print test page

Press Print test page to carry out the print test. The print progress is also
displayed on the screen.

2. Sets the Print Parameters

• Print

After the printer parameters are set, press Print to execute the print operation.

• Copies
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Press Copies, then rotate the multifunction knob  to set the number of copies
to be printed or use the pop-up numeric keypad to set it. The settable range is
from 1 to 99.

• Paper Size

The Paper Size menu is grayed out and disabled. The paper size only supported
by the oscilloscope is A4.

• Ink Saver

Press Ink Saver continuously to enable or disable the ink saver setting. If
disabled, you need to set Color. Press Color continuously to select "Gray" or
"Color".

23.2.12 Email

This oscilloscope supports sending files via emails. Press  > More Email to enter
the email setting menu.

1. Set the Email Server

Press Settings to enter the email server login setting menu. The following window
is displayed. After the setting, enable the touch screen to tap OK to complete the

server login. To cancel login, tap Cancel to exit or tap the icon  at the upper-
right corner of the window to exit. If you exit the server setting window, you can
press SMTP, Port, UserName, or PassWord to reopen the window.

- Set SMTP

Press SMTP to set the mail transmission protocol. For detailed settings of mail
transmission protocol, refer to descriptions in "To Create a Folder".

- Set the port
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Press Port to set the protocol port with the pop-up numeric keypad. Its range is
from 1 to 65,535.

- Set the user name

Press UserName to set the user name of the server. For detailed setting
methods for the user name, refer to descriptions in "To Create a Folder".

- Set the password

Press PassWord to set the password of the server. For detailed setting methods
for the password, refer to descriptions in "To Create a Folder".

- Email test

Press Test to test whether the e-mail server is properly set.

- Restore default settingsPress Default to restore the settings of receiver and

mail settings to defaults.

2. Set the Receiver

Press Receiver to display the receiver input interface, and you can edit the email
address of the receiver. For detailed input methods of the receiver email address,
refer to descriptions in "To Create a Folder".

3. Upload the Attachment

Press Attachment, then rotate the multifunction knob  to upload the

attachment type, and then press down the knob  to select the type. You can also
press Attachment continuously to select or enable the touch screen to tap the
attachment. The available attachments include "Screen", "Setup", and "Other". If
you select "Other", you also need to press File Select to select the file to be
uploaded.

4. Send the Mail

Press Send Mail to send the edited email to the receiver.

23.2.13 Key Locker

You can set whether to lock the front-panel keys.

Press  > More > Key Locker to select "Locked" or "Unlocked".

• Locked: indicates that all menu keys of the oscilloscope (except the Touch Lock

key) are locked.

• Unlocked: unlocks the front-panel keys.
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23.2.14 Quick Operation

You can set the shortcut functions for the  key on the front panel.

Press  > More > Quick settings to enter the quick key operation menu. You can

also enable the touch screen and then tap the function navigation icon  at the
lower-left corner of the screen to open the function navigation. Then, tap the "Quick"
icon to open the quick key setting menu.

The Quick key includes the following five shortcut functions:

1. Image Saving

When the Quick shortcut key is set to "Save Image", press  on the front panel to
capture the screen.

- Operation type

Press Operation and then rotate the multifunction knob  to select "Save

Image". Press down the knob  to select it. You can also press Operation
continuously or enable the touch screen to select the type.

- Image format

Press Format, and then rotate the multifunction knob  to select the image
format. You can also press Format continuously or enable the touch screen to
select the image format. The available image formats include "*.png", "*.bmp",
"*.jpg", and "*.tif".

- Invert

Press Invert continuously to enable or disable the invert function.

- Color

Press Color continuously to set the color of the saved image to "Color" or
"Gray".

2. Waveform Saving

When the Quick shortcut key is set to "Save Wave", press  on the front panel to
save the waveform.

- Operation type
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Press Operation and then rotate the multifunction knob  to select "Save

Wave". Press down the knob  to select it. You can also press Operation
continuously or enable the touch screen to select the type.

- Data source

Press Data Source continuously to select "Memory" or "Screen" as the source
of the saved waveform.

- Format

Press Format and then rotate the multifunction knob  to select the waveform
format. Press down the knob to select it. You can also press Format
continuously or enable the touch screen to select it. When the data source is
"Memory", the available formats are "*.bin" and "*.csv". When the data source is
"Memory", the available formats are "*.bin", "*.csv", and "*wfm".

- Storage channel

If the data source is "Memory", you need to set the storage channel. Press

Channel, and rotate the multifunction knob  to select the storage channel.
You can also press Channel continuously or enable the touch screen to select
the channel. The available storage channels include CH1-CH4.

3. Setup Saving

When the Quick shortcut key is set to "Save Setup", press  on the front panel to
save the setup of the oscilloscope.

Press Operation and then rotate the multifunction knob  to select "Save Setup".

Press down the knob  to select it. You can also press Operation continuously or
enable the touch screen to select the type. You do not need to set relevant
parameters.

4. All Measurement

When the Quick shortcut key is set to "All Measure", press  on the front panel
to measure all the parameters of the current measurement source.

- Operation type

Press Operation and then rotate the multifunction knob  to select "All

Measure". Press down the knob  to select it. You can also press Operation
continuously or enable the touch screen to select the type.
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- All MeasurementPress All Measure, then rotate the multifunction knob  to

select the desired measurement channel.

You can also press All Measure continuously to select or enable the touch
screen to tap the desired channel. The available measurement channels include
OFF and CH1-CH4.

5. Statistics Reset

When the Quick shortcut key is set to "Stat Reset", press  on the front panel to
make statistics reset of measurement or pass/fail test reset.

- Operation type

Press Operation and then rotate the multifunction knob  to select "Stat

Reset". Press down the knob  to select it. You can also press Operation
continuously or enable the touch screen to select the type.

- Statistics Reset

Press Stat Reset and then rotate the multifunction knob  to select the
function that requires statistics reset. Press down the knob to select it. You can
also press Stat Reset continuously to select among the options, or enable the
touch screen to tap the desired option. You can select "Measure" or "PassFail".

6. Print

When the Quick shortcut key is set to "Print", press  on the front panel to print
the screen image of the oscilloscope.

Press Operation and then rotate the multifunction knob  to select "Print". Press

down the knob  to select it. You can also press Operation continuously or
enable the touch screen to select the type.

7. Email

When the Quick shortcut key is set to "Email", press  on the front panel to send
the file through email.

Press Operation and then rotate the multifunction knob  to select "Email". Press

down the knob  to select it. You can also press Operation continuously or
enable the touch screen to select the type.

8. Record
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When the Quick shortcut key is set to "Record", press  on the front panel to
record the waveform.

Press Operation and then rotate the multifunction knob  to select "Record".

Press down the knob  to select it. You can also press Operation continuously or
enable the touch screen to select the type.

9. Save Group

When the Quick shortcut key is set to "Save Group", press  on the front panel to
save group.

- Operation type

Press Operation and then rotate the multifunction knob  to select "Save

Group". Press down the knob  to select it. You can also press Operation
continuously or enable the touch screen to select the type.

- Group

Set the Group parameter: press Group and then rotate the multifunction knob

 to select "Save Image", "Save Wave", or "Save Setup". Press down the knob
to select the desired one. You can also press Group continuously to select it.
You can also directly enable the touch screen and tap to select it. You can select

any or all of the three items. The sign  indicates that the item has been

selected, and  indicates that the item has not been selected.

23.2.15 Screen Saver

When the oscilloscope enters the idle state and holds for a certain period of time, the
screen saver program will be enabled.

Press More > Screen Saver to enter the screen saver menu. Press Screen Saver, then

rotate the multifunction knob  to select the screen saver type, and then press down

the knob  to select it. You can also press Screen Saver continuously or enable the
touch screen to select it. The available screen saver types include "Off", "Picture", and
"Text". The screen saver program is disabled by default.

1. Select the Screen Saver

- If you select "Off", the screen saver is disabled.

- If you select "Picture" under Screen Saver, press Select Picture to select the file.

The available file types include "*.png", "*.bmp", "*.jpg", and "*.tif".
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- If you select "Text" under Screen Saver, press Text, and then the filename input

interface is displayed. Input the filename, for example, "RIGOL Scope". For

details, refer to descriptions in "To Create a Folder".

2. Set the Screen Saver Time

Press Time to Start, then rotate the multifunction knob  to set the screen saver
time. You can also use the numeric keypad to set it. The range available is from 1
min to 999 min.

3. Preview the Screen Saver Time

Press Preview to view the set screen saver time.

4. Restore to the Default Screen Saver Settings

Press Default to restore to the screen saver default settings.

23.2.16 Self-check

The oscilloscope supports a variety of self-check functions, including keyboard check,
screen check, and touch screen check.

Press  > More > More > Self Check to enter the self-check menu.

1. Key Test

Press Key Test to enter the keyboard test interface (virtual keypads of the front
panel). At this time, you can press the keys on the front panel to check whether the
virtual keys are highlighted. If yes, it indicates that the keys work normally; if no, it
indicates that there's something wrong with the keys. If the virtual key is not

illuminated, the key may fail to work. Press  for three consecutive times to
exit the key test interface.

2. Screen Test

Press Screen Test to enter the screen test interface and check whether the

defective pixel exists. There are 15 screen test interfaces. Press  to switch to

the next screen test interface. Press  for three consecutive times to exit the
screen test interface.

3. Touch Test

Press Touch Test to enter the touch screen test interface first, as shown in the
figure below. Slide with your finger on the screen. If there is a line displaying at the
empty area where you slide on the screen and the box that you tap turns out to be
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filled with green background, it indicates that the touch function of this area is
normal.

Then press  to switch to the next touch screen test interface, as shown in the
figure below. At this time, you can pinch or stretch the icons on RIGOL to zoom out

or zoom in icons to check whether the gestures work normally. Press  for
three consecutive times to exit the touch test interface.

23.2.17 System Time

The system time is displayed at the lower-right side of the screen in "hh:mm
(hour:minute)" format. When you save the waveform, the output file will contain the
time information.

Press  > More > More > Time to open the time setting menu.

1. Set the System Time

 System Utility Function Setting

Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved. 375



a. Press Show Time continuously to open or close the system time interface.

b. Set "year": Press Year, rotate the multifunction knob  directly to set it or use

the pop-up numeric keypad to input the numeric value to set it.

c. Set "month": Press Month, rotate the multifunction knob  directly to set it or

use the pop-up numeric keypad to input the numeric value to set it.

d. Set "day": Press Day, rotate the multifunction knob  directly to set it or use

the pop-up numeric keypad to input the numeric value to set it.

e. Set "hour": Press Hour, rotate the multifunction knob  directly to set it or use

the pop-up numeric keypad to input the numeric value to set it.

f. Set "minute": Press Minute, rotate the multifunction knob  directly to set it or

use the pop-up numeric keypad to input the numeric value to set it.

The setting range of each item of the system time conforms to the convention.

- Year: 2017 to 2099

- Month: 01 to 12

- Date: 01 to 31 (28, 29, or 30)

- Hour: 00 to 23

- Minute: 00 to 59

- Second: 00 to 59

2. Apply the Currently Set System Time

Press Apply to validate the current settings. The time at the lower-right side of the
screen will be updated.

23.2.18 Default Option

Used for configuring the  key.

Press  > More > More > Default Option to enter the default option menu.
Press Keep Impedance to enable or disable the impedance keep function. If you

select ON, after you press , the impedance value that you set remains
unchanged and other settings will be restored to the default settings. If you select
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OFF, after you press , the impedance value will be restored to its default value
1 MΩ.
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24 Remote Control
The following ways of remote control are supported:

• User-defined Programming
Users can program and control the instrument by using the SCPI (Standard 

Commands for Programmable Instruments) commands. For details about the 

SCPI commands and programming, refer to Programming Guide of this product 

series.

• PC Software

Users can use the PC software to send commands to control the instrument 

remotely. RIGOL Ultra Sigma is recommended. You can download the software 

from RIGOL official website ( http:/ / www . rigol. com

Operation Procedures:

- Set up communication between the instrument and PC.

- Run Ultra Sigma and search for the instrument resource.

- Open the remote command control panel to send commands.

• Web Control
This instrument supports Web Control. Connect the instrument to the network, 

then input the IP address of the instrument into the address bar of the browser 

of your computer. The web control interface is displayed. Click Web Control to 

enter the web control page. Then you can view the display of the real-time 

interface of the instrument. Through the Web Control method, you can migrant 

the device control to the control terminals (e.g. PC, Mobile, iPad, and other smart 

terminals) to realize remote control of the instrument. When you first log in to 

the Web Control, the user name is "admin" and password is "rigol".

• VNC Control
This instrument supports VNC control. The VNC client (VNC Viewer) can be 

downloaded from its official website. When the VNC client is installed and your 

instrument is connected to the network, open the VNC Viewer client and input 

the IP address of the instrument into the VNC address bar. Then, you can view 

the screen of the instrument and operate the instrument remotely.

This instrument can be connected to the PC via the USB, LAN, or GPIB interface to set
up communication and realize remote control through the PC. The remote control can
be realized by using SCPI (Standard Commands for Programmable Instruments)
commands.

This chapter will illustrate how to use the RIGOL Ultra Sigma software to remotely
control the instrument via various interfaces. Note: When communicating with the PC
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via GPIB, the instrument does not support large data transmission operation such as
screen shot and waveform reading.

CAUTION

Before connecting the communication cable, please turn off the instrument to avoid

causing damage to the communication interfaces.

24.1 Remote Control via USB

1. Connect the device

Use the USB cable to connect the rear-panel USB DEVICE interface of the
instrument to the USB HOST interface of the PC.

2. Search for the device resource

Start up Ultra Sigma and the software will automatically search for the resource
currently connected to the PC via the USB interface. You can also click USB-TMC to
search for the resource.

3. View the device resource

The resources found will appear under the "RIGOL Online Resource" directory, and
the model number and USB interface information of the instrument will also be
displayed.

4. Control the instrument remotely

Right-click the device resource name and select "SCPI Panel Control" to open the
remotely command control panel. Then you can send commands and read data
through the panel. For details about the SCPI commands and programming, refer
to the Programming Guide of this instrument.

24.2 Remote Control via LAN

1. Connect the device

Use the network cable to connect the instrument to your local area network (LAN).

2. Configure network parameters

Configure the network parameters of the instrument in Utility>IO menu.

Click or tap the Notification Area at the lower-right corner of the screen, then the
Utility menu is displayed. Click or tap IO, and then click or tap the input field of
GPIB to input the GPIB address with the pop-up numeric keypad.

3. Search for Search device resource

Start up Ultra Sigma and click LAN to open the panel as shown in the figure below.
Click Search and the software searches for the instrument resources currently
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connected to the LAN and the resources found are displayed at the right section of
the window as shown in the figure below. Click OK to add it.

Besides, you can input the IP address of the instrument manually into the text field
under "Manual Input LAN Instrument IP", then click TEST. If the instrument passes
the test, click Add to add the instrument to the LAN instrument resource list in the
right section; if the instrument fails the test, please check whether the IP address
that you input is correct, or use the auto search method to add the instrument
resource.

4. View the device resource

The resources found will appear under the "RIGOL Online Resource" directory.

5. Control the instrument remotely

Right-click the device resource name and select "SCPI Panel Control" to open the
remotely command control panel. Then you can send commands and read data
through the panel.

6. Load LXI webpage

As this instrument conforms to LXI CORE 2011 DEVICE standards, you can load LXI
web page through Ultra Sigma (right-click the instrument resource name and
select "LXI-Web"). Various important information about the instrument (including
the model, manufacturer, serial number, description, MAC address, and IP address)
will be displayed on the web page. You can also directly input the IP address of the
instrument in the address bar of the PC browser to load the LXI web page.

24.3 Remote Control via GPIB

1. Connect the device

Use the USB-GPIB interface converter to extend the GPIB interface for the
instrument, and then use the GPIB cable to connect the instrument to the PC to
realize remote control.

2. Install the driver of GPIB card
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Correctly install the driver of the GPIB card which has been connected to the PC.

3. Set the GPIB address

Click or tap the Notification Area at the lower-right corner of the screen, then the
Utility menu is displayed. Click or tap IO, and then click or tap the input field of
GPIB to input the GPIB address with the pop-up numeric keypad.

4. Search for the device resource

Start Ultra Sigma, and then click GPIB. A window is displayed as shown in Figure
24.1 . Click Search and the software searches for the instrument resource currently
connected to the PC via the GPIB interface. The resource found is displayed at the
right side of the window, as shown in Figure 24.2 . Click OK to add it.

Figure 24.1 Search for the Available Device

Figure 24.2 Confirm the Available Device

5. View the device resource

Click OK to go back to the main interface of Ultra Sigma. The searched instrument
resource will be displayed under the directory of "RIGOL Online Resource".

6. Control the instrument remotely

Right-click the device resource name. In the displayed menu, select "SCPI Panel
Control" to open the programming command control panel. Then you can input
commands to send commands and read data.
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25 Troubleshooting

1. When I power on the instrument, the instrument stays black and does not
display anything.

a. Check whether the power supply has been connected correctly.

b. Check whether the power key is really pressed.

c. Check whether the fuse is blown. If you need to replace the fuse, use only the
specified fuse that conforms to the product.

d. Restart the instrument after finishing the above inspections.

e. If the problem still persists, please contact the manufacturer.

2. The USB storage device cannot be recognized.

a. Check whether the USB storage device can work normally when connected to
other instruments or PC.

b. Make sure that the USB storage device is FAT32 format and flash type. The
instrument doesn't support hardware USB storage device.

c. After restarting the instrument, insert the USB storage device again to check
whether it can work normally.

d. If the USB storage device still cannot work normally, please contact the
manufacturer.

3. How do you set the amplitude of the waveform in dBm?

a. Select the desired channel.

b. In the channel setting interface, check whether HighZ under OutputSet is set to
"On". If yes, you cannot set the amplitude of the waveform in dBm at this time.
Select "Off" to disable the HighZ, and use the numeric keypad, the arrow keys,
and knob to set it to a proper value.

c. Select the desired waveform, tap the Amplitude menu label, and then input the
desired value by using the numeric keypad. Then select the unit "dBm" from the
pop-up menu.

4. The touch-enabled operation does not work.

a. Check whether you have locked the touch screen. If yes, unlock the touch
screen.

b. Check whether the screen or your finger is stained with oil or sweat. If yes,
please clean the screen or dry your hands.

 Troubleshooting

382 Copyright ©RIGOL TECHNOLOGIES CO., LTD. All rights reserved.



c. Check whether there is a strong magnetic field around the instrument. If the
instrument is close to the strong magnetic field (e.g. a magnet), please move
the instrument away from the magnet field.

d. If the problem still persists, please contact the manufacturer.
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26 Appendix

26.1 Appendix A: Options and Accessories

Order Information Order No.

Model
MSO8204 (2 GHz, 10 GSa/s, 500 Mpts, 4+16 CH MSO) MSO8204

MSO8104 (1 GHz, 10 GSa/s, 500 Mpts, 4+16 CH MSO) MSO8104

MSO8064 (600 MHz, 10 GSa/s, 500 Mpts, 4+16 CH MSO) MSO8064

Standard Accessories
USB Cable CB-USBA-USBB-FF-150

Passive HighZ Probe x4 (500 MHz) RP3500A

Passive Low-impedance Probe x2 (1.5 GHz, only for the
MSO8204/MSO8104) RP6150A

Front Protective Cover MSO8000-FPC

Power Cord Conforming to the Standard of the Destination
Country -

Recommended Accessories
16-channel Logic Analyzer Probe RPL2316

Active Single-ended/Differential Probe (2.5 GHz BW) PVA7250

Active Differential Probe (1.5 GHz BW) RP7150

Active Differential Probe (800 MHz BW) RP7080

Active Single-ended Probe (1.5 GHz BW) RP7150S

Active Single-ended Probe (800 MHz BW) RP7080S

Rack Mount Kit RM6041

Near-field Probe NFP-3

Power Analysis Phase Deviation Correction Jig RPA246

Digital Oscilloscope Demonstration Plate DK-DS6000

USB-GPIB Adaptor USB-GPIB

Bandwidth Upgrade Option
Bandwidth Upgrades from 600 MHz to 1 GHz MSO8000-BW6T10

Bandwidth Upgrades from 600 GHz to 2 GHz MSO8000-BW6T20

Bandwidth Upgrades from 1 GHz to 2 GHz MSO8000-BW10T20

Bundle Option
Function and application bundle option, including
MSO8000-COMP, MSO8000-EMBD, MSO8000-AUTO,
MSO8000-FLEX, MSO8000-AUDIO, MSO8000-AERO,
MSO8000-AWG, MSO8000-JITTER and MSO8000-PWR

MSO8000-BND

Serial Protocol Analysis Option
PC Serial Bus Trigger and Analysis (RS232/UART) MSO8000-COMP

Embedded Serial Bus Trigger and Analysis (I2C, SPI) MSO8000-EMBD

Auto Serial Bus Trigger and Analysis (CAN, CAN-FD, LIN) MSO8000-AUTO
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Order Information Order No.

FlexRay Serial Bus Trigger and Analysis (FlexRay) MSO8000-FLEX

Audio Serial Bus Trigger and Analysis (I2S) MSO8000-AUDIO

MIL-STD-1553 Bus Trigger and Analysis (MIL-STD-1553) MSO8000-AERO

Measurement Application Option
Dual-channel 25 MHz Arbitrary Waveform Generator MSO8000-AWG

Built-in Power Analysis (Required to Purchase the RPA246
Phase Deviation Correction Jig) MSO8000-PWR

Real-time Eye Diagram and Jitter Analysis MSO8000-JITTER

NOTE

For all the accessories and options, please contact the local office of RIGOL.

26.2 Appendix B: Warranty
RIGOL TECHNOLOGIES CO., LTD. (hereinafter referred to as RIGOL) warrants that the
product mainframe and product accessories will be free from defects in materials and
workmanship within the warranty period. If a product proves defective within the
warranty period, RIGOL guarantees free replacement or repair for the defective
product.

To get repair service, please contact your nearest RIGOL sales or service office.

There is no other warranty, expressed or implied, except such as is expressly set forth
herein or other applicable warranty card. There is no implied warranty of
merchantability or fitness for a particular purpose. Under no circumstances shall
RIGOL be liable for any consequential, indirect, ensuing, or special damages for any
breach of warranty in any case.
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Index

Special Characters

-Duty 174

-SlewRate 180

-Width 174

+Duty 174

+SlewRate 180

+Width 174

A

AM VIII, 315

Area 181

Auto IP 359

B

Blackman-Harris 146

Burst VIII, 320

C

Channel Delay II, 57

D

Delay 176

Domain Name Server 360

Dots 296

Duty Cycle 303

E

ECG VIII, 306

End Keep 319

EOF error 242

Exp.Fall VIII, 306

Exp.Rise VIII, 305

F

Fall Time 174

Falling Edge Count 176

Flattop 147

FM VIII, 316

Frequency 174

Frequency Deviation 317

FSK VIII, 317

G

Gauss VIII, 307

H

Hamming 146

Hanning 146

Haversine VIII, 309

Horizontal time base II, 60

I

I2S Trigger IV, 126
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Idle Time 109

Impedance 302

IP Address 359

L

Lorentz VIII, 308

M

MAC 360

Modulating Waveform 316, 317

Modulation Depth 316

Modulation Frequency 316, 317

N

Negative Pulse Count 175

O

Offset Calibration II, 57

Overshoot 180

P

Parity error 241, 258

Pattern Setting 92, 95

Peak III, 70

Period 174

Period Area 181

Phase 176

Positive Pulse Count 175

Preshoot 180

Pulse Width Setting 85

R

Rectangular 146

Rise Time 174

Rising Edge Count 175

RMS 180

S

Set the Gateway 360

Sinc VIII, 304

Start keep 319

Start Phase 301

Static IP 359

Subnet Mask 360

Sweep VIII, 318

Sweep Trigger Source 319

Symmetry 302

Sync 90

Sync error 259

T

The trigger sources of the burst 321

Triangle 147

Trigger Condition 86

Tvmax 174

Tvmin 174

V

Vamp 179

Vavg 179

Index
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Vbase 179

Vector 296

Vertical Scale II, 48

Video Polarity 89

Video Standard 89

VISA 361

Vlower 179

Vmax 179

Vmid 179

Vmin 179

Vpp 179

Vtop 179

Vupper 179

W

Waveform Aliasing 71

Waveform Distortion 71

Waveform Leakage 72

Window Trigger III, 101

X

X Cursor 187

Y

Y Cursor 187

Index
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HEADQUARTER 

RIGOL TECHNOLOGIES СО., L ТО. 

No.8 Keling Road, New Oistrict, Suzhou, 
JiangSu, P.R.China 
Tel: +86-400620002 
Email: info@rigol. com 

EUROPE 

RIGOL TECHNOLOGIES EU GmbH 

Carl-Benz-Str.11 
82205 Gilching 
Germany 
Tel: +49(0)8105-27292-О 
Email: info-europe@rigol. com 

NORTH AMERICA 

RIGOL TECHNOLOGIES, USA INC. 

10220 SW Nimbus Ave. 
Suite К-7 
Portland, OR 97223 
Tel: +1-877-4-RIGOL-1 
Fax: +1-877-4-RIGOL-1 
Email: info@rigol. com 

JAPAN 

RIGOLJAPAN СО., L ТО. 

SF,3-45-6,Minamiotsuka, 
Toshima-Ku, 
Tokyo, 170-0005,Japan 
Tel: +81-3-6262-8932 
Fax: +81-3-6262-8933 
Email: info.jp@rigol. com 

RIGOL® is the trademark of RIGOL TECHNOLOGIES СО., L ТО. Product information in this document is subject to update without notice. For 
the latest information about RIGOL's products, applications and services, please contact local RIGOL channel partners ог access RIGOL 

official website: www. rigol. com 
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